Zurück   KNX-User-Forum > Öffentlicher Bereich > KNX EIB Forum
knx-user-forum - International KNX Award Winner 2010



Antwort
 
Themen-Optionen Ansicht
  #1  
Alt 14.06.2008, 18:21
Benutzer
 
Registriert seit: 30.08.2007
Ort: Lüdenscheid NRW
Beiträge: 10
Standard ETS30F NAT Modus bei KNXNetIP

Hallo alle miteinander,

hat jemand schon Erfahrungen mit dem seit der 30F Version vorhandenen NAT Modus gemacht. Das bisher verwendete Tool NATIP_Support (Peter Pan) hat ja gut funktioniert und ich bin davon ausgegangen, dass es jetzt offiziell in der ETS implementiert ist.

Leider klappt der Download via Internet bei mir nicht (der UniCast Test schlägt fehl), allerdings läuft das Tool von Peter Pan in der exakt gleichen Umgebung einwandfrei.

Gibt es für das Forwarding im Router vielleicht noch neue Anforderung gegenüber der alten Variante ?
Die Release Notes von KNX erwähnen diese Funktion erst gar nicht !

Vielen Dank im voraus und ein schönes WE

Uwe (Bullibus)
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #2  
Alt 29.05.2009, 17:02
Benutzerbild von multimedia
Erfahrener Benutzer
 
Registriert seit: 20.06.2008
Ort: Ainring (D) und Valbonne (F)
Beiträge: 564
Standard

Wollte das Thema nochmal aufgreifen.
Habe das gleiche Problem beim Zugriff auf ein entferntes KNX IP Gate.

Lokal funktioniert alles bestens,
Am entfernten Router ist Port forwarding korrekt eingerichtet,
Ping test funktioniert ebenso (auch über den ETS Ping Test),
Unicast Test schlägt fehl.

Woran kann das liegen?
__________________
Chris von www.proknx.com
KNX-proServ Supportforum. Bitte möglichst die Produktfragen zu unserem iOS und Android Controller hier posten.
Raspberry IP-extension zur SONOS Steuerung, konfiguriert über die ETS Produktdatenbank des proServ
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #3  
Alt 01.06.2009, 19:54
Benutzerbild von multimedia
Erfahrener Benutzer
 
Registriert seit: 20.06.2008
Ort: Ainring (D) und Valbonne (F)
Beiträge: 564
Standard

So, nun habe ich ne Menge gelesen und probiert.

Unter anderem habe ich das Tool von Peterpan heruntergeladen, obwohl dies wohl mit der ETS Version 3.0f nicht mehr erforderlich ist, da es da ja den NAT-Modus zum Auswählen gibt. Habe dabei auch die Ratschläge aus diesem Forum probiert, entgegen der Dokumentation im NAT Programm die lokale IP Adresse des Gates zu verwenden. Funktionierte leider auch nicht.

Hier die genaue Problembeschreibung:

- Ich versuche mit ETS 3.0f über Internet auf ein entferntes IP/KNX Gate zuzugreifen
- In der ETS habe ich die öffentliche IP des entfernten Routers eingegeben und den NAT Modus aktiviert
- Firewall läßt die Kommunikation der ETS mit dem Internet zu
- Im entfernten Router ist der Port 3671 zum IP/KNX Gate durchgeschaltet
- Das IP/KNX Gate arbeitet im tunneling Modus.
- Im KNXnet/IP Diagnoseassistent der ETS funktioniert der "Entferntes Gerat Ping Test", aber der "unicast Test" schlägt fehl

Auch bei Verwendung des Tools EIBnetIP_NAT_Support_Setup.zip ist keine Kommunikation möglich.

Hat vielleicht doch noch jemand hier Erfahrung und einen Ratschlag, der sich auf die ETS Version 3.0f bezieht?
Herzlichen Dank im Voraus
__________________
Chris von www.proknx.com
KNX-proServ Supportforum. Bitte möglichst die Produktfragen zu unserem iOS und Android Controller hier posten.
Raspberry IP-extension zur SONOS Steuerung, konfiguriert über die ETS Produktdatenbank des proServ
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #4  
Alt 02.06.2009, 09:09
Benutzerbild von multimedia
Erfahrener Benutzer
 
Registriert seit: 20.06.2008
Ort: Ainring (D) und Valbonne (F)
Beiträge: 564
Ausrufezeichen

So, nun ist hat sich doch noch alles geklart.

Für alle, die einmal ahnliche Probleme haben:

- Das EIBnetIP_NAT_Support Tool zur NAT Aktivierung ist (wie schon vermutet) für die ETS ab Version 3.0f nicht mehr erforderlich.
- Als Adresse ist in der ETS die öffentliche Adresse des entfernten Routers einzustellen, der vor dem IP/KNX Gate liegt.
- Der NAT Modus ist zu aktivieren.
- Die Firewall muß den Zugang der ETS zum Internet zulassen.
- Das Portforwarding an dem entfernten Router ist auf 3671 UDP einzustellen (nicht TCP!, das war mein Fehler)
- Auch wenn der unicast test nicht funktioniert, kommt eine Verbindung zustande.

Bei Fragen, einfach antworten!
__________________
Chris von www.proknx.com
KNX-proServ Supportforum. Bitte möglichst die Produktfragen zu unserem iOS und Android Controller hier posten.
Raspberry IP-extension zur SONOS Steuerung, konfiguriert über die ETS Produktdatenbank des proServ
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #5  
Alt 08.07.2009, 15:55
Benutzerbild von Olli.O
Benutzer
 
Registriert seit: 18.05.2008
Ort: Essen
Beiträge: 105
Standard

Hey Chris,

hatte das gleich Problem, mit EIBnetIP_NAT_Support Tool funzte es aber.
Hast Du vieleicht in der ETS noch die öffentliche IP des Router stehen?
Bei Verwendung vom sep. NAT Tool muß da die 127.0.0.1 stehen.:-)
__________________
Gruß

Olli
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #6  
Alt 23.02.2010, 22:03
Neuer Benutzer
 
Registriert seit: 23.02.2010
Ort: Piberbach
Beiträge: 2
Standard

Hallo

Ich habe das selbe Problem mit einer IP-Schnittstelle ABB IPS/S2.1!!
mit welcher Schnittstelle hattest du dein Problem???
kannst du mir helfen?

Danke

Mfg
Jarno
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are aus
Pingbacks are aus
Refbacks are aus



Alle Zeitangaben in WEZ +2. Es ist jetzt 15:29 Uhr.