Zurück   KNX-User-Forum > Öffentlicher Bereich > Sonstiges / Verwaltung / Archiv
knx-user-forum - International KNX Award Winner 2010



Antwort
 
Themen-Optionen Ansicht
  #41  
Alt 19.10.2012, 09:37
Erfahrener Benutzer
 
Registriert seit: 05.07.2010
Ort: Bayern, Obing
Beiträge: 1.292
Standard

Ja das mit einer Sound Karte ist klar. Hätte aber PA am Laufen.
Avahi nicht? ! Daher meine Frage. ich hätte zum testen dem shairport die Soundkarte überlassen... aber gehen tut es nicht wegen avahi.

Gruß
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #42  
Alt 19.10.2012, 22:27
Benutzerbild von makki
Erfahrener Benutzer
 
Registriert seit: 07.07.2007
Ort: München
Beiträge: 12.095
Standard

Avahi hat nichts mit der Soundkarte zu tun

Der Punkt ist, es kann nur einer auf die Karte via Alsa - und das Shairport kann soweit ich das sehe nur Alsa, kein PA (was blutig ist aber dieses Problem löst) - Also entweder/oder..

Makki
__________________
EIB/KNX & HS3(+Lüfter+picoPSU80), Multiroom-AV mit Russound,mpd,vdr,DM8000, Profilux II+, N141 DALI, DMX, dez. Lüfter (RS485), Wärmepumpe (RS422), 30+ 1-Wire Temp,Luft&Bodenfeuchte,IRTrans
WireGate - Supportforum - bitte keine PN's! - Meine eMail ist Vorname@Nachname.de
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #43  
Alt 19.10.2012, 22:41
Erfahrener Benutzer
 
Registriert seit: 05.07.2010
Ort: Bayern, Obing
Beiträge: 1.292
Standard

Das avahi nix mit der Soundkarte zu tun hat ist klar. Aber dbus bringt eben diese Meldung. (Daher die Vermutung das es am avahi kachelt, und der dbus deswegen spinnt)
Mein Plan wäre gewesen dem shairport ein eigenes pcm Device zu geben, und es dann per PA auf eine echte Soundkarte zu schieben.

Gruß
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #44  
Alt 19.10.2012, 23:22
Benutzerbild von makki
Erfahrener Benutzer
 
Registriert seit: 07.07.2007
Ort: München
Beiträge: 12.095
Standard

nun, ich kann dazu wenig sagen, bin mit meinem mpd mehr als glücklich; Ei & Co hab ich ned, ich kanns packagen aber das wars dann..
Nach meinem Verständniss greift das Shairport aber direkt auf die libao (Alsa), wird die Soundkarte also exklusiv für sich wollen..

Makki
__________________
EIB/KNX & HS3(+Lüfter+picoPSU80), Multiroom-AV mit Russound,mpd,vdr,DM8000, Profilux II+, N141 DALI, DMX, dez. Lüfter (RS485), Wärmepumpe (RS422), 30+ 1-Wire Temp,Luft&Bodenfeuchte,IRTrans
WireGate - Supportforum - bitte keine PN's! - Meine eMail ist Vorname@Nachname.de
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #45  
Alt 03.11.2012, 19:46
Benutzerbild von Chris M.
Erfahrener Benutzer
 
Registriert seit: 14.12.2008
Ort: Oberbayern
Beiträge: 5.592
Standard

Hab jetzt mal das shairport Paket ausprobiert.

Positiv: Die Standard-Music-App auf dem iPad erkennt's und spielt Musik wunderbar darüber ab

Negativ:
Die Musik-App meines NAS (also "DS audio" da Synology) findet auch den Shairport, kaum möchte ich darüber spielen, verschwindet es aus der Liste der verfügbaren Geräte.
Ein Check auf dem WG zeigt mir, dass der Prozess sich beendet hat.

Also mal per Hand:
Code:
root@wiregate655:/var/log# /usr/bin/shairport.pl -v    
**************************************
* IO::Socket::INET6 not present!     *
* Install this if iTunes won't play. *
**************************************

Listening...
Established under name '51F07308BF03@ShairPort 3865 on wiregate655'
So weit so gut. Nun mal einen Titel abspielen:
Code:
New connection from 192.168.0.30
REQ: OPTIONS
REQ: ANNOUNCE
Use of uninitialized value in print at /usr/bin/shairport.pl line 639.
Use of uninitialized value in subroutine entry at /usr/bin/shairport.pl line 641.
avahi daemon terminated or 'avahi-publish-service' binary not found at /usr/bin/shairport.pl line 237.
Audio Stream
Mist. Zumindest mal avahi checken:
Code:
root@wiregate655:/var/log# locate avahi-publish-service 
/usr/bin/avahi-publish-service
root@wiregate655:/var/log# ps aux  | grep avahi
106       1721  0.0  0.3   1944   740 ?        S    Oct17   0:10 avahi-autoipd: [eth0] bound 169.254.6.54      
root      1722  0.0  0.1   1732   252 ?        Ss   Oct17   0:00 avahi-autoipd: [eth0] callout dispatcher      
avahi     2634  0.0  0.6   2928  1528 ?        S    Oct17   0:13 avahi-daemon: running [wiregate655.local]
avahi     2635  0.0  0.1   2800   328 ?        Ss   Oct17   0:00 avahi-daemon: chroot helper
Hat jemand eine Ahnung was hier schief läuft?
__________________
TS2, B.IQ, DALI, WireGate für 1wire so wie Server für Logik und auf HomeCockpit Minor. - Bitte keine PNs, Fragen gehören in das Forum, damit jeder was von den Antworten hat!
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #46  
Alt 04.11.2012, 09:36
Benutzerbild von 2ndsky
Erfahrener Benutzer
 
Registriert seit: 24.10.2010
Ort: Amtzell
Beiträge: 6.052
Standard

Bei mir kommt es auch gelegentlich vor, dass shairport nach dem Abspielen (also wenn ich das Abspielen beende) sich beendet. Hab bisher noch nicht nach dem Problem gesucht, da hier noch einige kleine Baustellen im Haus sind die vorgehen und man den shairport mittels ssh Client am iPhone auch schnell wieder gestartet hat. Nichts hält länger als ein Provisorium
__________________
Mit freundlichen Grüßen
Niko Will

Logiken und Schnittstelle zu anderen Systemen: smarthome.py - Visualisierung: smartVISU
- Gira TS3 - iPhone & iPad - Mobotix T24 - ekey - Denon 2313 - Russound C5 (RIO over TCP Plugin) -
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #47  
Alt 08.01.2013, 15:35
Neuer Benutzer
 
Registriert seit: 08.01.2013
Ort: Würzburg
Beiträge: 1
Standard

Zitat von Chris M. Beitrag anzeigen
Hab jetzt mal das shairport Paket ausprobiert.

Positiv: Die Standard-Music-App auf dem iPad erkennt's und spielt Musik wunderbar darüber ab

Negativ:
Die Musik-App meines NAS (also "DS audio" da Synology) findet auch den Shairport, kaum möchte ich darüber spielen, verschwindet es aus der Liste der verfügbaren Geräte.
Ein Check auf dem WG zeigt mir, dass der Prozess sich beendet hat.

Also mal per Hand:
Code:
root@wiregate655:/var/log# /usr/bin/shairport.pl -v    
**************************************
* IO::Socket::INET6 not present!     *
* Install this if iTunes won't play. *
**************************************

Listening...
Established under name '51F07308BF03@ShairPort 3865 on wiregate655'
So weit so gut. Nun mal einen Titel abspielen:
Code:
New connection from 192.168.0.30
REQ: OPTIONS
REQ: ANNOUNCE
Use of uninitialized value in print at /usr/bin/shairport.pl line 639.
Use of uninitialized value in subroutine entry at /usr/bin/shairport.pl line 641.
avahi daemon terminated or 'avahi-publish-service' binary not found at /usr/bin/shairport.pl line 237.
Audio Stream
Mist. Zumindest mal avahi checken:
Code:
root@wiregate655:/var/log# locate avahi-publish-service 
/usr/bin/avahi-publish-service
root@wiregate655:/var/log# ps aux  | grep avahi
106       1721  0.0  0.3   1944   740 ?        S    Oct17   0:10 avahi-autoipd: [eth0] bound 169.254.6.54      
root      1722  0.0  0.1   1732   252 ?        Ss   Oct17   0:00 avahi-autoipd: [eth0] callout dispatcher      
avahi     2634  0.0  0.6   2928  1528 ?        S    Oct17   0:13 avahi-daemon: running [wiregate655.local]
avahi     2635  0.0  0.1   2800   328 ?        Ss   Oct17   0:00 avahi-daemon: chroot helper
Hat jemand eine Ahnung was hier schief läuft?

Hallo zusammen
Den oben beschriebenen Fehler bekomme ich auch mit meiner Discstation. Hat jemand dafür ne Lösung?
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #48  
Alt 16.01.2013, 03:20
Benutzerbild von makki
Erfahrener Benutzer
 
Registriert seit: 07.07.2007
Ort: München
Beiträge: 12.095
Standard

Könnte den Meldungen nach ein Ipv6-"Feature" sein.. Kann ich aber mangels (Sh)airport und völlig nutzlosem IPv6 nur schlecht bewerten
-> Gehts mit / ohne? (auf dem WG ist IPv6 - sehr absichtlich - deaktiviert..)

Makki
__________________
EIB/KNX & HS3(+Lüfter+picoPSU80), Multiroom-AV mit Russound,mpd,vdr,DM8000, Profilux II+, N141 DALI, DMX, dez. Lüfter (RS485), Wärmepumpe (RS422), 30+ 1-Wire Temp,Luft&Bodenfeuchte,IRTrans
WireGate - Supportforum - bitte keine PN's! - Meine eMail ist Vorname@Nachname.de
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #49  
Alt 21.01.2013, 23:27
Erfahrener Benutzer
 
Registriert seit: 17.12.2007
Ort: Cuxhaven
Beiträge: 2.804
Standard

Chris hast du den mal probiert?
https://github.com/E2OpenPlugins/e2o...rplayserver.py

Ist mir gerade übern weg gelaufen.
__________________
Nils
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
  #50  
Alt 26.03.2013, 18:58
Benutzer
 
Registriert seit: 11.08.2011
Ort: München
Beiträge: 105
Standard

Wenn ich shairport installiere wird mpd entfernt. Gibt es da Konflikte bei den benutzten Paketen?

Code:
root@wiregate735:~# apt-get install shairport
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht länger benötigt:
  libartsc0 libavutil49 libsensors4 libxvidcore4 libvorbisfile3
  libresid-builder0c2a libspeex1 esound-common libvorbisenc2 libavformat52
  libamrnb3 libwavpack1 libx264-65 libschroedinger-1.0-0 libmp3lame0 libamrwb3
  libsidutils0 libdirac0 libesd0 libtheora0 libice6 lm-sensors libsamplerate0
  libflac8 libaudiofile0 libshout3 libgsm1 libasyncns0 libsidplay2
  libavcodec51 libmad0 libid3tag0 libmodplug0c2 libsm6 libpulse0 liboil0.3
  libavahi-glib1 esound-clients libvorbis0a libaudio2 libxt6 libmpcdec3
  libsndfile1 libmms0 libogg0 libfaac0 libfaad0 liba52-0.7.4
Verwenden Sie »apt-get autoremove«, um sie zu entfernen.
Die folgenden zusätzlichen Pakete werden installiert:
  libao2
Die folgenden Pakete werden ENTFERNT:
  libao-common libao4 mpd
Die folgenden NEUEN Pakete werden installiert:
  libao2 shairport
0 aktualisiert, 2 neu installiert, 3 zu entfernen und 11 nicht aktualisiert.
Es müssen noch 0B von 67,8kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 487kB Plattenplatz freigegeben.
Möchten Sie fortfahren [J/n]?
P.S.: Auch ich habe kein I* Gerät. Aber Airplay kann auch unter jedem anderen OS benutzt werden z.B. mittels Airfoil unter Windows.
Damit kann ich einfach schnell z.B. ein Youtube Video zeigen und die Audio Ausgabe an meine Lautsprecher weiterleiten.
Bei Google nach dem markiertem Wort suchen Bei Wikipedia nach dem markiertem Wort suchen Im Forum nach dem markiertem Wort suchen
Mit Zitat antworten
Antwort

Themen-Optionen
Ansicht

Forumregeln
Es ist dir nicht erlaubt, neue Themen zu verfassen.
Es ist dir nicht erlaubt, auf Beiträge zu antworten.
Es ist dir nicht erlaubt, Anhänge hochzuladen.
Es ist dir nicht erlaubt, deine Beiträge zu bearbeiten.

BB-Code ist an.
Smileys sind an.
[IMG] Code ist an.
HTML-Code ist aus.
Trackbacks are aus
Pingbacks are aus
Refbacks are aus



Alle Zeitangaben in WEZ +2. Es ist jetzt 05:38 Uhr.