Ankündigung

Einklappen
Keine Ankündigung bisher.

BabTec EibPort V3 mit Permanenten Abstürzen

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    BabTec EibPort V3 mit Permanenten Abstürzen

    Hi Zusammen,

    ich hab hier einen EibPort V3 am Laufen, über welchen ich fast alle Logiken (ein paar wenige über EDOMI) und auch meine Visualisierung (Control L) laufen habe.

    Ich hab hier nur ein Problem mit der Kiste, denn der Eibport hängt sich in regelmäßigen abständen weg und initalisiert sich neu. Ich kann hinter den Abstürzen keine Logik erkennen. Manchmal läuft er ein zweit tage durch, manchmal hängt er sich mehrmal in einer Stunde weg, aber im Schnitt dürfte es so alle 2-4 Stunden einmal sein. Der Zustand ist natürlich ziemlich bescheiden, da sich wenn er sich neu Initalisiert er natürlich auch manche Werte in den Logiken sendet, die ich benötige damit alles richtig läuft, wenn die Kiste mal geplant neu gestartet wird.
    Hat vorgestern meine Gäste in den Wahnsinn getrieben da sich bei neu Initalisierung die Lichtszene immer wieder geändert hat und das war mehrmals so... Aber das ist nur Nebensache...

    Das eigentliche Problem ist, dass ich den Abstürzen nicht auf die schliche komme und ich keine Idee habe wo ich ansetzen soll.

    Ich hatte auch schon zweimal Kontakt mit BabTec. Die meinten aber nur immer dass dann die Buslast zu hoch sein muss und sich der EibPort bei zu hoher Telegramm-Last zum Schutz weghängt.... Aber das kann es doch nicht sein, dass sich eine KNX Server einfach weghängt wenn zuviele Telegramme laufen. (Finde ich zumindest)
    Ich hab mir eigentlich KNX im Neubau geleistet um ein stabiles System zu haben und Kein Frickelwerk als wenn ich HomeKit über einen Raspberry Pi am laufen habe.
    Das Gegenteil ist anscheinend der Fall....

    Nichts desto trotz habe ich natürlich die Telegrammlast geprüft, alle Logiken umgeschrieben, die eine Hohe Telegramm last verursachen könnten, zyklische Abrufe soweit wie möglich minimiert, den Logikeditor auf maximal 10 Telegramme gestellt, Edomi nur auf 7 Telegramme die Wetterstation nur auf maximal 5 usw.

    Derzeit habe ich eine Buslast von 5-6 Telegrammen maximal. Vielleicht mal maximal 11 wenn es hart auf hart kommt, aber nicht mehr.
    Kann man ja in Edomi in der Konsole und in den Logs und auch in der ETS recht schön verfolgen....

    Aber das Ding hängt sich immer noch weg und ich hab keine Ahnung warum.

    Hat irgendjemand von Euch, beim EibPort schon mal ein ähnliches Verhalten gehabt, oder kann mir wer sagen wie ich dem ganzen auf die schliche kommen kann???

    Ich wüsste auch nicht wo ich im EibPort Logs einsehen kann die mir verraten warum er abgestürzt ist, damit ich wenigstens mal weis wo ich anfangen soll...

    Ich bin echt ratlos und frustriert. Ich hab mein neues Haus jetzt seit 1 1/2 Jahren und ein KNX Smart Home war/ist ein Herzensprojekt, aber so macht es echt kein Spaß.
    Selbst ein Windows 8 Rechner läuft stabiler.
    Hab sogar schon mit dem Gedanken gespielt alle Logiken neu in Edomi zu schreiben oder mir noch einen HS zuzulegen.... Aber ich hab 1. Keine Lust mir die Arbeit nochmal zu machen (schon wieder) und 2. kann das nicht die Lösung sein, da der EibPort ja auch nicht wenig geld gekostet hat und dafür auch das tun soll für das er gekauft wurde.

    Ich hoffe jemand kann mir helfen der Sache auf die Schliche zu kommen.

    Grüße

    Andi
    Zuletzt geändert von MatthiasS; 24.04.2019, 21:56.

    #2
    Hi, welche Firmware hast du drauf - aktuell ist ja die 3.7.3.

    Hatte mal so ein ähnliches Problem, da konnte ich S0 Zähler Job als Verursacher identifizieren.

    Hast du nur Logikeditor Sachen oder auch Jobs?

    Schalt mal einzelne Jobs oder Logikeditor Programme ab um so den Verursacher zu identifizieren.

    Kommentar


      #3
      Zitat von andijegg Beitrag anzeigen
      Hat irgendjemand von Euch, beim EibPort schon mal ein ähnliches Verhalten gehabt, oder kann mir wer sagen wie ich dem ganzen auf die schliche kommen kann???
      Gleich nach dem Kauf hat mein eibPort V3 sporadische Bootprobleme gehabt und der Grund lag an schlechten Kontakt mit der internen microSD-Karte. Die microSD-Karte im eibPort DIMMboard ist mit Heisskleberklecks an den Kartenhalter befestigt, der bei mir die Karte unter mechanischen Spannung hielt und weg von Klemmen drückte. Nach dessen Entfernung und anschließenden neu-Einbringung, funktioniert mein eibPort nun seit Jahren tadellos.

      (Disclaimer: Falls dein eibPort noch Garantie hat, wäre sicherlich der richtige/bessere Weg es an die Werk zur Überprüfung/Reparatur zu schicken.)
      Werner Heisenberg hat mal gesagt: "Ein Fachmann ist ein Mann, der einige der größten Fehler kennt, die man in dem betreffenden Fach machen kann, und sie deshalb zu vermeiden versteht."

      Kommentar


        #4
        Verschickst du mit deinem eibport Mails oder machst sonst irgendwelche Abfrage im Internet?
        Etwaige NTP, DNS, SMTP, POP3, etc Server die du du verwendest sind alle gültig und erreichbar?

        Kommentar


          #5
          Hi, Danke für die Antworten.


          ​​​​​​​xrk
          Ich denke eben auch, dass es an irgend einen kleinen Fehler an der Hardware liegt. Denn die Fehler sind so sporadisch und nicht reproduzierbar.

          Hab ab ja auch schon von vielen gehört dass die Kiste stabil läuft, darum ist es ja auch zum Schluss der EibPort geworden und nicht der HS oder sonst ein Server.

          Aber es stellt einem die Haare auf wenn man die Heißkleber Kleckse sieht, bei einem KNX Server (welcher eigentlich ein Pi ist und dann ein entsprechender Preis abgerufen wird)

          Ja ich sollte eigentlich noch Garantie drauf haben, die Kiste ist noch keine 2 Jahre alt, darum hab ich ihn auch noch nicht auf gemacht.

          Mein Problem an der Sache ist, dass ich das Ding nicht wirklich ausbauen kann und zu BabTec schicken kann, da dann mein Haus still steht, solange die den Prüfen. Sprich ich bräuchte eigentlich einen Ersatz oder einen zur Überbrückung. Aber darauf will sich BabTec nicht einlassen.
          Ist ja auch ihr gutes Recht erst zu Prüfen an was es liegt.

          Aus Diesem Grund wüsste ich gerne wie ich die Abstürze eingrenzen könnte, um hier auch nachzuweisen dass es an der Hardware liegt.
          Sprich die Fehleranalyse selbst zu liefern.

          Gekauft hab hab ich den EibPort über Voltus.


          JMA

          Nein, derzeit werden keine Mails geschickt oder Abfragen über den EibPort generiert.

          Ich hab ihn eine Weile als IP-Gateway für Edomi verwendet, aber dadurch dass er sich immer weggegangen hat lief dadurch Edomi auch unrund und spuckte natürlich Fehler aus. Darum ist das App-Modul von BabTec jetzt IP-Gatway und Edomi läuft fehlerlos.
          Zuletzt geändert von andijegg; 22.04.2019, 11:09.

          Kommentar


            #6
            Um sicherzustellen dass das Problem an Hardware liegt, folgende Vorschlag:
            1. Mach mit ConfigTool ein Backup
            2. Spiel neueste FW ein (falls schon drauf, dann nochmals das gleiche), dies setzt alle Einstellungen auf Fabrikzustand
            3. Las halbe Tag (z.B. übers Nacht) laufen und schau danach ob es ohne Zwischenfälle mit Fabrikeinstellungen durchgelaufen hat oder nicht.
            Falls nicht, liegt mit hohem Wahrscheinlichkeit defekt an HW vor und es gibt dann kein Weg vorbei um es an Bab-Tec zu schicken.

            P.S. Es handelt bei dem Recheneinheit nicht um Raspberry Pi, sondern um ein für Bab-Tec hergestellte Vortex 86 DIMMBoard.
            Zuletzt geändert von xrk; 22.04.2019, 11:30.
            Werner Heisenberg hat mal gesagt: "Ein Fachmann ist ein Mann, der einige der größten Fehler kennt, die man in dem betreffenden Fach machen kann, und sie deshalb zu vermeiden versteht."

            Kommentar


              #7
              Gute Idee, das werd ich machen. Danke für den Vorschlag.

              Neuste Version ist natürlich drauf.

              Kommentar


                #8
                Hallo
                Ich habe seit Jahren das selbe Problem. Der Babtec Support hat leider auch keine Ursache gefunden. Nach einem Austausch der Hardware war es zwar merklich besser. Nach einem FW Update letztes Jahr tritt es nun wieder öfters auf. Zwar nicht Stündlich aber mehr als 4-5 Tage läuft der EIBPORT aber leider nicht durch. Was der Auslöser diese Reboots ist, habe ich bis jetzt auch nicht herausgefunden. Die Versuche Mail, SO, 1Wire oder Job abschalten habe mich auch auf keine Ursache geführt. Der Austausch der HW nur kurzfristig. Solltet du doch noch die Ursache herausfinden dann lass es mich bitte wissen.

                Kommentar


                  #9
                  Wie ist der Austausch der Hardware bei dir von Statten gegangen? Ich hab echt schiss dass ich mehrere Tage ohne KNX Server auskommen muss.

                  Kommentar


                    #10
                    Ich würd versuchen, die wichtigen Dinge nicht über den Server zu machen.
                    Manche Logiken hab ich über KNX Geräte gemacht. Da sind ja oft Logikgatter enthalten.

                    Kommentar


                      #11
                      Hast du auch schon in den Systemeinstellungen alle eingetragenen IP Adressen (NTP, DNS, Mail Server, etc..) überprüft ob die erreichbar sind?

                      Ich hatte mal ein Problem, dass mein eingetragener NTP-Server abgeschaltet wurde, hatte meinem eibPort auch nicht gefallen und er hat es mit Neustarts quittiert.
                      Hardware Defekt kann man natürlich auch nie ganz ausschließen.....
                      Aktuell läuft mein eibPort seit 43,5 Tagen.

                      Kommentar


                        #12
                        Ja das war so. Ich musst ca. ein Woche ohne meinen Eibport auskommen. Ich habe mir ein paar Taster für die wichtigsten Funktionen programmiert und diese dann per Hand ausgelöst.

                        Kommentar


                          #13
                          Dinkel75 Klar elementare Logiken mache ich auch soweit es geht ohne server. Aber bei uns läuft alles über PM und Tag und Nachtzustände mit verschiedenen Szenen. Ich hab an manchen Zimmertastern nicht mal das Licht zum Schalten Programmiert.

                          Sprich mittlerweile läuft sehr viel einfach über bestimmte Logiken, die mit KNX Teilnehmer nicht abzubilden sind. Klar kann ich mir das übergangsweise so umprogrammieren dass ich das behelfsmäßig über Taster schalten kann, aber eben nicht ohne erheblichen Aufwand.

                          JMA NTP und DNS Server ist meine eigene Unifi USG als zweiter DNS der 8.8.8.8 von Google. Meine USG läuft seit Monaten ohne Störung durch. Mailserver oder sonstiges hab ich nicht konfiguriert.

                          Ich hab gestern noch das Update auf 3.73 gemacht. Seither läuft er durch Derzeit 1 Tag und 10 Std. Das ist die längste Zeit seit langem. Ich schau ja jeden Tag mal auf die Seite wie lange der EibPort online ist, 1 tag hatte ich schon lange nicht mehr.
                          Aber wenn ich mich recht erinnere ist er nach dem letzten FW Update auch erst mal 2-3 Tage gelaufen, bis die Abstürze wieder anfingen.

                          Kommentar


                            #14
                            EDIT:

                            Ich finde es nur echt bescheiden, dass es nicht mal ein vernünftiges Log gibt an dem man sehen kann warum die Kiste aussteigt.

                            Kommentar


                              #15
                              Mein schlimmstes Problem war mal, eine Bootschleife.
                              Problem war: eibport schickt mir Telegram Nachricht, wenn Alarmanlage ein bzw. ausgeschaltet wird. Leider hatte ich aber einen Internetausfall für einige Stunden. Das hat dem eibport gar nicht gefallen! Hat erst wieder funktioniert, als auch das Internet wieder OK war. Jetzt hab ich noch eine "Internet-Ein" Abfrage bevor ich mir Nachrichten schicke, damit das nicht mehr funktioniert. Bin mir nicht sicher, ob das vom Support in einem Update schon ausgeräumt wurde - im Changelog hab ich davon noch nix gelesen.

                              Kommentar

                              Lädt...
                              X