Ankündigung

Einklappen
Keine Ankündigung bisher.

KNX Welten verbinden (Bereiche und Linien bei proprietären Komponenten)

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    KNX Welten verbinden (Bereiche und Linien bei proprietären Komponenten)

    Hallo zusammen, ich möchte euch um eine Empfehlung bitten.

    In unser neues Eigenheim ziehe ich eine KNX Anlage ein. Das Haus selber wurde von einer Firma gebaut, die bereits ein proprietäres System (myGEKKO) mit einem KNX Teil eingebaut hat.

    Ich überlege nun über die richtige Anordnung der Bereiche und Linien. Ich wollte eine Hauptlinie ziehen, die alle Hausgeräte umfasst und das vorhandene System mit einem Koppler einbindet. Sozusagen die Sparvariante der Hauptlinie aus den einschlägigen Threads dazu. Hier bitte ich um Empfehlung.

    Das vorhandene myGEKKO System hat bindet die Teilnehmer über einen Buszweig ein. Die physikalischen Adressen sind 10.10.x und 10.11.x - dieser Bereich und sind fix, daran kann ich nicht viel ändern (erstmal).
    Ich wollte meine Hauptlinie im Bereich 1.1.x erschaffen und, wie gesagt, den anderen Bereich per Koppler in die Hauptlinie holen.

    Macht das Sinn oder wird dies zu Konflikten führen? Würde es mehr Sinn machen, die Hauptlinie auch in den Bereich 10 zu legen, oder ist das irrelevant? Was würdet ihr machen, wenn ihr auf solche Gegebenheiten stoßen würdet?

    Danke und Gruß

    #2
    Nim daoch die 10.0.x als Hauptlinie, dann bleibst du im Bereich und alles ist sauber, Wie sind den 10.10 und 10.11 miteinander verbunden? Normalerweise geht das ja nur über eine 10.0.x Linie. Enweder ist bei Dir Pfusch verbaut, oder es gibt die Hauptlinie ja schon.
    Mfg Micha
    Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

    Kommentar


      #3
      Hi Micha, danke für den Vorschlag, werde ich wahrscheinlich so machen, dann bin ich auch weniger verwirrt über den Bereich.

      Wahrscheinlich ist es "Pfusch", aber im begrenzten Rahmen der bei mir verbauten Lösung funktioniert es wohl. Das System wird mit genau einer KNX Leitung verwendet. Die Linien 10.10. und 10.11. hängen beide da drauf, ohne Koppler.

      Die Idee dabei bei myGEKKO ist, dass die Teile schon vorprogrammiert sind und in ihrem Adressbereich stark definiert sind. Beim Hauptgerät sagt man nur noch "Dies ist ein myGEKKO 8-fach Taster, mit der Adresse 68", dann weiß myGEKKO "ok, es handelt sich um einen Taster mit der phys. Adresse 10.11.68 - dieser phys. Adresse ist der Gruppenadressenbereich 2/7/1 - 2/7/20 zugeordnet und auf 2/7/1 liegt Taste 1, auf 2/7/2 Taster 2 usw."

      Mal so gefragt, was ist eigentlich der Unterschied bzw. was passiert, wenn man z.B. Linie 1.1. und 1.2. auf ein Kabel legt, anstatt einen Koppler zu verwenden (abgesehen von der SV) entgegen eines Kopplers ohne Filterung?

      Danke und Gruß

      Kommentar


        #4
        Koppler ohne Filterung macht man genauso wenig, der leitet einen Befehl in die Linie, wo er nichts zu suchen hat (es gibt keinen Teilnehmer der diese GA nutzt). Es kommt dann auf dieser Linie kein ACK, und der Kopller sendet diese GA noch 2 Mal. Solange nichts los ist, auf dem Bus funktioniert das, bei hoher Last müllst Du Dir den Bus zu. Das kann zu "verstopften" LK und zu verzügerten telegrammen führen. Meist ist die Fehlersuche dann das Aufwendigste, da es ja nicht immer auftritt.
        Mfg Micha
        Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

        Kommentar


          #5
          Danke für die Zusammenfassung. An die ACK hätte ich nicht gedacht. Ich hatte meist nur gelesen, dass es bei kleinen Installationen keine Rolle spielt.

          Was spricht im Übrigen gegen das Verbinden von Linien ohne Koppler, wie oben beschrieben?

          Letzte, wahrscheinlich wirklich dumme Frage, ich bin nicht im Stande eine 10.0. oder 1.0. Linie in der ETS zu erzeugen, bei mir geht es erst mit x.1. los. Hier mache ich doch etwas falsch, oder?

          Kommentar


            #6
            Wenn Du dann einen Koppler einbaust, so wie Du es vor hast, wird er nur die Telegramme weiterleiten, die in die jeweilige Linie gehören. Dann bekommst Du halt Probleme, aber sonst geht sicher alles. Der Rest geht wenn Du auf Topologie einen Rechtsklick machst, dann hinzufügen, Bereich hinzufügen.
            Mfg Micha
            Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

            Kommentar


              #7
              Nochmal danke. Hmmm, ich kann keine 0-Linie hinzufügen. Der erste freie Bereich = 1, dann Anlegen einer Linie - erste freie Adresse führt zu 1.1 ... Ich kann die 0-Linie durch Vorauswahl auch nicht forcieren.

              Kommentar


                #8
                Du sollst ja auch keine Linie hinzufügen, sondern einen Bereich: Dazu einen Rechtsklick ganz oben auf "Topologie Backbone".

                Topologie.PNG
                Mfg Micha
                Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

                Kommentar


                  #9
                  Bei mir steht da lediglich "Topologie". Mit Rechtsklick kann ich Bereiche, Linien und Geräte hinzufügen. Klicke ich auf Bereich, wird Bereich 1 hinzugefügt. Dann kann ich eine Linie hinzufügen, diese wird dann zur 1.1

                  Verflucht, ich mache definitiv etwas falsch, aber was?

                  Kommentar


                    #10
                    Benenne doch den Bereich 1 in Bereich 10 um, oder wähle beim einfügen die letzte Option „Starte mit 10“, wobei Du halt die 10 manauell eintragen musst.
                    Mfg Micha
                    Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

                    Kommentar


                      #11
                      Ah, ich glaube, wir reden aneinander vorbei. Natürlich kann ich Bereiche anlegen und ändern, aber ich kann keine Linie beginnend mit 0 innerhalb eines Bereiches anlegen. 10.1.xxx geht, aber 10.0.xxx bekomme ich nicht hin.

                      Kommentar


                        #12
                        Das ist die 10.0 Dort kannst Du jetzt Geräte direkt im Bereich einfügen, wenn Du einen IP Router einfügst, bekommt der die 10.0.0
                        Mfg Micha
                        Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

                        Kommentar


                          #13
                          Ahhhh, jetzt verstehe ich! Herzlichen Dank! Das ist aber schon ziemlich versteckt und völlig unlogisch.
                          Danke, dass du dir die Zeit dafür genommen hast.

                          Kommentar


                            #14
                            Zitat von Phyxx Beitrag anzeigen
                            Was spricht im Übrigen gegen das Verbinden von Linien ohne Koppler, wie oben beschrieben?
                            Linien sind ein logisches Konstrukt, dazu gedacht, viele Telegramme über einen an sich langsamen Bus zu schicken. Das macht man über Segmentierung und Kopplung. Statt einer Leitung macht man mehrere, die man mit geeigneten Geräten koppelt. Natürlich kannst Du an eine physikalische Leitung verschiedene Geräte verschiedener Linien anschließen (bei Dir 10.10 und 10.11), die werden miteinander kommunizieren können, es wird alles funktionieren - aber damit hast Du noch lange nicht 2 Linien, sondern nur falsch vergebene PA an den Geräten.

                            Wenn Du wirklich verschiedene Linien (z.B. mit je 200 Geräten) ohne Koppler verbinden würdest, hast Du sofort folgende Probleme:
                            • 1 Netzteil kann nicht 400 Geräte treiben, 2 Netzteile sind ohne Kopplung nicht erlaubt (ich weiß, es gibt Ausnahmen, aber hier geht es ums Prinzip)
                            • 400 Geräte sind auf einem physikalischen Segment nicht zugelassen
                            • Die Leitung würde mit den Protokollen der 400 Geräte überlastet
                            Alles nur hypothetisch, weil so nicht möglich...

                            Gruß, Waldemar

                            Kommentar


                              #15
                              Eigentlich könnte er ja den Geräten durch das überschreiben der GA die richtige Linie zuweisen. Die Programierung wird ja dadurch nicht verändert.
                              Oder frag mal bei myGekko an, wie die das mit unterschiedlichen Linien handhaben. Theoretisch müsste es ja einen programmierten LK geben
                              Mfg Micha
                              Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

                              Kommentar

                              Lädt...
                              X