Ankündigung

Einklappen
Keine Ankündigung bisher.

OpenHAB 2 keine Verbindung zu Things über KNX-IP-Router

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    OpenHAB 2 keine Verbindung zu Things über KNX-IP-Router

    Hallo Zusammen
    Ich greife per MDT IP-Router (v.0003) über die ETS 5.7.4 auf meinen KNX-Bus zu. Nun möchte ich gerne die Daten auslesen und in mein OpenHAB 2.53 übernehmen und steuern. Ich habe bereits so viel gelesen, das Forum hier durchforstet (z.B. diese tolle Anleitung in diesem Thread https://knx-user-forum.de/forum/supp...-konfigurieren ) und auch die OpenHAB-Doc zum KNX-Binding. Ich komme einfach nicht weiter.

    Ich habe einen OpenHAB extra zum Testen neu aufgesetzt (ContainerStation QNAP) und im Moment nur KNX-Binding installiert.
    Konfiguration über PaperUI. Bisher nur IP-Router hinzugefügt - gemäss vielen Tipps nur Minimum eingegeben: Typ Router, Multicast Adresse 224.0.23.12, OpenHAB-IP im Netzwerk 192.168.169.200, KNX-Port 3671, fetch aus)
    Der Router wird erkannt und online angezeigt.
    Jedes weitere Thing (z.B. Schaltaktor, Dimmer), was ich installieren will (natürlich über Bridge vom Router), wird als offline angezeigt. Auch das Hinzufügen der einzelnen Channels (inkl. Schalt-GA oder Status-GA) ändert nichts.
    Testweise habe ich in der ETS 5.7.4 im IP-Router auf "Alle Gruppen und Physikalische Telegramme weiterleiten" eingestellt. Die Secure-Funktion vom Router habe ich ebenfalls deaktiviert.

    Einer eine Idee, wo ich noch suchen kann?

    #2
    Zitat von Gorki Beitrag anzeigen
    Einer eine Idee, wo ich noch suchen kann?
    Hallo,

    zur Fehlereingrenzung wäre wahrscheinlich noch interessant, ob das KNX/IP Routing grundsätzlich funktioniert. Zum testen könntest du Openhab2 auch mal über Tunneling anbinden, da es KNX-seitig doch einfacher zu konfigurieren ist.

    Bei mir habe ich Openhab2 zwar über Tunneling angebunden, aber habe zum testen schnell Routing konfiguriert.
    Laut Doku des Bindings musst du deine beschriebenen Adressen für eine Minimalkonfiguration nicht konfigurieren.

    Nachfolgend meine Einstellung, wo aber nicht viel zu sehen ist. Habe ja nur ein neues Thing angelegt, und auf Router gestellt.

    2020-04-17_113407.jpg

    Es hat bei mir mit dieser Minimalkonfiguration funktioniert. Jedoch hat es bis zu 2 Minuten gedauert, bis das KNX Device und der IP Router als "ONLINE" angezeigt wurden, und auch tatsächlich etwas senden und empfangen konnte. Aber sobald der KNX/IP Router als "ONLINE" angezeigt wurde, war das KNX Device, welches ich über den IP Router angebunden habe, auch "ONLINE"

    Nachfolgend noch meine Konfiguration des IP-Routers.

    2020-04-17_114724.jpg 2020-04-17_114736.jpg 2020-04-17_114606.jpg


    Viel Erfolg
    Franz
    Angehängte Dateien
    Zuletzt geändert von Fisch; 17.04.2020, 11:00.

    Kommentar


      #3
      Die Frage wäre wohl im openHab Unterforum besser aufgehoben ;-)
      Falls ein Moderator hier mit liest: Kann man den Beitrag ggf. verschieben?

      Zitat von Gorki Beitrag anzeigen
      Konfiguration über PaperUI
      Hast Du Dich bewusst gegen die Nutzung der Konfigurationsdateien entschieden?

      Kommentar


        #4
        Danke für eure Hinweise. Es ist fast erschreckend, wie einfach das bei euch funktioniert 😔
        Im Tunnel-Modus erhalte ich keinen Zugriff auf den IP-Router - er bleibt "Unknown".

        Mittlerweile vermute ich, dass das mit einem anderen Problem zusammenhängt. Vom Laptop aus erhalte ich einen schlechten Zugriff auf meinen IP-Router - die Verbindung bricht immer wieder ab. Der PC kann ganz normal über die ETS mit dem KNX-Bus kommunizieren. Was, wenn OpenHAB auch nicht auf meinen IP-Router zugreifen kann? Mein Netzwerk besteht aus einem Mesh-System von ASUS (RT-AC88U, RT-AC68U per Mesh-LAN, RT-AC68U per Mesh-WLAN mit angeschlossenem IP-Router.
        Ich schaue mal, ob ich das irgendwie umbauen und testen kann...

        Noch eine Antwort vergessen - auf meinem orgininalem OpenHAB habe ich mich mühsam in die Config-Dateien eingearbeitet - fand es bei diesen Problemen aber einfacher über die UI

        Kommentar


          #5
          Ich möchte euch gerne Rückmeldung geben: es hat sich heraus gestellt, dass tatsächlich Datentransfer zwischen NAS und IP-Router problematisch war. Ich weiss zwar noch nicht, woran das genau lag, werde dem Problem nun auf den Grund gehen. Bei Direktanschluss des Routers an einen kabelgebundenen Access-Point funktionierte tadellos. Ich habe also viel Zeit in die Lösungssuche auf Softwareseite investiert, obwohl das Problem wohl in der Hardware steckte.
          Danke nochmal für eure Hilfe.

          Kommentar


            #6
            Hallo zusammen,

            ich würde den Thread gerne nochmal aufleben lassen, da ich vor der selben, leider bis dato unlösbaren Problematik stehe:

            wir haben für ein Projekt ein Belüftungssystem mit KNX realisiert, das wir gerne mit openHAB2 visualisieren würden. OH2 läuft aktuell auf einem Raspberry Pi 3 und als KNX IP Router benutzen wir den MDT SCN-IP100.03 (mit IP und Data Secure).
            Auch wir haben das Problem, dass nur der KNX Router als "online"-Thing in der PaperUI aufscheint, die anderen Geräte (Aktor, Sensor) sind "offline".
            Ich habe schon mehrere Versuche gestartet, wie zB den Bus via OH2 lokal von meinem Rechner anzusprechen, um zu sehen ob es evt am Pi liegt, jedoch habe ich lokal die selbe Problematik - KNX Router ist online, der Rest ist offline. Haben auch schon das Secure Tunneling am Router deaktiviert, ändert aber auch nichts.

            Hier mal ein paar Screenshots von der PaperUI:


            thingsOFFLINE.PNG



            router_param.PNG

            Hier die ETS-Parameter:

            routerParam1.PNG

            routerParam2.PNG
            routerParam3.PNG


            Geräte-Info aus dem Web-Interface des KNX Routers:

            iprouter_webinterface71220.PNG

            Der KNX IP Router hängt via Ethernet an einem Netgear WLAN-Extender, der eiert altersbedingt etwas herum, weiß aber nicht, ob der die Wurzel allen Übels ist.

            Vielleicht hat jmd von euch eine Idee, woran das liegen könnte.
            Angehängte Dateien

            Kommentar


              #7
              Das ist alles kein KNX oder OH Problem sondern ein reines Netzwerkproblem. Können die WLAN Komponenten denn alle Multicast? Bin kein Netzwerkexperte aber wenn man sich die LAN-Probleme mit Router im Forum durchliest wird meist was wegen IGMP oder so als Lösungsstichwort behandelt.
              ----------------------------------------------------------------------------------
              "Der Hauptgrund für Stress ist der tägliche Kontakt mit Idioten."
              Albert Einstein

              Kommentar


                #8
                Zitat von elmosquito Beitrag anzeigen
                Der KNX IP Router hängt via Ethernet an einem Netgear WLAN-Extender, der eiert altersbedingt etwas herum, weiß aber nicht, ob der die Wurzel allen Übels ist.
                Hast du mal versucht, in OH den "IP Connection type" auf Tunneling zu ändern? Ich weiß nicht, ob das KNX Routing über Multicast deine Netzwerktechnik mag.

                Kommentar

                Lädt...
                X