Ankündigung

Einklappen
Keine Ankündigung bisher.

X1 - Problem Logik - Sprunghaftes Verhalten Button

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    X1 - Problem Logik - Sprunghaftes Verhalten Button

    Guten Morgen

    Ich habe leider ein Problem mit dem "X1" was mich komplett verzweifeln lässt!! Alle Einstellungen für Licht und Rollläden waren so weit kein Problem, aber die Heizung zeigt ein Verhalten was ich mir nicht erklären kann. Ich habe mir sehr viel Mühe gemacht alle Einstellungen übersichtlich in einem Screen aufzubereiten, damit jeder die Einstellungen und Verknüpfungen nachvollziehen kann und hoffe so den Aufwand zu minimiere inklusive GA Zuordnung etc! Über Hilfe würde ich mich sehr freuen


    SITUATION:
    Da wir eine alte Elektro-Fußbodenheizung haben, die mit Nachtstrom läuft, habe ich via X1 die Steuerung über einen Schaltaktor umgesetzt, der immer dann schalten soll, wenn IST < SOLL Temperatur ist. Grundsätzlich funktioniert die Logik ohne Probleme, auch das Setzen der Werte für die Betriebsmodies (Komfort,Nacht usw) läuft gut.


    PROBLEM:
    Checke ich am nächsten Tag die Funktion reagiert der Baustein welcher mit 3/3/2 "Heizung Esszimmer Freigabe" einfach nur AN / AUS schalten soll gar nicht mehr, ein Aktivieren ist nicht möglich. Er springt kurz hin zu EIN und bleibt aber auf AUS. Ich dachte, es liegt ggf. daran, weil ich keinen TRIGGER habe, deswegen habe ich diesen eingebunden, aber scheinbar nützt das auch nichts. Das Problem besteht seit 2 Wochen und alle Möglichkeiten das zu lösen schlugen fehl.

    Kappe ich die WLAN Verbindung zum X1 und aktiviere Sie wieder kann ich plötzlich den Baustein ohne Probleme wieder AN / AUS schalten via 3/3/2 mit der Gira App.
    Warum? Ich kann mir das Verhalten nicht erklären.

    X1 - Zustand:
    keine Internetverbindung - nur internes WLAN
    Version: 2.7.585
    Zeit: ist manuell gesetzt stimmt
    angeschlossen an WLAN Router mit einem Kabel




    Angehängte Dateien

    #2
    Sehe ich das richtig, dass 3/3/2 nur direkt im X1 Schalter gesetzt wird, oder wird er noch irgendwo anders ausgewertet? Was passiert auf dem Bus! Wenn du den Schalter umlegst? Der X1 verarbeitet in der Logik keine KNX Signale, die er selber geschrieben hat und nicht irgendwo auf dem Bus bestätigt werden (was bei laufender ETS /Gruppenmonitor aber erfolgt).
    Wahrscheinlich musst du auf eine Gerätevariable umstellen.
    Viel Erfolg, Florian

    Kommentar


      #3
      Ergänzung zu #2:
      Für die Zweipunkt-Regelung den LBS "Schwellwert mit Hysterese" verwenden anstelle des LBS "Vergleicher kleiner":
      • Oberer und unterer Schwellwert in den Baustein-Eigenschaften auf Eingang umschalten
      • Oberer Schwellwert := Heizung SOLL plus eine Konstante wie 1 (°C)
      • Unterer Schwellwert := Heizung SOLL minus eine Konstante wie 1 (°C)
      • Den Ausgang des LBS "Schwellwert mit Hysterese" invertieren und mit dem Aktor verbinden
      Zur Kontrolle die Funktion mit dem Simulator im GPA simulieren.

      Für rein X1-interne Datenpunkte benutze ich Variablen-Datenpunkte; die sind dann in ETS /Gruppenmonitor nicht zu sehen, sondern nur im GPA Datenpunktmonitor.

      Kommentar


        #4
        Guten Abend und erst einmal Danke für das Feedback Beleuchtfix !!

        Ja es handelt sich bei 3/3/2 nur um eine Variable, die ich nutze (nutzen will) um den Nutzer den Baustein AN / AUS schalten zu lassen. Auf dem BUS selbst passiert nix - es gibt keinen Schalter / Taster der das steuert....

        Mir war nicht bewusst, dass ich hier dann eine "Gerätevariable" nutzen muss, insofern Danke ich werde das mal testen.

        Ich komme grundsätzlich ja mit allem gut zurecht, nur erschließen sich mir manche Logiken nicht. Wenn ich als Entwickler z.B. in PHP ein Variable definiere und setze erwarte ich das diese dann auch verarbeitet wird, oder es eine Fehlermeldung gibt, die ich auslesen kann. Im "KNX Universum" sind einige Sachen leider etwas umständlicher oder ich habe noch nicht alles vollständig begriffen ....


        Kommentar


          #5
          Zitat von picard48 Beitrag anzeigen
          nur erschließen sich mir manche Logiken nicht
          Beim X1 ist es noch "viel schlimmer" als im restlichen "KNX Universum": Die Datenpunkte im X1 haben zwei Felder für GAs: Einmal "Senden" und ein zweites für "Status/Rückmeldung". Nicht in jedem Fall ist die gleiche GA in beiden Feldern sinnvoll, das hängt von der weiteren Verwendung der GAs ab.
          Insbesondere bei Schaltern habe ich eine Rückkopplung vom Status auf die Sende-GA beobachtet. Wenn das stört, dann das Feld "Status/Rückmeldung" leer lassen und dafür mit "Hören, neue Adresse hinzufügen" ein drittes Feld erzeugen lassen und die GA dort eintragen.
          Mit dem Gruppenmonitor und viel Fleiss beim Ausprobieren und Infos suchen bin ich beim Lernen gut voran gekommen.

          Zitat von picard48 Beitrag anzeigen
          Wenn ich als Entwickler z.B. in PHP ein Variable definiere und setze erwarte ich das diese dann auch verarbeitet wird ...
          Beim X1 sehe ich viel häufiger, dass die Variable gleich wieder rückgesetzt wird; ein "nicht verarbeiten" ist mir nicht geläufig. Kannst Du das im Gruppenmonitor zeigen?

          Kommentar

          Lädt...
          X