Ankündigung

Einklappen
Keine Ankündigung bisher.

MDT Glastaster (Status lesen nach Restart und Farbe LED)

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    MDT Glastaster (Status lesen nach Restart und Farbe LED)

    Hallo Zusammen

    Ich habe nun die Glastaster erhalten und habe dort zwei interessante Punkte festgestellt.

    Der erste Punkt ist, dass bei einigen weissen MDT Glastastern die linke untere LED gelblich geleuchtet hat. Die anderen 3 LEDs sind weiss. Dies egal bei welcher Helligkeit die LEDs eingestellt waren. Es war wie als ob eine LED mit einer anderen Farbtemperatur eingebaut worden ist.

    Hier hat aber MDT sofort angeboten, sich dem Problem anzunehmen. Daher denke ich nicht, dass dies ein grosses Ding wird. Auch wenn MDT noch nie von diesem Problem gehört hatte und doch schon ein paar von diesen Tastern verkauft hat. Daher würde ich gerne mal wissen, ob Ihr dieses Phänomen auch habt oder ob bei Euch alle LED "farbecht" waren und ich eine Montagsserie erwischt habe. Da bei mir 5 von 7 Schaltern nicht ok sind (3 von 4 4-Fach, 2 von 3 8-fach, immer genau eine LED immer die Linke in der 2 oder 4 Reihe. Aber natürlich immer nur genau eine LED pro Taster). Ich habe dies mit Peter versucht auf einem Photo festzuhalten, aber leider keine grosse Chance. Auf dem Foto sehen alle LED gleich überlichtet aus.

    Das zweite interessante Verhalten ist uns bei dem Verhalten nach Stromausfall (Neuprogrammierung) aufgefallen: Eine LED auf dem Taster bekommt den Status eines 20-fach MDT-Aktors zugewiesen. Dies funktioniert natürlich prima. Wenn nun eingestellt wird, dass der Taster sich bei einem Restart die Status beschaffen soll, dann ist im Monitor sichtbar, dass der Taster die Telegramme auslöst und eine korrekte Anwort bekommt. Nur reagiert die LED nicht auf das Telegramm. Wenn ich aber die im Bus-Monitor aufgezeichneten Telegramm danach sofort wieder abspiele, dann wird die LED am Taster hell... Ist aus meiner Sicht kein Ding, denn wegen den Stromausfall alle paar Jahre, macht mir dies nichts aus. Ist aber vielleicht für jemanden von Euch interessant.

    Beides wurde an MDT Support über Peter gemeldet. Ich fand aber, dass es für Euch vielleicht auch interessant sein könnte.

    Und so wie ich Peter verstanden hatte, wäre mir ein sofortiger Austausch angeboten worden (Klasse Service!)! Nur da ich ja sowieso erst in ein paar Monaten die Taster einbaue, war dies nicht notwendig und diese werden zuerst an MDT gesendet...

    Gruss
    Stef

    PS: Taster sind R1.2

    #2
    Zitat von lordhelmchench Beitrag anzeigen
    Wenn nun eingestellt wird, dass der Taster sich bei einem Restart die Status beschaffen soll, dann ist im Monitor sichtbar, dass der Taster die Telegramme auslöst und eine korrekte Anwort bekommt. Nur reagiert die LED nicht auf das Telegramm.
    Willkommen im Club: https://knx-user-forum.de/knx-eib-fo...iederkehr.html
    Das ist wohl bereits bei den normalen Tastern ein Problem. Hier ein Beispiel nach dem Anklemmen an den Bus:
    Code:
    01. 2013-01-22 16:54:59.226,A_GroupValue_Read,1.1.9,1/2/40,00,,,,0,low,6,T_DATA_XXX_REQ,0
    02. 2013-01-22 16:54:59.341,A_GroupValue_Read,1.1.9,1/2/31,00,,,,0,low,6,T_DATA_XXX_REQ,0
    03. 2013-01-22 16:54:59.451,A_GroupValue_Response,1.1.2,1/2/40,00,,,,0,low,6,T_DATA_XXX_REQ,0
    04. 2013-01-22 16:54:59.561,A_GroupValue_Read,1.1.9,1/1/1,00,0,DPT_Switch,1.001,0,low,6,T_DATA_XXX_REQ,0
    05. 2013-01-22 16:54:59.671,A_GroupValue_Response,1.1.7,1/2/31,01,,,,0,low,6,T_DATA_XXX_REQ,0
    06. 2013-01-22 16:54:59.786,A_GroupValue_Read,1.1.9,1/1/41,00,0,DPT_Switch,1.001,0,low,6,T_DATA_XXX_REQ,0
    07. 2013-01-22 16:54:59.901,A_GroupValue_Response,1.1.6,1/1/1,00,0,DPT_Switch,1.001,0,low,6,T_DATA_XXX_REQ,0
    08. 2013-01-22 16:55:00.022,A_GroupValue_Response,1.1.7,1/1/41,00,0,DPT_Switch,1.001,0,low,6,T_DATA_XXX_REQ,0
    09. 2013-01-22 16:55:00.707,A_GroupValue_Response,1.1.7,2/0/21,00,0,DPT_Switch,1.001,0,low,7,T_DATA_XXX_REQ,0
    10. 2013-01-22 16:56:03.420,A_GroupValue_Write,1.1.9,1/2/30,01,,,,0,low,6,T_DATA_XXX_REQ,0
    11. 2013-01-22 16:56:47.197,A_GroupValue_Write,1.1.9,1/2/30,00,,,,0,low,6,T_DATA_XXX_REQ,0
    12. 2013-01-22 16:56:47.382,A_GroupValue_Write,1.1.7,1/2/31,00,,,,0,low,6,T_DATA_XXX_REQ,0
    Der Taster hat die Adresse 1.1.9. Die Adressen 1.1.6 und 1.1.7 sind jeweils Schaltaktoren.

    In den Zeilen 1, 2, 4 und 6 fordert der Taster die Werte für "Wert für Umschaltung" an. In Zeile 5 antwortet ein Schaltaktor mit dem Wert "01" auf der GA für KO 6 der Taste 2. Die LED 2 (parametrisiert intern auf KO 6 mit rot/grün) bleibt rot, obwohl diese bei "01" grün sein müsste.

    Bei Zeile 10 drücke ich Taste 2 und das KO 5 sendet "01". Hier müsste jedoch eine "00" gesendet werden, da das KO 6 "Wert für Umschaltung" in Zeile 5 bereits den Wert "01" bekommen hat. Zeile 11 bildet einen erneuten Tastendruck auf Taste 2 ab, dessen Wirkung mit einer Zustandsänderung in Zeile 12 dokumentiert wird.

    Habe das MDT gemeldet und man kümmert sich drum. Mal sehen, was bei rauskommt. Bislang bin ich auch positiv von MDTs Service gestimmt.
    Gruß
    Karsten

    Kommentar


      #3
      Frage:

      Wie löst Ihr das mit dem "LED" wenn Ihr es als anzeige "eingeschaltet" Ein bleiben soll, bei einem mit UM schalten konfigurierten Tastenfeldes
      Bei mir blinke sie nur zur zeit auf wenn ich das Tastenfeld berühre doch es erlischt danach wieder wäre doch schön wenn es als "Ein" Rückmeldung an bleibt.
      Oder sehe ich den Wald vor lauter Bäumen nicht....

      Kommentar


        #4
        @Thomas: Es gibt 5 Möglichkeiten wie Du "LED x reagiert auf" einstellen kannst: externes Objekt, internes Objekt, Tastenbetätigung, externes Objekt und Tastenbetätigung, internes Objekt und Tastenbetätigung.

        Default ist "Tastenbetätigung". Einfach mal auf "externes Objekt" stellen, die Status-GA auf das Objekt und freuen.
        Gruß
        Frank

        Soziologen sind nützlich, aber keiner will sie. Bei Informatikern und Administratoren ist es umgekehrt.

        Kommentar


          #5
          Oder bei Umschaltungsfunktion auf internes Objekt legen, dessen KO den Wert für Umschaltung erwartet. Dann muss man bei Änderung der Status-GA nicht auch die GA für die LED wieder anfassen.
          Gruß
          Karsten

          Kommentar


            #6
            Perfekt getroffene Antworten THX

            Kommentar


              #7
              Hallo Karsten,

              zu deinem Problem:
              In den Zeilen 1, 2, 4 und 6 fordert der Taster die Werte für "Wert für Umschaltung" an. In Zeile 5 antwortet ein Schaltaktor mit dem Wert "01" auf der GA für KO 6 der Taste 2. Die LED 2 (parametrisiert intern auf KO 6 mit rot/grün) bleibt rot, obwohl diese bei "01" grün sein müsste.
              Damit der Response angenommen wird, muß das Aktualisieren-Flag gesetzt sein. Ansonsten können die LEDs dies Information nicht bekommen. Der Response wird leider bei KNX anders behandelt als ein Write. Nach dem Setzen des Flags wird es funktionieren.

              Gruß
              hjk

              Kommentar


                #8
                Zitat von hjk Beitrag anzeigen
                muß das Aktualisieren-Flag gesetzt sein
                Klasse, es geht! Vielen Dank und Kompliment an den MDT-Service.

                Eine Frage dazu habe ich allerdings. Wenn ich die Produktdatenbank v1.5 importiere und mir den Taster davon in meine Linie hole, so sind bei den KO für "Wert bei Umschaltung" nur die Flags K und S gesetzt.
                In dieser Konfiguration schickt der Taster beim Anklemmen nicht einmal ein Lesetelegramm auf den Bus. Daraufhin bekam ich von euch den Hinweis auf das Setzen des Ü-Flags. Das bewirkt, dass überhaupt die Übertragung stattfinden kann, also auch ein Lesetelegramm. Mit dem Setzen des A-Flags wurde die Sache nun rund.
                Gehören solche Flag-Einstellungen nicht in die Produktdatenbank? Zumal ich gerade im Handbuch auf Seite 13 auf die Standardeinstellungen der KO gestossen bin und sehe, dass dort bei "Wert für Umschaltung" die Flags K, S, Ü und A angeblich gesetzt sind.
                Handelt es sich daher um einen Fehler in der Produktdatenbank, im Handbuch oder in meinem Kenntnisstand?

                Übrigens steht auf der ersten Seite des Handbuchs oben links "Stand 12/2012", auf der letzen und vorletzten unten links "Stand: 1012"
                Gruß
                Karsten

                Kommentar


                  #9
                  Hallo Karsten,

                  die Flageinstellungen sind immer nur Voreinstellungen und können beliebig nach Bedarf geändert werden. Wir werden die Voreinstellungen aber anpassen und die betroffenen Flags per Default setzen.
                  Das vordere Datum ist das Datum des Handbuchs. Das Datum auf den letzten beiden Seiten bezieht sich auf das Datenblatt.

                  Gruß
                  hjk

                  Kommentar


                    #10
                    Zitat von hjk Beitrag anzeigen
                    Wir werden die Voreinstellungen aber anpassen und die betroffenen Flags per Default setzen.
                    Das ist gut. Dann stimmen Produktdatenbank und Handbuch wieder überein.

                    Zitat von hjk Beitrag anzeigen
                    [...]bezieht sich auf das Datenblatt.
                    Ok, hab nichts gesagt. :-)
                    Gruß
                    Karsten

                    Kommentar


                      #11
                      Zitat von evolution Beitrag anzeigen
                      @Thomas: Es gibt 5 Möglichkeiten wie Du "LED x reagiert auf" einstellen kannst: externes Objekt, internes Objekt, Tastenbetätigung, externes Objekt und Tastenbetätigung, internes Objekt und Tastenbetätigung.

                      Default ist "Tastenbetätigung". Einfach mal auf "externes Objekt" stellen, die Status-GA auf das Objekt und freuen.
                      DANKE, ich freu mich auch
                      Habe vor einer Stunde meinen ersten MDT ausgepackt und gleich mit den vorbereiteten Daten versorgt und alles geht, nur die LED blieb nicht an. Dank Deinem Eintrag konnte ich das Problem lösen - DANKE

                      Kommentar


                        #12
                        ...gern geschehen. (Ist mein Beitrag nicht schon ewig her?)

                        Edit: Ja schön über ein Jahr...
                        Gruß
                        Frank

                        Soziologen sind nützlich, aber keiner will sie. Bei Informatikern und Administratoren ist es umgekehrt.

                        Kommentar


                          #13
                          Frank, Du glaubst gar nicht wie oft mir Steinalte Beiträge was bringen

                          Kommentar


                            #14
                            Hallo Zusammen,
                            da ich eigentlich ganz zufrieden mit dem ersten MDT Glastaster bin und der Preis für das was man bekommt voll und ganz OK ist, habe ich mir nun weitere bestellt.
                            Nun kam mir eine Überlegung und mich würde Eure Meinung dazu interessieren

                            Ich möchte ja das diese lange Ihre Dienste tun und ich möchte zumindest an der Haustür und neben dem Bett zwei Tasten der Glastaster für den Status nutzen, Sprich beim Bett "Anwesend" und Schlafen" und neben der Haustür "Anwesend" und "Abwesend".

                            Diese Tasten sollen per LED beleuchtet werden. Bin ich Anwesend "weiß", wenn ich Abwesend oder Schlafe, dann Rot.

                            Bedeutet, dass die LEDs so ca. 12Stunden am Tag leuchten werden. Da diese aber lange halten sollen kam nun die Überlegung, das KO "LED Tasten Sperrobjekt" zu nutzen und diese durch die Präsenzmelder (Ausgang Melden) schalten zu lassen.
                            Würde doch im Grunde nichts dagegen sprechen und die Lebensdauer erheblich verlängern, wobei anstatt dauerhaft leuchten dann die LEDs öfters ein/ausschalten.

                            Was meint Ihr? Oder macht Ihr Euch über Lebendauer usw. gar keine Gedanken?

                            Grüße
                            Sven

                            Kommentar


                              #15
                              Eine LED hat eine Lebensdauer von ca. 100000 Stunden, macht bei 12 Stunden am Tag dann 22 Jahre.

                              Die Frage ist allenfalls, wieso willst Du den Status "Abwesend" anzeigen lassen - wenn niemand zuhause ist schaut auch niemand drauf...

                              Kommentar

                              Lädt...
                              X