Ankündigung

Einklappen
Keine Ankündigung bisher.

Edomi Backup auf Synology DiskStation ablegen

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • benji
    antwortet
    Hi,

    der Upload scheint zu funktionieren. Warum aber ist die Dateibezeichnung bei dir falsch? Normalerweise soll das Autobackup so zb: 2018-10-14-150000.edomibackup bezeichnet sein.

    Der Zweite Fehler vom Verzeichnis scheint bei der Abfrage der Anzahl zu kommen. Hast du am LBS etwas geändert?? Bei mir läuft der eigentlich ohne Probleme.

    Einen Kommentar schreiben:


  • ak68
    antwortet
    Nach der Änderung des Gastzugriffs auf: Vollzugriff, (da wohl FTP-Einstellungen: NO_ROOT_SQUASH) erfolgt folgender Fehler:

    2018_10_14_09_57_47_10.10.1.35_data_log_CUSTOMLOG_Backup_transfer_FTP_LBS19000169.htm_20181014095703.png

    ... weiterhin kann lt. Fehlermeldung nicht auf den Ordner zugegriffen werden !

    Ein Zugriff über den Windows-Browser mit tp://usernameassword@Turbo-NAS-IP_address/ ist möglich, auch wird wird
    - trotz Fehlermeldung auch auf den NAS-Ordner zugegriffen- auch die Größe der Sicherungsdatei ist o.K.

    2018_10_14_11_09_25_Index_von_Edomi_Opera.png
    Zuletzt geändert von ak68; 14.10.2018, 10:13.

    Einen Kommentar schreiben:


  • ak68
    antwortet
    Leider habe ich (auch) Probleme mit dem LBS. Der Upload zum FTP-Server (bei mir QNAP-NAS) wird mit folgendem Fehler abgebrochen:

    2018_10_14_09_12_45_10.10.1.35_data_log_CUSTOMLOG_Backup_transfer_FTP_LBS19000169.htm_20181014090020.png

    Das FTP-Verzeichnis existiert jedoch und hat Schreibrechte:

    2018_10_14_09_10_40_QNAP_Opera.png

    Auch alle FTP- Einstellungen habe ich durchprobiert (SSL ja/ nein, Unicode, anonymer Zugriff ...):

    2018_10_14_09_27_20_QNAP_Opera.png


    Mein Backup-Pfad ist der Standard-Pfad " /usr/local/edomi/www/data/tmp", Anzahl der Backups: "6", Pfad: "/Edomi/"

    IP/ URL im LBS: alle Syntax-Varianten "ausprobiert"

    Wo kann der Fehler noch liegen ?
    Zuletzt geändert von ak68; 14.10.2018, 08:33.

    Einen Kommentar schreiben:


  • g0bi
    antwortet
    Hi Benji,

    ich hab ein wenig Probleme mit dem Baustein. Er löscht mir die Backups nicht.

    usr/local/edomi/www/data/liveproject/lbs/EXE19000169.php | Fehlercode: 2 | Zeile: 223 | unlink(): Error Deleting file: 550 /edomi: permission denied.[CR][LF]

    Er sagt permission denied, aber auf der Synology hat der User Vollzugriff. Eine Idee??

    Grüße Stefan

    Einen Kommentar schreiben:


  • benji
    antwortet
    Ich habe den LBS nochmal etwas überarbeitet. Somit kann man sich Platz auf dem Edomi System sparen wenn man nur noch 1 Backup auf Edomi liegen hat.

    https://knx-user-forum.de/forum/proj...46#post1247146

    Einen Kommentar schreiben:


  • Langer89
    antwortet
    Stell mal die Anzahl der Backups auf 6 (wenn in der edomi.ini 7 eingetragen sind)

    Gruß

    Henrik

    Einen Kommentar schreiben:


  • rok123
    antwortet
    Hi, ich bekomme das Backup nicht auf meine Synology.
    LBS 19000169 Edomi-Backup-transfer FTP

    Per Filezilla ist das Verzeichnis mit dem BN und PW erreichbar.
    Anzahlt Backups 7
    Backup löschen 1

    Folgender Fehler im Log
    Code:
     [TABLE="border: 0, cellpadding: 0, cellspacing: 0"]
    [TR]
    [TD]2018-06-06 15:08:13[/TD]
     			[TD]731914[/TD]
     			[TD]13694[/TD]
     			[TD]debug[/TD]
     			[TD]LBS19000169 [v0.2]: LBS started[/TD]
     		[/TR]
    [TR]
    [TD]2018-06-07 00:15:00[/TD]
     			[TD]252429[/TD]
     			[TD]13694[/TD]
     			[TD]debug[/TD]
     			[TD]LBS19000169 [v0.2]: LBS started[/TD]
     		[/TR]
    [TR]
    [TD]2018-06-07 00:15:00[/TD]
     			[TD]255745[/TD]
     			[TD]13694[/TD]
     			[TD]debug[/TD]
     			[TD]LBS19000169 [v0.2]: LBS ended[/TD]
     		[/TR]
    [TR]
    [TD]2018-06-07 00:15:00[/TD]
     			[TD]274708[/TD]
     			[TD]31931[/TD]
     			[TD]debug[/TD]
     			[TD]EXE19000169 [v0.2]: 1[/TD]
     		[/TR]
    [TR]
    [TD]2018-06-07 00:15:01[/TD]
     			[TD]015162[/TD]
     			[TD]31931[/TD]
     			[TD]debug[/TD]
     			[TD]EXE19000169 [v0.2]: Es ist ein Fehler beim Upload aufgetreten[/TD]
     		[/TR]
    [TR]
    [TD]2018-06-07 00:15:01[/TD]
     			[TD]490427[/TD]
     			[TD]31931[/TD]
     			[TD]debug[/TD]
     			[TD]EXE19000169 [v0.2]: 1[/TD]
     		[/TR]
    [TR]
    [TD]2018-06-07 00:15:01[/TD]
     			[TD]696515[/TD]
     			[TD]31931[/TD]
     			[TD]debug[/TD]
     			[TD]EXE19000169 [v0.2]: Anzahl der Backups:0[/TD]
     		[/TR]
    [TR]
    [TD]2018-06-07 00:15:01[/TD]
     			[TD]698853[/TD]
     			[TD]31931[/TD]
     			[TD]debug[/TD]
     			[TD]EXE19000169 [v0.2]: EXEC End[/TD]
     		[/TR]
    [/TABLE]
    Danke für eure Hilfe

    Einen Kommentar schreiben:


  • shortyle
    antwortet
    Ganz vielen Dank Micha.
    ich denke das bekomme sogar ich hin
    Letzte Frage dazu. Hast du den systemweiten crontab (/etc/crontab) dafür genutzt oder einen komplett eigenen unter /var/spool/cron/crontabs/ erstellt?

    Einen Kommentar schreiben:


  • vento66
    antwortet
    Also so läuft das bei mir:

    erst mal nfs utils installieren:

    Code:
    yum install -y nfs-utils nfs-utils-lib
    Der crontab schaut so aus:

    Code:
    @reboot mount -t nfs 10.0.0.22:/volume1/backup/edomi /mnt/bkp;
    5,15,25,35,45,55 * * * * mountpoint -q /mnt/bkp || mount -t nfs 10.0.0.22:/volume1/backup/edomi /mnt/bkp;
    00 03 * * * cp  /var/edomi-backups/*.edomibackup /mnt/bkp;
    10 03 * * * find /mnt/bkp/* -name '*.edomibackup' -mtime +10  -exec rm -rf {} \;
    • nach einem Reboot wird der synology Ordner backup/edomi nach /mnt/bkp gemountet (10.0.0.22 ist die Syno)
    • aller 10 Minuten wird geprüft, ob das Laufwerk noch gemountet ist, wenn nicht wird es wieder gemountet
    • 3:00 Uhr wird der Inhalt von /var/edomi-backups in den gemounteten Ordner kopiert
    • 3:10 Uhr werden die älteren Dateien gelöscht.

    Einen Kommentar schreiben:


  • shortyle
    antwortet
    Mit dem WOL LBS klappt das schon mal. Den hatte ich probehalber mal in einer Visu eingebaut. Weiß nur nicht ob es wirklich noch Sinn macht die DiskStation immer am und aus zu machen oder nicht doch einfach bloß den Ruhezustand der HDD zu aktivieren.

    Einen Kommentar schreiben:


  • vento66
    antwortet
    Mit dem WOL LBS aus den Download, oder per Zeit. (Systemsteuerung -> Aufgabenplaner). Dann musst Du aber im Cronjob den Ordner immer mounten, da ja die Syno beim Ausschalten die Verbindung cancelt.

    Einen Kommentar schreiben:


  • shortyle
    antwortet
    Das wäre Weltklasse.
    Dann muss ich mir nur noch etwas überlegen wie ich mein NAS per WOL aufwecke. Würde aber wohl mehr Sinn machen es 24/7 laufen zu lassen. Habe aber noch nicht den Bedarf danach um Kamera Streams oder so dort zu speichern.

    Einen Kommentar schreiben:


  • vento66
    antwortet
    Hm, vielleicht hatte ich mal eine.... Aber ja, so wie Du sagst funktioniert das. Ich kann ja morgen mal den kompletten crontab posten. Damit das Laufwerk mit ntfs zu mounten geht, muss auch noch etwas nachinstalliert werden.

    Einen Kommentar schreiben:


  • shortyle
    antwortet
    Was würde ich dafür geben das alles zu verstehen und einfach umsetzen zu können
    Also hast du schlussendlich nur den Crontab und der mountet dir nach einem reboot das NAS, kopiert die Backups um 03:00 und löscht um 03:10 alles was älter als 14 Tage ist.
    Also hast du keine weitere backup.sh? Hatte das nur aus deinem Post auf der 1. Seite dieses Threads.

    Einen Kommentar schreiben:


  • vento66
    antwortet
    Das ist ein crontab. Der läuft direkt im Betriebssystem, unabhängig von EDOMI. Du musst natürlich dafür sorgen, das der Synology Pfad auch immer auf deinem EDOMI Rechner gemountet ist. Das macht bei mir z.B dieser Eintrag im Crontab:
    Code:
    @reboot mount -t nfs 10.0.0.22:/volume1/backup/edomi /mnt/bkp;

    Einen Kommentar schreiben:

Lädt...
X