Ankündigung

Einklappen
Keine Ankündigung bisher.

LBS19000935 - Husqvarna Automower Connect API

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    richtig.
    Sorry, hab den falschen Thread erwischt ...

    Kommentar


      #17
      Zitat von dpoth Beitrag anzeigen
      Hi Stefan-

      Das stimmt schon mit dem drum herum. ;-)
      Da habe ich mir schon was gebastelt um den Automower parametriert mähen zu lassen.
      Neben diesen Automow Settings sind diverse Abbruchbedingungen z.B. Regen oder Sturm definiert.

      Bildschirmfoto 2018-08-20 um 12.48.51.png

      Bildschirmfoto 2018-08-20 um 12.49.20.png

      Habe leider nur ein Problem, daß er manchmal nicht direkt Starten will.
      Das Start Kommando wird gegeben aber nicht ausgeführt. Kennst du das Problem?

      Das AMC APP Ausloggen kann ich bestätigen.
      Komisch diesen Issue hatte ich bei der manuellen Python Integration nicht.
      Danke für den Tipp. Muß ich mir auch einen 2. Account erstellen.

      Viele Grüße
      Detlef

      Wie bekommt man die "Location" und die "Timestamps" in lesbares übersetzt?
      Visu.JPG
      Angehängte Dateien

      Kommentar


        #18
        Eigentlich gibt es da nicht viel zu übersetzen.

        Der Timestamp ist wie der Name schon sagt ein Zeitstempel. Das ist ein einheitliches Zeitformat, welches die Sekunden seit dem 1.1.1970(?) zählt. Das kann man wie folgt übersetzen:
        2020-03-23 13_01_49-EDOMI · Administration.png

        Unter Location erhältst du einen JSON- String mit den geographischen Angaben der Position des Mähers in Längen- und Breitengrad. Das kannst du so auseinandernehmen und beliebig weiterverwerten:
        2020-03-23 13_05_38-EDOMI · Administration.png
        Gruß
        Stefan

        Kommentar


          #19
          Hallo Zusammen,

          was liefert der Ausgang A11 für ein Zeitstempel? Ich stehe irgendwie auf dem Schlauch!
          Vielen Dank

          LG Marcel

          Kommentar


            #20
            Zitat von skjold Beitrag anzeigen
            was liefert der Ausgang A11 für ein Zeitstempel?
            Das lässt sich garnicht so leicht herausfinden. Ich greife einfach nur aus der API die Eigenschaft "storedTimestamp" ab.
            Code:
            round($mowerstate -> storedTimestamp/1000,0)
            https://github.com/guenneguezt/phphusqvarna

            Laut der Herstellerseite handelt es sich um eine offene API. Leider konnte ich keine Doku finden in der die einzelnen Eigenschaften/Objekte näher erläutert sind.
            Gruß
            Stefan

            Kommentar


              #21
              Ok, vielen Dank für die schnelle Antwort. Ich versuche es mal rauszubekommen.

              Kommentar


                #22
                Zitat von MrIcemanLE Beitrag anzeigen
                Laut der Herstellerseite handelt es sich um eine offene API. Leider konnte ich keine Doku finden in der die einzelnen Eigenschaften/Objekte näher erläutert sind.
                Hast Du mal hier geschaut? https://developer.1689.cloud/

                Kommentar


                  #23
                  Da ich mir nun auch einen Husqvarna Rasenmähroboter zugelegt habe, habe ich einen kleinen LBS (LBS 19002170) erstellt, der u.a. die Statusmeldung als Text ausgibt. Nichts großes aber vielleicht ist es für den einen oder anderen ganz hilfreich.
                  Darüber hinaus habe ich den LBS zur Zeitformatierung (LBS 19000399) so angepasst, dass jetzt auch GMT verwendet wird.
                  Hintergrund: Die Timestamps vom Automower berücksichtigen schon die Zeitzone, so dass die Ausgabe des LBS im Sommer um 2 Stunden verschoben war.

                  Edit: Ich habe den LBS noch erweitert, jetzt ist auch eine Kartendarstellung im Image/Webseiten-Element einer Visu möglich.
                  Zuletzt geändert von panzaeron; 14.04.2020, 00:07.

                  Kommentar


                    #24
                    Zitat von panzaeron Beitrag anzeigen
                    Da ich mir nun auch einen Husqvarna Rasenmähroboter zugelegt habe, habe ich einen kleinen LBS (LBS 19002170) erstellt, der u.a. die Statusmeldung als Text ausgibt. Nichts großes aber vielleicht ist es für den einen oder anderen ganz hilfreich.
                    Darüber hinaus habe ich den LBS zur Zeitformatierung (LBS 19000399) so angepasst, dass jetzt auch GMT verwendet wird.
                    Hintergrund: Die Timestamps vom Automower berücksichtigen schon die Zeitzone, so dass die Ausgabe des LBS im Sommer um 2 Stunden verschoben war.

                    Edit: Ich habe den LBS noch erweitert, jetzt ist auch eine Kartendarstellung im Image/Webseiten-Element einer Visu möglich.

                    Moin panzaeron,

                    habe deinen Baustein mal getest funktionert super. Kommt man eigentlich auch an die Texte der Störmeldung ran? Hatte im Quelltext gesehen, dass du diese Übersetzt hast, kenne mich allergings nicht mit PHP aus, deswegen die "dumme Frage".

                    Gruß Marcel

                    Kommentar


                      #25
                      Hallo,
                      ich frag hier auch einfach mal nach...
                      Hab bei mir mit dem LBS19000935 das Problem das die CPU Last von Edomi Schrittweise sehr stark ansteigt und dann pulsiert im abstand von ca. 10-15sek. je nach eingestellter Intervallzeit.
                      Edomi wird neu gestartet oder Projekt neu aktiviert, alles ist gut und CPU Last bei 8-10% nach 2 Stunden bin ich schon bei ca. 40-50%.
                      Hat das jemand von euch schon jemand mal gehabt oder beobachten können? LBS neu einspielen und neu starten hat nix gebracht.

                      MrIcemanLE kannst du hierzu was sagen oder ist dir dieses Verhalten bekannt? Da ja bald wieder die Mäh-Saison los geht würde ich dann gerne den LBS wieder aktivieren.
                      Zuletzt geändert von beauty; 20.02.2021, 20:54.

                      Kommentar


                        #26
                        panzaeron

                        Habe mir ebenfalls Deinen LBS 19002170 heruntergeladen, läuft soweit echt super, nur verursacht er bei mir immer Fehler im Log. Undefined variable: mower_Marker

                        Irgendeine Idee?

                        Grüße Andi
                        Angehängte Dateien

                        Kommentar


                          #27
                          Zitat von skjold Beitrag anzeigen
                          Kommt man eigentlich auch an die Texte der Störmeldung ran?
                          Du hast recht, Fehlermeldungen werden nicht ausgegeben, in dem aktualisierten LBS im Download wird dieser über A1 mit ausgegegebn.

                          Zitat von andijegg Beitrag anzeigen
                          panzaeron...nur verursacht er bei mir immer Fehler im Log. Undefined variable: mower_Marker
                          Der Fehler ist auch im Download behoben, er ist immer dann aufgetaucht wenn die Grafik mower.png nicht vorhanden ist.

                          Kommentar


                            #28
                            Zitat von beauty Beitrag anzeigen
                            Hallo,
                            ich frag hier auch einfach mal nach...
                            Hab bei mir mit dem LBS19000935 das Problem das die CPU Last von Edomi Schrittweise sehr stark ansteigt und dann pulsiert im abstand von ca. 10-15sek. je nach eingestellter Intervallzeit.
                            Edomi wird neu gestartet oder Projekt neu aktiviert, alles ist gut und CPU Last bei 8-10% nach 2 Stunden bin ich schon bei ca. 40-50%.
                            Hat das jemand von euch schon jemand mal gehabt oder beobachten können? LBS neu einspielen und neu starten hat nix gebracht.

                            MrIcemanLE kannst du hierzu was sagen oder ist dir dieses Verhalten bekannt? Da ja bald wieder die Mäh-Saison los geht würde ich dann gerne den LBS wieder aktivieren.
                            Muss meinen Beitrag nochmals vorkramen da ich bisher noch keine Abhilfe gefunden habe.
                            Daher nochmals in die Runde gefragt... hab jemand auch ansteigende CPU Last wenn der LBS paar Tage läuft?

                            MrIcemanLE
                            wäre Top wenn du hier mal schauen könntest?

                            Kommentar


                              #29
                              Bei mir exakt das selbe Verhalten. Nach ein paar Tagen werden auch dann keine Daten mehr abgeholt vom Baustein. Edomi läuft allerdings in einer VM bei mir.

                              Kommentar


                                #30
                                Bei mir läuft Edomi auf einem Intel NUC. Hab aber auch eine Docker Test-Umgebung auf meiner Syno. Hier ist ebenfalls das gleiche zu beobachten.
                                CPU Last steigt täglich Stück für Stück an.

                                Kommentar

                                Lädt...
                                X