Ankündigung

Einklappen
Keine Ankündigung bisher.

KNX-Bus Verbindung über Wiregate, eibd und Edomi in Docker-Container

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    KNX-Bus Verbindung über Wiregate, eibd und Edomi in Docker-Container

    Hallo zusammen,

    ich versuche seit einigen Tagen verzweifelt folgende Konfiguration ans fliegen zu bekommen:
    1. Edomi V2.00 in einem Docker-Container auf Synology NAS
    2. KNX Anbindung mittels eibd auf wiregate1385 (1.42), Konfig siehe Anhänge...
    Leider ist es beim (erfolglosen) Versuch geblieben :'(

    Edomi stellt zwar eine Verbindung zum Bus her (siehe Screenshot) und empfängt genau ein Telegramm, danach ist leider Schluss und der Fehlercounter läuft zielstrebig ins Unendliche...

    Die Programmierung mittels ETS 5 über dieselbe Schnittstelle (eibd auf wiregate) funktioniert problemlos.

    Hat jemand von Euch eine Idee was ursächlich für das Kommunikationsproblem zwischen Edomi und dem Bus ist?

    Danke für Eure Hilfe & viele Grüße
    Sebastian
    Angehängte Dateien
    Zuletzt geändert von Grosche; 10.09.2019, 10:30.

    #2
    Hallo zusammen,

    leider bin ich bei meinem Problem nicht weitergekommen und wollte daher nochmals nachfragen, ob evtl. jemand von Euch eine Idee hat?

    Merci

    Viele Grüße
    Sebastian

    Kommentar


      #3
      Was sagen denn die EDOMI Log`s?
      Ev mal das KNX Log aktivieren in der ini

      Kommentar


        #4
        Hallo Markus,

        vielen Dank für Deine Antwort. Das Logging für KNX steht bereits auf Debug-Level.


        System-Log sagt:
        Code:
          
        2019-09-10 12:46:44 209605 KNX 690 KNX-Verbindung: Tunnel-PA: 0.0.0 / Channel-ID: 1 Ok
        2019-09-10 12:51:37 943569 KNX 690 KNX-Verbindung verloren. ERROR
        2019-09-10 12:51:40 956029 KNX 690 KNX-Schnittstelle: Name: eibd on WireGate / PA: 0.0.0 / MAC: 000000000000 Ok
        2019-09-10 12:51:40 977088 KNX 690 KNX-Verbindung: Tunnel-PA: 0.0.0 / Channel-ID: 1 Ok
        KNX-Log (Debug-Level) sagt nach einem Restart des eibd-Services:
        Code:
         
        2019-09-10 14:07:13 742048 690 ERROR KNX-Verbindung verloren.
        2019-09-10 14:07:16 742978 690 OK CE > | DESCRIPTION_REQUEST an 192.168.178.3:3671 / Raw: 06100203000E0801c0a8b202c350
        2019-09-10 14:07:16 754512 690 OK CE < | DESCRIPTION_RESPONSE / Status: Ok / Name: eibd on WireGate / PA: 0.0.0 / MAC: 000000000000 / Raw: 06100204004636010200000000000f0080576573e000170c00 000000000065696264206f6e20576972654761746500000000 000000000000000000000a020201030104010501
        2019-09-10 14:07:16 764795 690 OK CE > | CONNECT_REQUEST an 192.168.178.3:3671 / Raw: 06100205001A0801c0a8b202c3500801c0a8b202c351040402 00
        2019-09-10 14:07:16 775522 690 OK CE < | CONNECT_RESPONSE / CE: 192.168.178.2:50000 - 192.168.178.3:3671 / DE: 192.168.178.2:50001 - 192.168.178.3:3671 / Tunnel-PA: 0.0.0 / ChannelID: 1 / Raw: 06100206001401000801c0a8b2030e5704040000
        2019-09-10 14:07:16 785830 690 OK CE > | CONNECTIONSTATE_REQUEST / Raw: 06100207001001000801c0a8b202c350
        2019-09-10 14:07:16 796772 690 OK CE < | CONNECTIONSTATE_RESPONSE / Raw: 0610020800080100
        2019-09-10 14:07:26 184844 690 OK DE < | TUNNELING_REQUEST:L_Data.ind / Typ: Write / SeqCounter: 0 (0) / PA: 1.0.20 / GA: 7/1/16 = 150 / Raw: 061004200016040100002900bcd01014391002008096
        2019-09-10 14:07:26 184983 690 OK DE > | TUNNELING_ACK / SeqCounter: 0 / Raw: 06100421000A04010000
        2019-09-10 14:07:27 182868 690 ERROR DE < | TUNNELING_REQUEST / Hinweis: SequenceCounter abweichend (ACK): Ist-Wert=0, Soll-Wert=1 / Raw: 061004200016040100002900bcd01014391002008096
        dann wiederholt sich:
        Code:
         
        2019-09-10 14:07:27 183085 690 OK DE > | TUNNELING_ACK / SeqCounter: 0 / Raw: 06100421000A04010000
        2019-09-10 14:07:28 181751 690 ERROR DE < | TUNNELING_REQUEST / Hinweis: SequenceCounter abweichend (ACK): Ist-Wert=0, Soll-Wert=1 / Raw: 061004200016040100002900bcd01014391002008096
        Kannst Du damit etwas anfangen?

        Bezüglich der Reproduktion bin ich ein "Schrittchen" weiter. Es scheint wohl am eibd auf dem WireGate zu liegen. Sobald ich den eibd-Dienst neustarte, empfängt Edomi wieder genau ein Telegramm. Das lässt sich beliebig wiederholen...

        Viele Grüße
        Sebastian
        Zuletzt geändert von Grosche; 11.09.2019, 07:20.

        Kommentar


          #5
          Ich kenne mich mit dem EIBD nicht aus.
          Aber bitte das Log in Code Tags setzen, das ist so fast nicht lesbar. Und poste mal das KNX Log min 30sec vor und nach dem Verbindungsabbruch

          Kommentar


            #6
            Heute habe ich mal an der Fritzbox den Netzwerk-Traffic mitgeschnitten.

            1. Verbindungsaufbau zum Eibd on Wiregate mittels ETS5 auf Laptop --> funktioniert problemlos (Request --> Response):
            Bildschirmfoto 2019-09-11 um 13.41.01.png
            2. Verbindungsaufbau zum Eibd on Wiregate mittels Edomi auf Synology NAS (Docker) --> schlägt fehl (Request --> kein Reponse):
            Bildschirmfoto 2019-09-11 um 13.48.15.png

            Die Request-Pakete sehen dabei (abgesehen von IP-Adressen und Ports) ziemlich identisch aus. Sehr seltsam das Ganze.

            Richtig schlau werde ich daraus nicht...

            Viele Grüße
            Sebastian

            Kommentar

            Lädt...
            X