Ankündigung

Einklappen
Keine Ankündigung bisher.

Edomi ProxMox- bzw. LXC-Template

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    auf "local" läuft das Backup durch. Auf dem NFS bricht er ab... also ist der Container ansich ja in Ordnung.
    kann das was mit der Dateiendung zu tun haben? .tmp zum Beispiel?
    Katy Perry: Can you here me roar?
    Alissa White Gluz: ... hold my beer!

    Kommentar


      ok habs!

      in der vzdump.conf muss das /tmp Verzeichnis eingefügt werden. Dann läufts sauber auf NFS durch...

      vzdump default settings


      #tmpdir: DIR
      tmpdir: /tmp
      #dumpdir: DIR
      #storage: STORAGE_ID
      #mode: snapshot|suspend|stop
      #bwlimit: KBPS
      #ionice: PRI
      #lockwait: MINUTES
      #stopwait: MINUTES
      #size: MB
      #stdexcludes: BOOLEAN
      #mailto: ADDRESSLIST
      #maxfiles: N
      #script: FILENAME
      #exclude-path: PATHLIST
      #pigz: N

      Katy Perry: Can you here me roar?
      Alissa White Gluz: ... hold my beer!

      Kommentar


        Hi

        Zitat von Amokd0c Beitrag anzeigen
        in der vzdump.conf muss das /tmp Verzeichnis eingefügt werden. Dann läufts sauber auf NFS durch...
        Du schraubst händisch an irgendwelchen Konfigurationen herum? Zumindest an dieser Stelle musste ich das noch nie machen und alle Container werden sauber auf dem NAS gebackup. Zumindest kann ich mich im Moment nicht daran erinnern. Aber ich werde da zuhause nochmal genau schauen...
        Kind regards,
        Yves

        Kommentar


          Zitat von starwarsfan Beitrag anzeigen
          Aber ich werde da zuhause nochmal genau schauen...
          Du! Ich kann dir das nicht erklären, warum und wieso. Auch war ich der Meinung, da ich schon mal Edomi auf dieser Maschine habe laufen lassen, auch das Backup schon mal funktioniert hat. Sollte auch dein Image gewesen sein.
          Habe danach alle VMs inkl. dem CT ein Backup nach Plan machen lassen. Läuft!
          Die Lösung hab ich auch erstmal mit den richtigen Schlagworten suchen müssen.

          Auch hatte anfangs der Emailversand nach dem Backup problemlos funktioniert. Der tut es aber auch nimmer, keine Ahnung wieso!

          Grüße...
          Katy Perry: Can you here me roar?
          Alissa White Gluz: ... hold my beer!

          Kommentar


            Hallo Proxmox-Experten,

            hier läuft seit geraumer Zeit Edomi 2.03 in Yves LXC-Container. Durch Zufall habe ich jetzt festgestellt, dass der sshd nach einem Neustart nicht mehr aktiv ist. Nach einem
            Code:
            systemctl start sshd
            startet er wieder normal. Bei dieser Gelegenheit habe ich mal die Bootmeldungen durchgesehen (journalctl -b) und jede Menge Fehler entdeckt, hier ein Auszug:

            Code:
            Jun 15 15:31:08 edomi2 ntpd[1201]: 0.0.0.0 c615 05 clock_sync
            Jun 15 15:31:08 edomi2 ntpd[1201]: ntp_adjtime() failed: Operation not permitted
            Jun 15 15:32:08 edomi2 ntpd[1201]: ntp_adjtime() failed: Operation not permitted
            Jun 15 15:34:23 edomi2 ntpd[1201]: ntp_adjtime() failed: Operation not permitted
            Jun 15 15:35:26 edomi2 systemd[1]: user.slice: Failed to set invocation ID on control group /user.slice, ignoring: Operation not permitted
            Jun 15 15:35:26 edomi2 systemd[1]: user-0.slice: Failed to set invocation ID on control group /user.slice/user-0.slice, ignoring: Operation not permitted
            Jun 15 15:35:26 edomi2 systemd[1]: Created slice User Slice of root.
            Jun 15 15:35:26 edomi2 systemd[1]: user.slice: Failed to set invocation ID on control group /user.slice, ignoring: Operation not permitted
            Jun 15 15:35:26 edomi2 systemd[1]: user-0.slice: Failed to set invocation ID on control group /user.slice/user-0.slice, ignoring: Operation not permitted
            Jun 15 15:35:26 edomi2 systemd[1]: user@0.service: Failed to set invocation ID on control group /user.slice/user-0.slice/user@0.service, ignoring: Operation not permitted
            Jun 15 15:35:26 edomi2 systemd[1]: Starting User Manager for UID 0...
            Jun 15 15:35:26 edomi2 systemd[1]: session-c1.scope: Failed to set invocation ID on control group /user.slice/user-0.slice/session-c1.scope, ignoring: Operation not permitted
            Könnte es sein, dass sich das CentOS diverse Stati nicht merken kann und daher auch die Aktivierung des ssh-Servers durch
            Code:
            systemctl enable sshd
            den Reboot nicht übersteht? Der Container ist unprivileged und nesting ist aktiviert.

            Als Nicht-Experte in Sachen Proxmox hoffe ich da auf eure Inputs, um den Fehler eingrenzen zu können.

            Besten Dank!

            Kommentar


              Hallo miteinander,

              eben habe ich einen neuen Thread zur RockyLinux-basierten neuen Template-Version aufgemacht. Bzgl. diesen neuen Templates weiter im dortigen Thread, hier nur noch zu den alten Versionen.

              Danke und weiterhin viel Spass mit Edomi!
              Kind regards,
              Yves

              Kommentar

              Lädt...
              X