Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

Xiaomi / Roboroc Baustein 19001929

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Wie immer: Bitte die LBS-Beschaltung posten, dann kann ich mehr sagen.

    Kommentar


      Sorry, klar kommt sofort:
      image.png

      Kommentar


        Von der Beschaltung her schaut alles gut aus.

        Was steht sonst im Fehlerlog ? Irgendwas, dass der Login fehlgeschlagen ist ?

        Kommentar


          Hi,

          der Fehler ist gefunden. Im Passwort fehlte ein Zeichen. Warum das allerdings von heute auf morgen sich verändert hat, ist mir schleierhaft. Den Baustein hatte ich ewig nichts angefasst.

          Vielen Dank für die Hilfe trotzdem!

          VG Finn

          Kommentar


            Hi sipiyou

            Dein Visu Element ist toll, wenn man ne Visu hat ;-) , aber viele Dinge möchte man doch automatisieren :-)
            Die "Pläne" in der Xiaomi App sind ja ganz nett dafür.
            Die jetzt mit Edomi zu verheiraten wäre super.

            Jetzt habe ich hier gelesen das diese wohl auch in der API Punkte zu gibt.
            https://github.com/marcelrv/XiaomiRo...aster/timer.md


            Mich würde da der vor allem der Punkt Enable/Disable interessieren
            https://github.com/marcelrv/XiaomiRo...cleaning-timer

            Sehe ich das überhaupt richtig? Falls ja wie stehen die Chancen das mal fürs Winterupdate mit aufzunehmen 💐 ?
            LG

            Jean-Luc Picard: "Things are only impossible until they are not."

            Kommentar


              Puh. Also, eigentlich wollte ich diese Funktionen nicht implementieren. Wenn du den per Timer laufen lassen willst, kannst du die Edomi-Timer verwenden und dann den LBS entsprechend triggern.

              Oder was spricht gegen Edomi-Timer ?

              Kommentar


                Hi,

                hatte jetzt schon den Fall das er plötzlich morgens mit dem edomi zsu sich im raum verwechselt hat. obwohl ich natürlich vorher den raummap getriggert hatte. das lief ja auch wochen gut. Das hatte die Folge das er einen Parkett gewischt hat den ich nicht mit Microfaser wischen würde.
                Hier ist ein Vorteil der app Timer. falls da eine Zuordnung mal nicht stimmt führt er das einfach nicht aus. Gerade bei automatisch ohne Anwesenheit muss man halt sicher sein das da auch das richtige läuft.
                hier würde meines achtens de/activate timer reichen. aber klar wenn ich der einzige bin dann lohnt sichs auch nicht

                lg
                Jean-Luc Picard: "Things are only impossible until they are not."

                Kommentar


                  Seit heute lässt sich mein S7MaxV nicht mehr per LBS steuern.
                  Es scheint als wäre das Cloud Token abgelaufen. Ich sehe folgende Info im Log:

                  Code:
                  2022-09-14 16:37:01 954442 15288 Info Xiaomi cloud token=L9VnvrMbdgO/4sOcx7pJiAQu7RtMcVzbz#####################iNl61/GP3S8Jt+0LjG09bdpGcOkin6+Aotd3T7xvWe2fbuYqfv3a3lmUmQ5D1Xn0i0sTqkRpb/00+ZOjw0P7TZNCroe1IvBH4rYHduCmHIXV+UgWV7Jfg=[LF]e1KvkgC1w4S8LT8/9d130g==[LF]1585584860
                  2022-09-14 16:37:14 042759 18029 Debug Cloud-Daten aus Cache verwenden. Kein Login!
                  2022-09-14 16:37:14 042898 18029 Debug V3=L9VnvrMbdgO/4sOcx7pJiAQu7RtMcVzbz###################fsiNl61/GP3S8Jt+0LjG09bdpGcOkin6+Aotd3T7xvWe2fbuYqfv3a3lmUmQ5D1Xn0i0sTqkRpb/00+ZOjw0P7TZNCroe1IvBH4rYHduCmHIXV+UgWV7Jfg=V4=e1KvkgC1w4S8LT8/9d130g==V5=1585584860
                  2022-09-14 16:37:14 042932 18029 Debug ip: bzw. token : sind leer. Cloud->getDeviceStatus()
                  2022-09-14 16:37:14 364649 18029 Kritisch Geräte-Status konnte nicht aus der Cloud ermittelt werden![LF]
                  2022-09-14 16:37:14 364722 18029 Debug cloud->isAccessible:Y-E10=-E11=
                  2022-09-14 16:37:14 364742 18029 Kritisch IP/Token leer! Baustein muss richtig konfiguriert werden! Abbruch
                  2022-09-14 16:37:14 390955 18029 Debug Ausführungszeit: 0.34871006011963 [s]
                  der LBS ist wie folgt beschaltet:

                  robo.png

                  Wie kann ich die Anmeldung wieder reaktivieren?
                  Habe schon versucht das Cloud Token am Eingang E7 zurückzusetzen, aber ohne Erfolg. An 10 taucht auch kein neues Token mehr auf.
                  Ich bin ein wenig ratlos...

                  sipiyou Kannst du mir einen Tip geben, was zu tun ist?

                  Kommentar


                    jonofe Bist du sicher, dass die Geräte-ID gleich geblieben ist ? Der Token wird automatisch erneuert, spätestens, wenn du Edomi neustartest.
                    D.h. wenn nach einem Edomi-Neustart das immer noch nicht geht, liegt der Fehler woanders.

                    Kommentar


                      Er läuft wieder. Ich habe den Ausgang A17 per remanentem iKO mit E7 verbunden. Das ist doch richtig, oder?

                      Ich musste manuell das iKO in der Liveansicht auf leer setzen und dann EDOMI neustarten, damit er sich neu einloggt und dann ein neues Token generiert.

                      Meine Vermutung ist folgende:
                      Solange E7 belegt ist, ist die userid ($V[5]) immer gesetzt und somit wird immer nur restoreCloudCredentials() aufgerufen und nicht cloudLogin(). So zumindest meine Vermutung. Oder gibt es noch eine andere Stelle, an der die Gültigkeit des Tokens geprüft und ggf. erneuert wird. Evtl. hab ich aber auch noch irgendwas anderes falsch konfiguriert.

                      Kommentar


                        Das ist dann der Fehler.

                        Wenn du nur einen Roboter hast, dann darfst du E7 nicht belegen, der Wert aus A10 ist dann auch egal.

                        Wenn mehere Roboter laufen, dann hast du einen "Master"-LBS, wo du E2+E3 angibst, aber E7 leer lässt.
                        Bei den "Slave"-LBS wird nur E7 mit den Wert aus A10 bestückt. Wichtig ist auch, dass das keine remanente Variable ist, weil der Token sich ändert und entsprechend auch abgerufen wird.

                        Wenn nur ein Roboter existiert, dann wird nur E2+E3 angegeben. A7 bleibt leer und A10 kann ignoriert werden.

                        Kommentar


                          Zitat von sipiyou Beitrag anzeigen
                          Wenn du nur einen Roboter hast
                          Okay verstehe. Dann war das meine Fehlinterpretation aus der Hilfe, da dort zuerst von Xiaomi Geräten und danach von Robotern die Rede ist. Da ich mehrere Xiaomi Geräte habe (daher auch die ID 9 meines Roboters) aber nur einen Roborock, kam es wohl zu dem Missverständnis.
                          Hab jetzt E7 unbelegt gelassen, damit sollte es dann jetzt dauerhaft laufen.

                          sipiyou: Danke für die Hilfe!

                          Kommentar

                          Lädt...
                          X