Ankündigung

Einklappen
Keine Ankündigung bisher.

LBS für easee Wallbox

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • AtoTheB
    antwortet
    Hallo zusammen,

    ich habe wie ctx ebenfalls die Fehlermeldungen, das der index ; status fehlt. Hat das mal jemand behoben bekommen?

    Hat jemand von euch zufällig eine PV-Überschuss-Regelung realisiert bekommen?


    Mir fehlt da leider das Know-How. Vielleicht kann mich hier jemand unterstützen oder hat hier was gebastelt was man für eine Spende mit nutzen könnte?

    Ich habe interne iKo´s in Edomi mit den notwendigen Daten (Ladestatus Batterie, akt. Hausverbrauch und akt. PV-Leistung, etc.)
    Der LBS läuft ja auch ohne Probleme nur, wenn ich nicht zuhause bin und meine Frau das Auto selbstständig lädt, dann ist der Batteriespeicher ständig leer -> das ist ziemlich ärgerlich *g*

    Wäre nett falls sich jemand bissel mehr auskennt und mir helfen könnte.
    Zuletzt geändert von AtoTheB; 02.10.2022, 19:32.

    Einen Kommentar schreiben:


  • kingolli
    antwortet
    ....und der Aktualisierungsinterval ist natürlich noch interessant...

    Einen Kommentar schreiben:


  • kingolli
    antwortet
    Zitat von basaltnischl Beitrag anzeigen

    So sieht es im Moment bei mir aus


    A973BBD4-A861-49AA-8DFC-5D455F25309C.jpeg
    Moin!

    Würdest du mal teilen, welche KOs du da verknüpft hast, gerade auto(Überschuss) wäre für interessant und welche KOs du auf welchen LBS Eingang verbindest? E11, E12 und E13 sind mir irgendwie unklar.

    Danke!

    Grüße
    David

    Einen Kommentar schreiben:


  • bobeknx
    antwortet
    Wo finde ich die aktuelle Version? bzw welche Version ist aktuell?

    Einen Kommentar schreiben:


  • basaltnischl
    antwortet
    Hallo Sebastian,
    keine Ahnung warum ich den mal rein genommen habe. Benutze den selber nicht.

    Ja die Doku ist etwas mau, mußte mich schon oft damit rumärgern.
    https://api.easee.cloud/index.html

    Hab A11 mit eingefügt für die nächste Version :-)
    Danke

    Einen Kommentar schreiben:


  • Fritze484
    antwortet
    Danke für den LBS!

    Noch eine Anmerkung: OutputPhase (A14) scheint mir der Phasenwinkel zu sein (bei mir wird 30 ausgegeben) und NICHT der Phasenmodus (in der Hilfe wird auf E10 verwiesen, aber das 1/3phasige Laden wird ja bereits auf A1 ausgegeben).
    Kann das jemand bestätigen?

    Ergänzend zu ChargerOPMode (A11): 5= Error, 6= Ready to Charge.


    Ich finde die Dokumentation der Zurückgelieferten Werte von Easee selbst als Herausgeber der API etwas Mager, oder kennt jemand ne gute Quelle?

    Einen Kommentar schreiben:


  • ctx
    antwortet
    Hallo Zusammen

    Ich habe täglich eine Errormeldung und ich weiss nicht woher ? ...

    Code:
    2021-07-14 19:10:02;305553;?;19833;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR 2021-07-15 19:04:00;996186;?;5621;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status, ERROR
    2021-07-16 18:58:00;932943;?;25419;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR 2021-07-17 18:52:00;821038;?;13539;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR 2021-07-18 18:46:00;882240;?;1498;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR
    2021-07-19 18:40:01;503762;?;21573;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR 2021-07-20 18:34:00;938041;?;10253;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR 2021-07-21 18:28:00;749686;?;4329;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR
    2021-07-22 18:22:00;897114;?;25798;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR 2021-07-23 18:16:00;988157;?;13110;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR 2021-07-24 18:10:01;607750;?;32763;Datei: /usr/local/edomi/www/data/liveproject/lbs/EXE19000215.php | Fehlercode: 8 | Zeile: 43 | Undefined index: status;ERROR
    ich benutze noch den Solarmanger, dieser regelt Primär das Gerät.
    Mit dem Baustein lese ich nur aus.

    Einen Kommentar schreiben:


  • basaltnischl
    antwortet
    Zitat von AtoTheB Beitrag anzeigen
    ich bin gerade dabei den LBS in die Visu einzubauen, wie habt ihr das optisch für euch gelöst? Wäre für den ein oder anderen Input Dankbar
    So sieht es im Moment bei mir aus


    A973BBD4-A861-49AA-8DFC-5D455F25309C.jpeg

    Einen Kommentar schreiben:


  • beamlight
    antwortet
    Bei mir funktioniert der LBS jetzt. Besten Dank für die Anpassungen

    Einen Kommentar schreiben:


  • AtoTheB
    antwortet
    Hallo Leute,

    ich bin gerade dabei den LBS in die Visu einzubauen, wie habt ihr das optisch für euch gelöst? Wäre für den ein oder anderen Input Dankbar

    Grüße

    André

    Einen Kommentar schreiben:


  • AtoTheB
    antwortet
    Hallo Frank,

    Vielen Dank für deine Mühe und das updaten der LBS. Import und Funktion i.O. nur in der Hilfe hat er das 'ü' nicht korrekt übernommen, aber das ist auch wurscht. Falls deine V2.0 fertig ist, freue ich mich aufs testen. *g*

    Liebe Grüße

    André

    Einen Kommentar schreiben:


  • basaltnischl
    antwortet
    So jetzt noch mal geändert.

    Ich nutze auf dem Mac BBedit. Damit funktioniert das kopieren und einfügen in den Baustein Problemlos.
    Aber evtl. gibt es Probleme beim speichern des LBS.

    Einen Kommentar schreiben:


  • AtoTheB
    antwortet
    Hallo zusammen,

    ich habe für die Editierung Notepad + + genutzt. Bei mir funktioniert der Upload des LBS ohne Probleme. Diesen habe ich auch an Frank geschickt. Ich hab keine Ahnung, wo nun der Bug liegt.

    Habe die Fragezeichen nun nochmal entfernt und Frank den LBS zugesendet. Ich hoffe das es das nun gewesen ist.

    LG
    Zuletzt geändert von AtoTheB; 09.07.2021, 21:17.

    Einen Kommentar schreiben:


  • starwarsfan
    antwortet
    Hallo miteinander,

    schon besser, die Fehler sind in der IDE weg. Import habe ich jetzt mangels greifbarer Edomi-Dev-Instanz nicht getestet. Es hat allerdings noch immer einige seltsame Zeichen im Baustein:

    19000215_leichtKaputt.png

    Schau ich mir die Datei als Hex-Dump an und suche bspw. nach A16, findet sich folgendes:

    19000215_leichtKaputtHex.png

    Das vierte Zeichen der ersten Zeile ist ein "richtiges" Leerzeichen, #20. In der zweiten Zeile das dritte Zeichen sollte auch ein Leerzeichen sein, ist aber #3F. Das ist laut ASCII-Tabelle tatsächlich ein Fragezeichen. Sehr seltsam...

    Welchen Editor benutzt Du denn genau?

    Einen Kommentar schreiben:


  • ctx
    antwortet
    Merci basaltnischl

    Auf Zeile 263 und 267 hat es bei $url noch ein ? (ich denke das ist zu viel ), ohne diese kann ich den Baustein laden.

    So nun können wir richtig loslegen.
    Bei E1 legst du ein Trigger an jede Minute oder wie viel mal kann die API getriggert werden ?
    Zuletzt geändert von ctx; 09.07.2021, 18:43.

    Einen Kommentar schreiben:

Lädt...
X