Ankündigung

Einklappen
Keine Ankündigung bisher.

Homeconnect Suite LBS 19002520-19002530

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #61
    Nabend zusammen.

    Ich bekomme leider nicht einmal den Server regestriert. Was mache ich falsch?
    Error.png
    Angehängte Dateien

    Kommentar


      #62
      Ist die Appplikation neu erstellt, oder eine schon etwas länger bestehende? Wenn es eine ältere ist, dann mal eine neue anlegen, da gibt es scheinbar Unterschiede bei der Registrierung.
      Mfg Micha
      Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

      Kommentar


        #63
        Ich habe die Applikation vorhin erstellt. Auch schon zwei mal gelöscht und neu erstellt.

        Kommentar


          #64
          Nutzt Du Docker oder ähnliches? Was steht bei Dir in der edomi.ini für eine IP vom EDOMI Rechner? Diese globale Variable wird für die Registrierung verwendet. Wenn Du es schaffst, schau mal in die /usr/local/edomi/www/data/redir.php.

          Dort sollte eine Zeile auftauchen die mit
          Code:
          $postdata =
          beginnt. darin sollte
          Code:
          &redirect_uri=http://DEINE_EDOMI_IP/visu/redir.php
          auftauchen. Wenn die IP nicht drinnsteht, muss ich dem LBS den Eingang 4 wieder spendieren.


          Edit: die IP müsste auch in dem Text an A2 drin stehen, spart einiges an Sucherei.
          Mfg Micha
          Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

          Kommentar


            #65
            Zitat von vento66 Beitrag anzeigen
            Ja, sollte eigentlich mit E14 =100 umzuschalten sein, zumindest ist 100 die manuelle Auswahl, und ungleich 100 eine der fixen Farben.
            Über die Eingabe von 32 bis 40 wechselt er in die "Farbauswahl" mit der gewählten Farbe.
            Zurück in die "Eigene Farbe" komme ich nicht mehr. Mit Eingabe von 100 in E14 kommt das:

            Code:
            2022-01-14 21:58:58 574815 15334 debug LBS19002522 [v0.23]: call exec
            2022-01-14 21:58:58 638319 20650 debug EXE19002522 [v0.23]: postdata: https://api.home-connect.com/api/homeappliances/SIEMENS-LD88WMM66-68A40E521259/settings/BSH.Common.Setting.AmbientLightColor {"data":{"key":"BSH.Common.Setting.AmbientLightCol or","value":"BSH.Common.EnumType.AmbientLightColor .CustomColor"}}
            2022-01-14 21:59:01 706332 20650 debug EXE19002522 [v0.23]: Send header HTTP/1.1 204 No Content[CR][LF]Date: Fri, 14 Jan 2022 20:59:01 GMT[CR][LF]Connection: keep-alive[CR][LF]access-control-allow-origin: *[CR][LF]access-control-allow-methods: GET,POST,OPTIONS,PUT,DELETE[CR][LF]access-control-allow-credentials: true[CR][LF]access-control-allow-headers: Authorization,Content-Type,Accept,Cache-Control,Last-Event-ID,If-Modified-Since,X-Requested-With,X-Events-Facade,User-Agent[CR][LF]referrer-policy: origin[CR][LF]x-frame-options: sameorigin[CR][LF]x-content-type-options: nosniff[CR][LF]x-xss-protection: 1; mode=block[CR][LF]api-gateway-service: api-gateway[CR][LF]hc-env: EU-PRD[CR][LF]x-vcap-request-id: 04b762ff-3e3d-4c8c-5a63-198533e0fc0b[CR][LF][CR][LF]
            Wenn ich über App zwischen der Reitern "Eigene Farbe" und "Farbauswahl" wechsle kommt im Log:

            Code:
            2022-01-14 21:57:32 128287 15334 debug LBS19002522 [v0.23]: call exec
            2022-01-14 21:57:32 193970 20572 debug EXE19002522 [v0.23]: Array E1
            2022-01-14 21:57:32 194219 20572 debug EXE19002522 [v0.23]: ================ ARRAY/OBJECT START ================
            2022-01-14 21:57:32 194312 20572 debug EXE19002522 [v0.23]: {"items":[{"name":"Farbwahl und Helligkeit","timestamp":1642193851,"handling":"non e","uri":"\/api\/homeappliances\/SIEMENS-LD88WMM66-68A40E521259\/settings\/BSH.Common.Setting.AmbientLightColor","key":"BSH.C ommon.Setting.AmbientLightColor","displayvalue":"M ittelblau","value":"BSH.Common.EnumType.AmbientLig htColor.Color32","level":"hint"}],"haId":"SIEMENS-LD88WMM66-68A40E521259"}
            2022-01-14 21:57:32 194377 20572 debug EXE19002522 [v0.23]: ================ ARRAY/OBJECT END ================
            2022-01-14 21:57:38 629776 15334 debug LBS19002522 [v0.23]: call exec
            2022-01-14 21:57:38 691943 20591 debug EXE19002522 [v0.23]: Array E1
            2022-01-14 21:57:38 692181 20591 debug EXE19002522 [v0.23]: ================ ARRAY/OBJECT START ================
            2022-01-14 21:57:38 692266 20591 debug EXE19002522 [v0.23]: {"items":[{"name":"Farbwahl und Helligkeit","timestamp":1642193857,"handling":"non e","uri":"\/api\/homeappliances\/SIEMENS-LD88WMM66-68A40E521259\/settings\/BSH.Common.Setting.AmbientLightColor","key":"BSH.C ommon.Setting.AmbientLightColor","displayvalue":"E igene Farbe","value":"BSH.Common.EnumType.AmbientLightCo lor.CustomColor","level":"hint"}],"haId":"SIEMENS-LD88WMM66-68A40E521259"}
            2022-01-14 21:57:38 692316 20591 debug EXE19002522 [v0.23]: ================ ARRAY/OBJECT END ================
            2022-01-14 21:57:42 199325 15334 debug LBS19002522 [v0.23]: call exec
            2022-01-14 21:57:42 265091 20598 debug EXE19002522 [v0.23]: Array E1
            2022-01-14 21:57:42 265362 20598 debug EXE19002522 [v0.23]: ================ ARRAY/OBJECT START ================
            2022-01-14 21:57:42 265429 20598 debug EXE19002522 [v0.23]: {"items":[{"name":"Farbwahl und Helligkeit","timestamp":1642193861,"handling":"non e","uri":"\/api\/homeappliances\/SIEMENS-LD88WMM66-68A40E521259\/settings\/BSH.Common.Setting.AmbientLightColor","key":"BSH.C ommon.Setting.AmbientLightColor","displayvalue":"M ittelblau","value":"BSH.Common.EnumType.AmbientLig htColor.Color32","level":"hint"}],"haId":"SIEMENS-LD88WMM66-68A40E521259"}
            2022-01-14 21:57:42 265479 20598 debug EXE19002522 [v0.23]: ================ ARRAY/OBJECT END ================
            2022-01-14 21:57:45 152903 15334 debug LBS19002522 [v0.23]: call exec
            2022-01-14 21:57:45 214914 20605 debug EXE19002522 [v0.23]: Array E1
            2022-01-14 21:57:45 215138 20605 debug EXE19002522 [v0.23]: ================ ARRAY/OBJECT START ================
            2022-01-14 21:57:45 215219 20605 debug EXE19002522 [v0.23]: {"items":[{"name":"Farbwahl und Helligkeit","timestamp":1642193864,"handling":"non e","uri":"\/api\/homeappliances\/SIEMENS-LD88WMM66-68A40E521259\/settings\/BSH.Common.Setting.AmbientLightColor","key":"BSH.C ommon.Setting.AmbientLightColor","displayvalue":"E igene Farbe","value":"BSH.Common.EnumType.AmbientLightCo lor.CustomColor","level":"hint"}],"haId":"SIEMENS-LD88WMM66-68A40E521259"}

            Kommentar


              #66
              Zitat von vento66 Beitrag anzeigen
              Nutzt Du Docker oder ähnliches?
              .
              Edit: die IP müsste auch in dem Text an A2 drin stehen, spart einiges an Sucherei.
              Docker oder ähnliches nutze ich nicht.
              In dem Text an A2 steht die richtige IP

              Kommentar


                #67
                Und in der Applikation passen die Einstellungen? Die IP muss ja bei Dir stimmen... Aber der Rest? Ich hab so gar keine Idee, wo es klemmen könnte. Keine Ahnung, ob es zwingend notwendig ist, aber dein homeconnect Gerät ist in der APP (IOS / Android) angelegt?




                hc_reg.png

                Und in der Applikation ist 'OAuth Flow Authorization Code Grant Flow' eingestellt?
                Zuletzt geändert von vento66; 15.01.2022, 08:25.
                Mfg Micha
                Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                Kommentar


                  #68
                  toddler Du bekommst nach dem Senden über EDOMI den Statuscode 204 zurück

                  Homeconnect meint dazu:
                  Code:
                  Once again, a response of 204 - No Content means it worked.
                  Ich kann auch keinen Unterschied erkennen...
                  Mfg Micha
                  Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                  Kommentar


                    #69
                    vento66 Ist alles ganz genau so wie bei dir, nur das halt meine IP dort eingetragen ist.

                    Kommentar


                      #70
                      Jetz bin ich etwas ratlos, an E2 / E3 hat sich am Ende kein Leerzeichen / Zeilenumbruch eingeschlichen?
                      Mfg Micha
                      Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                      Kommentar


                        #71
                        Ich bekomme seit ein paar Tagen immer "429 Too Many Requests sleep until 22:44:46" als Fehler.
                        Der LBS läuft mit einer 1 an E1, eine Idee woran das liegt? Es gibt nur den einen HomeConnect LBS.
                        ---
                        Martin

                        Kommentar


                          #72
                          Zitat von vento66 Beitrag anzeigen
                          an E2 / E3 hat sich am Ende kein Leerzeichen / Zeilenumbruch eingeschlichen?
                          leider nicht 😔

                          Kommentar


                            #73
                            martinb07 Das war ein Fehler im "alten" 19002520. Hoffentlich ist es jetzt in der Version 0.3 bereinigt.
                            Mfg Micha
                            Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                            Kommentar


                              #74
                              BuBa Dein EDOMI Rechner kommt aber ins Internet? Mir gehen echt die Ideen aus.
                              Mfg Micha
                              Qualifizierte und richtige Antworten gibts nur von Leuten, die während des Neustarts des HS Zeit für einen Post haben!

                              Kommentar


                                #75
                                Ja ins Internet kommt er definitiv. Ich denke ich werde die Tage mal ein Testsystem aufsetzen und dort noch einmal mein Glück versuchen.

                                Kommentar

                                Lädt...
                                X