Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

LBS 19000141 - Beschattungssteuerung

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Fehler in Hilfe Text gesichtet.

    Code:
    E27: Breite eines gewuenschten Lichtstreifens. Legt fest, wie weit die Sonne in den Raum hinein scheinen soll. Muss
    in der gleichen Einheit wie E16 angegeben werden. Also beide in bspw. mm oder cm.
    E28: Gesamthoehe resp. Fahrweg der Jalousie. Wird benoetigt, wenn unter E27 ein Lichtstreifen eingestellt wird, um
    die Position der unteren Kante der Jalousie zu berechnen. Muss in der gleichen Einheit wie E15 angegeben werden.
    Also beide in bspw. mm oder cm.
    E16 = E28
    E15 = E27


    Gruß
    Klaus

    Kommentar


      Hallo Klaus

      Zitat von sunnyhd Beitrag anzeigen
      Fehler in Hilfe Text gesichtet.
      Danke für die Info. Ein Überbleibsel des Refactorings der Version 2.x, wird korrigiert.
      Kind regards,
      Yves

      Kommentar


        Zitat von starwarsfan Beitrag anzeigen
        Du könntest evtl. mal noch einen Screenshot mit ein paar Kommentaren hier einstellen, wie Du die Verknüpfungen nun effektiv gemacht hast. Der eine oder andere hat sicher seine liebe Mühe damit, der Beschreibung folgen zu können...
        mach ich sobald es alles wirklich stabil über ein paar Tage mal läuft... ist leider auch alles etwas tricky, da ich nun schon wieder einen Fall gefunden habe in dem die Rückmeldung des MCU09 leider wieder den LBS sperrt. Die jetzt eben definierte Lösung (Logik vor dem Rückmeldeeingang des LBS) kommt nun hoffentlich mit allen Fällen klar (auch mit dem der kontinuierlichen Rückmeldung des MCU09, da ich das Feature schon schön für die Visu fand)

        Zitat von starwarsfan Beitrag anzeigen
        PS: Achja, ich bin daran, den separaten Eingang für die Beschattungsschwelle zu implementieren...
        Danke!

        Gruß
        Andi

        Kommentar


          Zitat von sunnyhd Beitrag anzeigen
          Hallo Yves,
          hab die letzen Tage auch Deinen tollen Baustein getestet.
          Hab nur Rollläden aber das funktioniert echt gut.
          sunnyhd: Könntest Du mal einen Screenshot machen. Ich habe auch "nur" Rolläden. Mich hat bisher die Komplexität des Bausteins abgeschreckt. Wenn ich diese reduzieren könnte, indem ich weiss welche Eingänge bei Rolläden relevant sind und welche nicht, dann würde mir das sehr helfen.

          Kommentar


            Hallo Andre

            Zitat von jonofe Beitrag anzeigen
            Mich hat bisher die Komplexität des Bausteins abgeschreckt.
            Du solltest einfach alles was sich auf Winkel der Lamellen bezieht ignorieren können.
            Kind regards,
            Yves

            Kommentar


              Hier ein Screenshot.
              Hab aktuell noch keine Wetterstation im Einsatz. E3-E5 kommen in der Regel von einer Wetterstation.

              Gruß
              Klaus

              Bildschirmfoto 2016-09-04 um 22.30.44.png Bildschirmfoto 2016-09-04 um 22.30.44.png

              Kommentar


                starwarsfan & sunnyhd: Super, vielen Dank für eure Rückmeldung. Denke ich werde mich nächstes Wochenende mal da ranmachen. Vermutlich aber nicht ohne weitere Rückfragen.

                Kommentar


                  da es nun seit 2 Tagen ohne Probleme funktioniert hier nun mal meine Einbindung des Bausteins mit einem BMS MCU-09. LBS_Beschattungssteuerung.PNG
                  Gruß
                  Andi

                  Kommentar


                    Hi,

                    inzwischen läuft die autom. Beschattung recht zuverlässig bei mir. Was ich nun auch eingestellt habe ist die Deaktivierung der Automatik über E33 und E34. Klappt auch gut.

                    Was ich noch nicht hinbekomme ist Folgendes: Wenn ich die Jalousien händisch bewege, wird die Automatik deaktiviert. Ich setze über A8 ein internes Status-KO auf 1 oder 0. Zusätzlich habe ich ein internes "Aktivierungs-KO" für jeden Baustein. Damit kann ich in der Visu die Funktion "Zwischen 0 und 1 mit Status-KO umschalten" verwenden. Auch das klappt, es wird das abhängig vom Status-KO über das Aktivierungs-KO 1 oder 0 gesendet und der Baustein entsprechend wieder ein- oder ausgeschaltet. Wenn ich nun einen über E33/E34 deaktivierten Baustein über das "Aktivierungs-KO" wieder anschalte, so bekomme ich zwar über mein Status-KO die Rückmeldung, dass der Baustein wieder aktiv ist - allerdings bewegt sich der Raffstore nicht und bleibt in der manuell gesetzten Position. Ich hätte jetzt erwartet, dass nach Wiedereinschalten eines Bausteins direkt die Ermittlung der anzufahrenden Werte ausgelöst wird. Nun liegt das sicher daran, dass das Einschalten des Bausteins noch kein Trigger ist - deswegen habe ich das Aktivierungs-KO ebenfalls an E1 gehängt, falls der Wert "1" gesendet wird. Allerdings fährt der Raffstore dennoch nicht in die Automatikposition.

                    Kann mir jemand dabei helfen, wie ich das am besten umgesetzt bekomme? Danke schonmal!

                    €dit: Ich habe es gerade nochmal getestet: scheinbar wird die Berechnung erst beim nächsten "normalen" Trigger über E3 oder E5 ausgeführt, nicht aber bei E1 - kann es sein, dass das noch ein Bug ist?
                    Zuletzt geändert von baumhaus123; 16.09.2016, 09:34. Grund: Ergänzung Testfall
                    Gruß,
                    Matthias

                    Kommentar


                      Dass E1 keine Neuberechnung triggert ist mir beim testen auch schon aufgefallen.

                      Zusätzlich habe ich bei mir noch ein kleines Problem dem ich nicht ganz auf die Schliche komme.
                      Ich habe mit den aktuellen Behangstatus in ein remanentes interenes KO geschrieben, welches ich auch mit dem initial Behang Eingang verknüpft habe. Dennoch fährt mein Test-Store nach einem EDOMI-Neustart erst mal komplett zu (Höhe 100% / Winkel 100%) und danach sofort in die Beschattungsposition.

                      Viele Grüße,
                      Tim

                      Edit:
                      Ist es sinnvoll bzw. gewollt, dass der Baustein nicht triggert, wenn man z.B. E15 (Beschattung aktiv/inaktiv) ändert? Ich hatte gehofft, dass die Lamellen sich wieder öffnen, wenn ich bei aktiver Beschattung den Eingang auf 0 setze.
                      Zuletzt geändert von Crimson; 16.09.2016, 16:17. Grund: Frage hinzugefügt

                      Kommentar


                        Hi,

                        da ja jetzt langsam die Zeit kommt, in der die Sonne oft nicht mehr ausgesperrt werden soll, weil es kälter wird, mal eine Frage in die Runde: wie konfiguriert ihr für solche Fälle den Baustein? Die Beschattung ist bisher bei mir auf E15 fest mit "1" verdrahtet. Jetzt könnte man diesen Eingang ja auch schön über eine Logik befüllen, z.B. "aktiviere Beschattung wenn Differenz zwischen Außen und Innen-Temp den Wert X überschreitet und zusätzlich mind. Innentemp- von Y" oder Ähnliches - habt ihr dafür best-practices?

                        @Yves: was ich toll fände wäre ein zusätzlicher Eingang für "Heligkeit für Dämmerungsschwelle". Damit könnte man jedem Baustein dasselbe Helligkeits-KO zuweisen, und die Raffstoren würde Abends gleichzeitig wieder zufahren. Bisher habe ich teilweise minutenlange Zeitdifferenzen, wenn die untergehende Sonne im Westen noch lange scheint, während der Osten bereits zugemacht hat. Ist nicht dramatisch, aber ein gleichzeitiges Schließen fände ich schöner.
                        Und das mit dem Trigger in E1 habe ich auch nicht hinbekommen.

                        Habe es inzwischen auch so wie tger977 implementiert, dass nach manuellem Verstellen ein Timer den Baustein nach 2 h wieder aktiviert. Funktioniert super und ist sehr komfortabel. Der Baustein ist einfach genial!
                        Gruß,
                        Matthias

                        Kommentar


                          Hallo und guten Abend

                          Zitat von baumhaus123 Beitrag anzeigen
                          Ich habe es gerade nochmal getestet: scheinbar wird die Berechnung erst beim nächsten "normalen" Trigger über E3 oder E5 ausgeführt, nicht aber bei E1 - kann es sein, dass das noch ein Bug ist?
                          Das kann ich so nicht nachvollziehen. Ein Refresh an E1,3,5,11,16,21,29 und neu E40 lösen den Baustein aus. Was steht denn im Debug-Log?


                          Zitat von baumhaus123 Beitrag anzeigen
                          was ich toll fände wäre ein zusätzlicher Eingang für "Heligkeit für Dämmerungsschwelle". Damit könnte man jedem Baustein dasselbe Helligkeits-KO zuweisen, und die Raffstoren würde Abends gleichzeitig wieder zufahren.
                          Das ist bereits implementiert und kommt mit dem nächsten Update. Bin noch am testen...


                          Zitat von baumhaus123 Beitrag anzeigen
                          Der Baustein ist einfach genial!
                          Das hört man gern.
                          Kind regards,
                          Yves

                          Kommentar


                            Danke fürs Feedback! Log werde ich am WE mal eins erstellen - irgendwie konnte ich es noch nicht richtig nachvollziehen, wann es geht und wann nicht. Manchmal triggert er die Ermittlung sofort, manchmal tut sich nichts. Getestet hatte ich es, indem ich nachts die Raffstoren geöffnet habe, der Baustein hat sich gesperrt, und anschließend habe ich den Baustein wieder mittels "1 auf E32 wieder angeschaltet und die Behang-Ermittlung mittels "1" auf E1 getriggert. Allerdings ist der Behang in der geöffneten Position geblieben. Wie gesagt, Log kommt am WE.
                            Gruß,
                            Matthias

                            Kommentar


                              Zitat von baumhaus123 Beitrag anzeigen
                              Hi,

                              da ja jetzt langsam die Zeit kommt, in der die Sonne oft nicht mehr ausgesperrt werden soll, weil es kälter wird, mal eine Frage in die Runde: wie konfiguriert ihr für solche Fälle den Baustein? Die Beschattung ist bisher bei mir auf E15 fest mit "1" verdrahtet. Jetzt könnte man diesen Eingang ja auch schön über eine Logik befüllen, z.B. "aktiviere Beschattung wenn Differenz zwischen Außen und Innen-Temp den Wert X überschreitet und zusätzlich mind. Innentemp- von Y" oder Ähnliches - habt ihr dafür best-practices?
                              Ich mach das so:

                              filedata/fetch?id=990832&d=1472332883&type=thumb


                              den Baustein werde ich die kommenden Tage dann auch endlich mal ins LBS-Portal hochladen, kann nix besonderes, aber u.a. genau das, was du suchst...

                              Kommentar


                                MrMirror : dein Baustein klingt super, werde ich mir dann gerne mal anschauen!
                                starwarsfan : hier mal ein Log von gerade eben:
                                HTML-Code:
                                2016-09-22 20:37:49    822144    22275    INFO:    LBS disabled through external angle change
                                2016-09-22 20:38:11    833900    22275    INFO:    LBS reactivated
                                2016-09-22 20:38:11    835882    22275    INFO:    Azimut 285.70001220703°: Facade at 267° is illuminated (from 177° to 357°, Azimut calc 108.70001220703°, entry calc at 0°, exit calc at 180°)
                                2016-09-22 20:38:11    836199    22275    INFO:    Shutter angle 100% = 90°
                                2016-09-22 20:38:11    839725    22275    INFO:    Previous values == current values, no new timer started (isInSun: 1, produceShadow: 0, heightPercent: 100, anglePercent: 100, previousShutterState: -2, shutterState: -2)
                                2016-09-22 20:38:11    882388    22275    INFO:    LBS reactivated
                                2016-09-22 20:38:11    883111    22275    INFO:    Azimut 285.70001220703°: Facade at 267° is illuminated (from 177° to 357°, Azimut calc 108.70001220703°, entry calc at 0°, exit calc at 180°)
                                2016-09-22 20:38:11    883358    22275    INFO:    Shutter angle 100% = 90°
                                2016-09-22 20:38:11    884280    22275    INFO:    Previous values == current values, no new timer started (isInSun: 1, produceShadow: 0, heightPercent: 100, anglePercent: 100, previousShutterState: -2, shutterState: -2)
                                Es ist aktuell dunkel draussen und der Raffstore ist komplett runtergefahren und geschlossen. Ich habe die "Sonderfall"-Raffstores, bei denen 50% komplett waagrecht bedeutet. Testfenster ist im Westen.
                                Um 20:38:11 habe ich die Lamellen in der Visu auf 26 % geöffnet, woraufhin sich der Baustein deaktiviert hat.
                                Um 20:38:11 habe ich via Button in der Visu den Baustein händisch wieder aktiviert. Allerdings schreibt er dann ja, dass Previous values == current values seien, was ja nicht stimmt, denn der Raffstore ist ja immer noch auf 26%.

                                Hier mal meine Konfiguration, evtl. hab ich ja auch hier einen Dreher:

                                Beschattungs_LBS_EG_Buero_Westfenster.png
                                Gruß,
                                Matthias

                                Kommentar

                                Lädt...
                                X