Ankündigung

Einklappen
Keine Ankündigung bisher.

vcontrold (Dämon für Viessmann Heizungssteuerungen) für EDOMI

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Log Level vom LBS hoch setzen hat nix ergeben...
    Mir ist jetzt aufgefallen, dass der Baustein unter CentOS 7 keine PID vom vcontrold am Ausgang A3 anzeigt.
    Der Daemon läuft aber, wenn man manuell im Logikeditor die Wertabfrage antriggert, blinkt der LBS auch nicht.

    EDIT: Noch was vergessen, es macht auch keinen Unterschied ob ich die selbst compilierten Binaries nutze,
    oder die aus dem Paket.
    2020-12-23 15:38:50 769232 2384 debug EXE19001530 [v1.3]: LBS started
    2020-12-23 15:38:50 777225 2384 debug EXE19001530 [v1.3]: starte vcontrold neu
    2020-12-23 15:38:50 777499 2384 debug EXE19001530 [v1.3]: stoppe vcontrold (neustart)
    2020-12-23 15:38:50 780668 2384 debug EXE19001530 [v1.3]: Fehler beim neustarten (beenden) von vcontrol : 127
    2020-12-23 15:38:50 780951 2384 debug EXE19001530 [v1.3]: LBS gestoppt
    Zuletzt geändert von urknall; 23.12.2020, 15:41.

    Kommentar


      2020-12-23 15:59:07 648041 2308 debug EXE19001530 [v1.3]: LBS started
      2020-12-23 15:59:07 649285 2308 debug EXE19001530 [v1.3]: Kommandos in /usr/local/edomi/main/vcontrol/template/410-vc-commands.txt schreiben
      2020-12-23 15:59:07 649833 2308 debug EXE19001530 [v1.3]: Template: Vorlage in /usr/local/edomi/main/vcontrol/template/410-vc-status.tmpl schreiben
      2020-12-23 15:59:07 657538 2308 debug EXE19001530 [v1.3]: starte vcontrold
      2020-12-23 15:59:07 659662 2308 debug EXE19001530 [v1.3]: Command: /usr/local/edomi/main/vcontrol/vcontrold -x /usr/local/edomi/main/vcontrol/vcontrold.xml -d /dev/ttyUSB0 -l /usr/local/edomi/main/vcontrol/vcontrold.log -p 3002 >/dev/null 2>&1 & echo $!
      2020-12-23 15:59:07 659930 2308 debug EXE19001530 [v1.3]: vcontrold gestartet mit PID: 2316
      2020-12-23 15:59:07 661201 2308 debug EXE19001530 [v1.3]: LBS stopped
      2020-12-23 15:59:18 444036 2371 debug EXE19001530 [v1.3]: LBS started
      2020-12-23 15:59:18 451102 2371 debug EXE19001530 [v1.3]: starte vcontrold neu
      2020-12-23 15:59:18 451406 2371 debug EXE19001530 [v1.3]: stoppe vcontrold (neustart)
      2020-12-23 15:59:18 454142 2371 debug EXE19001530 [v1.3]: Fehler beim neustarten (beenden) von vcontrol : 127
      2020-12-23 15:59:18 454480 2371 debug EXE19001530 [v1.3]: LBS gestoppt

      Kommentar


        Gelöst:

        killall commando fehlte in CentOS7 minimal:

        yum install psmisc

        Kommentar


          Hallo zusammen,

          ich bin gerade dabei den vcontrol auf meiner Edomi Instanz zum laufen zu bringen (Vitocal 222) Nach einigen Stolpersteinen kann ich zumindest per Telnet die Vitocal abfragen und auch Betriebsarten umschalten.

          Über Edomi läuft es aktuell nicht, mir fehlen irgendwie Ordner in der ZIP Datei. Kann es sein das der ZIP im Download Bereich unvollständig ist?
          Ordner Template zb fehlt in der Zip.

          @ MrIcemanLE könntest du evtl mal den LBS Zip checken? Das wäre ein super fein

          Besten Dank

          EDIT: Sorry für den Quark von oben, läuft nun. Der LBS ist komplett, allerdings musste ich den Ordner Template per Hand anlegen, damit er dann die Template Dateien ablegt. Läuft nun, Danke für den klasse Baustein
          Zuletzt geändert von BootCamper; 26.10.2021, 07:43.

          Kommentar

          Lädt...
          X