Ankündigung

Einklappen
Keine Ankündigung bisher.

Zwei knxd stören sich

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Zwei knxd stören sich

    Habe zwei Raspberrys mit knxd und smarthomeng in einem Netzwerk am laufen. Wenn ich beide aktiv habe, gibt's es in einem von beiden immer zufallige Schaltvorgänge. Kann ich irgendwie über eine knxd Option sicherstellen, dass nur über die eigene smarthomeng Instanz Befehle empfangen werden können?

    #2
    Warum hast Du 2? Wenn es schon so sein soll, dann darf nur auf einem das Routing aktiv sein.
    Mfg Micha
    Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

    Kommentar


      #3
      Zwei Häuser mit eigenem knx die ein LAN haben und beide ihre eigene visu nutzen sollen. Leider geht das nicht mit einem knxd. Haben beide die Onkel Andy Images.

      Kommentar


        #4
        Wenn die ein gemeinsames LAN haben, dann geht das sicher!
        Mfg Micha
        Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

        Kommentar


          #5
          Habe aber gleiche gruppenadressen auf beiden bussen. Hatte das damals schon gefragt http://knx-user-forum.de/forum/proje...-laufen-lassen

          Kommentar


            #6
            Code:
            [A.tcp]
            server = knxd_tcp
            systemd-ignore = true
            [B.ipt]
            driver = ipt
            filters = C.pace
            ip-address = 192.168.xx.xx
            [C.pace]
            delay = 30
            filter = pace
            [main]
            addr = 1.1.75
            client-addrs=1.1.76:8
            cache = D.cache
            connections = A.tcp,B.ipt
            systemd = systemd
            Wie kann ich da die Routing-Option deaktivieren?

            Kommentar


              #7
              Welche Routing-Option?
              Sicher dass da nicht die Gateways mit rumpfuschen?
              1wire, KNX, OpenHAB, Python, Asterisk, SMD-Lötkolben

              Kommentar


                #8
                Die "Störungen" treten nur auf wenn beide knxd laufen. Das spricht gegen die Gatewaytheorie. Stoppe ich einen von beiden, funktioniert alles wie es soll. Habe jetzt festgestellt, dass der eine knxd noch über eine alte knxd.conf konfiguriert war mit den Optionen -D -T -R -S. Und nur der anderen über die oben beschriebene Konfiguration mit einer knxd.ini läuft. Habe mal das -R entfernt. Bisher scheint es zu helfen. Würde das so ein Verhalten erklären?

                Kommentar

                Lädt...
                X