Ankündigung

Einklappen
Keine Ankündigung bisher.

knxd Config

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • rdorsch
    antwortet
    Hi Manfred,

    that is what I am using here:

    rd@home:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Debian
    Description: Debian GNU/Linux 9.5 (stretch)
    Release: 9.5
    Codename: stretch
    rd@home:~$ apt-cache policy knxd
    knxd:
    Installed: 0.14.23-1
    Candidate: 0.14.23-1
    Version table:
    *** 0.14.23-1 100
    100 /var/lib/dpkg/status
    rd@home:~$ cat /etc/knxd.conf
    # configuration for knxd.service
    #KNXD_OPTS="-e 0.0.1 -E 0.0.2:8 -u /tmp/eib -b ip:"
    #KNXD_OPTS=" -f9 -t 0xffe -e 1.1.227 -E 1.0.228:8 -t 65535 -u /tmp/eib -B single --send-delay=70 -b ipt:192.168.0.17"
    KNXD_OPTS="-e 1.1.227 -E 1.1.228:8 -t 65535 -u /tmp/eib -B single --send-delay=70 -b ipt:mdt"

    # The default options are "-u /tmp/eib -b ip:"
    # which tell knxd to route between all of
    # /tmp/eib (legacy socket (-u))
    # multicast client (-b ip.
    # knxd's own bus address is 0.0.1; it will assign 0.0.2…0.0.9 to clients.
    # The knxd.socket file also tells knxd to listen to
    # /run/eib (socket activation via systemd)
    # TCP port 6720 (socket activation via systemd)
    # You *need* the -e option. Clients cannot connect without "-E".

    # You can read knxd's logs with
    # $ journalctl -u knxd --since "10 min ago"
    # (or whatever). See the manpage for details.
    # You need to be a member of the "adm" group.
    # Add "-f9 -t1023" to the beginning of the command line for extensive logging.

    # *** DO NOT use "-u" / "-u /run/knx" or "-i" / "-i 6720" here.
    # Systemd already does that on behalf of knxd, via 'knx.socket'.

    # *** DO NOT use both "-RS" and "-b ip:" (unless you specify a
    # different multicast address on one of them). You'd create a loop.

    # If you have KNX hardware on a serial port or USB, add the appropriate
    # "-b TYPE:…" option. In this case, you probably want to set up a multicast
    # server, not a client (i.e. use "-D -T -R -S", not "-b ip:").
    # DO NOT use both.
    #
    # If your KNX hardware is a KNX/IP gateway that doesn't do multicast,
    # use "-b ipt:192.168.1.2" (or its DNS name) to talk to it.
    #
    # KNX MUST NOT have more than one path between any two devices. Thus,
    # you need to make sure that the KNX/IP gateway does not route multicast
    # before you use both "-S" and "-b ipt:".

    # The default bus address of knxd is 0.0.1. If that's in use in your KNX
    # network (or if you run more than one knxd on your network), set a
    # different address, for example "-e 7.0.99".

    # You should have a block of free addresses on your KNX bus which knxd can
    # assign to clients: "-E 7.0.100:28" will use 7.0.100 through 7.0.127.
    # If no such range is given, or if it's full, knxd uses its own address.
    # That mostly works, but separate addresses are much better.

    # Run `knxd --help` to get a complete list of available options and drivers.

    ## DO NOT use the following options:
    ## -i -- /lib/systemd/system/knxd.socket does this for us
    ## -u /run/knx -- likewise
    ## -d -- /lib/systemd/system/knxd.service expects knxd to run in the foreground
    ## -p PIDFILE -- please use systemctl to control knxd

    ################################################## #############################
    # This file is ignored when NOT using systemd: edit /etc/default/knxd instead #
    ################################################## #############################
    rd@home:~$
    grep mdt /etc/hosts
    192.168.0.24 mdt
    rd@home:~$



    On the MDT KNX IP Interface

    KNX IP-Interface
    Status Programming Mode: Off
    Change Programming Mode:
    Individual Address 1. 1.241
    Tunneling Addresses 1. 1.250
    1. 1.251
    1. 1.252
    1. 1.253
    Set Tunneling Addresses
    Serial Number XXXXXXX
    TP Device
    Status Programming Mode: Off
    Change Programming Mode:
    Individual Address 1. 1.242
    Serial Number XXXXXXXX



    I have a minor issue with the config:
    If I program physical addresses from ETS, I have to stop knxd before. Otherwise ETS complains that two devices on the bus are in programming mode and responding....

    ....but there have been discussions in the forum on that topic, but I did not get through them so far (also since it is not urgent, I rarely program physical addresses, programming just the application works without issues).

    Rainer
    Zuletzt geändert von rdorsch; 06.10.2018, 07:56. Grund: Additional information added

    Einen Kommentar schreiben:


  • Tru
    antwortet
    Zitat von ManfredA Beitrag anzeigen
    Can anyone help me to config my knxd?
    Another question is, what the meaning of "client addr"?
    To see all options type "knxd --help" (or knxd_args --help).
    "client addr" are free (unused) bus addresses knxd will assign dynamically to instances connecting to the bus through knxd. knxtool for example is one of them.
    To connect knxd to an IP interface your options typically look like this: -e a.b.c -E a.b.d:9 -DTS -b ipt:<ip of interface>
    If you want debugging info add -t 1023 before -b
    If you want knxd to act like a KNX router add R before S; with T it acts like an IP interface but with many tunnels in parallel (here 10)

    Einen Kommentar schreiben:


  • ManfredA
    hat ein Thema erstellt knxd Config

    knxd Config

    Hello;
    I'm biginner in the knxd, I installed the knxd package on my debian 9.
    I try to connect to my MDT IP interface to send a telegram on the KNX bus.
    when I send a telegram via "knxtool groupswrite" command to the KNX bus I can just see my telegram on "knxtool vbusmonitor1". but it dosen't show on my ETS bus monitoring.
    I think my problem is on the knxd configuration.
    Can anyone help me to config my knxd?
    Another question is, what the meaning of "client addr"?
    Thanks
Lädt...
X