Ankündigung

Einklappen
Keine Ankündigung bisher.

Prüfen ob Busware Pigator angeschlossen ist?

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Prüfen ob Busware Pigator angeschlossen ist?

    Hallo Zusammen,

    ich habe die Befuerchtung, dass mein Pigator von Busware defekt ist. Daher wuerde ich euch bitten, mir euren Output von

    Code:
    sudo udevadm info -a /dev/ttyAMA0
    zu zeigen.
    Ich habe sowohl mit einem Pi3 als auch einem Pi2 verscuht den knxd zum laufen zu bekommen. knxd beaendet sich immer wider weil er keine Verbindung auf Serial aufbauen kann.

    Bei mir kommt folgendes:
    Code:
    looking at device '/devices/platform/soc/3f201000.serial/tty/ttyAMA0':
    
        KERNEL=="ttyAMA0"
    
        SUBSYSTEM=="tty"
    
        DRIVER==""
    
        ATTR{port}=="0x0"
    
        ATTR{line}=="0"
    
        ATTR{iomem_reg_shift}=="0"
    
        ATTR{custom_divisor}=="0"
    
        ATTR{type}=="32"
    
        ATTR{io_type}=="2"
    
        ATTR{close_delay}=="50"
    
        ATTR{irq}=="81"
    
        ATTR{iomem_base}=="0x3F201000"
    
        ATTR{flags}=="0x10000000"
    
        ATTR{closing_wait}=="3000"
    
        ATTR{uartclk}=="0"
    
        ATTR{xmit_fifo_size}=="16"
    
    
    
    
      looking at parent device '/devices/platform/soc/3f201000.serial':
    
        KERNELS=="3f201000.serial"
    
        SUBSYSTEMS=="amba"
    
        DRIVERS=="uart-pl011"
    
        ATTRS{irq0}=="81"
    
        ATTRS{driver_override}=="(null)"
    
        ATTRS{id}=="00241011"
    
    
    
    
      looking at parent device '/devices/platform/soc':
    
        KERNELS=="soc"
    
        SUBSYSTEMS=="platform"
    
        DRIVERS==""
    
        ATTRS{driver_override}=="(null)"
    
    
    
    
      looking at parent device '/devices/platform':
    
        KERNELS=="platform"
    
        SUBSYSTEMS==""
    
        DRIVERS==""
    Ich suche genau die folgende Zeile:

    Code:
    ATTRS{manufacturer}=="busware.de".
    vielen Dank fuer die Hilfe, die man einfach nicht von Busware bekommt.

    #2
    udev interessiert sich nicht die Bohne für das, was hinter einer seriellen Schnittstelle hängt, geschweige denn der Konsole. Du wirst dort ganz bestimmt keine Attribute zum daran angeschlossenen Gerät finden.
    1wire, KNX, OpenHAB, Python, Asterisk, SMD-Lötkolben

    Kommentar


      #3
      mhmm ok.
      Vermutlich bekomme ich einen solchen output nur wenn ich TPUARt ueber USB und nicht wie in meinem Fall ueber serial nutzen will?

      Frage: Muss das KNX Kabel angeschlossen sein, damit der Pigator funktioniert? Der Daemon laueft, aber sobald ich das interface auf tpuarts stelle, versucht der Service sich permanent neu zu starten, da ein Fehler vorliegt. Aktuell habe ich KEIN KNX Kabel angeschlossen.

      Danke fuer die Hilfe

      Kommentar


        #4
        Ohne KNX-Kabel geht nix, weil der TPUART nicht reagiert, die rote LED muss leuchten.
        1wire, KNX, OpenHAB, Python, Asterisk, SMD-Lötkolben

        Kommentar


          #5
          Vielen Dank!

          Fuer alle die, wo der KNXD Service nicht starten will, klemmt eine Stromquelle an!

          Kommentar


            #6
            Also ich habe es aufgegeben, knxd mit dem Pigator zum Laufen zu bringen. Irgendwie kriege ich das nicht hin. Nun aber die Banausenfrage: Bei mir werkelt nun seit Jahren ein Raspi 1 mit Pigator Hat und eibd. Den nutzen hier die ETS und edomi und die funktionieren wunderbar. Welchen Grund gibt es denn, zum knxd zu wechseln?

            Kommentar


              #7
              Wenn es läuft? Keinen!
              Mfg Micha
              Ich sage ja nicht, das wir alle dummen Menschen loswerden müssen, aber könnten wir nicht einfach alle Warnhinweise entfernen und den Dingen ihren Lauf lassen?

              Kommentar


                #8
                Hallo,
                ich habe meine Pigator mit Raspi 3 mit folgenden Einstellungen am laufen, kannst du ja evtl. mal probieren wenn es noch aktuell ist:

                nano /etc/udev/rules.d/70-knxd.rules
                ACTION=="add", SUBSYSTEM=="tty", ATTRS{id}=="00241011", KERNELS=="3f201000.serial", SYMLINK+="ttyKNX1", OWNER="knxd"
                nano /boot/config.txt
                ###
                disable bluetooth and wifi
                ###
                dtoverlay=pi3-disable-bt
                dtoverlay=pi3-disable-wifi
                nano /boot/cmd.txt

                dwc_otg.lpm_enable=0 console=tty1 root=PARTUUID=ef201f6e-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait
                nano /etc/knxd.conf

                KNXD_OPTS="-e 0.0.1 -E 0.0.2:8 -t 0xffc -f 9 -DTS -c -b tpuarts:/dev/ttyKNX1"
                Ob das alles nötig bzw. richtig ist weiß ich nicht, funktioniert aber seit längerer Zeit ohne Probleme. Evtl. hilfts dir ja.

                Viele Grüße
                Tom

                Kommentar


                  #9
                  Zitat von vento66 Beitrag anzeigen
                  Wenn es läuft? Keinen!
                  Danke, da bin ich beruhigt.

                  Kommentar


                    #10
                    bkr wie gesagt, ich habe dem Pigator keinen Strom ueber die KNX Stromversorgung gegeben. Deshalb fuhr die Schnittstelle auch nicht hoch. Wenn Du das sicher gestellt hast, dann schau Dir die Log-Ausgabe vom KNXD an und Du solltest weiter kommen
                    Du kannst ja auch mal Deine Einstellungen schicken.

                    Kommentar

                    Lädt...
                    X