Ankündigung

Einklappen
Keine Ankündigung bisher.

RPI4 / 2GB / Buster - KNXD lässt sich nicht starten

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    RPI4 / 2GB / Buster - KNXD lässt sich nicht starten

    Hi,

    ich setze gerade als Ersatz meines RPI3B einen RPI4 auf und ich scheitere an KNXD. Liegt es an mir? Per Build (nach Github Anleitung) kann ich die Installation ohne Feher durchführen, aber knxd nicht starten:

    Code:
    [....] Starting knxd (via systemctl): knxd.serviceJob for knxd.service failed because the control process exited with error code.
    See "systemctl status knxd.service" and "journalctl -xe" for details.
     failed!
    Versuche ich bei Buster die Installation via
    Code:
    sudo apt-get install knxd
    lande ich direkt bei:

    Code:
    Paketlisten werden gelesen... Fertig
    Abh▒ngigkeitsbaum wird aufgebaut.
    Statusinformationen werden eingelesen.... Fertig
    knxd ist schon die neueste Version (0.14.30-1).
    0 aktualisiert, 0 neu installiert, 0 zu entfernen und 177 nicht aktualisiert.
    1 nicht vollst▒ndig installiert oder entfernt.
    Nach dieser Operation werden 0 B Plattenplatz zus▒tzlich benutzt.
    M▒chten Sie fortfahren? [J/n] j
    knxd (0.14.30-1) wird eingerichtet ...
    addgroup: Die Gruppe ▒knxd▒ existiert bereits als Systemgruppe. Programmende.
    Warnung: Das von Ihnen angegebene Home-Verzeichnis /var/lib/knxd existiert bereits.
    Der Systembenutzer ▒knxd▒ existiert bereits. Programmende.
    Job for knxd.socket failed.
    See "systemctl status knxd.socket" and "journalctl -xe" for details.
    A dependency job for knxd.service failed. See 'journalctl -xe' for details.
    Job for knxd.service failed because the control process exited with error code.
    See "systemctl status knxd.service" and "journalctl -xe" for details.
    invoke-rc.d: initscript knxd, action "restart" failed.
    * knxd.service - KNX Daemon
       Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: enabled)
       Active: activating (auto-restart) (Result: exit-code) since Thu 2019-10-03 00:15:59 CEST; 24ms ago
      Process: 773 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=2)
     Main PID: 773 (code=exited, status=2)
    dpkg: Fehler beim Bearbeiten des Paketes knxd (--configure):
     installiertes knxd-Skript des Paketes post-installation-Unterprozess gab den Fehlerwert 1 zurück
    Fehler traten auf beim Bearbeiten von:
     knxd
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    #2
    Buster enthält den KNXd doch? Warum baust Du den selbst?

    „apt-get install knxd knxd-tools“ sollte eigentlich genügen... werfe doch mal Deine selbst gebaute Version runter und versuche die in buster enthaltene...
    Zuletzt geändert von MGK; 03.10.2019, 06:42.

    Kommentar


      #3
      Genau das hatte ich erfolglos als erstes versucht... Ich probiere es nochmal mit einem jungfräulichen Buster...

      Kommentar


        #4
        Jetzt hat es geklappt - es lag entweder an den vergessenen KNXD-Tools oder das copy-paste einfügen meines "KNXD_OPTS= " Strings hat irgendetwas vermurkst. Händisch neu eingetippt klappt es jetzt. Danke euch/dir!

        Kommentar

        Lädt...
        X