Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

EibPC spinnt

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    EibPC spinnt

    Hallo und schönen Feiertag.

    Mein EibPC2 hat heute Nacht das spinnen angefangen. Dran geändert hab ich seit Wochen nichts.
    heute über Nacht kamen so 3000 Events, fast ausschließlich „ERR_UNKNOWN“.

    Webserver lief noch normal, er hat aber nichts von den automatischen Routinen ausgeführt.

    Hab ihn dann für 15 Sek vom Strom getrennt, lief erst normal, jetzt gehts wieder los.

    Jemand ne Idee.




    Code:
    0:ERR_ASYNC_SERIAL_2@2022-10-0310:28:42
    0:ERR_UNKNOWN@2022-10-03 10:30:25
    0:ERR_UNKNOWN@2022-10-03 10:30:25
    0:ERR_UNKNOWN@2022-10-03 10:30:25
    0:ERR_UNKNOWN@2022-10-03 10:30:25
    0:ERR_UNKNOWN@2022-10-03 10:30:25
    0:ERR_UNKNOWN@2022-10-03 10:30:25
    <>:ERR_FT12_RESET_REQ_IN@2022-10-0310:30:25
    <>:ERR_UNKNOWN@2022-10-03 10:30:25
    <>:ERR_FT12_RESET_REQ_IN@2022-10-0310:30:25
    <>:ERR_UNKNOWN@2022-10-03 10:30:25
    <>:ERR_UNKNOWN@2022-10-03 10:30:25
    <>:ERR_UNKNOWN@2022-10-03 10:30:25
    ​
    ....und versuchen Sie nicht erst anhand der Farbe der Stichflamme zu erkennen, was Sie falsch gemacht haben!

    #2
    ich würde den Support kontaktieren...

    Du kannst den eibpc natürlich auf Werksreset setzen und dann neu programmieren...
    EPIX
    ...und möge der Saft mit euch sein...
    Getippt von meinen Zeigefingern auf einer QWERTZ Tastatur

    Kommentar


      #3
      Was sagt denn die Objektauslastung? Ansonsten bitte mal einen Support-Export und optimalerweise einen Export der Events an uns schicken, dann schauen wir, was los ist.

      Kommentar


        #4
        Also nach den 3.000 Events über Nacht und dem Neustart kamen genau noch die 13 Events von oben. Seitdem war wieder Ruhe.
        Keine Ahnung welche Laus ihm da über die Leber gelaufen ist.
        ....und versuchen Sie nicht erst anhand der Farbe der Stichflamme zu erkennen, was Sie falsch gemacht haben!

        Kommentar


          #5
          ... interessant ...

          Ich hatte jetzt zwei mal genau das selbe. "Out of nothing" gingen vom EIBPC gesteuerte Funktionen nicht mehr, das Eventlog war voll von unknown Events im wechsel mit "failed to send". Nach einem Neustart der Applikation erstmal wieder alles normal - auch sammeln sich da keinerlei weiteren events.

          Nur wie das jetzt debuggen? Ich habe da nicht so viel Hoffnung das der Support da was im Projekt sehen kann, zumal sich das in meinem Fall schon sehr lange nicht mehr nennenswert geändert hat.

          Kommentar


            #6
            Das kann eigentlich nur ein Speicherproblem sein, also RAM voll. Nach einem Neustart könnte es trotzdem erneut dazu kommen, falls timebuffer die Ursache dafür sind. Ansonsten fällt mir nichts ein. In diesem Fall wäre am hilfreichsten, die Events mit den Objektnummern zu exportieren und mit dem unmodifizierten Programm an uns zu schicken. Dann können wir genau prüfen, welche Objekte betroffen sind. Wir haben bisher aber keine weiteren Hinweise darauf, das irgendeine Funktion im Laufe der Zeit Speicher "verliert".

            Kommentar


              #7
              kleiner Update: Gestern wieder so ein seltsamer Fall, allerdings mit komplett leerem Eventspeicher. Der EIB-PC hat keinerlei KNX Nachrichten mehr auf den Bus geschickt, obwohl die eigenen Nachrichten im EIB-Studio Gruppenmonitor angezeigt wurden. Der Empfang von Nachrichten lieft scheinbar problemlos. Ein Neustart des Programmes hat das Problem behoben.

              Aufgrund der fehlenden Events bin ich ja jetzt auch ratlos wie ich das debuggen sollte...

              Kommentar


                #8
                Hallo,

                klingt fast so, als sei die Busverbindung weg gewesen. EibPC1 oder 2? Welche Schnittstelle?

                Seltsam ist aber das Fehlen von Events, da Verbindungsabbrüche bei der Schnittstelle eigentlich geloggt werden.

                Kommentar


                  #9
                  ... und heute wieder. Nur ein einziger Event: ERR_PROC_OBJECT 5838(0x16cd) - allerdings schon 8 Tage alt. Wäre das der Auslöser für den Aufhänger gewesen, dann wäre mir das schon früher aufgefallen.
                  Es ist ein EIBPC2. Diesmal hat der reine Neustart der Applikation nicht ausgereicht - diese ist nicht mal mehr gestartet.
                  Powercycle hat es gerichtet.

                  Meine einzige Idee: Ich verwende den EIBPC auch als ETH-KNX router für eine andere Applikation. Vielleicht ist ihm das "zuviel"...
                  Zuletzt geändert von cds; 16.11.2022, 10:06.

                  Kommentar


                    #10
                    Hi

                    Zitat von cds Beitrag anzeigen
                    Vielleicht ist ihm das "zuviel"...
                    Uwe! verwendest du auch die Schnittstelle im "Dauerbetrieb" für andere Geräte? So könnten wir das ggf. eingrenzen. Würde aber insofern eine Möglichkeit sein, als dass die Schnittstelle weiterläuft, wenn das Programm neu gestartet wird.

                    Kommentar


                      #11
                      Im Dauerbetrieb eigentlich nicht, aber die ETS nimmt sie normal.
                      Grundsätzlich ist mein Eindruck, dass die Anzahl der Events im EibPC mit der Auslastung auf der Schnittstelle steigt.
                      ....und versuchen Sie nicht erst anhand der Farbe der Stichflamme zu erkennen, was Sie falsch gemacht haben!

                      Kommentar


                        #12
                        Also, an der Nutzung als Gateway lag es nicht. KNX send ist wieder tot, diesmal allerdings mit etlichen Events:
                        20.11.2022, 12:00:06 0(0x0) ERR_KNXNET_IP_L_DATA_CON
                        15.11.2022, 20:35:32 0(0x0) ERR_MSGSND_INTERFACE_IN_2
                        15.11.2022, 20:35:32 0(0x0) 0x080b

                        Letztere beiden vieeeeele.

                        Was noch auffällt: Kurz bevor obige beiden Fehler - die übrigens immer zusammen kommen - auftreten hatte ich eine ganze Reihe
                        15.11.2022, 20:32:45 65530(0xfffa) ERR_PROC_OBJECT



                        Was sagt mir das jetzt?

                        Kommentar


                          #13
                          Heute gehts mal wieder los.
                          seit 9:54:15 hagelt es 0:ERR_UNKNOWN. Immer zwei Stück alle ca. 10 Sek.
                          Ab und an mal von einem 0:ERR_PARSEXML_INTERNAL unterbrochen.


                          Webserver ist auf den ersten Blick normal bedienbar, es gehen aber keine Telegramme mehr rein oder raus.

                          Über EibStudio ist er auch nicht erreichbar. Einzig Trennung vom Strom hat geholfen. Da fehlt der Reboot Befehl im WebServer, oder gibt's den zwischenzeitlich?
                          Werd ich die Stromversorgung mal auf einen Aktorkanal legen müssen.
                          Zuletzt geändert von Uwe!; 22.11.2022, 14:56.
                          ....und versuchen Sie nicht erst anhand der Farbe der Stichflamme zu erkennen, was Sie falsch gemacht haben!

                          Kommentar


                            #14
                            cds
                            ERR_MSGSND_INTERFACE_IN_2 wird aufgezeichnet, wenn die interne Warteschlange für die Bus-Schnittstelle eingangsseitig überläuft, d.h. der EibPC kann die eintreffenden Telegramme nicht weiterverarbeiten.

                            Entweder ist die Hauptschleife so stark verzögert oder es kommen zu viele Telegramme. Oder Speicher voll.

                            Uwe!

                            ERR_PARSEXML_INTERNAL kommt, wenn zum XML-Parsen kein Speicher vorhanden ist.
                            Zum ERR_FT12_RESET_REQ_IN aus dem ersten Post: Das dürfte gar nicht auftauchen, falls eine IP-Schnittslelle (auch die integrierte Schnittstelle) verwendet wurde.

                            Was gegen die Speicher-Theorie spricht: es müsste dann auch im Eventlog ERR_SYSTEM_MEM_LOW aufgezeichnet werden.

                            Insgesamt habe ich noch keine richtige Idee, was die Ursache ist.

                            Bitte schickt und einen Support-Export, hoffentlich lässt sich in der Debug-Umgebung rausfinden, was da los ist. Ähnliches Verhalten haben wir bisher nirgendwo sonst

                            Zitat von Uwe! Beitrag anzeigen
                            oder gibt's den zwischenzeitlich?
                            Ne, wir versuchen statt dessen lieber, die Ursache zu finden.​

                            Kommentar


                              #15
                              Zitat von foobar0815 Beitrag anzeigen
                              Das dürfte gar nicht auftauchen, falls eine IP-Schnittslelle
                              War diesmal auch nicht dabei, aber so oder so wurde und wird nur die IP-Schnittstelle verwendet.
                              Zitat von foobar0815 Beitrag anzeigen
                              müsste dann auch im Eventlog ERR_SYSTEM_MEM_LOW
                              war nicht dabei!
                              Zitat von foobar0815 Beitrag anzeigen
                              Support-Export
                              kommt!
                              Zitat von foobar0815 Beitrag anzeigen
                              wir versuchen statt dessen lieber, die Ursache zu finden.​
                              Grundsätzlich der richtige Ansatz, aber das eine schließt das andere ja nicht automatisch aus.
                              ....und versuchen Sie nicht erst anhand der Farbe der Stichflamme zu erkennen, was Sie falsch gemacht haben!

                              Kommentar

                              Lädt...
                              X