Ankündigung

Einklappen
Keine Ankündigung bisher.

MDT SCN-IP100.03 IP Router mit Secure - Sichere Inbetriebnahme

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • meti
    antwortet
    Zitat von lopsch Beitrag anzeigen
    wartet auf testwillige Nutzer.
    bevor sich jemand wundert: mit dem MDT Interface, um das es ja hier im Thread geht, funktioniert der Keyring Export aus ETS nicht richtig - das müsste man dann händisch anpassen. Dazu die userid um 1 dekrementieren. 🙄

    Einen Kommentar schreiben:


  • lopsch
    antwortet
    OH arbeitet an der Secure Verbindung sowohl im Tunneling als auch im Router Modus. Wenn ich das richtig sehe, ist beides bereits implementiert und wartet auf testwillige Nutzer. Forum Post und Github Issue. Falls man keine externen Links posten darf (bin nicht sicher), entferne ich es wieder.

    Einen Kommentar schreiben:


  • Jonas88
    antwortet
    hallo!

    Bei der .things-config ist weniger mehr - gerade beim KNX Binding.
    So sollte es funktionieren:

    Code:
    Bridge knx:ip:bridge [
    type="TUNNEL",
    ipAddress="XXX.XXX.XXX.XXX", //IP Adresse des KNX Routers
    useNAT=false
    
    ]{
    Thing device Lichtschalter "KNX Lichtschalter" [

    Einen Kommentar schreiben:


  • udo1toni
    antwortet
    Die eine Frage ist, ob die Kommunikation läuft.
    Vergiss bitte in dem Zusammenhang mit dem ROUTER Mode die Online/Offline Anzeige.
    Du musst schon ein Thing unterhalb der Bridge anlegen und schauen, ob GA zum und vom knx Bus transportiert werden.

    Die andere Frage ist die nach dem spezifischen Router, da lautet die Antwort: gar nicht. Es gibt keinen spezifischen Router in einem knx Universum. es mag sein, dass Du nur einen hast, Du kannst aber auch 10 oder 100 Router in dem Universum haben, das spielt keine Rolle. Die knx/IP Router sind alle über IP zu einem Backbone verbunden. Die gesamte Kommunikation läuft über Multicast. Multicast bedeutet, dass alle beteiligten Geräte eine bestimmte IP abonnieren (eben die 224.0.23.12). Die beteiligten Switche kümmern sich darum, dass die Pakete zu allen Geräten transportiert werden, die die Multicast Adresse eingetragen haben.

    Der TUNNEL Modus muss aber auf jeden Fall funktionieren. Jeder knx/IP Router stellt auch den TUNNEL Modus bereit, solange wir von offiziellen Geräten sprechen.

    Warum die Verbindung nicht zustande kommt, kann ich nur raten. Mein erster Tipp wäre aber, mal die knx Bridge komplett zu löschen und neu anzulegen (oder noch besser: zuerst neu anlegen und dann die alte Bridge löschen) weil sich eventuell das knx Binding irgendwie verschluckt haben könnte..

    Ein anderer Punkt: wird die Schnittstelle evtl. von anderen Geräten blockiert?

    Einen Kommentar schreiben:


  • FelixAchtNeun
    antwortet
    ok, jetzt habe ich das Ding im Router Modus online bekommen. Kleine Verständnisfrage: Ohne jetzt die IP des KNX Routers eingegeben zu haben, woher erkennt OH dann meinen (spezifischen) Router?

    Habe irgendwie noch das Gefühl dass es sich um einen false positive handelt, also OH garnicht mit KNX verbunden ist.



    Code:
    UID: knx:ip:cc68057122
    label: KNX/IP Gateway
    thingTypeUID: knx:ip
    configuration:
    useNAT: false
    readRetriesLimit: 3
    ipAddress: 224.0.23.12
    autoReconnectPeriod: 60
    localIp: 192.168.178.96
    type: ROUTER
    localSourceAddr: 0.0.0
    readingPause: 50
    portNumber: 3671
    responseTimeout: 10

    Einen Kommentar schreiben:


  • FelixAchtNeun
    antwortet
    Danke für die Tipps.

    Ich habe jetzt mal den Typ auf Tunnel geändert, dann ist der Status auf Offline gesprungen. (COMMUNICATION_ERROR timeout connecting to control endpoint /192.168.178.92:3671)

    Die Syntax habe ich tatsächlich einfach aus der Code Ansicht übernommen. Könnte es sein dass OH3 hier eine vereinfachte Syntax hat?

    Code:
    UID: knx:ip:cc68057122
    label: KNX/IP Gateway
    thingTypeUID: knx:ip
    configuration:
    useNAT: false
    readRetriesLimit: 3
    ipAddress: 192.168.178.92
    autoReconnectPeriod: 60
    localIp: 192.168.178.96
    type: TUNNEL
    localSourceAddr: 0.0.0
    readingPause: 50
    portNumber: 3671
    responseTimeout: 10
    Bin ehrlich gesagt etwas ratlos, so wahnsinnig viele Einstellungen gibt es da ja nicht und die beiden IP Adressen sind sicherlich richtig..

    Einen Kommentar schreiben:


  • udo1toni
    antwortet
    Zitat von thoern Beitrag anzeigen
    Hallo,

    bin mir jetzt gar nicht sicher, aber ich glaube, du musst in der Config deine Strings in Hochkommas setzen. Und ob das mit Doppelpunkt hinhaut, weiss ich auch nicht. Mach das lieber mal so:
    ipAddress="192.168.178.92"
    Sicher bin ich mir auch nicht, aber gewöhnlich setzt man die Parameter ja über die UI und schaltet dann in den Code-Modus, um die Konfiguration hier posten zu können (also ohne Screenshots...) Die UI schreibt die Werte dann schon so hin, wie es formatiert werden muss...

    Einen Kommentar schreiben:


  • udo1toni
    antwortet
    Nein. 224.*.*.* ist Multicast, das hat nichts mit Deinem "normalen" Adressbereich zu tun.

    Einen Kommentar schreiben:


  • McMaster05
    antwortet
    Zitat von udo1toni Beitrag anzeigen
    Im ROUTER-Modus ist es die Multicast IP, welche für knx offiziell 224.0.23.12 lautet (man kann diese auch ändern, sollte das aber nur tun, wenn man echt gute Gründe dafür hat und exakt weiß, was man da tut)
    Ich verstehe nicht ganz: Wenn ich bei mir zuhause den Netzwerkbereich 192.168.1.0/24 definiert habe, dann können die Geräte doch die 224... gar nicht erreichen. Dann muss ich das doch umstellen, oder?

    Einen Kommentar schreiben:


  • thoern
    antwortet
    Hallo,

    Zitat von FelixAchtNeun Beitrag anzeigen
    Moin und guten Tag zusammen,

    ich habe mich gerade im Forum registriert weil ich ein scheinbar ähnliches Problem habe. Meine Code des MDT SCN-IP100.03 in der Openhab:

    Code:
    UID: knx:ip:cc68057122
    label: KNX/IP Gateway
    thingTypeUID: knx:ip
    configuration:
    useNAT: false
    readRetriesLimit: 3
    ipAddress: 192.168.178.92
    autoReconnectPeriod: 60
    type: ROUTER
    localSourceAddr: 0.0.0
    readingPause: 50
    portNumber: 3671
    responseTimeout: 10
    Angezeigt wird der Status dann als unknown. Irgendetwas wird wohl nicht stimmen? Danke für Eure Hilfe.
    bin mir jetzt gar nicht sicher, aber ich glaube, du musst in der Config deine Strings in Hochkommas setzen. Und ob das mit Doppelpunkt hinhaut, weiss ich auch nicht. Mach das lieber mal so:
    ipAddress="192.168.178.92"

    Einen Kommentar schreiben:


  • thoern
    antwortet
    Hallo,
    Zitat von McMaster05 Beitrag anzeigen
    Eine Frage hierzu: Was ist denn bei Dir die IP 10.0.0.3? Ich vermute, dass ist die IP, die Du in der ETS dem Interface zugeordnet hast.
    Ja

    Was ist dann die IP 10.0.0.12? Ist das die IP des Gerätes, auf dem Openhab läuft?
    Ja

    Und die 0.0.0? Ist das die im ETS-Projekt zugeordnete physikalische Adresse des SCN-IP?
    => default.
    => udo1toni hat bereits alles vollständig und perfekt erklärt!

    Gruß
    thoern

    Einen Kommentar schreiben:


  • udo1toni
    antwortet
    Wenn Du den ROUTER Modus nutzt, muss die ipAddress entweder leer sein oder auf 224.0.23.12 stehen. Du musst dann zwingend die localIp auf die IP-Adresse des openHAB Systems setzen.
    Alternativ kannst Du den TUNNEL Mode nutzen, ipAddress muss dann die IP des knx/IP-Gateways sein, eine korrekt eingetragene localIp kann auch hier nicht schaden.

    Einen Kommentar schreiben:


  • FelixAchtNeun
    antwortet
    Moin und guten Tag zusammen,

    ich habe mich gerade im Forum registriert weil ich ein scheinbar ähnliches Problem habe. Meine Code des MDT SCN-IP100.03 in der Openhab:

    Code:
    UID: knx:ip:cc68057122
    label: KNX/IP Gateway
    thingTypeUID: knx:ip
    configuration:
    useNAT: false
    readRetriesLimit: 3
    ipAddress: 192.168.178.92
    autoReconnectPeriod: 60
    type: ROUTER
    localSourceAddr: 0.0.0
    readingPause: 50
    portNumber: 3671
    responseTimeout: 10
    Angezeigt wird der Status dann als unknown. Irgendetwas wird wohl nicht stimmen? Danke für Eure Hilfe.

    Einen Kommentar schreiben:


  • udo1toni
    antwortet
    Ich antworte mal stellvertretend:

    ipAddress ist die IP des knx/IP-Gateways. Im TUNNEL-Modus ist dies eine IP aus dem LAN, die auch im Gateway selbst eingestellt wird (oder auch per DHCP bezogen wurde) Im ROUTER-Modus ist es die Multicast IP, welche für knx offiziell 224.0.23.12 lautet (man kann diese auch ändern, sollte das aber nur tun, wenn man echt gute Gründe dafür hat und exakt weiß, was man da tut). Deshalb muss ipAddress im ROUTER-Modus gewöhnlich nicht gesetzt werden, da es eine Default Multicast IP Adresse gibt. Im gleichen knx Universum haben alle knx/IP-Router die identische Multicast IP-Adresse eingetragen!

    localIp ist die IP Adresse des openHAB Systems. Hier darf nicht localhost oder 127.0.0.1 angegeben werden, es muss die IP Adresse angegeben werden, unter der das openHAB System selbst erreicht werden kann. ein FQDN ist hier nicht erlaubt, da der Resolver im Betriebssystem automatisch nach 127.0.0.1 auflösen würde.

    localSourceAddr ist eine zwingend freie physikalische Adresse, sie darf von keinem Gerät am Bus genutzt werden, auch nicht vom Gateway selbst. 0.0.0 ist meines Wissens der Default Wert für nicht programmierte Devices, so dass diese Adresse fast sicher frei sein dürfte. openHAB nutzt automatisch 0.0.0, falls hier kein Wert gesetzt wird.

    Kommuniktaionsprobleme zwischen knx und openHAB lassen sich sehr häufig auf eine falsch gesetzte localSourceAddr zurückführen. Ich kann nur dringend empfehlen, den Wert zunächst auf 0.0.0 zu lassen. Erst wenn die Kommunikation sicher funktioniert, kann man den Wert testweise auch verändern, aber immer achtgeben, dass die Adresse auch wirklich frei ist (ein Fake Device in ETS darf man aber ohne weiteres anlegen...)

    Einen Kommentar schreiben:


  • McMaster05
    antwortet
    Zitat von thoern Beitrag anzeigen
    Hi,

    ich benutze das IP-Interface SCN-IP000.02 von MDT. Funktioniert seit Jahren problemlos. Schon mal im Tunnel-Mode probiert?

    HTML-Code:
    Bridge knx:ip:bridge [
    ipAddress="10.0.0.3",
    portNumber=3671,
    localIp="10.0.0.12",
    type="TUNNEL",
    readingPause=50,
    responseTimeout=10,
    readRetriesLimit=3,
    autoReconnectPeriod=1,
    localSourceAddr="0.0.0"
    ] {
    Thing device n510-0011 "Siemens N510" @ "KNX" [
    address="0.0.11",
    fetch=true,
    pingInterval=300,
    readInterval=3600
    ] {
    Gruß
    thoern
    Eine Frage hierzu: Was ist denn bei Dir die IP 10.0.0.3? Ich vermute, dass ist die IP, die Du in der ETS dem Interface zugeordnet hast.
    Was ist dann die IP 10.0.0.12? Ist das die IP des Gerätes, auf dem Openhab läuft?
    Und die 0.0.0? Ist das die im ETS-Projekt zugeordnete physikalische Adresse des SCN-IP?

    Einen Kommentar schreiben:

Lädt...
X