Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

Status bei Schalten & Sperren

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Status bei Schalten & Sperren

    Zum Schalten von Steckdosen verwende ich die "AUX" Schalter und habe im proServ hierfür die GA zum Schalten (e.g. 1.1.001) und für den Status (e.g. 1.1.100) in dieser Reihenfolge (IN/OUT) beim entsprechenden Objekt hinterlegt. Die GAs sind direkt mit dem MDT Aktor verknüpft und ein "update" wurde in der Visu (Android) durchgeführt.
    Nun werden die Kanäle des Aktors gesperrt und somit wird der entsprechende Kanal auf "aus" geschalten und der Status bleibt immer auf 0. Klappt alles wie gewünscht, nur der proServ zeigt bei "AUX" nicht den Status von 1.1.100, sondern immer den Zustand von 1.1.001 an. Wie kann ich den proServ dazu bewegen den Status des "AUX" Schalters anzuzeigen aber mit dem gleichen Schalter die Schaltfunktion auszuführen?
    Gruß
    Frank

    Soziologen sind nützlich, aber keiner will sie. Bei Informatikern und Administratoren ist es umgekehrt.

    #2
    Hallo Frank,
    Ich nehme jetzt mal an, dass Du die AUX Funktion auf "umschalten" gestellt hast.
    Wenn dem so ist dann überprüfe doch bitte, ob ein "S" in der Spalte "Senden" der Gruppenadresse 1.1.001 steht. Wenn nicht, dann bitte über das Kontextmenü das Objekt des proServ in dieser GA auf "sendend setzten".

    Solltest Du mit separaten Tasten "EIN" oder "AUS" schalten (also nicht "umschalten"), dann kann man das Feedback (und damit den Farbumschlag der Taste) mit #f im Anschluss an den Text des Funktionsnamen erzwingen. Auch hier muss das Senden Attribut korrekt gesetzt sein.

    Liebe Grüsse
    Christian


    Chris (https://proknx.com)
    wir haben ARAGON entwickelt, einen offline Sprachassistenten für KNX.

    Google, Amazon und Apple hätten das auch gekonnt. Aber sie verdienen eben besser an unseren persönlichen Daten...

    Kommentar


      #3
      Hallo Christian,

      wie Du richtig vermutet hast, nutze ich die AUX-Funktion "umschalten". Die Flags der GA 1.1.001 (IN) beim proServ sind auf K-SÜ- gesetzt und von der GA 1.1.100 (OUT) ebenfalls auf K-SÜ-. Mit #f funktioniert das Erzwingen der Feedback-Anzeige bei der Funktion "Umschalten" leider nicht.
      Gruß
      Frank

      Soziologen sind nützlich, aber keiner will sie. Bei Informatikern und Administratoren ist es umgekehrt.

      Kommentar


        #4
        Hi Frank,

        ich meine nicht die Flags, sondern das "S" in der Spalte "Senden".

        senden.PNG

        Sofern "umschalten" gewählt ist, wird immer auch das feedback in der Taste angezeigt.
        Chris (https://proknx.com)
        wir haben ARAGON entwickelt, einen offline Sprachassistenten für KNX.

        Google, Amazon und Apple hätten das auch gekonnt. Aber sie verdienen eben besser an unseren persönlichen Daten...

        Kommentar


          #5
          HAllo Zusammen,

          ich habe ein ähnliches Problem. Ich will über die PRoServ App meine Steckstosen an bzw. ausschalten.
          Dazu habe ich die Funktion auf AUX Schalten und auf umschalten gesetzt.
          Die Gruppenadresse wurde entsprechend verknüpft. Mit dem Taster an der Wand funktioniert das an und ausschalten auch. Mit der iKNX App aber nicht.

          Hier kann ich nur einschalten. Auch den Status zeigt es mir in der App nicht an.

          Habe mir mal den Gruppenmonitor angeschaut und die App sendet immer an. Egal ob die Steckdose an oder aus ist. Ich vermute es liegt daran, dass der Status nicht korrekt in die App bzw. die Funktion zurück übermittelt wird. Wie kann ich das Problem lösen?

          Es gibt ja nur ein Kommunikationsobjekt und nicht extra eines für den Status.

          Danke und Gruß

          Kommentar


            #6
            Hi,
            Du brauchst das Kommunikationsobjekt des proServ nur noch ein zweites Mal zuordnen, und zwar der Gruppenadresse mit der Rückmeldung des Steckdosenaktors...
            Dort hört es dann entsprechend mit und kennt den korrekten Status
            Chris (https://proknx.com)
            wir haben ARAGON entwickelt, einen offline Sprachassistenten für KNX.

            Google, Amazon und Apple hätten das auch gekonnt. Aber sie verdienen eben besser an unseren persönlichen Daten...

            Kommentar


              #7
              Hi. Das hatte ich versucht, hat aber nicht geklappt. Ich stelle morgen mal ein Screenshot rein.

              Kommentar


                #8
                So, jetzt komme ich endlich dazu mal die SCreenshots zu senden.
                Anbei meine Verknüpfungen.

                Habe gerade auch nochmal die Applikation neu draufgeladen.
                Wie gesagt, anschalten geht aber nicht ausschalten und der STatus wird in iKNX auch nicht angezeigt.
                Was mache ich denn flasch? Bin etwas ratlos.



                image.pngimage.pngimage.png

                Kommentar


                  #9
                  Ich denke du musst nur in den Parametern des proServ "Umschalten" für diese Funktion wählen. Alles andere ist OK
                  Chris (https://proknx.com)
                  wir haben ARAGON entwickelt, einen offline Sprachassistenten für KNX.

                  Google, Amazon und Apple hätten das auch gekonnt. Aber sie verdienen eben besser an unseren persönlichen Daten...

                  Kommentar


                    #10
                    Hi. Proserv steht bereits auf umschalten. Das war am Anfang mein Fehler. Da war nur auf ein. Aber umstellen auf umschalten und applikationsprogramm neu einspielen hat keine Änderung gebracht

                    Kommentar


                      #11
                      Hast Du die App aktualisiert?
                      Chris (https://proknx.com)
                      wir haben ARAGON entwickelt, einen offline Sprachassistenten für KNX.

                      Google, Amazon und Apple hätten das auch gekonnt. Aber sie verdienen eben besser an unseren persönlichen Daten...

                      Kommentar


                        #12
                        Nicht bewusst. Also halt neu gestartet. Oder muss ich die aktiv aktualisieren? Falls ja wo mache ich das denn? Danke

                        Kommentar


                          #13
                          Morjen,

                          rechts oben auf das "Zahnrad" tippen
                          dann auf "Verfügbare Profile" tippen
                          dann auf deinen proServ-Namen (darunter steht die IP)
                          dann unten den Button "Update"

                          dann dauert's n Moment und die App sollte gupdatet wieder zurückkommen.

                          Gruss
                          Guido
                          Google oder Wiki-Hilfe-Hinweise nehme ich nur an wenn sie mich total blamieren..... dann ertrage ich sie auch in Demut und Dankbarkeit;-)

                          Kommentar


                            #14
                            Perfekt. Danke. Das wusste ich nicht dass ich die App auch aktualisieren muss. Denke daran liegt es. Werde ich heute Abend gleich mal versuchen 👍👍

                            Kommentar


                              #15
                              Super. Vielen Dank. Jetzt funktioniert es.
                              hatte gedacht die App synchronisiert sich automatisch bei Neustart.

                              Kommentar

                              Lädt...
                              X