Ankündigung

Einklappen
Keine Ankündigung bisher.

Neues Plugin für Solaredge Wechselrichter / Sunspec in Arbeit

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #91
    es müsste dann auch der SE12,5 per Modbus auslesbar sein, die Frage ist nur über welche RegisterAdressen bzw. welche Modbus-Adresse(Unit).

    Kommentar


      #92
      Ich werde mir heute Abend mal den wechselrichter anschauen und allenfalls den 2 ebenfalls per LAN anbinden
      Gruss Oliver

      Projektleiter Technische Gebäudeausrüstung

      Kommentar


        #93
        vielleicht gilt es nur die richtige Adresse vom SE12 ,5 herauszufinden, welche dann mit dem Attribut "modBusUnit: xx " in den Items eingestellt werden könnte.Ohne Angabe wird die MODBUS-Adresse (Unit) aus der plugin.yaml verwendet oder als default die "1".
        Wenn du dich an die Einstellungen des Wechselrichters herantraust. Oder vielleicht weiß der Installateur oder Solaredge/Servicedie eingestellte MODBUS-Adresse.

        image.png
        Zuletzt geändert von ivande; 21.09.2022, 09:27.

        Kommentar


          #94
          Hallo Ivan

          ich konnte folgendes in Erfahrung bringen:

          SE3500 ist der Master dieser hängt auch im Netzwerk.
          Der SE12,5 ist per RS485 verbunden mit dem Protokoll Solar Edge Sekundärgerät.. RS485-2 (Solar Edge Spezial Gedöns)

          RS485-1 Modbus Multigerät wegen der Batterie und dem Zähler dort ist die ID1 für den WR und ID2 für den Zähler und ID15 für die Batterie Hinterlegt.

          Ich habe vorhin etwas umgestellt nachdem kamen keine Daten mehr über das Modbus Plugin dies konnte ich mit mühe und not wieder fixen.

          Da ich keine Berechtigung für die SetAPP habe muss ich alles über Umwege machen und dementsprechend den Hotspot aktiv schalten und dann auf den SE3500 - Auf den SE12,5 komme ich gar nicht drauf
          Zuletzt geändert von jonny7792; 22.09.2022, 19:45.
          Gruss Oliver

          Projektleiter Technische Gebäudeausrüstung

          Kommentar


            #95
            es wird zwar etwas dauern bis man eine Antwort bekommt, aber ich würde beim Solaredge-support nachfragen, wie/ob man an die Daten des SE12,5 kommt. Alternativ mit zusätzlicher Lan Anbindung und zweiter modbus_tcp-Plugin-Instanz versuchen.

            Kommentar


              #96
              Hallo,
              habe bei mir auch 2 SE WR + Akku im Einsatz.
              Es funktioniert über eine modbus_tcp instanz.
              wichtig ist, dass du immer pro Item und WR die jeweilige modBusUnit mitgibst:

              Code:
                  SE10K:
                      C_Version:
                          type: str
                          name: C_Version
                          modBusAddress: 40044
                          modBusDataType: string16
                          modBusUnit: '1'​
                      B_Manufacturer:
                          type: str
                          name: B_Manufacturer
                          modBusUnit: '1'
                          modBusAddress: 57600
                          modBusDataType: string16​
                  SE5000:
                      C_Version:
                          type: str
                          name: C_Version
                          modBusAddress: 40044
                          modBusDataType: string16
                          modBusUnit: '3'​
              Die Ausgabe von Modul_Leistung und Verbrauch muss dann in einem extra Item addiert werden und ensprechend im HTML Layout angepasst werden.

              Kommentar


                #97
                Guten Morgen

                KleskMS

                Ich konnte jetzt den anderen WR in das System einbinden.

                Nun Stimmen Aber die Werte nicht mit dem Portal überein



                portal.png

                visu.png


                Wie hast du diese Items verknüpft ?
                Zuletzt geändert von jonny7792; 04.01.2023, 11:10.
                Gruss Oliver

                Projektleiter Technische Gebäudeausrüstung

                Kommentar


                  #98
                  am besten mal per SetApp App nachschauen wie die Modbus Adressen vergeben sind.
                  Falls du kein SetApp App Login hast, verbinde dich mit dem WLAN deines WR... und schau unter der Adresse http://172.16.0.1 dir die Konfig an und dann noch am 2 WR das gleiche nochmal.
                  Bei mir hat der
                  1.WR die Modbus Adresse 1
                  der
                  2.WR die Modbus Adresse 3

                  Beide über RS485 verbunden, der Master per LAN im Netzwerk.

                  Kommentar


                    #99
                    Hi,

                    Ich bekomme in nächster Zeit einen Fronius Symo Gen24 geliefert.
                    Lässt sich dieser mit diesem Plugin auslesen?

                    Ich habe aktuell einen Kostal in Betrieb den ich mit dem Kostal Plugin auslese.

                    Mfg
                    Markus

                    P.S. geht wohl einfacher mit den jsonread plugin.
                    Zuletzt geändert von fuxl66; 30.10.2022, 14:04.

                    Kommentar


                      Zitat von fuxl66 Beitrag anzeigen
                      Ich bekomme in nächster Zeit einen Fronius Symo Gen24 geliefert.
                      Lässt sich dieser mit diesem Plugin auslesen?
                      dies sollte mit dem modbus_tcp - Plugin, wenn die modbus-Register-Adressen des Wechselrichters bekannt sind, auszulesen gehen

                      Kommentar


                        Hallo, ich muss hier nochmal den Thread aufgreifen. Bekomme leider keine Daten von meinem Wechselrichter. Habe einen SolarEdge SE10K-RWS84BEN4.
                        Die Register sind Anhand dieses Beitrags hier gleich benannt wie in dem Beispiel von Seite 2

                        1. Habe mir das Modbus-Plugin(1.0.7) über Github heruntergeladen und aktiviert. (war in meiner SmarthomeNG 1.8.2. noch nicht drin)

                        2. Dann das Solaredge-Plugin aus Seite übernommen und auch die YAML in die Items gepackt und das Plugin aktiviert.

                        3. Unter der Liste der Plugins sehe ich auch das die Verbindung mit Modbus-Solaredge TCP steht. (grünes Licht)

                        4. Jetzt bekommen meine Items aber keine Inhalte. Habe schonmal mit modBusUnit: '1' experimentiert bei den Items. leider ohne Erfolg.

                        Ich habe über die SetApp zugriff auf meinen WR. ModbusTCP ist aktiviert (die Verbindung zu SmarthomeNG klappt ja). Der RS485-1 Zähler (Solaredge-Energiezähler) hat die Geräte-ID 2, In der App sehe ich noch unter "RS485-2 ein "Solaredge-Sekundärgerät" mit der Geräte-ID 1.

                        Welche ID muss ich denn als modBusUnit nehmen? 1 oder 2? Kann man in dem Plugin irgendwie die Logs besser aktivieren um Fehler zu finden? Habe das loglevel schon auf INFO gestellt aber ich bekomme weder Fehler- noch sonstige Meldungen in den Logs an denen ich einen Fehler suchen könnte?

                        Hat von euch jemand eine Idee wie ich das zum Laufen bekommen könnte?

                        Auszug aus plugin.yaml
                        Code:
                        solaredge:
                            plugin_name: modbus_tcp
                            instance: solaredge
                            host: 192.168.2.60
                            port: '1502'
                            cycle: 30
                            slaveUnit: 1
                        Auszug aus items/solaredge.yaml
                        Code:
                        Photovoltaik:
                            C_Version:
                                type: str
                                name: C_Version
                                modBusAddress: 40044
                                modBusDataType: string16
                                modBusUnit: '1'
                        ​
                        Besten Dank!
                        GRüße
                        Carsten

                        Kommentar


                          evtl. mit einem modbus-Tool (gibt es als freeware) zuerst versuchen ob die Register ausgelesen werden können. Bei mir ist es die slave unit=1 jedoch sollte der port doch 502 sein?


                          im etc/logging.yaml
                          beim Punkt handlers und loggers folgende Zeilen einfügen (und SH neustarten) dann wird alles modbus_tcp relevante in eine eigene Datei gelogt..​

                          Code:
                          handlers:
                              fileModBus:
                                  #class: logging.handlers.TimedRotatingFileHandler
                                  (): lib.log.ShngTimedRotatingFileHandler
                                  level: DEBUG
                                  formatter: shng_detail1
                                  when: midnight
                                  backupCount: 3
                                  filename: ./var/log/modBusTCP.log
                                  
                          loggers:
                              plugins.modbus_tcp:
                                  handlers: [fileModBus]
                                  level: DEBUG
                          Gruß Ivan

                          Kommentar


                            Hallo Ivan,
                            danke für die Hinweise. Mit Modprobe bin ich per Slave-ID1 und dem Port 1502 drauf gekommen. 1502 hat mir auch die SetApp vorgeschlagen. Deswegen hab ich das mal übernommen.

                            Was mir aber komisch vorkommt?!? Müssten nicht in der Konfiguration des Plugins die Adressen auftauchen die es lesen soll? Bei mir ist diese Ansicht leer. : - (

                            Bildschirmfoto 2023-01-15 um 20.42.05.png


                            Code:
                            2023-01-15 20:55:00 CET INFO     __init__          modbusTCP_poll_device_solaredge solaredge@: connected to ModbusTcpClient(192.168.2.60:1502)  --  (__init__.py:poll_device:184)
                            
                            2023-01-15 20:55:00 CET DEBUG    __init__          modbusTCP_poll_device_solaredge solaredge@: poll_device: 0 register readed requed-time: 0:00:00.000021  --  (__init__.py:poll_device:226)
                            
                            2023-01-15 20:55:30 CET INFO     __init__          modbusTCP_poll_device_solaredge solaredge@: connected to ModbusTcpClient(192.168.2.60:1502)  --  (__init__.py:poll_device:184)
                            
                            2023-01-15 20:55:30 CET DEBUG    __init__          modbusTCP_poll_device_solaredge solaredge@: poll_device: 0 register readed requed-time: 0:00:00.000018  --  (__init__.py:poll_device:226)
                            ​
                            sagen jetzt die Logs. Er verbindet sich also korrekt, aber lädt keine register :-(

                            Noch Ideen? :-) Danke!!! Grüße Carsten
                            Zuletzt geändert von Netsrac80; 15.01.2023, 20:56.

                            Kommentar


                              Zitat von Netsrac80 Beitrag anzeigen
                              2. Dann das Solaredge-Plugin aus Seite übernommen und auch die YAML in die Items gepackt und das Plugin aktiviert.
                              Das war mein Fehler!! Ich habe vom Threadersteller das Plugin genommen. Hab jetzt direkt das ModbusTCP-Plugin verwendet und die items.yaml die hier auf Seite 5 mal aufgetaucht wird.

                              jetzt klappt alles. Danke für die Hilfe!! : - )

                              Kommentar


                                Guten Abend

                                Ich habe ein kleines Problem - Ich versuche folgendes Register auszulesen :

                                40093 40094 2 I_AC_Energy_WH acc32 WattHours AC Lifetime Energy production

                                Das Funktioniert auch soweit und er spuckt mir diese Werte aus :
                                HoldingRegister 40093 1 4587469 I_AC_Energy_WH uint32 06.02.2023 20:02:04 0

                                Das wären gerade einmal ca 4500kWh

                                Jedoch stimmt dieser Wert nicht ansatzweise mit der Tatsächlichen Erzeugung überein.


                                Ziel wäre es den Eigenverbrauch anzeigen zu lassen.
                                Zuletzt geändert von jonny7792; Gestern, 20:08.
                                Gruss Oliver

                                Projektleiter Technische Gebäudeausrüstung

                                Kommentar

                                Lädt...
                                X