Ankündigung

Einklappen
Keine Ankündigung bisher.

Einbindung von Modbus TCP

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Zitat von Cannon Beitrag anzeigen
    Schau mal im develop branch bei den plugins.
    Da wird er nix finden, da Deine Änderungen noch nicht akzeptiert wurden. Die sind noch in einem 'Zwischenstadium', siehe oben. Irgendwann lernen wir beide vielleicht mal, wie man auf Github auch gegen *einzelne* Plugins *einzelne* PR's machen kann (ich bin zu doof dafür) - dann geht's wohl auch schneller.

    /tom

    Kommentar


      Zitat von Tom Bombadil Beitrag anzeigen
      ich bin zu doof dafür
      Ja ich auch. Ich hatte verstanden, dass das wenigstens im Develop drin ist. Wie sollen die Leute denn das dann testen?

      Zitat von Tom Bombadil Beitrag anzeigen
      einzelne* Plugins *einzelne* PR's machen kann
      Geht das überhaupt? So wie ich das sehe muss man immer das komplette Release als Basis nehmen, was ich ehrlich gesagt als etwas umständlich erachte. Denn man hat Mühe überhaupt festzustellen, wo was geändert wurde. Einzeln runterladen kann man das ja bei github auch nicht - geht immer nur das komplette Paket. Oder ich stelle mich da auch zu doof für an.

      Kommentar


        Zitat von Tom Bombadil Beitrag anzeigen
        Da wird er nix finden, da Deine Änderungen noch nicht akzeptiert wurden. Die sind noch in einem 'Zwischenstadium', siehe oben. Irgendwann lernen wir beide vielleicht mal, wie man auf Github auch gegen *einzelne* Plugins *einzelne* PR's machen kann (ich bin zu doof dafür) - dann geht's wohl auch schneller.
        Tom Bombadil Zu dem Kudelmuddel um diesen PR und den Aussagen dazu in diesem Thread habe ich Dir eine PN geschrieben.
        Viele Grüße
        Martin

        There is no cloud. It's only someone else's computer.

        Kommentar


          Zitat von Cannon Beitrag anzeigen

          Ja ich auch. Ich hatte verstanden, dass das wenigstens im Develop drin ist. Wie sollen die Leute denn das dann testen?



          Geht das überhaupt? So wie ich das sehe muss man immer das komplette Release als Basis nehmen, was ich ehrlich gesagt als etwas umständlich erachte. Denn man hat Mühe überhaupt festzustellen, wo was geändert wurde. Einzeln runterladen kann man das ja bei github auch nicht - geht immer nur das komplette Paket. Oder ich stelle mich da auch zu doof für an.
          ich hab mir mal den Stand aus deinem Repo geklont und in SHNG 1.9.3 in Betrieb genommen. Das Plugin läuft jetzt, ich bekomme auch Werte vom Bus. Die sind allerdings noch nicht richtig. Da das mein erster Modbus versuch ist kann das aber an mir liegen

          Kommentar


            Bei grundsätzlichen Fragen zu Modbus hilft evtl. --> das hier.

            /tom

            Kommentar


              Hallo,

              nur ein kurzer Kommentar und falls doppelt bitte ignorieren:
              bekam gestern eine Fehlermeldung beim Laden von modbus_tcp v1.0.7 mit pymodbus v3.0.2 / pymodbus3 v1.0.0:

              ModuleNotFoundError: No module named 'pymodbus.client.sync'
              No module named 'pymodbus.client.sync'
              Hab' dann die Loesung die ich in pluggit von msinn gefunden haben uebernommen:
              Code:
              try:
                  # for newer versions of pymodbus
                  from pymodbus.client.tcp import ModbusTcpClient
              except:
                  # for older versions of pymodbus
                  from pymodbus.client.sync import ModbusTcpClient

              HTH + LG - tullsta

              Kommentar


                Tom Bombadil: Danke für den Link. Ich komme aber dennoch nicht weiter.

                Wenn ich das InputRegister 343 mit QModMaster auslese wird der Wert richtig angezeigt. In SHNG ist der Wert immer falsch, egal ob ich Endian.Big oder Little auswähle.
                Den angezeigten Wert aus SHNG bekomme ich in QModMaster angezeigt, wenn ich in den Setting als Base Address 0 auswähle.
                Das Item ist wie folgt konfiguriert:
                Code:
                    TotalActiveEnergy:
                        type: num
                        name: TotalActiveEnergy
                        modBusObjectType: InputRegister     #(optional) default: HoldingRegister
                        modBusAddress: 343
                        modBusDataType: float32               #(optional) default: uint16
                        modBusByteOrder: 'Endian.Big'    #(optional) default: 'Endian.Big'
                        modBusWordOrder: 'Endian.Big'    #(optional) default: 'Endian.Big'
                        #modBusDirection: 'read'       #(optional) default: 'read'
                        #modBusUnit: 2                   #(optional) default: slaveUnit aus der Plugin-Konfig
                        #modBusFactor: 0.1                  #(optional) default: 1
                        #modBusDirection: read_write        #(optional) default: 'read'​
                Angehängte Dateien

                Kommentar


                  Zitat von Jackhammer Beitrag anzeigen
                  Tom Bombadil: Danke für den Link. Ich komme aber dennoch nicht weiter.
                  Zitat von Jackhammer Beitrag anzeigen
                  Den angezeigten Wert aus SHNG bekomme ich in QModMaster angezeigt, wenn ich in den Setting als Base Address 0 auswähle.
                  Letzteres ist evtl. der richtige Hinweis.

                  Versuch mal bitte ein Register weiter unten (342) oder weiter oben (344). Vermutlich fängt Deine Registerübersicht bei 1 an, während die Adressierung bei 0 beginnt (nur die alternative 40.000er-Schreibweise fängt bei 40.001 an).

                  Ein Beispiel dafür hier - beide Arten der Adressierung für dasselbe Register sind in diesem Beispiel enthalten, die 'kleine' über die ID und die 'große' über HoldingRegister HR.

                  /tom

                  Kommentar


                    Zitat von Tom Bombadil Beitrag anzeigen



                    Letzteres ist evtl. der richtige Hinweis.

                    Versuch mal bitte ein Register weiter unten (342) oder weiter oben (344). Vermutlich fängt Deine Registerübersicht bei 1 an, während die Adressierung bei 0 beginnt (nur die alternative 40.000er-Schreibweise fängt bei 40.001 an).
                    /tom
                    ​Minus 1 sieht gut aus. Werde das die Tage mit den anderen Registern verproben.

                    Das Gerät ist übrigens ein EASTRON SDM-72D-M V2, falls hier irgendwann noch jemand das Problem haben sollte :P
                    Angehängte Dateien

                    Kommentar

                    Lädt...
                    X