Ankündigung

Einklappen
Keine Ankündigung bisher.

Startup geht bei mir nicht

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Startup geht bei mir nicht

    Hallo zusammen,

    ich habe bei mir auf Raspi3 knxd und smarthome installiert, und bis jetzt immer manuel gestartet mit
    Code:
    cd /usr/local/smarthome/bin
    sudo python3 ./smarthome.py -d
    Im smarthome.log stehen keine Fehlermeldungen, die Loggingfunktion die ich eingebaut habe, funktioniert prima.
    Ich habe 2 Plugins, knx und BackendServer aktiviert.
    Wenn ich den Status von smarthome.service abfrage, bekomme ich einen Fehler:
    Code:
    pi@raspberrypi:~ $ sudo systemctl status smarthome.service
    ● smarthome.service - SmartHomeNG daemon
       Loaded: loaded (/lib/systemd/system/smarthome.service; enabled; vendor preset: enabled)  
       Active: failed (Result: exit-code) since Sat 2017-11-25 21:25:19 CET; 1 day 12h ago
    Main PID: 573 (code=exited, status=1/FAILURE)
    
    Nov 25 21:25:06 raspberrypi systemd[1]: Starting SmartHomeNG daemon...
    Nov 25 21:25:18 raspberrypi python3[455]: Daemon PID 573
    Nov 25 21:25:18 raspberrypi systemd[1]: smarthome.service: Supervising process 573 which is not our child. We'll most likely not notice when it exits.
    Nov 25 21:25:18 raspberrypi systemd[1]: Started SmartHomeNG daemon.
    Nov 25 21:25:19 raspberrypi systemd[1]: smarthome.service: Main process exited, code=exited, status=1/FAILURE
    Nov 25 21:25:19 raspberrypi systemd[1]: smarthome.service: Unit entered failed state.
    Nov 25 21:25:19 raspberrypi systemd[1]: smarthome.service: Failed with result 'exit-code'.
    pi@raspberrypi:~ $

    Den Startup-Dienst habe ich ebenfalls erstellt im /lib/systemd/system/smarthome.service:
    Code:
    [Unit] Description=SmartHomeNG daemon
    After=network.target
    After=knxd.service
    After=knxd.socket
    
    [Service]
    Type=forking
    ExecStart=/usr/bin/python3 /usr/local/smarthome/bin/smarthome.py
    User=smarthome
    PIDFile=/usr/local/smarthome/var/run/smarthome.pid
    Restart=on-abort
    
    [Install]
    WantedBy=default.target
    Nach einem Spannungsreset wird smarthome nicht automatisch gestartet(die Loggingfunktion geht nicht) und die Seite http:\:8383 wird nicht angezeigt.

    Weiss jemand, wo ich den Fehler gemacht habe ?
    Danke



    Hier noch meine Einstellungen:
    plugin.yaml: https://pastebin.com/9d469NKr
    logging.yaml: https://pastebin.com/kmFDvsav
    items/Schaff.yaml: https://pastebin.com/mtc6cP1B



    #2
    Hm. Wenn Du immer mit sudo startest, läuft alles unter root. Ich habe keine Ahnung, wie das bei einem Service aussieht. Um zu schauen, was bei Deinem Service nicht startet mach mal sudo journalctl -u smarthome.service und poste das Ergebnis.

    Kommentar


      #3
      Unter [service] hast Du user=smarthome eingetragen.

      Ich schließe daraus, dass der Service unter dem user smarthome läuft/laufen soll. Da Du vorher SmartHomeNG als root gestartet hast, kann es sein, dass Dateirechte so gesetzt sind, dass der user smarthome Dateien nicht lesen oder schreiben kann.
      Viele Grüße
      Martin

      There is no cloud. It's only someone else's computer.

      Kommentar


        #4
        Hier das Ergebnis:
        Code:
        pi@raspberrypi:~ $ sudo journalctl -u smarthome.service
        -- Logs begin at Thu 2016-11-03 18:16:42 CET, end at Mon 2017-11-27 16:33:15 CET. --
        Nov 25 21:25:06 raspberrypi systemd[1]: Starting SmartHomeNG daemon...
        Nov 25 21:25:18 raspberrypi python3[455]: Daemon PID 573
        Nov 25 21:25:18 raspberrypi systemd[1]: smarthome.service: Supervising process 573 which is not our child. We'll most likely not notice when it exits.
        Nov 25 21:25:18 raspberrypi systemd[1]: Started SmartHomeNG daemon.
        Nov 25 21:25:19 raspberrypi systemd[1]: smarthome.service: Main process exited, code=exited, status=1/FAILURE
        Nov 25 21:25:19 raspberrypi systemd[1]: smarthome.service: Unit entered failed state.
        Nov 25 21:25:19 raspberrypi systemd[1]: smarthome.service: Failed with result 'exit-code'.
        pi@raspberrypi:~ $
        Was muss ich tun, damit ohne sudo starten kann ? Das bekomme ich ohne sudo:
        Code:
        pi@raspberrypi:/usr/local/smarthome/bin $ python3 ./smarthome.py -d
        Traceback (most recent call last):
          File "./smarthome.py", line 634, in <module>
            lib.daemon.write_pidfile(psutil.Process().pid, PIDFILE)
          File "/usr/local/smarthome/lib/daemon.py", line 89, in write_pidfile
            fd = open(pidfile, 'w+')
        PermissionError: [Errno 13] Permission denied: '/usr/local/smarthome/var/run/smarthome.pid'

        Danke

        Kommentar


          #5
          Ein sudo chown -R smarthome:smarthome /usr/local/smarthome könnte helfen

          Kommentar


            #6
            juhuu, Volltreffer:
            Code:
            pi@raspberrypi:~ $ sudo systemctl status smarthome.service
            ● smarthome.service - SmartHomeNG daemon
               Loaded: loaded (/lib/systemd/system/smarthome.service; enabled; vendor preset: enabled)
               Active: active (running) since Mon 2017-11-27 18:29:21 CET; 6min ago
              Process: 447 ExecStart=/usr/bin/python3 /usr/local/smarthome/bin/smarthome.py (code=exited, status=0/SUCCESS)
             Main PID: 532 (python3)
               CGroup: /system.slice/smarthome.service
                       └─532 /usr/bin/python3 /usr/local/smarthome/bin/smarthome.py
            
            Nov 27 18:29:16 raspberrypi systemd[1]: Starting SmartHomeNG daemon...
            Nov 27 18:29:21 raspberrypi python3[447]: Daemon PID 532
            Nov 27 18:29:21 raspberrypi systemd[1]: smarthome.service: Supervising process 532 which is not our child. We'll most likely not notice when it exits.
            Nov 27 18:29:21 raspberrypi systemd[1]: Started SmartHomeNG daemon.
            pi@raspberrypi:~ $

            Danke !

            Kommentar

            Lädt...
            X