Ankündigung

Einklappen
Keine Ankündigung bisher.

Smarthome NG von externem Raspi zusätzlich einbinden

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Smarthome NG von externem Raspi zusätzlich einbinden

    Hallo zusammen,
    ich habe seit geraumer Zeit eine KNX-Installation (selbst erstellt; Handwerksmeister Elektro, KNX-zertifiziert) und habe damals ein dutzend KNX-Visualisierungen im Laufe der Zeit ans Rennen gebracht. Da war von IP-Symcom über den Eisbären von Alexander Maier und dem Merten InSide-Control bis hin zu den Touchpanels von MDT alles dabei.

    Diese Dinge waren mir aber für den "Eigenbedarf" einfach zu steif in der Handhabung; oder aber schlichtweg zu teuer. Folglich habe ich kurz vor Weihnachten mich ans Werk gemacht und einen Raspberry gekauft und angefangen zu basteln... Ohne jegliche Erfahrung im Bereich Linux und allem was dazu gehört, war der Anfang recht holprig und steinig. Nach dreimaligem Neuaufsetzen läuft das Ding nun mit Grundfunktionen (Heizungsregler, Beleuchtung, Zeitschaltuhr) super stabil.
    Dies verdanke ich den eifrigen Leuten, die sich hier der ganzen Sache angenommen haben und hier wie wild Infos raushauen. Vielen dank, das hat mir sehr geholfen! Ich habe gelesen und gelesen und gelesen...

    Nun habe ich aber trotzdem mal eine Frage, bei der ich nicht weiterkomme...
    Zunächst die Konfiguration: Mein Raspberry visualisiert die Daten über die Smartvisu 2.9, bereitgestellt von Smarthome NG und vom Bus abgefragt über KNXD via einem MDT IP-Interface der ersten Generation.

    Das funktioniert hervorragend; nun möchte ich das System auf etwas andere Weise erweitern. Dazu habe ich hier bisher überhaupt nichts gefunden, daher hier mein Problem:

    Ich habe abgesetzt vom Grundstück eine Garage (WLAN kommt da noch problemlos an) mit Garagentorantrieb mit externem Taster und einem Endschalter für "Tor offen". Da das Tor von Haus aus nicht einsehbar ist, habe ich mir einen zweiten Raspberry PI gekauft, und frage über die GPIO-Pins den Torstatus "Offen" ab; und brücke über ein Relais den externen Taster, um das Tor auf- bzw- zuzufahren.

    Nun würde ich gerne den Raspberry für die Garage mit in die Smartvisu einbinden, die auch den KNX verwaltet, um einfach eine einzige Visualisierungsoberfläche zu haben und gegebenfalls im Endzustand auch über einen KNX-Taster das Tor zu steuern.

    Die Lösung, die mir zunächst einfällt, ist die Installation von Smarthome NG mit der Abfrage der GPIO-Pins und einer eigenständigen Smartvisu mit eigener interner IP auf dem zweiten, abgesetzten System. Dann müsste ich aber immer zwei Systeme parallel pflegen und ändern, und der KNX-Taster wären nicht mit einzubinden.

    Daher die Frage:
    Lässt sich in der Smartvisu eine weitere Datenquelle auf Basis von SmarthomeNG zusätzlich einbinden?
    Oder hat jemant eine Idee, wie ich die Daten von einem weiteren Smarthome-NG per WLAN auf das Smarthome NG mit der Smartvisu gekoppelt bekomme?

    Für eventuelle Gedankenanreize bin ich dankbar!

    Gruß Torsten
    Zuletzt geändert von bmx; 26.01.2018, 08:02.

    #2
    Ich würde einfach 2 SHNGs aufsetzen, die via Network Plugin Daten austauschen.. Ich habe einen Raspi Zero W in der Garage, der via GPIO Plugin bisher nur von einem Luftdrucksensor Daten abgreift und an die "Zentral SHNG Instanz" auf meinem NAS sendet. Dazu noch einen Raspi3 im Haus, der via Bluetooth Daten von Xiaomi Pflanzesensoren + via USB den CO2 Wert abgreift (der Server ist im Stahlbetonkeller, da kommt leider nichts durch). Auch diese werden via Network Plugin an die Zentrale gesendet.. klappt 1a.

    Das sieht beim Client Raspi dann so aus:
    logic.yaml:
    Code:
    NWSend:
        filename: nw.py
        watch_item: '*:send_nw'
    items.yaml:
    Code:
    plants:
    
        sensor_gallery:
    
            temperature:
                type: num
                xiaomi_data_type@xiaomi_4: temperature
                cache: 'true'
                nw: 'yes'
                send_nw: 1
    
            light:
                type: num
                xiaomi_data_type@xiaomi_4: light
                cache: 'true'
                nw: 'yes'
                send_nw: 1
    
            moisture:
                type: num
                xiaomi_data_type@xiaomi_4: moisture
                cache: 'true'
                nw: 'yes'
                send_nw: 1
    
            conductivity:
                type: num
                xiaomi_data_type@xiaomi_4: conductivity
                nw: 'yes'
                send_nw: 1
    
            name:
                type: str
                xiaomi_data_type@xiaomi_4: name
                cache: 'true'
                nw: 'yes'
                send_nw: 1
    
            firmware:
                type: str
                xiaomi_data_type@xiaomi_4: firmware
                cache: 'true'
                nw: 'yes'
                send_nw: 1
    
            battery:
                type: num
                xiaomi_data_type@xiaomi_4: battery
                cache: 'true'
                nw: 'yes'
                send_nw: 1
    Logik nw.py:
    Code:
    #!/usr/bin/env python
    #
    # Realisiert einen generischen UDP Sender.
    #
    # logik nur, wenn von Item getriggert
    if trigger['by'] == 'Item':
        lItemName = trigger['source']
        lItem = sh.return_item(lItemName)
        sh.nw.udp('192.168.178.100', 9999, 'item|{0}|{1}'.format(lItemName, lItem()))
        logger.info("udpSend: {0}, {1}".format(lItemName, lItem()))
    else:
        logger.debug("Keine Triggerung udpSend von Item")
    Auf Serverseite "lauscht" das Network Plugin - die Items von oben gibt es natürlich analog dort auch!:
    Code:
    nw:
        class_name: Network
        class_path: plugins.network
        ip: 192.168.178.100
        port: 9999
        tcp: 'yes'
        # tcp_acl= 127.0.0.1 | 10.0.0.150
        udp: 'yes'
        http: 8888
    Achtung: der RASPI hat eine Art Wlan Standby Funktion, die man deaktivieren muss.. Ich hatte mich anfangs immer gewundert, warum nach geraumer Zeit keine Daten kamen..
    Zuletzt geändert von psilo; 25.01.2018, 19:08.

    Kommentar


      #3
      Hi,

      ich habe auch mal so was gemacht. Garagen-Raspi über WLAN am Haus-KNX. Ich habe damals in der Garage eine eigene KNX-Linie eingerichtet und den Raspi mit Smarthome benutzt, der KNXD wurde als Router verwendet. Das hat auch funktioniert, ich weiß aber überhaupt nicht mehr die Settings, das ist über ein Jahr her. Inzwischen habe ich alles verkabelt.

      Aber wie gesagt, Du könntest das sicherlich auch als Linie mit einem KNX-Router aufbauen.

      Gruß, Waldemar

      Kommentar


        #4
        Alternativ zum Netzwerkplugin könntest du auch das MQTT Plugin nutzen. Hat noch eine ganze Reihe Vorteile und ist auch einfacher aufzusetzen.

        Kommentar


          #5
          Onkelandy oder das webservices plugin

          Kommentar


            #6
            Hi zusammen,

            zunächst einmal ein ganz herzliches Dankeschön für die vielen Ideen. Ich hab heute gebastelt und mittels Try-and-Error erfolgreich das Ganze über MQTT ans laufen gebracht! Ich hab gelesen und experimentiert und schlussendlich alles hinbekommen.

            Jedoch stolpere ich noch über ein Problem. Zunächst kurz die Konfiguration des Systems: Der Raspberry in der Garage (Garagen-PI) holt sich den Status des Garagentors mittels Endschalter über einen klassischen Eingang (GPIO). Des weiteren schliesst er ein Relais; ebenfalls über GPIO, um das Tor zu verfahren.

            Die Daten bekommt er über den zweiten Raspberry (Haus-PI), welcher im Haus verbaut ist. Auf diesem läuft auch der Broker mit der Visu, welche mir einerseits anzeigt, ob das Tor geschlossen ist; alternativ lässt sich über einen Basic-Switch das Tor öffnen oder schliessen. Das alles funktioniert bis dahin ohne Probleme.

            Wenn ich den Broker (also den Haus-PI) jedoch nebst Visu reboote, dann passiert folgendes: Der Torstatus von dem Garagen-PI wird nach dem Hochlaufen der Visu wieder ordnungsgemäß aktualisiert. Taste ich aber in der Visu auf den Knopf, der das Garagentor verfahren soll, reagiert das Relais des Garagen-PI überhaupt nicht. Erst wenn ich den Garagen-PI neu starte, dann funktioniert wieder alles.

            Wenn ich den Haus-PI reboote passiert folgendes: Der Basic-Switch der Visu sendet das Signal und wird mittels dem Autotimer nach zwei Sekunden automatisch zurückgesetzt. Im Haus-PI läuft das Ganze ohne Probleme. Im SmarthomNG wird das ITEM von false zu true; nach zwei Sekunden wieder zu false. Im Garagen-PI passiert jedoch nichts. Reboote ich diesen, ist alles OK.
            Warum sendet der Haus-PI mit Broker keine Daten nach dem Neustart an den Garagen-PI, empfängt aber offensichtlich die Daten umgekehrt (der Torstatur wird ja angezeigt)???

            Kommentar


              #7
              Schreib das am besten Mal in den Thread "neues MQTT" Plugin bzw. beobachte mal ein DEBUG Log des Plugins. Könnte sein, dass das "Reconnect" nach dem Wiederauftauchen des Brokers nicht so fix funzt.

              Kommentar

              Lädt...
              X