Ankündigung

Einklappen
Keine Ankündigung bisher.

Support-Thread zum OpenWeatherMap Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Zitat von jentz1986 Beitrag anzeigen
    Kannst Du das auch noch machen?
    Ja, das mache ich. Dauert aber ein wenig. Du bekommst dann wieder einen PR

    Kommentar


      Zitat von jentz1986 Beitrag anzeigen
      Kannst Du das auch noch machen?
      Schau mal, PR ist gestellt.

      BTW: Kannst Du mir mal aufzeigen, wie man das eine Plugin zur Entwicklung "auslagert"? Was ich meine ist, dass Du auch erst auf eine clone des gesamten Plugin Repos gearbeitet hast und nun das OWM Plugin ausgelagert hast.

      Kommentar


        Hi, das steht hier im Post 98 https://knx-user-forum.de/forum/supp...14#post1686214

        Die PR schau ich mir am Wochenende an - bin auf Workshop und keiner macht meine normale Arbeit…

        Kommentar


          Zitat von jentz1986 Beitrag anzeigen
          Die PR schau ich mir am Wochenende an
          Prima.

          Kommentar


            Sooo... ist gemerged und ins normale Repo forwarded, d.h. Deine Arbeit ist jetzt auch an meinem PR aufgetaucht. Sehr schick, man sieht sogar, dass es von Dir ist. Das mag ich.

            Kommentar


              So, ich hab mich mal mit eurem OWM-Plugin beschäftigt, d.h. aus jentz' Repo installiert und mit den Beispielitembäumen aus der user_doc.rst aktiviert.

              Daten bekomme ich jede Menge, aber wiederholt nach jedem Abruf die Meldung

              Code:
              2021-10-09 10:46:41 INFO plugins.priv_openweathermap (where available) Wind gust. Units default metre/sec, metric metre/sec, imperial miles/hour. INFO: owm-string: current/wind_gust --> current/wind_gust from wrk=onecall, Error: Missing child 'wind_gust' after 'current' (complete path missing: wind_gust)
              Ich habe den entsprechenden Code und die "Einstellungen" (soft_fails_to...) gefunden. Ich finde die unterschiedliche Behandlung und auch die Voreinstellung etwas unglücklich; es würde ständig entsprechende Meldungen geben.

              Sind die (nicht gefunden) oder sollen die konfigurierbar (plugin.yaml) gemacht werden? Ansonsten könnte man überlegen, "unerlaubte" Werte (z.B. -1 für Regen/Schnee/Wind) zurückzugeben. Damit kann man arbeiten (ist nicht ungültig), es könnte bei statistischen Berechnungen einfach ausgespart werden und es ist eine eindeutige Rückmeldung (anders/besser als 0).

              Kommentar


                Alles was ein Echtes Problem ist wird auf Logstufe WARN oder ERROR rausgegeben. Wenn man einmal sein Setup hat, sollte man das LogLevel auf WARN stellen und alles ist gut.

                Bei wind_gust wäre der Rückfallwert eigentlich gleich dem Wind-wert. (Was „keine Böen“, sondern konstanter Wind bedeutet, und bei 0 Wind auch der richtige Wert 0 wäre). Hab da nur nicht weiter gemacht.
                Morg Kannst du mir in mein GitHub-Repo ein Issue dazu einstellen?

                ​​​

                Kommentar


                  Done. Ich würde aber nicht unbedingt wind_gust auf wind setzen - wenn der (konstante) Wind hoch ist und kein gust-Wert kommt, könnte das je nach Setup trotzdem einen Alarm auslösen o.ä.

                  Aber mach mal

                  Kommentar

                  Lädt...
                  X