Ankündigung

Einklappen

Aufruf

Bitte helft bei unserer Spendenaktion: Spendenaktion Helmut Lintschinger
Mehr anzeigen
Weniger anzeigen

Problem mit "autotimer"

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • bamus007
    antwortet
    Ich wollte hier niemanden beschuldigen - ja und das AVM Plugin macht was es soll.

    Hier das vollständige Item:

    Code:
    avm:
        dect:
            socket_bad:
                type: bool
                alexa_device: dg-bad-irheizung
                alexa_name: Heizstrahler
                alexa_actions: TurnOn TurnOff
                alexa_description: Heizstrahler im Bad
                alexa_icon: SMARTPLUG
                visu_acl: rw
                knx_dpt: 1
                knx_listen: 3/2/48
                knx_send: 3/2/48
                autotimer: 30m = 0
                avm_data_type@fritzbox_6490: aha_device
                ain: 08761 0488103
                energy:
                    avm_data_type: energy
                    type: num
                    visu_acl: ro
                power:
                    avm_data_type: power
                    type: num
                    sqlite: 'yes'
                    enforce_updates: 'true'
                    visu_acl: ro
                    eval: value / 100
                temperature:
                    avm_data_type: temperature
                    type: num
                    visu_acl: ro
    Es ist eben so, dass wenn der Updade Cycle läuft - was ja auch sein muss - der autotimer ausgelöst wird.

    Kannst Du mir bitte eine Hilfestellung geben wie ich das in einem Hilfs-Item machen kann)

    Einen Kommentar schreiben:


  • psilo
    antwortet
    das avm plugin macht das wie jedes andere plugin auch. viell. solltest du mal das vollstaendige item posten und mehr infos rausruecken, bevor du beschuldigungen ausgiebst..

    wenn du ein avm item nimmst, wird das halt regelmaessig durch das plugin geupdated. das soll es aber auch

    vermutlich kommt das update deinem autotime in den weg. dann musst du halt ein hilfsitem machen
    Zuletzt geändert von psilo; 01.01.2019, 20:41.

    Einen Kommentar schreiben:


  • bamus007
    antwortet
    Also ich vermute das Problem im AVM Plugin.

    In einem "normalen" Item funktioniert der autotimer korrekt und verschindet nach Ablauf auch im Scheduler.

    Das AVM Plugin scheint beim Update-Cycle den autotimer zu zerschießen.
    Stelle ich in der plugin.yaml den cycle z.B. auf 400 also gößer als die Verzögerungszeit, funktioniert autotimer und verschwindet nach Ablauf auch aus dem Scheduler. Sobald der Update Cyle läuft, ist der autotimer wieder im Scheduler und die Zeit läuft - es wird aber keine Schaltung ausgelöst.

    Fazit: Der Update Cycle des AVM Plugins löst definitiv den autotimer aus und startet die Zeit immer wieder von neuem.

    Einen Kommentar schreiben:


  • bamus007
    antwortet
    "False" und auch 0 ändern nichts am Verhalten

    Einen Kommentar schreiben:


  • psilo
    antwortet
    probiere das mit false => False mal aus.. bin nicht sicher, ob beim autotimer ungültige python bools ("false") in ein False geparsed werden..

    Einen Kommentar schreiben:


  • bamus007
    antwortet
    nein der Scheduler ist danach nicht leer.

    Bei längerem Beobachten des Scheduler fällt mir auf, dass sich der Scheduler trotz ausgeschaltetem Item alle 5 Minuten neu setzt.

    Der Autotimer steht aktuell auf 5m. Ich habe mal Screenshots der Scheduler und vom Item beigefügt.

    Das Item ist "false" und wurde die letzten Minuten nicht verändert!

    Einen Kommentar schreiben:


  • schuma
    antwortet
    Nur so eine Idee:

    versuche mal

    Code:
     
     autotimer: 45m = False
    oder
    Code:
       
     autotimer: 45m = 0

    Einen Kommentar schreiben:


  • psilo
    antwortet
    also der korrekte und erwartete zeitpunkt? ist der scheduler nach dieser zeit dann weg?

    Einen Kommentar schreiben:


  • bamus007
    antwortet
    Zitat von psilo Beitrag anzeigen
    was steht denn unter "nächste Ausführung"?
    Die Einschaltuhrzeit + die Verzögerungszeit

    Einen Kommentar schreiben:


  • psilo
    antwortet
    was steht denn unter "nächste Ausführung"? ein screenshot wäre auch spannend. keine ahnung ob ein auf einen zeitpunkt gesetzter scheduler nen crontab kriegt.. ich hätte erwartet sofern nächste ausführung passt, dass alles ok ist.

    Einen Kommentar schreiben:


  • bamus007
    antwortet
    Im scheduler steht beim Autotimer in der Spalte Crontab nichts drin. Ist das richtig?

    Einen Kommentar schreiben:


  • bamus007
    antwortet
    Im scheduler steht auch die passende Zeit (Einschaltuhrzeit + Verzögerungszeit) bei nächste Ausführung.

    Nur passieren tut nichts?

    Einen Kommentar schreiben:


  • psilo
    antwortet
    müsste man das nicht über die scheduler im backend plugin sehen? ich dachte der autotimer liegt einen an sobald er aktiv wird?!

    Einen Kommentar schreiben:


  • bamus007
    hat ein Thema erstellt Problem mit "autotimer"

    Problem mit "autotimer"

    Hallo ich habe ein seltsames Problem mit autotimer.

    Ich habe über das AVM Plugin eine Fritz DECT 200 Steckdose angebunden. Schalten über Visu, KNX, Alexa kalppt alles einwandfrei.

    Nun möchte ich, dass die DECT Steckdose selbstständig nach 45 Minuten ausschaltet. Dazu nutze ich den autotimer.

    Wenn ich die Zeit mit "autotimer: 1m = false" auf eine Minute stelle klappt das automatische Ausschalten. Wenn ich dann die Zeit z.B. auf 5 oder auch 45 Minuten stelle "autotimer: 5m = false" schält die Steckdose nicht selbständig aus. Also 1 Minute geht, mehr nicht?

    Code:
            socket_bad:
                type: bool
                alexa_device: dg-bad-irheizung
                alexa_name: Heizstrahler
                alexa_actions: TurnOn TurnOff
                alexa_description: Heizstrahler im Bad
                alexa_icon: SMARTPLUG
                visu_acl: rw
                knx_dpt: 1
                knx_listen: 3/2/48
                knx_send: 3/2/48
                autotimer: 45m = false
                avm_data_type@fritzbox_6490: aha_device
                ain: 08761 0488103
Lädt...
X