Ankündigung

Einklappen
Keine Ankündigung bisher.

Alexa Text to Speach

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Hallo Jürgen,

    Du musst fürs encodieren auf einer Website
    Code:
    myuser@mydomain.de:password
    encodieren nicht mail-Adresse und Passwort separat.
    Hast Du das so gemacht, ich vermute nicht. Hab eben nochmals übers Web-Interface getestet, geht bei mir durch.
    Eventuell hier nochmal prüfen ob in der warning.log was hochkommt.
    In der Result-Text-Area des Web-IF sollte :

    ==================================
    Encoding done
    replaced credentials in temporary file
    stored new config to filesystem
    ==================================
    erscheinen

    Kommentar


      Hallo Andre,
      natürlich nicht ;-) Deine Beschreibung ist nicht Dau kompatibel:

      you enter your credentials like "user.test@test.gmail.com" you will get "dXNlci50ZXN0QHRlc3QuZ21haWwuY29t" . So please enter "dXNlci50ZXN0QHRlc3QuZ21haWwuY29t" in the /etc/plugin.yaml
      Da da kein Doppelpunkt und Passwort drin war, habe ich die Email als Passwort angesehen und nur dieses kodiert.
      Ändere die Beschreibung besser in

      you enter your credentials like "user.test@test.gmail.com:Password" you will get "dXNlci50ZXN0QHRlc3QuZ21haWwuY29tOlBhc3N3b3Jk" . So please enter "dXNlci50ZXN0QHRlc3QuZ21haWwuY29tOlBhc3N3b3Jk" in the /etc/plugin.yaml

      Dann ist es eindeutig.
      OK, Webinterface generiert nun auch, schon komisch.
      Login geht, beide Spione weren erkannt.
      Mal sehen, ob der relogin reicht, zuletzt war schon nach zwei Tagen ein neues cookie fällig.

      So , nachem der Show 5 nun auch da ist, geht es munter weiter mit der Ausgabe der Webcam bei Bewegung vor der Tür, aber nicht mehr heute ;-)

      Gruß und Dank für die tolle Arbeit
      Jürgen
      Zuletzt geändert von Jürgen; 26.07.2019, 16:21.

      Kommentar


        Hi Jürgen,

        die Doku werde ich ergänzen.
        Für den Kamerazugriff auf Deine eigene Cam musst Du den "ProxyCam4AlexaP3" oder einen Web-Service nutzen.
        Ausser deine Kamera unterstützt TLSv1.2 auf Port 443
        Ich würde die shng - Variante bevorzugen. Liess dir am besten mal die README durch.

        Den "Proxy" gibts auf meinem Git-Account. Da hier wenig interesse war hab ich das Thema hinten angestellt (ist noch nicht fertig). Bei mir funktioniert er aber.
        Falls Du daran interesse hast kann ich gerne support leisten, bei der Hitze aber nicht allzu oft.

        Bin im Moment noch mit der Überarbeitung des Indego-Plugins beschäftigt.
        Da Alexa sich weigert den Pool auszusaugen muss wenigstens der Mähroboter funktionieren.

        Weiterhin viel Erfolg

        Gruss Andre
        Zuletzt geändert von AndreK; 26.07.2019, 16:54. Grund: Nachtrag für Standart TLSv1.2 - Cams

        Kommentar


          Nehmt lieber php zum encodieren. Seine amazon creds an 'irgendeine' webseite zu posten halte ich für fahrlässig

          Kommentar


            Hi psilo

            das WebIF kann dass nun auch, ist nur noch nicht in der Doku - ich habe den Verweis in der Doku rausgenommen und auf die Möglichkeit im Web-IF geändert.
            Ging gerade hoch. (Das mit der Umstellung komplett auf requests läuft noch, Indego geht gerade Vorang)


            Kommentar


              AndreK ok. sowas könnte man evtl auch mal in das toolset des admin ifs aufnehmen. derzeit geht da aber auch nix.. erstmal den sommer überstehen.

              lass dir mit requests zeit, gut ding will weile haben!

              bisher läuft bei mir auch alles stabil und gut.. bereichert wirklich das plugin!

              Kommentar


                Hallo zusammen,

                mein Echo ist seit heute still :-( Busbefehle funktionieren, aber ein Test der Sprachausgabe im Backend bringt ein http 401.
                Credentials hatte ich fest verdrahtet.
                Klappt es bei Euch noch? Habe auf dem Handy ein Update der Alexa APP installiert, vielleicht hat Amazon etwas geändert?

                Gruß Jürgen

                Kommentar


                  Hallo Jürgen,

                  da war was mit Änderung der AGB's. Geh mal über den Web-Browser auf die Alexa-Seite.
                  Bei mir läut im Moment noch alles, aber es gab bei psilo vor ein paar Tagen auch ein Problem siehe hier Post #672

                  Gruss Andre

                  Kommentar


                    Hallo Andre,

                    nichts besonderes auf der Webseite, Smarthome Befehle sind in der Liste, "Sprich mir nach" nicht.
                    Im Backend bekomme ich auch nach einem Restart ein 401...

                    Ich versuche es die Tage mal mit dem Cookie File, schaun mer mal...

                    Gruß Jürgen

                    Kommentar


                      Hallo Jürgen,

                      was meldet denn das Web-IF wenn Du LogOff / LogOn machst ?
                      Kannst du die Meldungen ma posten ?

                      Kommentar


                        Hallo Andre,

                        nach log off, log on funktioniert es...
                        Den Trace kann ich leider nicht kopieren, alles andere schon.

                        Schon komisch....
                        Gruß Jürgen

                        Kommentar


                          Guten Morgen,

                          mein Echo bleibt schon wieder stumm :-(..
                          Edith hat ins Backend geschaut: Letzte Anmeldung vor drei Tagen, nächste Anmeldung in drei Tagen.
                          Kann man das manuell aktualisieren? Ich habe dann wieder das Cookie File eingefügt, dann ging es wieder...

                          Gruß Jürgen
                          Zuletzt geändert von Jürgen; 29.08.2019, 06:04.

                          Kommentar


                            Hallo @Jürgen,

                            Rückmeldung etwas verspätet, hatte mal Urlaub

                            Du kannst die Zeit für die Erneuerung in der ./etc/plugin.yaml anpassen.
                            login_update_cycle: 432000
                            = 5 Tage steht bei mir,

                            default ist : 604800 = 7 Tage

                            Du kannst jederzeit über das Web-Interface abmelden (Logoff) und wieder anmelden (Login).
                            Das sollte dann Abhilfe schaffen.

                            Besser passt Du den Parameter fürs Auto-Update in der ./etc/plugin.yaml an.
                            Bei mir läuft es auch während des Urlaubs so durch.

                            Ich werde beim nächsten Update die default-Zeit auf 432000 anpassen.

                            Gruss Andre

                            Kommentar


                              Hallo Andre,
                              Alexa war wieder bockig...
                              Interessant ist: Es lief zwei Wochen durch, aber NACH dem letzten Autologin war Ende:
                              last/next Auto-Login 2019-09-11 20:24:29(2019-09-17 15:17:49)
                              Kannst Du vielleicht noch ein Logfile einbauen / auswerten, ob der Autologin geklappt hat?

                              Manuelles Abmelden und Wiederanmelden hat funktioniert.

                              Gruß Jürgen

                              Kommentar


                                Hallo Jürgen ,

                                das wird bereits protokoliert, bitte prüf mal deine "smarthome-details.log". Bei mir steht dort, Update von heute :

                                Code:
                                2019-09-12  21:17:58 INFO     plugins.alexarc4shng Status of log_off: 200
                                2019-09-12  21:17:58 INFO     plugins.alexarc4shng Status of Auto-Login First Step: 200
                                2019-09-12  21:17:59 INFO     plugins.alexarc4shng Status of Auto-Login Second Step: 200
                                2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of Auto-Login third Step: 200
                                2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of Auto-Login fourth Step: 404
                                2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of Auto-Login fifth Step - got CSRF: XXXXXXXXXXX
                                2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of check_login_state: 200
                                Der HTTP-Error 404 in Step 4 ist OK-das liegt daran, dass Amazon irgendwelche Web-Verweise geändert hat. Wichtg ist Step-5.
                                Eigentlich sollte auch das Web-IF anzeigen ob man korrekt angemeldet ist, falls keine korrekte Anmeldung vorhanden ist werden keine Geräte angezeigt und das
                                Cookie ist "traurig".
                                Du hattest zuletzt gepostet, dass du das Cookie-File manuell eingefügt hast. Wie hier das Verhalten mit Auto-Login ist muss ich mir nochmal anschauen.
                                Ich kann auf jeden Fall bestätigen, dass mit
                                Code:
                                login_update_cycle: 432000
                                das Plugin bei mir seit nunmehr Monaten durchläuft. Ich weiß das nutzt Dir nichts, nimm auf jeden Fall mal die login_update_cylce Zeit auf 43200 runter.
                                Lösche die Datei "lastlogin.txt" im Ordner plugins/alexarc4shng. Die Datei ist der Merker für erneuern des Cookies.

                                "Ich nehme auf die Todo-Liste" : aktualisieren der "lastlogin.txt" bei manuellen LogOff/Login und einfügen eines Cookie-Files - das passiert aktuell noch nicht - :-(

                                Ich hoffe das hilft Dir weiter, falls nicht bitte Info.

                                Gruss Andre


                                Kommentar

                                Lädt...
                                X