Ankündigung

Einklappen
Keine Ankündigung bisher.

Alexa Text to Speach

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Jürgen
    antwortet
    Hallo Schuma,

    na, da gibt Hoffnung..
    Meine sagten gerade knapp zwei Tage nach dem letzten login wieder nix.
    Im Backend war kein Ausgaberät zu finden, Bedienung der KNX Geräte lief aber problemlos.
    Nach Relogin wieder zwei Geräte da und Testausgabe funktioniert..
    Habe gestern die App aktialisiert, vielleicht lag es daran.

    Schaun mer mal...
    Gruß
    Jürgen

    Einen Kommentar schreiben:


  • schuma
    antwortet
    Ich kann dir da zwar nicht wirklich helfen, aber zumindestens kann ich die Info weitergeben, dass es bei mir schon länger perfekt funktioniert.
    Bit der von Andre vorgeschlagenen Einstellung 432000.

    Einen Kommentar schreiben:


  • Jürgen
    antwortet
    N´Ahmd..
    Die erste automatische Aktualisierung nach vier Tagen hat geklappt, nach weiteren drei Tagen wieder nix mehr...
    Logout, login, alles wieder da...
    Bin völlig ratlos..
    Hat sonst niemand Probleme damit?
    Soll ich auf zwei Tage gehen?

    Gruß Jürgen

    Einen Kommentar schreiben:


  • AndreK
    antwortet
    Hi Jürgen,

    good luck, schön das nicht nur mir solche Dinge passieren.

    Gruss Andre

    Einen Kommentar schreiben:


  • Jürgen
    antwortet
    Hallo Andre,
    kein Tippfehler, stand auf 43200, hab ich nun auf 345600 gesetzt, also 4 Tage, Rechner rebootet.
    Ähem und dann in der richtigen Datei in /etc und nicht im im alexarc4shng Verzeichnis geändert, wo nur der Default steht. Manchmal ist man schon DAU...
    Nun stimmt auch die Zeit im Backend mit vier Tagen, schaun mer mal.

    Gruß und Dank
    Jürgen

    Einen Kommentar schreiben:


  • AndreK
    antwortet
    Hallo Jürgen,

    interpretiere ich Deinen Post richtig - Du hast immer noch Probleme mit dem Auto-Login nach Timer ?

    42.200 = 11,72 Stunden - wenn hier immer noch 6 Tage stehen stimmt was nicht, war das ein Typo ?
    Hast Du smarthomeNG neu gestartet ?

    eine Einstellung ist 432.000 = 432.000 / 60 / 60 / 24 = 5 Tage
    M
    Zitat von AndreK Beitrag anzeigen
    login_update_cycle: 432000
    Kannst Du irgendwas im Log erkennen ?

    Gruss Andre

    Einen Kommentar schreiben:


  • Jürgen
    antwortet
    Hallo Andre,

    habe den Parameter nun geändert auf 42.200. Im Backend stehen aber immer noch knapp 6 Tage bis zum nächsten Autologin..
    Die Datei lastlogin.txt hatte ich gelöscht....
    Sechs Tage sind offensichtlich zu lang...

    Gruß Jürgen

    Einen Kommentar schreiben:


  • schuma
    antwortet
    Hallo, da mir das mit dem time.sleep nicht so gut gefallen hat, habe ich es jetzt bei mir mit einem Hilfsitem gelöst:

    Logik wird getriggert von:
    - avm.monitor.incoming.is_call_incoming.delay
    - avm.monitor.incoming.is_call_incoming

    Logik:
    Code:
    tmpsource = sh.return_item(trigger['source'])
    triggerval = trigger['value']
    if (str(tmpsource) == 'avm.monitor.incoming.is_call_incoming.delay') and (triggerval == False):
        if sh.Setup.meldung_audio.audioalexa_an_aus() == 1:
            textts = 'Hu hu, ' + sh.avm.monitor.incoming.last_caller() + ' ruft an!'
            sh.AlexaRc4shNG.send_cmd_by_curl('Echo_Wohnzimmer','Text2Speech',textts)
    
    elif (str(tmpsource) == 'avm.monitor.incoming.is_call_incoming') and (triggerval == True):
        sh.avm.monitor.incoming.is_call_incoming.delay.timer(2,0)
    Item:
    Code:
                is_call_incoming:
                    type: bool
                    avm_data_type@fritzbox_1: is_call_incoming
                    
                    delay:
                        type: bool
                        enforce_updates: 'yes'
    Grüße, Marc

    Einen Kommentar schreiben:


  • schuma
    antwortet
    Zitat von psilo Beitrag anzeigen
    Ich hab einfach nen simplen time.sleep drin
    OK, dann setzte ich das auch so um. Danke.
    Zitat von psilo Beitrag anzeigen
    derzeit habe ich aber einigen delay beim vorlesen. früher ging das besser. bin noch unsicher ob das an alexa liegt, oder am avm plugin / bzw. der fritzbox selber oder an shng..
    Bei mir läuft das sehr gut!

    Grüße, Marc

    Einen Kommentar schreiben:


  • psilo
    antwortet
    Ich hab einfach nen simplen time.sleep drin

    Code:
    if sh.avm.monitor.incoming.is_call_incoming():
        time.sleep(2)
        text = 'Anruf von '+sh.avm.monitor.incoming.last_caller()
        sh.alexarc4shng.send_cmd_by_curl('Büro', 'Text2Speech', text);
    derzeit habe ich aber einigen delay beim vorlesen. früher ging das besser. bin noch unsicher ob das an alexa liegt, oder am avm plugin / bzw. der fritzbox selber oder an shng..

    Einen Kommentar schreiben:


  • schuma
    antwortet
    Zitat von psilo Beitrag anzeigen
    Ich habe bspw. gerade Alexa mit der Anrufererkennung der Fritzbox (AVM Plugin) kombiniert. Sobald jemand anruft, liest mir Alexa den Anrufernamen vor
    Hallo psilo kannst Du hier kurz erklären welche Items du dafür genommen hats?
    Wenn ich das so mache, bin ich irgendwie zu schnell und es wird immer der Anrufer vor dem aktuellen angesagt:

    Code:
    if str(tmpsource) == 'avm.monitor.incoming.is_call_incoming':
        if sh.Setup.meldung_audio.audioalexa_an_aus() == 1:
            textts = 'Hu hu, ' + sh.avm.monitor.incoming.last_caller() + ' ruft an!'
            sh.AlexaRc4shNG.send_cmd_by_curl('Echo_Wohnzimmer','Text2Speech',textts)
    Grüße, Marc

    Einen Kommentar schreiben:


  • AndreK
    antwortet
    Hallo Jürgen ,

    das wird bereits protokoliert, bitte prüf mal deine "smarthome-details.log". Bei mir steht dort, Update von heute :

    Code:
    2019-09-12  21:17:58 INFO     plugins.alexarc4shng Status of log_off: 200
    2019-09-12  21:17:58 INFO     plugins.alexarc4shng Status of Auto-Login First Step: 200
    2019-09-12  21:17:59 INFO     plugins.alexarc4shng Status of Auto-Login Second Step: 200
    2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of Auto-Login third Step: 200
    2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of Auto-Login fourth Step: 404
    2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of Auto-Login fifth Step - got CSRF: XXXXXXXXXXX
    2019-09-12  21:18:00 INFO     plugins.alexarc4shng Status of check_login_state: 200
    Der HTTP-Error 404 in Step 4 ist OK-das liegt daran, dass Amazon irgendwelche Web-Verweise geändert hat. Wichtg ist Step-5.
    Eigentlich sollte auch das Web-IF anzeigen ob man korrekt angemeldet ist, falls keine korrekte Anmeldung vorhanden ist werden keine Geräte angezeigt und das
    Cookie ist "traurig".
    Du hattest zuletzt gepostet, dass du das Cookie-File manuell eingefügt hast. Wie hier das Verhalten mit Auto-Login ist muss ich mir nochmal anschauen.
    Ich kann auf jeden Fall bestätigen, dass mit
    Code:
    login_update_cycle: 432000
    das Plugin bei mir seit nunmehr Monaten durchläuft. Ich weiß das nutzt Dir nichts, nimm auf jeden Fall mal die login_update_cylce Zeit auf 43200 runter.
    Lösche die Datei "lastlogin.txt" im Ordner plugins/alexarc4shng. Die Datei ist der Merker für erneuern des Cookies.

    "Ich nehme auf die Todo-Liste" : aktualisieren der "lastlogin.txt" bei manuellen LogOff/Login und einfügen eines Cookie-Files - das passiert aktuell noch nicht - :-(

    Ich hoffe das hilft Dir weiter, falls nicht bitte Info.

    Gruss Andre


    Einen Kommentar schreiben:


  • Jürgen
    antwortet
    Hallo Andre,
    Alexa war wieder bockig...
    Interessant ist: Es lief zwei Wochen durch, aber NACH dem letzten Autologin war Ende:
    last/next Auto-Login 2019-09-11 20:24:29(2019-09-17 15:17:49)
    Kannst Du vielleicht noch ein Logfile einbauen / auswerten, ob der Autologin geklappt hat?

    Manuelles Abmelden und Wiederanmelden hat funktioniert.

    Gruß Jürgen

    Einen Kommentar schreiben:


  • AndreK
    antwortet
    Hallo @Jürgen,

    Rückmeldung etwas verspätet, hatte mal Urlaub

    Du kannst die Zeit für die Erneuerung in der ./etc/plugin.yaml anpassen.
    login_update_cycle: 432000
    = 5 Tage steht bei mir,

    default ist : 604800 = 7 Tage

    Du kannst jederzeit über das Web-Interface abmelden (Logoff) und wieder anmelden (Login).
    Das sollte dann Abhilfe schaffen.

    Besser passt Du den Parameter fürs Auto-Update in der ./etc/plugin.yaml an.
    Bei mir läuft es auch während des Urlaubs so durch.

    Ich werde beim nächsten Update die default-Zeit auf 432000 anpassen.

    Gruss Andre

    Einen Kommentar schreiben:


  • Jürgen
    antwortet
    Guten Morgen,

    mein Echo bleibt schon wieder stumm :-(..
    Edith hat ins Backend geschaut: Letzte Anmeldung vor drei Tagen, nächste Anmeldung in drei Tagen.
    Kann man das manuell aktualisieren? Ich habe dann wieder das Cookie File eingefügt, dann ging es wieder...

    Gruß Jürgen
    Zuletzt geändert von Jürgen; 29.08.2019, 06:04.

    Einen Kommentar schreiben:

Lädt...
X