Ankündigung

Einklappen
Keine Ankündigung bisher.

WLAN-Steckdosen schalten

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Msinn
    antwortet
    Der früheste Zeitpunkt wäre sinnvollerweise das Release 1.7.

    In SmartHomeNG 1.7 wird die MQTT Unterstützung im Core (in Form eines Moduls) implementiert sein. Dadurch kann MQTT dann in Plugins aber auch in Logiken genutzt werden. Für Logiken stehen hierzu drei neue Funktionen zur Verfügung. Für Plugins gibt es eine neue Klasse MqttPlugin (abgeleitet von SmartPlugin), die die benötigten Methoden zur Verfügung stellt.

    Aktuell kann das ganze nur getestet werden, wenn man auf der aktuellsten Version des Develop Branches unterwegs ist und das Modul mqtt geladen und konfiguriert hat. Da auch eine Reihe von Libs angepasst wurden um die Funktionalität möglichst einfach nutzen zu können, funktioniert es auf älteren Develop Ständen oder dem v1.6er Master nicht.

    Ich habe keine Tasmota Geräte im Einsatz, sonst könnte ich ein Plugin dafür recht schnell vom Shelly Plugin ableiten.

    Einen Kommentar schreiben:


  • henfri
    antwortet
    Das mache ich aber frühestens im nächsten Winter ;-)

    Einen Kommentar schreiben:


  • Sisamiwe
    antwortet
    Zitat von henfri Beitrag anzeigen
    Mir juckt es in den Fingern, das als Vorlage für ein Tasmota Plugin zu verwenden.
    Das wäre eine tolle Sache!
    Ich kann gern testen, denn ich habe diverse SONOFFs, H801 etc mit Tasmota am Start.

    Einen Kommentar schreiben:


  • henfri
    antwortet
    Schön!

    Mir juckt es in den Fingern, das als Vorlage für ein Tasmota Plugin zu verwenden.

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Zitat von TCr82 Beitrag anzeigen
    Ich glaube die shelly Sachen funktionieren bzw. sind sehr gut Dokumentiert was das alles angeht:

    https://shelly-api-docs.shelly.cloud...amily-overview
    Ein Teaser: Mit SmartHomeNG v1.7 wird ein Shelly Plugin kommen, welches über MQTT kommuniziert.
    Auszug aus der Doku im Develop Branch: shelly Plugin

    Einen Kommentar schreiben:


  • Sisamiwe
    antwortet
    Zitat von Gue0411 Beitrag anzeigen
    Gibt es eigentlich eine elegante Möglichkeit irgendwie zu erkennen, ob die Steckdose überhaupt im Netzwerk da ist?
    Bei neuen Geräte im Netzwerk meldet mir das meine Fritzbox mit der entsprechenden IP-Adresse.
    Mit dieser kannst Du das Interface des Gerätes bzw. Steckdose audfrufen. Dort musst Du ja dann die Eintellungen für MQTT vornehmen.

    Einen Kommentar schreiben:


  • henfri
    antwortet
    Hallo,

    Zitat von Gue0411 Beitrag anzeigen
    Kann es dann sein, dass du einen Fehler in deinem item-Baum hast?
    Nein :-)

    Zitat von Gue0411 Beitrag anzeigen
    Es würden dann doch insgesamt 4 mqtt-items drin sein, oder?
    Code:
     mqtt_topic_in: stat/MeineSteckdose1/POWER
    mqtt_topic_out: cmnd/MeineSteckdose1/power
    vom struct:
    mqtt_topic_in: stat/gosundXX/POWER
    mqtt_topic_out: cmnd/gosundXX/power
    Mit dem Zweiten überschreibst du das Erste. Das Erste ist der Default Wert. Könnte man hier auch weglassen.

    Zitat von Gue0411 Beitrag anzeigen

    Schon allein wenn ich nur die ersten beiden drin lasse, schaltet die Steckdose andauernd an, aus, an, aus, an, aus, ...
    Mit nur einem out-item funktioniert das Schalten mittlerweile.
    Mit nur einem: was meinst du damit: ein out und kein in?

    Zeig mal deine Konfiguration jetzt.

    Zitat von Gue0411 Beitrag anzeigen
    Allerdings bekomme ich den "Anfangszustand" nicht mit...
    Was meinst du damit?

    Zitat von Gue0411 Beitrag anzeigen
    [SH-Update]
    Die Zeit und die Befürchtung, dass dann so einiges nicht mehr funktionieren wird... und dann die damit wiederum verbundene Zeit, welche ich aktuell nicht hab... (und vielleicht ein wenig das Gemeckere meiner Frau, dass nichts mehr funktioniert... )
    Mach doch einfach ein Backup des /usr/local/smarthome Ordner.

    Zitat von Gue0411 Beitrag anzeigen
    Gibt es eigentlich eine elegante Möglichkeit irgendwie zu erkennen, ob die Steckdose überhaupt im Netzwerk da ist?
    Ich habe TasmoAdmin installiert - via Docker ging das super einfach.

    Zitat von Gue0411 Beitrag anzeigen
    Dachte da an ein ping-Kommando, leider funktioniert alles irgendwie nicht, was ich ausprobiert hatte...
    Hier geht es.
    Vielleicht funktioniert es ja und das Gerät ist nicht im Netzwerk ;-)
    Code:
    ping 192.168.177.148
    PING 192.168.177.148 (192.168.177.148) 56(84) bytes of data.
    64 bytes from 192.168.177.148: icmp_seq=1 ttl=255 time=89.8 ms
    64 bytes from 192.168.177.148: icmp_seq=2 ttl=255 time=2.40 ms
    ^C
    --- 192.168.177.148 ping statistics ---
    2 packets transmitted, 2 received, 0% packet loss, time 1001ms
    rtt min/avg/max/mdev = 2.402/46.121/89.841/43.720 ms
    Ansonsten halt per http auf das Webinterface gehen?!

    Gruß,
    Hendrik

    Einen Kommentar schreiben:


  • Gue0411
    antwortet
    Gibt es eigentlich eine elegante Möglichkeit irgendwie zu erkennen, ob die Steckdose überhaupt im Netzwerk da ist?
    Dachte da an ein ping-Kommando, leider funktioniert alles irgendwie nicht, was ich ausprobiert hatte...
    Hat sowas schon mal wer umgesetzt?

    Einen Kommentar schreiben:


  • Gue0411
    antwortet
    bmx: Die Zeit und die Befürchtung, dass dann so einiges nicht mehr funktionieren wird... und dann die damit wiederum verbundene Zeit, welche ich aktuell nicht hab... (und vielleicht ein wenig das Gemeckere meiner Frau, dass nichts mehr funktioniert... )


    Lonie: Danke!

    Einen Kommentar schreiben:


  • bmx
    antwortet
    Gue0411 Was hält Dich vom Update auf die 1.6.x ab?

    Einen Kommentar schreiben:


  • Lonie
    antwortet
    Bezüglich Leistungsdaten gibt es TelePeriod

    Einen Kommentar schreiben:


  • Gue0411
    antwortet
    Hat ein wenig gedauert, aber...

    Das struct-item kann erst ab SHNG 1.6 verwendet werden, ich habe noch 1.5, deswegen bekam ich Fehler...
    Ich habe dann versucht, das struct manuell aufzulösen und bei mir nachzubilden.
    Kann es dann sein, dass du einen Fehler in deinem item-Baum hast?
    Es würden dann doch insgesamt 4 mqtt-items drin sein, oder?
    Code:
        mqtt_topic_in:  stat/MeineSteckdose1/POWER
        mqtt_topic_out: cmnd/MeineSteckdose1/power
    vom struct:
        mqtt_topic_in:  stat/gosundXX/POWER
        mqtt_topic_out: cmnd/gosundXX/power
    Schon allein wenn ich nur die ersten beiden drin lasse, schaltet die Steckdose andauernd an, aus, an, aus, an, aus, ...
    Mit nur einem out-item funktioniert das Schalten mittlerweile.
    Allerdings bekomme ich den "Anfangszustand" nicht mit...

    Kann man außerdem irgendwie einstellen, wie oft die Leistungsdaten übermittelt werden? Alle 10min sind mir zu wenig...

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    -m ist die Option für das Tool. Die Payload ist dann 1. Es ist nicht die Message. Eine MQTT Message besteht immer aus 2 Teilen (Topic und Payload).

    Einen Kommentar schreiben:


  • Gue0411
    antwortet
    das Payload ist doch die message, oder?
    also das "-m 1"

    Hab im Webinterface gesehen, dass das Template auf Default wieder stand, warum auch immer...
    Mit dem richtigen Template funktioniert nun auch das Schalten!
    Also sowohl übers Webinterface, als auch über mosquitto_pub!

    edit: die Fehlermeldung sah ich in der Console vom Tasmota.

    Einen Kommentar schreiben:


  • henfri
    antwortet
    Kannst du die Steckdose im Webinterface von Tasmota schalten?
    Wo siehst du die Fehlermeldung?


    Kannst das Kommando auch per webconsole testen. Siehe mein Link oben.

    Oder:
    Code:
     http://<ip>/cm?cmnd=Power%20On
    Zuletzt geändert von henfri; 02.01.2020, 18:07.

    Einen Kommentar schreiben:

Lädt...
X