Ankündigung

Einklappen
Keine Ankündigung bisher.

Support Thread für das Shelly Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Msinn
    antwortet
    Wenn man bei einer unbekannten Materie (wie bei Dir MQTT) nur einem Blog folgt und auch beim Auftreten von Problemen nicht in die Doku schaut, dann muss man dafür halt mit Zeitaufwand bezahlen...

    Zitat von TCr82 Beitrag anzeigen
    Sorry dafür, hoffentlich ist es so besser
    Man kann hier im Forum ganz normal mit Einrückungen pasten. Um den Usern das Suchen wie das geht im ganzen knx-user-forum zu ersparen, haben wir sogar einen gepinnten Thread im SmartHomeNG Forum.

    Aus Deinem Post werde ich nicht ganz schlau. Du hast geschrieben Du hättest einen Shelly1. Bei Deiner Änderung hast Du jetzt aber eine Shelly-Plug konfiguriert. Das sind schon unterschiedliche Devices.

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Zitat von Msinn Beitrag anzeigen
    Aber wenn Du bei der Konfiguration des MQTT Moduls (z.B. in der Admin GUI) eine Netzwerk Konfiguration für einen MQTT Broker vornehmen sollst und Dir nicht klar ist was ein Broker ist
    In der module.yaml worüber ich das Modul eingerichtet habe (und dazu dem Blog gefolgt bin) ist das nicht ersichtlich dass man da eine Netzwerkkonfig eingeben kann. Und da ich annahm, dass der Broker shNG selbst ist, habe ich auch anfangs nicht danach gesucht - erst nachdem trotz aller Bemühungen im Admin Modul unter Dienste immer ein Fehler bei "Broker für die MQTT Unterstützung" stand und das ganze nicht lief - habe ich Intensiver danach gesucht und naja, letztendlich habe ich es ja heraus bekommen ohne jemanden damit zur last zu fallen

    Zitat von Msinn Beitrag anzeigen
    Hätte ich vielleicht, wenn Dein Post eine vernünftige Formatierung hätte
    Sorry dafür, hoffentlich ist es so besser.
    Zuletzt geändert von TCr82; 25.07.2020, 21:28.

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    TCr82 Aber wenn Du bei der Konfiguration des MQTT Moduls (z.B. in der Admin GUI) eine Netzwerk Konfiguration für einen MQTT Broker vornehmen sollst und Dir nicht klar ist was ein Broker ist, hätte eine Eingabe des Wortes Broker im Suchfeld der Doku Dir in der Ergebnisliste direkt an zweiter Stelle den Eintrag MQTT Broker installieren geliefert.

    Zitat von TCr82 Beitrag anzeigen
    hast du eine Idee wieso das so ist wie ich oben Beschrieben habe (Heute, 11:30)?
    Hätte ich vielleicht, wenn Dein Post eine vernünftige Formatierung hätte. So fräse ich mich durch die Konfiguration nicht durch.

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    whe
    Naja, nicht jeder installiert es mit Onkelandy `setup_all` - deswegen war mir das leider nicht klar.

    Msinn
    hast du eine Idee wieso das so ist wie ich oben Beschrieben habe (Heute, 11:30)?

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    whe Ich habe Dir das editieren freigeschaltet.

    Einen Kommentar schreiben:


  • whe
    antwortet
    Zitat von TCr82 Beitrag anzeigen
    In dem tollen Blog Beitrag könnte man ergänzen dass man für das MQTT dieses mosquitto installieren muss.
    dachte das ginge daraus hervor, weil ich von Onkelandies image ausgegangen bin.

    Vorbereitungen in SmarthomeNG 1.7

    zunächst mal muss MQTT aufgesetzt werden; dies habe ich natürlich, dank „Onkelandy“ über das setup_all script gemacht.
    leider kann ich den Beitrag nicht mehr anpassen, sonnst könnte ich noch einen Satz ergänzen.

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Sorry, das hatte ich aus dem Blog-Post von whe. Kann das gerne verbessern (wenn mir jemand Zugriff darauf gibt) und gleich noch den Hinweis bzgl. des MQTT Brokers einbauen, für alle "MQTT-Anfänger" wie mich

    EDIT:

    Also ich habe das mit dem "richtigen" shelly_type ausprobiert. Aber dann erscheint das so und geht auch nicht - bzw geht gar nicht mehr:

    Shelly WebIF.PNG
    Auf der Fritzbox tauchen die shelly Geräte auch mit dem Namen shelly1-MAC auf. Irgendwie passt das mit dem shelly_type nicht ganz.

    Meinen Items sehen so aus:
    Code:
    kg:
       hwr:
          name: Waschraum
          sv_page: room
    
          licht:
             name: Waschraum
             type: bool
             visu_acl: rw
             sv_widget: "{{ my_widgets.switch('item', 'item.name', 'item') }}"
             sv_item_type: light
             shelly_id: A4CF12F48F62
             shelly_type: shellyplug
             enforce_updates: true
    
       buero:
          name: Büro
          sv_page: room
    
          licht:
             name: Büro
             type: bool
             visu_acl: rw
             sv_widget: "{{ my_widgets.switch('item', 'item.name', 'item') }}"
             sv_item_type: light
             shelly_id: A4CF12F46C20
             shelly_type: shellyplug
             enforce_updates: true
    Zuletzt geändert von TCr82; 25.07.2020, 21:27.

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Die default Werte sollten eigentlich greifen, wenn Du einen unterstützten shelly_type eingetragen hättest. shelly1 steht nicht als gültiger shelly_type in der Doku.

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Hätte das überhaupt passieren dürfen?
    Ich habe gerade mal in der Dokuhttp://smarthomeng.de/dev/user/plugi...ig/shelly.html gelesen und da steht, dass die zwei vergessen Item Parameter eigentlich ja per default genau das haben, was ich gesetzt habe. Sollte ja eigentlich dann nicht von nöten sein

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Ok, ich bin wohl einfach schon zu müde. Habe den Fehler gefunden:

    Code:
    licht:
       name: Büro
       type: bool
       visu_acl: rw
       sv_widget: "{{ my_widgets.switch('item', 'item.name', 'item') }}"
       sv_item_type: light
       shelly_id: A4CF12F46C20
       shelly_type: shelly1
       enforce_updates: true
    Hatte shelly_attr und shelly_relay nicht aus dem Blog übernommen, da ich nicht wusste was das macht. Nachdem ich das jetzt einfach übernommen habe funktioniert es
    Zuletzt geändert von TCr82; 25.07.2020, 21:23.

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Hi, ich habe heute auch meinen ersten Shelly1 im Keller eingebaut und das ganze hier mit aktuellen shNG getestet.

    In dem tollen Blog Beitrag könnte man ergänzen dass man für das MQTT dieses mosquitto installieren muss. Das war schon mal nicht ganze einfach raus zu finden - Ich dachte vorher, dass shNG der Broker ist... Hab es dann letztlich auf der Seite entdeckt: https://www.smarthomeng.de/user/inst...mosquitto.html

    Aber endlich kann ich jetzt den Shelly über shNG an und aus schalten. Nur habe ich das Problem, dass der Status nicht übermittelt wird. Ich also keine Änderung übermittelt bekommen, wenn ich den Schalter im Raum betätige.

    Auch sehe ich im Webinterface des Shelly Plugins auf der Registerkarte "Shelly devices" auch die Status Infos nicht.

    Hat wer eine Idee was ich vergessen haben könnte?

    Grüße
    Zuletzt geändert von TCr82; 24.07.2020, 23:27.

    Einen Kommentar schreiben:


  • whe
    antwortet
    Hier jetzt der Link zu meinem Blog Beitrag:
    https://www.smarthomeng.de/wie-ich-m...ngebunden-habe

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Wenn Shelly im MQTT Mode läuft, nutzen sie keine Cloud. Das steht auch explizit in der Shelly Doku. Ich bin mit den Shellies soweit zufrieden.

    Im Core ist nur das eine MQTT Protokoll abgebildet (mit der Kommunikation zum Broker). Das Modul im Core stellt Methoden zur Verfügung, damit verschiedene Plugins (mqtt, Shelly, ...) und Logiken MQTT nutzen können ohne dass jedes Plugin den MQTT Protokoll Stack implementieren muss.

    Siehe auch: www.smarthomeng.de/neuerungen-bei-mqtt-in-smarthomeng-v1-7

    Einen Kommentar schreiben:


  • heckmannju
    antwortet
    Danke für die Antwort Martin, ich habe halt bedenken mit geräten die mit Clouds arbeiten.


    Ich habe noch eine Frage wenn SmarthomeNG schon im core MQTT spricht warum braucht es dann ein shelly plugin?

    Bist du zufriden mit der Shelly proodukt?

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Zitat von heckmannju Beitrag anzeigen
    hast du diesen Shelly sachen schon mal probiert auf Tasmota umzustellen?
    Da die Shelly Teile direkt MQTT sprechen habe ich für mich keinen Grund gesehen, die Firmware der Teile aus Tasmota zu flashen.

    Einen Kommentar schreiben:

Lädt...
X