Ankündigung

Einklappen
Keine Ankündigung bisher.

Support Thread für das Shelly Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Msinn
    antwortet
    Das ist trotzdem kein Thema des Plugins, da das Plugin gar nicht weiss, dass es über einen Autotimer angesteuert wird. Da musst Du schon mehr von Deiner Konfiguration posten, damit jemand beurteilen kann, ob da irgendwo Seiteneffekte auftreten.

    Wie gesagt: Im Shelly Plugin Support Thread, wirst Du nicht viel Hilfe bekommen, da den vermutlich nur Leute lesen, die das Shelly Plugin einsetzen und nicht alle die mit Autotimern hantieren.

    Einen Kommentar schreiben:


  • Quack888
    antwortet
    Sorry das ich mich erst jetzt wieder melde.
    Das ist jetzt eben meine Frage. Ist es normal das Shelly das Item alle 30 Sekunden akualisiert und dadurch der Autotimer zurück gesetzt wird oder liegt das am Autotimer. Ich habe noch andere Lichter die ganz normal über KNX laufen da funktionitert der Autotimer ganz wunderbar. Deswegen war ich jetzt beim dem Shelly etwas überrascht das es mit einer größeren Zeit nichtmehr funktioniert. Hier mal ein Bild das den Update des Item Zeigt.
    Shelly_Item.jpg

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Wenn Du Deine Frage in einem anderen Thread stellst, findest Du evtl. Mehr Leute die Dir helfen können. Nei Deinem Problem geht es um die Nutzung der autotimer Attributes und nicht um das Shelly Plugin.

    Um Nebeneffekte auszuschließen würde ich übrigens erstmal mit einer konstanten Dauer testen und statt sh.Keller.Lichter.TerppenhausEG.Dauer() erstmal einen festen Wert angeben.

    Einen Kommentar schreiben:


  • Quack888
    antwortet
    Hallo zusammen,

    ich habe mir auch einen Shelly besorgt und habe den beim Keller Licht eingebaut. Es ist ein Shelly1. Das funktioniert dank der Anleitung von Wil Heynen soweit auch ganz gut. Jetzt habe wollte ich den Shelly mit Autotimer wieder ausschalten. Praktisch ein Treppenlicht Automat. Dasfunktioniert auch, aber nur wenn die Zeit unter 30Sekunden liegt. Bei mir wird das Shelly Item alle 30 Sekunden wieder aktualisiert und der Timer zurück gesetzt.

    Kennt dieses Verhalten jemand?

    Mein Item ist so Konfiguriert:
    Code:
    type: bool
    shelly_id: 40F5202DFFB6
    shelly_type: shelly1
    shelly_attr: relay
    shelly_relay: 0
    visu_acl: rw
    cache: 'True'
    enforce_updates: 'false'
    autotimer: sh.Keller.Lichter.TreppenhausKG.Dauer() = False
    SmartHomeNG 1.7.2.master

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Hi, Leute!

    Heute habe ich einen weiteren Shelly in Betrieb genommen - diesmal ein Shelly1pm

    Da hat sich mir erstmal die Frage gestellt, was und in welcher Einheit die Werte power und energy ausgegeben werden. Dazu habe ich in der Online-Plugin-Doku leider nichts genaues gefunden. Deswegen habe ich dann in der Shelly MQTT Doku weiter gesucht und folgendes gefunden:

    Screenshot_20201209_200953.png

    Die Frage für power hat sich somit geklärt - nur energy bin ich mir nicht sicher - aber ich vermute es wird hier der Wert total ausgegeben?

    Weiß jemand, für welche Periode dieser Wert gilt? Seid dem Einschalten oder Anschließen?

    Und ob man den Wert irgendwo zurück setzten kann (wenn seid Anschließen)?

    Gruß

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Zitat von Msinn Beitrag anzeigen

    Nun kannst Du shelly1 konfigurieren und es wird als gültiger Eintrag anerkannt.
    Bewirkt das eine Veränderung?
    Sorry für die späte Rückmeldung - ja wenn ich das so mache, kann ich `shelly_attr` auch weg lassen und es funktioniert.

    Zitat von Msinn Beitrag anzeigen
    Btw.: was zeigt Dir das Tab shelly Devices im Webinterface des Plugins? Dort sollten alle Shelly Devices auftauchen (zumindest nach einiger Zeit, > 5 Min.), auch die die nicht in SmartHomeNG konfiguriert sind.
    Das funktioniert nun auch richtig - wie das vorher aussah hatte ich ja hier gepostet:

    Gruß
    Zuletzt geändert von TCr82; 12.10.2020, 16:35.

    Einen Kommentar schreiben:


  • whe
    antwortet
    Zitat von Msinn Beitrag anzeigen
    whe Ich habe Dir das editieren freigeschaltet.
    danke, habe jetzt einen Satz ergänzt.

    auch habe ich das Beitragsbild getauscht, der Shelly Plug hat andere Attribute, dazu wollte ich evtl. auch noch mal etwas posten.

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Die Prüfungen gibt es bisher nur im develop. Die kommen erst mit dem Release 1.8 in den master.

    Einen Kommentar schreiben:


  • whe
    antwortet
    Zitat von Msinn Beitrag anzeigen
    Das funktioniert nur, weil die Eintragungen für Item Attribute bei Dir noch nicht gegen die Metadaten geprüft werden (wie es für Plugin Parameter schon seit einigen Versionen von SmartHomeNG der Fall ist).
    aber ich nutze doch die neuesten Master Versionen:

    SHNG 1.7.2
    shelly plugin 1.1.3

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Das funktioniert nur, weil die Eintragungen für Item Attribute bei Dir noch nicht gegen die Metadaten geprüft werden (wie es für Plugin Parameter schon seit einigen Versionen von SmartHomeNG der Fall ist).

    Einen Kommentar schreiben:


  • whe
    antwortet
    meine item Definition sieht so aus und ich benutze ein shelly1:
    Code:
            Tor:
                name: Tor
                shelly_id: 8CAAB505559E
                [MARKIEREN]shelly_type: shelly1[/MARKIEREN]
                shelly_attr: relay
                shelly_relay: 0
                enforce_updates: true
                type: bool
                visu: 'yes'
                visu_acl: rw
                sv_widget: "{{ basic.stateswitch('item', 'item', 'midi', 1, '', '', '', 'blink') }}"
                nw: yes

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Laut der (aktuellen) Shelly Doku sollten sich der shelly1 und der shelly1pm gleich verhalten. Probier aber mal folgendes:

    Füge in den Metadaten (der plugin.yaml) des Plugins unter shelly_type den Eintrag shelly1 hinzu:

    Code:
    item_attributes:
        # Definition of item attributes defined by this plugin (enter 'item_attributes: NONE', if section should be empty)
        shelly_id:
            type: str
            description:
                de: 'ID des Shelly Devices'
                en: 'ID of the Shelly device'
    
        shelly_type:
            type: str
            valid_list:
                - shellyplug
                - shellyplug-s
                - shelly1pm
                - shellyswitch
                - shellyswitch25
                - shelly4pro
            description:
                de: "Typ des Shelly Devices (z.B. Shellyplug, Shellyplug-s, Shelly1/pm, Shelly2, Shelly2.5, Shelly4Pro)"
                en: "Type of Shelly device (e.g. Shellyplug, Shellyplug-s. Shelly1/pm, Shelly2, Shelly2.5, Shelly4Pro)"
    ändern in

    Code:
    item_attributes:
        # Definition of item attributes defined by this plugin (enter 'item_attributes: NONE', if section should be empty)
        shelly_id:
            type: str
            description:
                de: 'ID des Shelly Devices'
                en: 'ID of the Shelly device'
    
        shelly_type:
            type: str
            valid_list:
                - shellyplug
                - shellyplug-s
                - shelly1
                - shelly1pm
                - shellyswitch
                - shellyswitch25
                - shelly4pro
            description:
                de: "Typ des Shelly Devices (z.B. Shellyplug, Shellyplug-s, Shelly1/pm, Shelly2, Shelly2.5, Shelly4Pro)"
                en: "Type of Shelly device (e.g. Shellyplug, Shellyplug-s. Shelly1/pm, Shelly2, Shelly2.5, Shelly4Pro)"
    Nun kannst Du shelly1 konfigurieren und es wird als gültiger Eintrag anerkannt.
    Bewirkt das eine Veränderung?

    Btw.: was zeigt Dir das Tab shelly Devices im Webinterface des Plugins? Dort sollten alle Shelly Devices auftauchen (zumindest nach einiger Zeit, > 5 Min.), auch die die nicht in SmartHomeNG konfiguriert sind.

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Also ich vermute man sollte einfach den Typ shelly1 ergänzen.

    Ohne jetzt mir den Code des Plugins durchzulesen, habe ich einfach mal in der Doku von Shelly nachgesehen.

    Dort gibt es sehr wohl den Typ shelly1 - mit dem es ja bei mir auch geht - nur muss ich wie schon geschrieben shelly_attr definieren, obwohl das ja per Standard das macht was ich definiere: nämlich relay - und somit eigentlich ja überflüssig ist.

    http://shelly-api-docs.shelly.cloud/.../#shelly1-mqtt

    Einen Kommentar schreiben:


  • TCr82
    antwortet
    Ja, ich weiß was der shelly1pm ist - ist im Prinzip der shelly1 mit strommessung.

    Wenn ich shelly1pm als Typ benutze, inkl der zwei weiteren Definitionen dann geht es auch nicht.

    Siehe auch das Bild was ich angehängt habe.
    Er sagt dann auch dass das Gerät mit shelly1pm-mac konfiguriert ist. Und findet ausserdem den shelly1-mac und sagt dass es nicht konfiguriert ist.

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Shelly1 als Typ ist FALSCH (Schau einfach mal in die Doku). Da ich kein Shelly1 habe kann ich im Moment nicht testen was bei der Einstellung shelly1pm passiert und nicht funktioniert.

    Das mit dem Eintrag shelly1pm das Modell Shelly1/PM gemeint ist und nur das Sonderzeichen des Produktnamen weggelassen wurde ist Dir aber schon klar, oder?

    Was passiert denn wenn Du statt shelly1 shelly1pm wählst und shelly_attr sowie shelly_relay setzt?

    Einen Kommentar schreiben:

Lädt...
X