Ankündigung

Einklappen
Keine Ankündigung bisher.

Support Thread für das MPD Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Support Thread für das MPD Plugin

    Der Titel sagt es: Support für das MPD Plugin gibt es hier ...


    #2
    Hallo,

    ich habe heute mal testweise ein Update auf die Version 1.8.1 gemacht.

    Dabei habe ich festgestellt, dass das Abspielen einer URL im mpd-Plugin nicht mehr funktioniert.

    Das Item sieht so aus:
    Code:
    ndr2_test:[INDENT]type: bool
    mpd_url@gaeste_wc: "http://ndr-ndr2-niedersachsen.cast.addradio.de/ndr/ndr2/niedersachsen/mp3/128/stream.mp3"
    enforce_updates: 'yes'[/INDENT]
    In Version 1.7.2 war es so, dass der Stream beim Setzen des Items auf True abgespielt wurde.

    Jetzt kommt folgende Meldung im Log:
    Code:
    2021-01-30 09:59:41 ERROR plugins.mpd gaeste_wc@: MPD_gaeste_wc: ACK [2@0] {add} wrong number of arguments for "add"

    Kommentar


      #3
      Moin!
      Ich komme da auch nicht weiter, wobei bereits beim Initialisieren ein Warning ausgegeben wird:

      Code:
      2021-01-30 20:19:02 WARNING lib.smarthome.main -------------------- SmartHomeNG restarting, initiated by admin interface --------------------
      2021-01-30 20:19:41 WARNING lib.smarthome.main -------------------- Init SmartHomeNG 1.8.1.master (84873f74) --------------------
      2021-01-30 20:19:41 WARNING lib.smarthome.main Running in Python interpreter 'v3.7.3 final', from directory /usr/local/smarthome
      2021-01-30 20:19:41 WARNING lib.smarthome.main - on Linux-5.4.83-v7+-armv7l-with-debian-10.7 (pid=14466)
      2021-01-30 20:19:41 WARNING lib.smarthome.main - Nutze Feiertage für Land 'DE', Provinz 'HH', 1 benutzerdefinierte(r) Feiertag(e) definiert
      [MARKIEREN]2021-01-30 20:19:52 WARNING lib.metadata Item 'webradio.ndr', attribute 'mpd_url': value 'http://ndr-xxxxxx.mp3' can not be converted to type 'bool' (defined in webradio.yaml)[/MARKIEREN]

      Kommentar


        #4
        Schau ich Morgen Mal drauf. Vielleicht ist da ein Fehler in der plugin.yaml

        Kommentar


          #5
          Das scheinen einige Ungereimtheiten drin zu sein. Der aktuellen maintainer E3EAT könnte da vielleicht mal reinschauen da ich keinen mpd am Laufen habe.

          Da Ihr beide knxms und beavon das Plugin nutzt, trage ich Euch mal als Tester ein.

          Ich habe in develop einen Fix gepusht, schaut mal ob es damit geht.
          Zuletzt geändert von bmx; 31.01.2021, 07:33.

          Kommentar


            #6
            Sieht gut aus, danke.
            Ich teste dann mal weiter.

            Kommentar


              #7
              Moin!
              Auf die Schnelle auch von meiner Seite:
              Weitere Tests kommen dann noch.

              Kommentar


                #8
                Hallo Zusammen,

                nach kürzlichem Update auf die SmarthomeNG Version 1.9.0 bekomme ich Probleme mit dem MPD Plugin Version 1.5.0. Diese schauen wie folgt aus und treten gemäß dafault Cycle Time von 2 sec entsprechend oft täglich auf. Kann mir dabei bitte jemand helfen, was ich dagegen tun kann. Vielen Dank.

                Code:
                2022-01-08 16:26:23 ERROR plugins.mpd.MPD Method plugins.mpd.MPD exception: 'MPD' object has no attribute 'connected'
                > Traceback (most recent call last):
                > File "/usr/local/smarthome/lib/scheduler.py", line 670, in _task
                > obj()
                > File "/usr/local/smarthome/plugins/mpd/__init__.py", line 169, in update_status
                > self.update_currentsong(warn)
                > File "/usr/local/smarthome/plugins/mpd/__init__.py", line 191, in update_currentsong
                > if not self.connected:
                > AttributeError: 'MPD' object has no attribute 'connected'
                Zuletzt geändert von bmx; 15.01.2022, 16:08.

                Kommentar


                  #9
                  der dazugehörige plugin.yaml Eintrag sieht bei mir wie folgt aus:

                  mpd:
                  plugin_name: mpd
                  host: 127.0.0.1
                  port: 6600

                  Kommentar


                    #10
                    Von welcher SmartHomeNG Version hast Du ein Update gemacht? 1.8 oder früher?
                    Zuletzt geändert von bmx; 15.01.2022, 16:08.

                    Kommentar


                      #11
                      Ich hatte zuvor die letzten Version 1.8.3 des SmarthomeNG im Einsatz und auch davon aus das Update durchgeführt.


                      Zuletzt geändert von FamilieP; 09.01.2022, 09:08.

                      Kommentar


                        #12
                        Darf ich fragen, ob es denn niemanden gibt, der mir mit meinem geschilderten Problem vom 06.01.2022 helfen kann?
                        Ein klares Nein würde mir ja reichen, dann würde ich meine Aufmerksamkeit wieder auf andere Dinge lenken als hier täglich einen Blick reinzuwerfen.
                        Auch eine Rückfrage zu stellen, darauf eine Antwort zu bekommen und dann nichts mehr von sich zu geben hilft mir jetzt persönlich auch nicht weiter.

                        Vielen Dank.

                        Kommentar


                          #13
                          Offensichtlich kann Dir aktuell niemand weiterhelfen.
                          Ich kann mich auch nicht an einen Supportvertrag mit Dir erinnern. Du Etwa?
                          Das ist alles eine Freizeitangelegenheit. Keine Freizeit, keine Unterstützung möglich.
                          Es gibt im Forum auch die Möglichkeit der Benachrichtigung bei Neuigkeiten, dann musst Du nicht ständig das Forum aufrufen.
                          Und ja, ich schaue mir das an aber nur dann wenn ich Zeit habe. Und da ich keinen MPD installiert habe, weiss ich auch nicht ob ich da was finde.

                          Kommentar


                            #14
                            In Zeile 191 sollte stehen:

                            Code:
                            if not self._client.connected:
                            ebenso in Zeile 204

                            Probier mal ob es das Problem für Dich löst.

                            Kommentar


                              #15
                              Hallo bmx,

                              entschuldige bitte, ich wollte mit meinen Anmerkungen keinem, auch dir nicht, zu nahe treten.
                              Mir ist sehr wohl bewusst, dass es keinen Support gibt und das jeder tut was er kann und dann in seiner verfügbaren Zeit.
                              Ich war nur verwundert sonst nichts.

                              Ich schaue mir gerne die von dir genannten Einträge mal an. Vielleicht kannst du mir noch sagen, wo ich diese in welchem File finden kann.

                              Vielen Dank.

                              Kommentar

                              Lädt...
                              X