Ankündigung

Einklappen
Keine Ankündigung bisher.

Support Thread für das MPD Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Support Thread für das MPD Plugin

    Der Titel sagt es: Support für das MPD Plugin gibt es hier ...


    #2
    Hallo,

    ich habe heute mal testweise ein Update auf die Version 1.8.1 gemacht.

    Dabei habe ich festgestellt, dass das Abspielen einer URL im mpd-Plugin nicht mehr funktioniert.

    Das Item sieht so aus:
    Code:
    ndr2_test:
    type: bool mpd_url@gaeste_wc: "http://ndr-ndr2-niedersachsen.cast.addradio.de/ndr/ndr2/niedersachsen/mp3/128/stream.mp3" enforce_updates: 'yes'
    In Version 1.7.2 war es so, dass der Stream beim Setzen des Items auf True abgespielt wurde.

    Jetzt kommt folgende Meldung im Log:
    Code:
    2021-01-30 09:59:41 ERROR plugins.mpd gaeste_wc@: MPD_gaeste_wc: ACK [2@0] {add} wrong number of arguments for "add"

    Kommentar


      #3
      Moin!
      Ich komme da auch nicht weiter, wobei bereits beim Initialisieren ein Warning ausgegeben wird:

      Code:
      2021-01-30 20:19:02 WARNING lib.smarthome.main -------------------- SmartHomeNG restarting, initiated by admin interface --------------------
      2021-01-30 20:19:41 WARNING lib.smarthome.main -------------------- Init SmartHomeNG 1.8.1.master (84873f74) --------------------
      2021-01-30 20:19:41 WARNING lib.smarthome.main Running in Python interpreter 'v3.7.3 final', from directory /usr/local/smarthome
      2021-01-30 20:19:41 WARNING lib.smarthome.main - on Linux-5.4.83-v7+-armv7l-with-debian-10.7 (pid=14466)
      2021-01-30 20:19:41 WARNING lib.smarthome.main - Nutze Feiertage für Land 'DE', Provinz 'HH', 1 benutzerdefinierte(r) Feiertag(e) definiert
      2021-01-30 20:19:52 WARNING lib.metadata Item 'webradio.ndr', attribute 'mpd_url': value 'http://ndr-xxxxxx.mp3' can not be converted to type 'bool' (defined in webradio.yaml)

      Kommentar


        #4
        Schau ich Morgen Mal drauf. Vielleicht ist da ein Fehler in der plugin.yaml

        Kommentar


          #5
          Das scheinen einige Ungereimtheiten drin zu sein. Der aktuellen maintainer E3EAT könnte da vielleicht mal reinschauen da ich keinen mpd am Laufen habe.

          Da Ihr beide knxms und beavon das Plugin nutzt, trage ich Euch mal als Tester ein.

          Ich habe in develop einen Fix gepusht, schaut mal ob es damit geht.
          Zuletzt geändert von bmx; 31.01.2021, 07:33.

          Kommentar


            #6
            Sieht gut aus, danke.
            Ich teste dann mal weiter.

            Kommentar


              #7
              Moin!
              Auf die Schnelle auch von meiner Seite:
              Weitere Tests kommen dann noch.

              Kommentar

              Lädt...
              X