Ankündigung

Einklappen
Keine Ankündigung bisher.

SmarthomeNG 1.8.2 Image für Raspberry Pi

Einklappen
Das ist ein wichtiges Thema.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Onkelandy
    antwortet
    Ich meinte das dhcp Problem

    Einen Kommentar schreiben:


  • whisperbot
    antwortet
    Zitat von Onkelandy Beitrag anzeigen
    Hat sonst noch wer das Problem?
    alles gut läuft stabil Raspi 1 B+ und Raspi 3 B

    Gruß
    whisper

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Häng doch bitte mal den Rechner an nen Monitor und poste den relevanten Teil des Logs.
    Notfalls muss ich drum bitten, bei dir eine fixe IP einzustellen, zB indem du die /etc/dhcpcd.conf Datei entsprechend adaptierst.

    Hat sonst noch wer das Problem?

    Einen Kommentar schreiben:


  • Haiphong
    antwortet
    Moin Andy,

    unter dem Image 1.8.1 hat der Raspi die IP 192.168.178.28 per DHCP bekommen.

    Die SD-Karte ist eine Transcend mit 16GB

    Der Raspi ist ein 4'er mit 4GB ( hab ich mir neu geleistet )
    Dachte zuerst es liegt an dem - neuen - Raspi, daher hab ich dann ältere Versionen getestet.

    Mir ist beim 1.8.2 noch aufgefallen,
    daß die grüne LED am Raspi, am Anfang / Start kurz leuchtet und dann nicht mehr.
    ( hab ca. 30 Min. auf eine IP gewartet. eventuell nicht lange genug - keine Ahnung )

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Hm, sehr sonderbar. Ich hatte bei mir das Problem schon bei 1.8.1 mit einem frischen Raspbian OS und keine Ahnung, woran das liegt. An nem anderen Netzwerkport hatte ich keine Probleme. Die Fritzbox mag da was nicht. Sorry, aber ich weiß nicht, wo ansetzen.
    Was für ne interne IP Range hast du? Zufällig 10.0.0.x?

    Einen Kommentar schreiben:


  • Haiphong
    antwortet
    Servus Andy,

    danke für das Image

    Mit dem Image 1.8.2 stimmt etwas nicht ( bekommt keine IP, hab mit Fing und über die Fritz gesucht )

    Das Image 1.8.1 läuft normal ( IP per DHCP vorhanden. Zugriff über Putty läuft )

    Hab das Image jeweils mit Win32DiskImager auf eine 16GB SD-Karte geschoben
    Zuletzt geändert von Haiphong; 26.02.2021, 00:45.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Das Image 10.1.8.1 habe ich gelöscht und durch die neue Version mit shng 10.1.8.2 ersetzt. Es gab auch bezüglich knxd ein paar kleine Probleme, die nun im neuen Image gefixt sind. Aber generell ist es nicht nötig, das ganze Image runterzuladen - es reicht ein system_update

    Leider hat sich im aktuellen Image ein kleiner Fehler eingeschlichen. Wer freeradius nutzt, muss in der Datei /etc/freeradius/3.0/radiusd.conf beim auskommentierten log_dir das "#" entfernen.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    -s ist wirkungslos, wenn shng als Dienst gestartet wurde, ja. Wenn du -d nutzen willst, beendest du den Dienst wie oben beschrieben und startest manuell mit dem von dir gelisteten Befehl, jawoll.

    Einen Kommentar schreiben:


  • ElektroRudi
    antwortet
    Zitat von Onkelandy Beitrag anzeigen
    Was passiert bei systemctl stop smarthome?
    Dann wird SH beendet.
    Also ist SH als Systemdienst eingerichtet und dieser startet selbstständig neu.
    Dann ist der Parameter -s quasi wirkungslos. Gibt es noch andere Parameter die davon betroffen sind?
    Wenn ich also SH im debug-Modus starten will, beende ich erst den Systemdienst und starte dann SH manuell mit Parameter -d.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Was passiert bei systemctl stop smarthome?

    Einen Kommentar schreiben:


  • ElektroRudi
    antwortet
    Moin,
    ist bei dieser Installation etwas eingestellt damit sich smarthome immer wieder selber startet?
    Wenn ich über den Befehl
    "python3 /usr/local/smarthome/bin/smarthome.py -s"
    SH stoppen will, kommen irgendwann die Meldungen
    "Stopping SmartHomeNG, please wait...
    Trying to terminate SmartHomeNG timed out, killing process".

    Smarthome startet aber wieder so wie ich ein restart ausgelöst hätte.
    Mach ich was falsch?

    Einen Kommentar schreiben:


  • Morg
    antwortet
    dhcp.conf, dhcpd.conf und dhcpcd.conf sind aber schon drei verschiedene Dateien.

    Und soweit ich weiß, ist die von Medicusi angegebene Syntax die der interfaces-Datei. Deine Syntax passt für die dhcpcd.conf.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Soweit ich mitbekommen haben sollten bei aktuellen System fixe IP Adressen in der Datei dhcpcd.conf definiert werden:
    Code:
    interface eth0
        static ip_address=10.0.0.150
        static routers=10.0.0.138
    Beim Image habe ich dort tatsächlich eine Fallback IP Adresse 10.0.0.22 hinterlegt. Bei mir hat die Fritzbox dem Raspi zu Beginn nämlich auch nie eine IP zugewiesen und ich hab keine Ahnung warum..

    Einen Kommentar schreiben:


  • Morg
    antwortet
    a) Sicher, dass das hier ins Thema passt?
    b) die Zeile gehört aber nicht in die dhcpd.conf...bestenfalls in die interfaces.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    ??

    Einen Kommentar schreiben:

Lädt...
X