Ankündigung

Einklappen
Keine Ankündigung bisher.

SmarthomeNG 1.8.2 Image für Raspberry Pi

Einklappen
Das ist ein wichtiges Thema.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • aschwith
    antwortet
    Das ist es leider nicht. Wie oben geschrieben habe ich in der dhcpcd.conf die richtige statische IP konfiguriert. Das funktioniert auch gut bis man einmalig das Netzwerkkabel zieht. Wenn das Kabel wieder eingesteckt wird, bekommt er keine Lan Verbindung mehr. Es sei denn, ich mache einen reboot. Dann geht wieder alles. Funktioniert denn hotplug bei Dir? Kannst du das mal testen ?

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Schau mal ob in
    /etc/dhcpcd.conf eine (falsche) fixe IP drin ist

    Einen Kommentar schreiben:


  • aschwith
    antwortet
    Mit früheren Images hatte ich auch nie Probleme

    Einen Kommentar schreiben:


  • Morg
    antwortet
    Mit anderen OS bzw. Images habe ich damit bislang keine Probleme gehabt; ich habe mehrere Raspis im dauerhaften Einsatz, und die sind alle schon zeitweilig im Betrieb ohne Kabel bzw. ohne Gegenstelle gewesen, bisher ohne Probleme.

    Das shng-Image habe ich noch nicht probiert.

    Einen Kommentar schreiben:


  • aschwith
    antwortet
    Hallo zusammen,
    ich habe auch ein Problem mit dem Image und eth0:

    Problem:
    Nach einem sauberern start bekommt der RasPi per DHCP eine IP zugewiesen. Das funktioniert. Wenn jetzt kurzzeitig das Netzerk nicht verfügbar ist , bekommt der RasPi anschließend keine Verbindung mehr.

    Nachstellen:
    Nachstellen kann man das sehr gut, in dem man für 20 Sekunden das Ethernetkabel zieht und anschließend wieder verbindet.

    a) Ich habe den RasPi testweise auf statische IP in der dhcpcd.conf umgestellt. Auch hier ist das Ethernet nicht hotplug fähig.

    b) Der Raspberry selber läuft noch, sieht man auch in den SmarthomeNG logs. Allerdings halt ohne Netwerkverbingung.

    Kennt einer von Euch das Problem, bzw. kann es bei sich nachstellen?

    Danke und besten Gruß
    Alex

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Ich meinte das dhcp Problem

    Einen Kommentar schreiben:


  • whisperbot
    antwortet
    Zitat von Onkelandy Beitrag anzeigen
    Hat sonst noch wer das Problem?
    alles gut läuft stabil Raspi 1 B+ und Raspi 3 B

    Gruß
    whisper

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Häng doch bitte mal den Rechner an nen Monitor und poste den relevanten Teil des Logs.
    Notfalls muss ich drum bitten, bei dir eine fixe IP einzustellen, zB indem du die /etc/dhcpcd.conf Datei entsprechend adaptierst.

    Hat sonst noch wer das Problem?

    Einen Kommentar schreiben:


  • Haiphong
    antwortet
    Moin Andy,

    unter dem Image 1.8.1 hat der Raspi die IP 192.168.178.28 per DHCP bekommen.

    Die SD-Karte ist eine Transcend mit 16GB

    Der Raspi ist ein 4'er mit 4GB ( hab ich mir neu geleistet )
    Dachte zuerst es liegt an dem - neuen - Raspi, daher hab ich dann ältere Versionen getestet.

    Mir ist beim 1.8.2 noch aufgefallen,
    daß die grüne LED am Raspi, am Anfang / Start kurz leuchtet und dann nicht mehr.
    ( hab ca. 30 Min. auf eine IP gewartet. eventuell nicht lange genug - keine Ahnung )

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Hm, sehr sonderbar. Ich hatte bei mir das Problem schon bei 1.8.1 mit einem frischen Raspbian OS und keine Ahnung, woran das liegt. An nem anderen Netzwerkport hatte ich keine Probleme. Die Fritzbox mag da was nicht. Sorry, aber ich weiß nicht, wo ansetzen.
    Was für ne interne IP Range hast du? Zufällig 10.0.0.x?

    Einen Kommentar schreiben:


  • Haiphong
    antwortet
    Servus Andy,

    danke für das Image

    Mit dem Image 1.8.2 stimmt etwas nicht ( bekommt keine IP, hab mit Fing und über die Fritz gesucht )

    Das Image 1.8.1 läuft normal ( IP per DHCP vorhanden. Zugriff über Putty läuft )

    Hab das Image jeweils mit Win32DiskImager auf eine 16GB SD-Karte geschoben
    Zuletzt geändert von Haiphong; 26.02.2021, 00:45.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Das Image 10.1.8.1 habe ich gelöscht und durch die neue Version mit shng 10.1.8.2 ersetzt. Es gab auch bezüglich knxd ein paar kleine Probleme, die nun im neuen Image gefixt sind. Aber generell ist es nicht nötig, das ganze Image runterzuladen - es reicht ein system_update

    Leider hat sich im aktuellen Image ein kleiner Fehler eingeschlichen. Wer freeradius nutzt, muss in der Datei /etc/freeradius/3.0/radiusd.conf beim auskommentierten log_dir das "#" entfernen.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    -s ist wirkungslos, wenn shng als Dienst gestartet wurde, ja. Wenn du -d nutzen willst, beendest du den Dienst wie oben beschrieben und startest manuell mit dem von dir gelisteten Befehl, jawoll.

    Einen Kommentar schreiben:


  • ElektroRudi
    antwortet
    Zitat von Onkelandy Beitrag anzeigen
    Was passiert bei systemctl stop smarthome?
    Dann wird SH beendet.
    Also ist SH als Systemdienst eingerichtet und dieser startet selbstständig neu.
    Dann ist der Parameter -s quasi wirkungslos. Gibt es noch andere Parameter die davon betroffen sind?
    Wenn ich also SH im debug-Modus starten will, beende ich erst den Systemdienst und starte dann SH manuell mit Parameter -d.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Was passiert bei systemctl stop smarthome?

    Einen Kommentar schreiben:

Lädt...
X