Ankündigung

Einklappen
Keine Ankündigung bisher.

Verständnisfrage für den Beginner

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Verständnisfrage für den Beginner

    Hallo zusammen,

    ich bitte um Entschuldigung - ich bin ein blutiger Anfänger und versuche ein einfachen Tastendruck als Trigger für eine Logik zu kreieren.

    Dabei habe ich vermutlich ein grosses Verständnisproblem.

    Nach langem lesen bin ich auf den hervorragenden Post von mumpf gestossen.
    https://knx-user-forum.de/forum/supportforen/smarthome-py/1320287-verständnisfrage-knx-und-smarthomeng?p=1320365#post1320365

    Hier beschreibt mumpf detailiert die unterschiede der verschieden knx_*-Attribute.

    knx_listen: Das Item bekommt den Wert der GA (entspricht dem S-Flag), wobei bei shNG knx_listen auch auf replies reagiert (was dem A-Flag entspricht)
    knx_send: Der Wert des Items wird auf die GA geschrieben (entspicht dem Ü-Flag)
    Nachdem ich das gelesen hatte - vermutete ich das ich mit dem unteren Item ein True erhalte sobald ich auf der Gruppenadresse (6/1/0) den Schalter betätige und eine 1 auslöse.

    Nach betätigen des Tasters (aber auch über knxtool) sehe ich zwar das umschalten im Busmonitor aber ich sehe nicht das sich der Wert des items audio.eg.esszimmer.status von False zu True ändert.


    dies ist das item:

    Code:
    audio:
    eg:
    esszimmer:
    status:
    type: bool
    rus_path: 1.2.status
    knx_dpt: 1
    knx_send: 6/1/0
    knx_listen: 6/1/0
    Worin liegt mein Verständnisproblem - wie kann ich diesen Werteübertrag von der Gruppenadresse auf ein Item forcieren?

    Seit Monaten nutze ich nun schon SmartHomeNg und KNX. Je tiefer man aber einsteigt, je weniger ist mir klar, ob ich alles verstanden habe. ;-) Mir geht es um die item-Funktionen des KNX-plugins. Machen wir mal ein Beispiel: Ich habe einen Schaltaktor, der über eine GA schaltet und über eine andere GA den Status schalten

    #2
    Siehst du denn, im backend , das die items auch richtig geladen wurden?

    Kommentar


      #3
      Bonze Hallo

      ja die items sehe ich richtig geladen im backend.

      auch die Logik funktioniert wenn ich das item im backend auf True stelle. Nur kriege ich die gruppenadresse vom Knx nicht auf das item übertragen .

      ich dachte dies wird durch knx_Listen ausgelöst

      Kommentar


        #4
        Hallo,

        hier mal ein Beispiel für die KNX-Integration:
        Code:
        steckdosen:
            waschkueche:
                waschmaschine:
                    onoff:
                        type: bool
                        visu_acl: rw
                        knx_dpt: 1
                        knx_send: 2/3/8
                        knx_cache: 2/3/9
        Das Attribut knx_send wird für die schaltende GA verwendet, also wenn shNG die Funktion eines KNX-Tasters übernehmen soll. Wie der Name sagt, wird darauf gesendet, also shNG bzw. der KNX Plugin schreibt auf diese GA.

        Das Attribut knx_listen hört auf den Bus und schreibt die Nachrichten der angegebenen GA in das Item. Ich verwende hier immer die GA für die Statusrückmeldung des Aktors. knx_cache beinhaltet knx_listen, versucht aber beim Start von shNG den letzten Wert aus dem Cache zu lesen und somit das Item entsprechend zu setzen.

        Versuche es mal damit.

        brunosa3

        Bitte versuche beim Eintrag von Code hier im Thread die Formatierung richtig darzustellen. siehe hier

        Kommentar


          #5
          kann es vielleicht sein, das dein aktor verschiedene Gas nutzt? 1 zum setzen und 1 für den Status?

          Kommentar


            #6
            Zitat von Bonze Beitrag anzeigen
            kann es vielleicht sein, das dein aktor verschiedene Gas nutzt? 1 zum setzen und 1 für den Status?
            Ist das nicht immer so?
            Manchmal muss man in der ETS nur die Rückmeldung noch aktivieren.

            Kommentar


              #7
              Hi,

              Zitat von brunosa3 Beitrag anzeigen
              auch die Logik funktioniert wenn ich das item im backend auf True stelle. Nur kriege ich die gruppenadresse vom Knx nicht auf das item übertragen
              wenn Du das Item im Backend auf true setzt, wird denn dann auch ein Telegramm auf den KNX-Bus geschickt (sieht man im Gruppenmonitor)?

              Ich würde derzeit vermuten, dass Deine Kommunikation zwischen shNG und knxd nicht funktioniert, dann kann auch nichts vom KNX-Bus in shNG landen (und umgekehrt). Oder anders gefragt: Hast Du schon irgendein anderes Item, dass erfolgreich mit dem KNX-Bus kommunizieren kann?

              Gruß, Waldemar

              Kommentar


                #8
                Hallo zusammen,

                vielen Dank für Euer Feedback.

                mumpf tatsächlich wird beim setzten auf True im backend für das item keine knx_send: auf die angegebene Adresse ausgelöst - somit liegt es wohl doch an der Verbindung von knxd.

                Im log file finde ich jedoch keinen Error bezüglich der Verbindung. Jedenfalls kann ich knxtool ohne Probleme verwenden (sehe die Schaltungen auf dem Bus).

                2021-07-18 14:16:22 DEBUG lib.network Connecting to 127.0.0.1 using IPv4 127.0.0.1 on TCP port 6720 with autoreconnect
                2021-07-18 14:16:22 WARNING lib.smarthome.main -------------------- SmartHomeNG initialization finished --------------------
                2021-07-18 14:16:22 INFO lib.network Connected to 127.0.0.1 on TCP port 6720
                2021-07-18 14:16:22 WARNING plugins.smartvisu Not generating pages because smartVISU v3.0.1 in directory /var/www/html/smartvisu is not yet configured
                2021-07-18 14:16:22 WARNING plugins.smartvisu Not generating item-masterfile because smartVISU v3.0.1 in directory /var/www/html/smartvisu is not yet configured

                Oder anders gefragt: Hast Du schon irgendein anderes Item, dass erfolgreich mit dem KNX-Bus kommunizieren kann?
                Nein, ich bin noch am Anfang - lerne gerade an mit shNG zu laufen.



                Manchmal muss man in der ETS nur die Rückmeldung noch aktivieren.
                Bezüglich meines knx_listen Problem hatte ich auch stark an Sisamiwe hypothese geglaubt, dass ich einfach den L flag in der ETS setzen muss. Aber nun wo der knx_send auch nicht funktioniert spricht es whol eher zu einem Verbindungsproblem

                Habe es aber dennoch ohne Erfolg kurz getestet

                Ich versuche hier über meien Glastaster die Musik auf meinem Russound auszulösen. Hierfür habe ich nun in einer Gruppenadresse die Schalter mit dem L-flag gesetzt (mein Verständnis nach sollte ich damit die Schaltung lesen können) und den Status für den Taster auf S gesetzt, sodass ich dem Taster sagen könnte, dass die Musik bereits läuft, wenn ich SIe zB über die Visu einschalte.

                Habe ich auch hier einen Denk/Verständnis-Problem?

                audio_gruppenadresse.PNG

                Kommentar


                  #9
                  brunosa3

                  Also knxd funktioniert, da die mit knxtool auf den Bus senden kannst, richtig?

                  Dann könnte es noch an der knx-Plugin Konfig liegen. Stelle doch bitte mal die Konfiguration Deines knx-Plugins hier ein.
                  Diese findest Du im AdminModul im Menu Plugins / Konfigurationen oder direkt im Ordner /etc in der Datei plugin.yaml

                  Damit können wir mal die Verbindung von shNG zu knxd prüfen.

                  Zudem kannst Du auch mal ins WebIF des knx-Plugins schauen. AdminIF --> Plugins --> Liste der Plugins --> Auf das Symbol in der Spalte WebIF

                  Kommentar


                    #10
                    Sisamiwe vielen Dank für den Tipp (Kannte das WebIf noch nicht ).

                    Kann es leider nicht öffnen spricht wahrscheinlich wieder dafür, dass ich keine Verbindung herstellen kann.

                    Also knxd funktioniert, da die mit knxtool auf den Bus senden kannst, richtig?
                    Ja, knxtool funktioniert - ich sehe es auf dem Bus

                    knx config im plugin.yaml

                    knx_config.PNG

                    Die Plugin Liste:


                    plugin_liste.PNG

                    Das KNX WebIF:

                    knx_webif.PNG




                    Kommentar


                      #11
                      Noch zum Hintergrund:

                      shNG kommuniziert mit dem knxd, der wiederum mit dem KNX-Bus. knxtool gehört zum knxd und zeigt Dir nur, dass der knxd mit dem Bus kommunizieren kann. Da das klappt, sitzt das Problem bei der shNG <-> knxd Kommunikation.

                      Mach es wie von Sisamiwe vorgeschlagen, dann findet man das Problem sicherlich bald.

                      Gruß, Waldemar

                      Kommentar


                        #12
                        Vielen Dank mumpf - ja ich spüre das wir auf dem richtigen Weg sind es zum Laufen zu kriegen

                        Kommentar


                          #13
                          brunosa3

                          Hast Du mehrere Anbindungen an den KNX-Bus da Du "instance: merry" konfiguriert hast.
                          Wenn du eine oder mehrere Instanzen eines Plugin konfiguriert hast, musst Du bei der Item Attributen die Instanz mit angeben.

                          Ich gehe aber davon aus, dass Du nur eine Verbindung zum KNX hast, daher nimm mal in der Plugin Konfig die Instanz weg und starte neu.

                          Zur weiteren Eingrenzung kannst Du auch mal das Logging "hochdrehen". Nach dem Du noch am Anfang stehst (wie du schriebst), gehe ich davon aus, dass Du noch nicht arg viele Plugins nutzt. Die einfachste Möglichkeit, dass Loggin "hochzudrehen", also mehr Informationen zu bekommen, ist:
                          AdminIF --> Logs --> Konfiguration

                          Im Editor im Abschnitt "loggers" "plugins"

                          Code:
                              plugins:
                                  # Default logger for SmartHomeNG plugins
                                  handlers: [shng_details_file]
                                  level: WARNING
                          den Level von "WARNING" auf "DEBUG" setzen.

                          Rechts oben sichern clicken und neu starten. Nun schreiben alle Plugins im Log-Level DEBUG in die Logfiles. Dann kann man besser sehen, was das knx-Plugin macht.

                          Probier mal.

                          Kommentar


                            #14
                            Sisamiwe

                            Ohhhhhhh ..... das war es die Instanz war das Problem - müsste ich in jedem Item dann die Instanz setzen?

                            Momentan habe ich nur eine Anbindung an den Bus - Plane aber in Zukunft noch eine zweite, deshalb habe ich hier eine Instanz gesetzt. Wenn es so ist würde ich den Plan über den Haufen werfen und bei einer Anbindung bleiben


                            Man bin ich froh das es jetzt geht - hocke jetzt schon zwei Tage dran Letzlich bin ich aber froh, dass es so gelaufen ist, da ich extrem viel von Euch gelernt habe!

                            Danke Euch mumpf Bonze @Sisamiwe

                            Kommentar


                              #15
                              Zitat von brunosa3 Beitrag anzeigen
                              Momentan habe ich nur eine Anbindung an den Bus - Plane aber in Zukunft noch eine zweite, deshalb habe ich hier eine Instanz gesetzt. Wenn es so ist würde ich den Plan über den Haufen werfen und bei einer Anbindung bleiben
                              Ja, du musst dann bei jedem Itemattribut angeben, welche Instanz des Plugins genutzt werden soll.
                              Ein Beispiel: Ich habe 2 Fritzboxen und habe diese eingebunden. Nun sind die Befehle ja für beide Fritzboxen mit dem AVM Plugin gleich. Woher soll shNG nun wissen, welches Gerät du ansprechen möchtest. Ähnlich wäre es ja auch bei deinem KNX. Woher soll shNG wissen, welche Busanbindung genutzt werden soll?

                              Zitat von brunosa3 Beitrag anzeigen
                              Danke Euch
                              Gern!

                              Viel Spaß nun.

                              Kommentar

                              Lädt...
                              X