Ankündigung

Einklappen
Keine Ankündigung bisher.

Item wird nicht auf den KNX-Bus gesendet

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    #16
    Ich habe neuerdings einen Timberwolf-Server, der auch eine Schnittstelle zum Bus bietet. Vielleicht kann ich die alternativ verwenden, um zu testen, ob meine bisher verwendete IP-Schnittstelle das Problem ist.

    Leider funktioniert es nicht, in der knxd.conf einfach die IP-Adresse auf die des Timberwolf-Servers zu ändern. Wie gehe ich das denn richtig an? Derzeit habe ich eine Weinzierl 731 und meine knx.conf sieht so aus:

    Code:
    # configuration for knxd.service
    #KNXD_OPTS="-e 0.0.1 -E 0.0.2:8 -u /tmp/eib -b ip:"
    KNXD_OPTS="-e 0.0.1 -E 0.0.2:8 -c -b ipt:192.168.1.101"
    
    # configuration for knxd.service using new configuration format in /etc/knxd.ini
    # use only this line if you used knxd_args to convert your old startup options
    # KNXD_OPTS=/etc/knxd.ini
    
    # The default options are "-u /tmp/eib -b ip:"
    # which tell knxd to route between all of
    #  /tmp/eib (legacy socket (-u))
    #  multicast client (-b ip:).
    # knxd's own bus address is 0.0.1; it will assign 0.0.2…0.0.9 to clients.
    # The knxd.socket file also tells knxd to listen to
    #  /run/eib (socket activation via systemd)
    #  TCP port 6720 (socket activation via systemd)
    # You *need* the -e option. Clients cannot connect without "-E".
    
    # You can read knxd's logs with
    # $ journalctl -u knxd --since "10 min ago"
    # (or whatever). See the manpage for details.
    # You need to be a member of the "adm" group.
    # Add "-f9 -t1023" to the beginning of the command line for extensive logging.
    
    # *** DO NOT use "-u" / "-u /run/knx" or "-i" / "-i 6720" here.
    # Systemd already does that on behalf of knxd, via 'knx.socket'.
    
    # *** DO NOT use both "-RS" and "-b ip:" (unless you specify a
    # different multicast address on one of them). You'd create a loop.
    
    # If you have KNX hardware on a serial port or USB, add the appropriate
    # "-b TYPE:…" option. In this case, you probably want to set up a multicast
    # server, not a client (i.e. use "-D -T -R -S", not "-b ip:").
    # DO NOT use both.
    #
    # If your KNX hardware is a KNX/IP gateway that doesn't do multicast,
    # use "-b ipt:192.168.1.2" (or its DNS name) to talk to it.
    #
    # KNX MUST NOT have more than one path between any two devices. Thus,
    # you need to make sure that the KNX/IP gateway does not route multicast
    # before you use both "-S" and "-b ipt:".
    
    # The default bus address of knxd is 0.0.1. If that's in use in your KNX
    # network (or if you run more than one knxd on your network), set a
    # different address, for example "-e 7.0.99".
    
    # You should have a block of free addresses on your KNX bus which knxd can
    # assign to clients: "-E 7.0.100:28" will use 7.0.100 through 7.0.127.
    # If no such range is given, or if it's full, knxd uses its own address.
    # That mostly works, but separate addresses are much better.
    
    # Run `knxd --help` to get a complete list of available options and drivers.
    
    ## DO NOT use the following options:
    ## -i           -- /lib/systemd/system/knxd.socket does this for us
    ## -u /run/knx  -- likewise
    ## -d           -- /lib/systemd/system/knxd.service expects knxd to run in the foreground
    ## -p PIDFILE   -- please use systemctl to control knxd
    
    ###############################################################################
    # This file is ignored when NOT using systemd: edit /etc/default/knxd instead #
    ###############################################################################
    Cheers
    Art Mooney

    Kommentar


      #17
      Eben habe ich noch etwas über die Konfiguration von knxd nachgelesen: hier. Dort steht, man soll es mit einem "–send-delay=30" hinter dem "-c" in der /etc/knxd.conf versuchen, um Telegrammverlust zu vermeiden! Es wäre zu schön, wenn das die Lösung meines Problems wäre. Ich habe das jetzt eingetragen und warte ab.
      Cheers
      Art Mooney

      Kommentar


        #18
        Schade, dass mit dem "-send-delay=30" geht auch nicht. Ich bekomme dann:

        Code:
        smarthome@smarthomeNG:~$ sudo systemctl status knxd.service
        ● knxd.service - KNX Daemon
        Loaded: loaded (/lib/systemd/system/knxd.service; enabled; vendor preset: ena
        Active: activating (auto-restart) (Result: exit-code) since Sun 2022-01-09 21
        Process: 761 ExecStart=/usr/bin/knxd $KNXD_OPTS (code=exited, status=2)
        Main PID: 761 (code=exited, status=2)
        Cheers
        Art Mooney

        Kommentar


          #19
          Zusätzlich habe ich eben folgendes in meinem Log gelesen:

          Code:
          2022-01-09  21:19:03 WARNING  lib.network         No connection to 127.0.0.1, cannot send data bytearray(b"\x00\x06\x00\'\x19\xdd\x00\x81"). Error: [Errno 32] Broken pipe
          2022-01-09  21:19:04 WARNING  lib.network         No connection to 127.0.0.1, cannot send data bytearray(b"\x00\x06\x00\'\x11\xdc\x00\x81"). Error: [Errno 32] Broken pipe
          Was kann denn das wieder sein? Diese Meldung hatte ich vorher nicht.
          Cheers
          Art Mooney

          Kommentar


            #20
            Sieh Dir die Doku vom knxd an. Die Option send-delay wird mit 2 Minuszeichen geschrieben.
            Code:
            -–send-delay=30
            die Meldungen von lib.network kommen daher, dass der knxd nicht mehr läuft.

            Gruß
            Wolfram

            Kommentar


              #21
              Danke für den Hinweis. Das hat die Fehlermeldung beseitigt.
              Cheers
              Art Mooney

              Kommentar


                #22
                Ich bin jetzt verhalten optimistisch, dass das Problem gelöst ist. Seit einer Woche sind keine Fehler mehr aufgefallen, in den Logs ist auch nichts Verdächtiges. Es scheint, als habe das alles an dem "--send-delay=30" gelegen.
                Cheers
                Art Mooney

                Kommentar

                Lädt...
                X