Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

8383 bereits belegt

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    8383 bereits belegt

    ​​​​​​Ich hatte unter der letzten SmarthomeNG 1.9..2 ein Plugin laufen an dem ich noch einige Verbesserungen vornehmen wollte. Die neue Smarthome 1.9.3 erschien gerade zum richtigen Zeitpunkt. Also frisch aufgesetzt mit dem IMG auf einem Raspberry.
    Jetzt komme ich leider durch den Dauerfehler 8383 bereits belegt nicht meht weiter. Ich habe hier einmal unter dem Punkt Problem1 die modul.yaml angehängt. Steckt hier noch der Fehler?


    Außerdem habe ich immer eine Unzahl von laufenden smarthomes nach dem Neustart mit /usr/local/smarthome/bin/smarthome.py -r.
    Unter Problem 2 sind meine Versuche dargestellt!

    Ich sitze zur Zeit auf dem Schlauch und finde das Problem und die Lösung nicht!
    Ich bitte um Unterstützung!

    Meine IP des Raspi ist 192.xxx.xxx.54 , falls ich in der yaml die IP falsch interpretiert haben sollte.

    [smarthome@SmartHomeNG93 ~]$ python -V
    Python 3.9.2

    Problem 1
    Die Einrückunge passen, das Testfile hat sie leiden verschluckt! Sorry

    #Modul.yaml
    %YAML 1.1
    ---
    # etc/module.yaml
    # support for web server
    http:
    module_name: http
    starturl: admin
    # support for graphical admin interface
    user: admin
    port: 8383
    tls_port: 8385
    use_tls: false
    servicesport: 8384
    showpluginlist: true
    threads: 4
    ip: 0.0.0.0
    showservicelist: true
    showtraceback: true
    hashed_password: 46460de0afbb4f85bdfe1d00cfef64fd6a544a9a5c6270cb0b e830cc151685d3d274d75c778a532f2cfc35729d4c551e21f7 f580d09b3a998b215fe180a4eb18

    admin:
    module_name: admin
    websocket_host: 127.0.0.1
    click_dropdown_header: true
    login_expiration: 168
    login_autorenew: true
    pypi_timeout: 5
    itemtree_fullpath: true
    itemtree_searchstart: 2
    websocket_port: 2424
    log_chunksize: 1000

    websocket:
    module_name: websocket
    #port: 2424
    #tls_port: 2425
    #tls_key: myprivate.key
    #tls_cert: myprivate.pem
    #use_tls: true
    #enable, if mqtt protocol is going to be used

    mqtt:
    module_name: mqtt
    ip: 127.0.0.1
    port: 2424
    tls_port: 2425




    Problem 2
    start
    #hier sind immer viele smarthomes unterwegs

    [smarthome@SmartHomeNG93 ~]$ /usr/local/smarthome/bin/smarthome.py -r
    Stopping SmartHomeNG, please wait...
    Daemon PID 43881
    [smarthome@SmartHomeNG93 ~]$ ps -ef|grep smarthome|grep bin
    smartho+ 36446 1 0 12:45 ? 00:02:08 /usr/local/bin/python3 /usr/local/smarthome/bin/smarthome.py -r
    smartho+ 37368 1 0 13:11 ? 00:00:57 python3 /usr/local/smarthome/bin/smarthome.py -r
    smartho+ 38575 1 0 13:48 ? 00:00:49 python3 /usr/local/smarthome/bin/smarthome.py -r
    smartho+ 43695 1 15 16:39 ? 00:00:12 python3 /usr/local/smarthome/bin/smarthome.py -r
    smartho+ 43881 1 81 16:40 ? 00:00:11 python3 /usr/local/smarthome/bin/smarthome.py -r
    smartho+ 43907 1 99 16:40 ? 00:00:10 /usr/bin/python /usr/local/smarthome/bin/smarthome.py

    #alle gekillt !!
    [smarthome@SmartHomeNG93 ~]$ kill -9 37368
    [smarthome@SmartHomeNG93 ~]$ kill -9 38575
    [smarthome@SmartHomeNG93 ~]$ kill -9 43695
    [smarthome@SmartHomeNG93 ~]$ kill -9 43881
    [smarthome@SmartHomeNG93 ~]$ kill -9 43907
    [smarthome@SmartHomeNG93 ~]$ kill -9 44105

    [smarthome@SmartHomeNG93 ~]$ ps -ef|grep smarthome|grep bin
    smartho+ 44401 1 8 16:55 ? 00:00:13 /usr/bin/python /usr/local/smarthome/bin/smarthome.py

    ###Neuer Start
    /usr/local/smarthome/bin/smarthome.py -r

    Stopping SmartHomeNG, please wait...
    Daemon PID 44577
    [smarthome@SmartHomeNG93 ~]$

    [smarthome@SmartHomeNG93 ~]$ ps -ef|grep smarthome|grep bin
    smartho+ 44577 1 7 17:01 ? 00:00:13 python3 /usr/local/smarthome/bin/smarthome.py -r
    smartho+ 44615 1 6 17:01 ? 00:00:12 /usr/bin/python /usr/local/smarthome/bin/smarthome.py
    [smarthome@SmartHomeNG93 ~]$


    17:01:18 CET NOTICE lib.smarthome smarthome __init__ ln:315 -------------------- Init SmartHomeNG v1.9.3-master (aa143b82) -------------------- ---- Main
    2022-11-24 17:01:18 CET NOTICE lib.smarthome smarthome __init__ ln:316 Running in Python interpreter 'v3.9.2 final', from directory /usr/local/smarthome ---- Main
    2022-11-24 17:01:18 CET NOTICE lib.smarthome smarthome __init__ ln:317 - on Linux-5.15.76-v8+-aarch64-with-glibc2.31 (pid=44615) ---- Main
    2022-11-24 17:01:20 CET NOTICE lib.smarthome smarthome __init__ ln:378 - Nutze Feiertage für Land 'DE', Provinz 'BY', 3 benutzerdefinierte(r) Feiertag(e) definiert ---- Main ok bis hier !!

    2022-11-24 17:01:21 CET CRITICAL modules.http __init__ __init__ ln:142 Error starting http module: port 8383 is already in use ---- Main
    2022-11-24 17:01:21 CET ERROR lib.module module _load_module ln:292 Modules: Module 'http' initialization failed, module not loaded ---- Main
    2022-11-24 17:01:21 CET WARNING lib.plugin plugin _test_duplicate_pluginconfiguration ln:330 Plugin section 'smartvisu_pages' uses same class 'SmartVisu' and instance 'default' as plugin section 'smartvisu' ---- Main ?????

    2022-11-24 17:01:21 CET ERROR modules.admin __init__ __init__ ln:93 Module 'admin': Not initializing - Module 'http' has to be loaded BEFORE this module ---- Main
    2022-11-24 17:01:21 CET ERROR lib.module module _load_module ln:292 Modules: Module 'admin' initialization failed, module not loaded ---- Main
    2022-11-24 17:01:22 CET CRITICAL lib.module module _load_module ln:238 Module 'mqtt' (modules.mqtt) exception during import of __init__.py: module 'lib' has no attribute 'X509_V_FLAG_CB_ISSUER_CHECK' ---- Main
    2022-11-24 17:01:23 CET WARNING plugins.database smartplugin init_webinterface ln:751 Module 'http' not loaded. Not initializing the web interface for the plugin ---- Main

    ​​
    Zuletzt geändert von schloessl; 24.11.2022, 17:53.

    #2
    Msinn hatte Dir hier schon einen Hinweis gegeben wie Du mit Yaml Files umgehen kannst hier im Forum. Es wäre nett wenn Du Deinen Beitrag entsprechend anpasst.

    Könnte es sein, das Du SmartHomeNG als Dienst installiert hast? Und könnte es weiterhin sein, das Du SHNG irgendwann mal als root gestartet hast?

    Bei Deinem module.yaml irritiert mich das Dein Websocket Port nicht belegt ist aber das als Port bei mqtt drin ist. Nicht das das was mit Deinem Problem zu tun hat aber ist schon strange

    Kommentar


      #3
      Danke für die ersten Hinweise!
      Ich werde den Text überarbeiten, ich hatte den Text in einem Editor zusammengetragen, leider sind die Einrückungen bei der Übernahme verschwunden.
      Den Hinweis als Root gestartet. Möglich, werde ich nachher prüfen.
      Jedoch beim Hinweis “als Dienst gestartet”, wie kann ich das prüfen und stoppen?
      Danke für Deine Hilfe!
      LG Wolfgang

      Kommentar


        #4
        Mit Linux Bordmitteln kannst Du herausfinden, welche Software / welcher Prozess einen Port nutzt. Dafür benötigst Du netstat. In neueren Debian Distributionen ist das nicht mehr enthalten. Du kannst es bei Bedarf aber mit

        Code:
        sudo apt install net-tools
        nachinstallieren.

        Dann kannst Du prüfen, welcher Prozess den Port nutzt:
        Code:
        $ sudo netstat -tulpn|grep 8383
        
        tcp        0      0 10.0.0.140:8383         0.0.0.0:*               LISTEN      17474/python3
        Die Zahl am Ende (im Beispiel 17474) ist die Prozess ID. python3 ist der Name des Binaries welches ausgeführt wird.

        Um genaueres zu erfahren, kannst Du mit
        Code:
        $ ps -ef|grep 17474
        ​
        (Die Prozess ID muss Du natürlich durch die bei Dir ermittelte ersetzen.)

        In der Ausgabe siehst Du die vollständige Kommandozeile mit der der Prozess gestartet wurde:
        Code:
        smartho+ 17474     1 16 15:22 ?        00:46:21 /home/smarthome/environments/py_38/bin/python3 /usr/local/shng_dev/bin/smarthome.py
        
        smartho+ 24413 15287  0 20:03 pts/1    00:00:00 grep 17474
        ​
        Viele Grüße
        Martin

        There is no cloud. It's only someone else's computer.

        Kommentar


          #5
          Code:
          [smarthome@SmartHomeNG93 ~]$ [smarthome@SmartHomeNG93 ~]$ sudo netstat -tulpn|grep 8383
          tcp 0 0 127.0.0.1:8383 0.0.0.0:* LISTEN 74553/python3
          
          [smarthome@SmartHomeNG93 ~]$ ps -ef|grep 74553
          smartho+ 74553 1 1 13:34 ? 00:00:23 /usr/local/bin/python3 /usr/local/smarthome/bin/smarthome.py -r
          smartho+ 75929 68736 0 13:59 pts/0 00:00:00 grep --color=auto 74553
          
          [smarthome@SmartHomeNG93 ~]$ /usr/local/smarthome/bin/smarthome.py -s
          Stopping SmartHomeNG, please wait...
          Hier kurz beendet. Sollte jetzt nicht 8383 frei sein? Wenn ich das richtig sehe, hält python3 an der 8383 fest1
          Code:
          [smarthome@SmartHomeNG93 ~]$ sudo netstat -tulpn|grep 8383
          tcp 0 0 127.0.0.1:8383 0.0.0.0:* LISTEN 74553/python3
          
          [smarthome@SmartHomeNG93 ~]$ ps -ef|grep 74553
          smartho+ 74553 1 1 13:34 ? 00:00:25 /usr/local/bin/python3 /usr/local/smarthome/bin/smarthome.py -r
          smartho+ 76158 68736 0 14:02 pts/0 00:00:00 grep --color=auto 74553
          [smarthome@SmartHomeNG93 ~]$
          
          ​

          Danke für die Hilfe! Aber es klemmt immer noch!

          LG Wolfgang​

          Hier noch einmal der aktuelle Stand der modul.yaml

          Code:
          %YAML 1.1
          ---
          # etc/module.yaml
          # support for web server
          http:
              module_name: http
              starturl: admin
          # support for graphical admin interface
              user: admin
              port: 8383
              tls_port: 8385
              use_tls: false
              servicesport: 8384
              showpluginlist: true
              threads: 4
              ip: 127.0.0.1
              showservicelist: true
              showtraceback: false
              hashed_password: 46460de0afbb4f85bdfe1d00cfef64fd6a544a9a5c6270cb0be830cc151685d3d274d75c778a532f2cfc35729d4c551e21f7f580d09b3a998b215fe180a4eb18
              service_user: ' '
          
          admin:
              module_name: admin
              websocket_host: 127.0.0.1
              click_dropdown_header: true
              login_expiration: 168
              login_autorenew: true
              pypi_timeout: 5
              itemtree_fullpath: true
              itemtree_searchstart: 2
              websocket_port: 2424
              log_chunksize: 1000
          
          websocket:
              module_name: websocket
              #port: 2424
              #tls_port: 2425
              #tls_key: myprivate.key
              #tls_cert: myprivate.pem
              #use_tls: true
          #enable, if mqtt protocol is going to be used
              ip: 127.0.0.1
          
          mqtt:
              module_name: mqtt
              ip: 127.0.0.1
              port: 2424
              tls_port: 2425
          Zuletzt geändert von schloessl; 25.11.2022, 14:51.

          Kommentar


            #6
            Zitat von schloessl Beitrag anzeigen
            ier kurz beendet. Sollte jetzt nicht 8383 frei sein?
            Nein, da Du SmartHomeNG nicht beendest, sondern neu starten willst. Allerdings sollte nach einem Neustart eine andere Prozess ID auftauchen.

            Da Du nach dem Neustart die selbe Prozess ID hast, ist der ursprüngliche Prozess nicht beendet worden (und beim Restart dürfte vermutlich sogar noch eine SmartHomeNG Version in "Wartestellung" laufen")

            Beende erstmal alle evtl. störenden Prozesse und schau dann weiter.

            UND: Formatiere bitte Deine Konfigurationsdaten in den Posts richtig. Du bist bereits 2 mal darauf hingewiesen worden (auch mit Link wo steht wie das geht)!
            Viele Grüße
            Martin

            There is no cloud. It's only someone else's computer.

            Kommentar

            Lädt...
            X