Ankündigung

Einklappen

Hinweis

Die Forenregeln wurden überarbeitet (Stand 7.11.22). Sie sind ab sofort verbindlich. Wir bitten um Beachtung.
Mehr anzeigen
Weniger anzeigen

- √ - could not connect to SM.py

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Brick
    antwortet
    so.. Fehler gefunden.. !!

    ja was soll ich sagen.. war wohl ein kleiner Tippfehler !

    der groupwrite sollte eigentlich groupswrite heißen.. dann
    gehts auch aus der Konsole !!

    (über die Visu konnt ich noch nichts schalten, da ich die
    noch nicht eingerichtet hab.. damit befass ich mich jetzt
    im laufe der nächsten Woche).

    Danke für die Hilfe

    Gruß Martin

    Einen Kommentar schreiben:


  • Brick
    antwortet
    Guten Morgen,

    bin leider nicht mehr weiter zum testen gekommen.. zu viel anderes Zeug zu
    erledigen gewesen.. also..

    in der default/eibd steht:
    EIB_ARGS="--daemon --Server --Tunnelling --Discovery --GroupCache --listen-tcp"
    #EIB_ADDR="0.0.1"
    EIB_IF="ipt:192.168.178.25"
    EIB_UID="1000"

    (das ist die IP der KNX Schnittstelle, die vom EIBMarkt..(N401))...

    wenn ich :
    tail -f /usr/local/smarthome/var/log/smarthome.log
    ausführe kommt:
    root@smarthome:~# tail -f /usr/local/smarthome/var/log/smarthome.log
    1970-01-01 01:00:35 SmartHome.py INFO Init Scheduler
    1970-01-01 01:00:35 SmartHome.py INFO Init Plugins
    1970-01-01 01:00:35 SmartHome.py ERROR Onewire: could not connect to 127.0.0.1:4304: [Errno 111] Connection refused
    1970-01-01 01:00:37 SmartHome.py INFO Init Items
    1970-01-01 01:00:37 SmartHome.py INFO Start Plugins
    1970-01-01 01:00:37 SmartHome.py INFO Start Logics
    1970-01-01 01:00:37 SmartHome.py WARNING hello: Could not access logic file (hello_world.py) => ignoring.
    1970-01-01 01:00:37 sh.con INFO KNX: connected to 127.0.0.1:6720
    2013-04-14 09:43:03 SmartHome.py INFO KNX: connection to 127.0.0.1:6720 closed
    2013-04-14 09:43:09 sh.con INFO KNX: connected to 127.0.0.1:6720


    hab jetzt eben mal beim EibPC die Schnittstelle deaktiviert.. ETS
    ist eh aus... dann bei der Schnittstelle das Netzwerkkabel gezogen
    und wieder eingesteckt und den EIBD neu gestartet.. leider immer
    noch ohne Erfolg..

    ein "groupwrite ip:localhost 0/0/7 1" löst nichts aus..

    (Beleuchtung.Kellergeschoss.0/0/7 Licht Hobby mitte EIS 1 'Switching' (1 Bit) Low 36589)


    Gruß Martin

    Einen Kommentar schreiben:


  • callidomus
    antwortet
    Hallo,

    die Meldung mit dem Protocol missmatch ist ein known Bug der inzwischen gefixed wurde. Ist nicht so tragisch.

    Über welche Schnittstelle soll sich denn Dein eibd mit dem KNX-Bus verbinden? Und wie sieht Deine Konfig unter /etc/default/eibd aus?

    Bis bald

    Marcus

    Einen Kommentar schreiben:


  • Dragonos2000
    antwortet
    Wo kommt diese Meldung?
    Startet denn der eibd? Welche Schnittstelle zum KNX hast Du/nutzt Du?

    Gruss
    Jochen.

    Einen Kommentar schreiben:


  • Brick
    antwortet
    jetzt kommt als "Fehlermeldung:"

    Protocol mismatch
    driver is: v2
    smarthome.py is: v1

    immerhin is es jetzt nur ne Info.. keine Fehlermeldung mehr !!

    EDIT: Irgendwie bekomm ich auch keine Verbindung zum Bus..
    hab mal den Eibpc deaktiviert.. trotzdem kann ich keine Befehle an den Bus schicken..
    groupwrite ip:localhost 0/0/7 1 wurden zwar mit "sending..." beantwortet.. aber
    geschaltet wurde nicht..

    Einen Kommentar schreiben:


  • Brick
    antwortet
    ich spiel jetzt mal das Image neu auf die Karte !!

    wer weiß was es da hat.. ich geb bescheid, wenn
    ich soweit bin !!

    Gruß Martin

    Einen Kommentar schreiben:


  • Brick
    antwortet
    wie gewünscht:

    root@smarthome:~# /etc/init.d/smarthome.py stop
    root@smarthome:~# /usr/local/smarthome/bin/smarthome.py -n
    2013-04-12 17:17:03,849 SmartHome.py INFO Init SmartHome.py v0.8-101-g4c45ddd -- smarthome.py:__init__:192
    2013-04-12 17:17:03,856 SmartHome.py INFO Init Scheduler -- scheduler.py:__init__:53
    2013-04-12 17:17:03,862 SmartHome.py INFO Init Plugins -- smarthome.py:__init__:207
    2013-04-12 17:17:03,875 Scheduler DEBUG creating 5 workers -- scheduler.py:run:59
    2013-04-12 17:17:03,884 SmartHome.py DEBUG Plugin: knx -- plugin.py:__init__:42
    2013-04-12 17:17:03,934 SmartHome.py DEBUG Plugin: ow -- plugin.py:__init__:42
    2013-04-12 17:17:03,956 SmartHome.py ERROR Onewire: could not connect to 127.0.0.1:4304: [Errno 111] Verbindungsaufbau abgelehnt -- __init__.py:connect:62
    2013-04-12 17:17:03,963 SmartHome.py DEBUG Plugin: cli -- plugin.py:__init__:42
    2013-04-12 17:17:03,977 SmartHome.py DEBUG Plugin: visu -- plugin.py:__init__:42
    2013-04-12 17:17:04,082 SmartHome.py DEBUG Plugin: rrd -- plugin.py:__init__:42
    2013-04-12 17:17:04,394 SmartHome.py INFO Init Items -- smarthome.py:__init__:209
    2013-04-12 17:17:04,510 SmartHome.py DEBUG knx: second.sleeping.light.level listen on 3/2/14 -- __init__.pyarse_item:210
    2013-04-12 17:17:04,514 SmartHome.py DEBUG knx: Light listen on 0/0/8 -- __init__.pyarse_item:210
    2013-04-12 17:17:04,790 SmartHome.py INFO Start Plugins -- plugin.py:start:63
    2013-04-12 17:17:04,802 ow DEBUG 1w-disc next time: 2013-04-12 17:17:04+02:00 -- scheduler.py:_next_time:238
    2013-04-12 17:17:04,818 SmartHome.py INFO Start Logics -- logic.py:__init__:32
    2013-04-12 17:17:04,822 SmartHome.py DEBUG reading logics from /usr/local/smarthome/etc/logic.conf -- logic.py:__init__:38
    2013-04-12 17:17:04,837 rrd DEBUG rrd next time: 2013-04-12 17:18:44+02:00 -- scheduler.py:_next_time:238
    2013-04-12 17:17:04,828 sh.con INFO KNX: connected to 127.0.0.1:6720 -- my_asynchat.py:connect:69
    2013-04-12 17:17:04,845 SmartHome.py DEBUG Logic: hello -- logic.py:__init__:45
    2013-04-12 17:17:04,864 SmartHome.py WARNING hello: Could not access logic file (hello_world.py) => ignoring. -- logic.py:generate_bytecode:106
    2013-04-12 17:17:05,156 sh.gc DEBUG Garbage collector: collected 789 objects. -- smarthome.py:_garbage_collection:343
    2013-04-12 17:17:05,206 visu DEBUG series next time: 2013-04-12 17:17:14+02:00 -- scheduler.py:_next_time:238
    2013-04-12 17:17:05,321 Scheduler DEBUG sh.gc next time: 2013-04-13 02:04:00+02:00 -- scheduler.py:_next_time:238
    2013-04-12 17:17:05,327 Scheduler DEBUG 1w-disc next time: 2013-04-12 17:27:05+02:00 -- scheduler.py:_next_time:238
    2013-04-12 17:17:14,208 Scheduler DEBUG series next time: 2013-04-12 17:17:24+02:00 -- scheduler.py:_next_time:238
    ^C2013-04-12 17:17:20,311 SmartHome.py INFO Stop Plugins -- plugin.py:stop:68
    2013-04-12 17:17:20,315 SmartHome.py INFO KNX: connection to 127.0.0.1:6720 closed -- my_asynchat.py:handle_close:103
    2013-04-12 17:17:20,319 SmartHome.py DEBUG Closing listen -- __init__.py:stop:126
    2013-04-12 17:17:20,824 SmartHome.py INFO SmartHome.py stopped -- smarthome.py:stop:337

    Einen Kommentar schreiben:


  • callidomus
    antwortet
    Hi,

    Du hast Recht. Das sieht verdächtig aus.

    Mach bitte mal:

    Code:
    /etc/init.d/smarthome.py stop
    
    /usr/local/smarthome/bin/smarthome.py -n
    und poste den Output. (-n gibt den Debug-Output aus und bleibt im Vordergrund)
    Mit Ctrl-c kann man es stoppen.

    Danke

    Marcus

    Einen Kommentar schreiben:


  • Brick
    antwortet
    Hi,

    da steht :


    root@smarthome:~# tail -f /usr/local/smarthome/var/log/smarthome.log
    2013-04-12 16:53:51 SmartHome.py INFO Init Items
    2013-04-12 16:53:51 SmartHome.py INFO Start Plugins
    2013-04-12 16:53:51 SmartHome.py INFO Start Logics
    2013-04-12 16:53:51 SmartHome.py WARNING hello: Could not access logic file (hello_world.py) => ignoring.
    2013-04-12 16:53:51 sh.con INFO KNX: connected to 127.0.0.1:6720
    2013-04-12 16:55:17 SmartHome.py INFO second.sleeping.light = True via KNX 0.0.0
    2013-04-12 16:55:20 SmartHome.py INFO second.sleeping.light = False via KNX 0.0.0
    2013-04-12 16:57:40 SmartHome.py INFO Stop Plugins
    2013-04-12 16:57:40 SmartHome.py INFO KNX: connection to 127.0.0.1:6720 closed
    2013-04-12 16:57:41 SmartHome.py INFO SmartHome.py stopped


    das StartHome.py klingt schon mal verdächtig !!

    EDIT: hab /etc/init.d/smarthome.py start eingegeben.. leider ohne Besserung !!

    Einen Kommentar schreiben:


  • callidomus
    antwortet
    Hi Martin,

    wenn Du unser Image verwendest hast dann läuft SmartHome.py, smartVISU und der eibd.

    Auf der Seite https://github.com/mknx/smarthome/wiki/SmartHome.pi findest Du die Basis-Dokumentation für die Einstellungen und wie man die Dienste starten/stoppen kann.
    Der eibd ist z.B. so konfiguriert, das man ihn direkt mit ETS verwenden kann.
    Ok, die Schnittstelle musst Du evtl. anpassen, wenn Du nicht die busware extention verwendest.

    Wie Apollo bereits vorgeschlagen hat, hätte ich auf auf die IP-Adresse in der smartVISU-Config getippt.

    Du kannst Dir z.B. das Logfile mit
    Code:
    tail -f /usr/local/smarthome/var/log/smarthome.log
    ansehen.
    Was steht denn da?

    Bis bald

    Marcus

    Einen Kommentar schreiben:


  • Brick
    antwortet
    Zitat von Sipple Beitrag anzeigen
    Hi

    Läuft denn smarthome.py überhaupt?

    ps -ef zeigt dir die laufenden Prozesse.

    Wenn es läuft, stoppe es mal und starte neu.
    Hi, hab jetzt endlich gesehen wie man den Startet... war er wohl nicht..
    jetzt bekomm ich die Fehlermeldung nicht mehr !!

    Danke für die Tipps und Hilfe !!

    Gruß Martin

    EDIT: zu früh gefreut... des wars doch nicht.. hat nur länger gedauert, bis es wieder kam..

    Einen Kommentar schreiben:


  • Brick
    antwortet
    Sieht hier alles OK aus.. ??
    das war die letzte Datei in der ich etwas geändert (dann aber wieder zurückgestellt hab !)

    /etc/init.d/eibd

    #!/bin/sh
    ### BEGIN INIT INFO
    # Provides: eibd
    # Required-Start: $syslog $network
    # Required-Stop: $syslog $network
    # Default-Start: 2 3 4 5
    # Default-Stop: 0 1 6
    # Short-Description: Start the eib daemon.
    ### END INIT INFO

    DESC="EIB daemon"
    NAME=eibd
    EIB_ARGS="--daemon --Server --Tunnelling --Discovery --GroupCache --listen-tcp"
    EIB_ADDR="0.0.1"
    EIB_IF="tpuarts:/dev/ttyAMA0"
    EIB_UID="1000"

    PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/bin
    DAEMON=/usr/bin/$NAME
    PIDFILE=/var/run/$NAME.pid
    SCRIPTNAME=/etc/init.d/$NAME

    [ -x "$DAEMON" ] || exit 0

    [ -r /etc/default/$NAME ] && . /etc/default/$NAME

    DAEMON_ARGS="$EIB_ARGS --pid-file=$PIDFILE --eibaddr=$EIB_ADDR $EIB_IF"

    do_start()

    Ich wollte das EIBD so gestartet wird, das ich den RaspPi auch gleich als IP Gateway (zb. für die ETS) verwenden kann.

    Einen Kommentar schreiben:


  • Brick
    antwortet
    Zitat von Apollo Beitrag anzeigen
    Geb mal bei der smartVISU statt smarthome.local die IP Adresse (des Raspberry) an.
    nein.. das hat nichts gebracht..

    ich glaub der Prozess läuft nicht.. bin noch am schauen, wie ich den wieder
    starten kann !!

    Einen Kommentar schreiben:


  • Apollo
    antwortet
    Geb mal bei der smartVISU statt smarthome.local die IP Adresse (des Raspberry) an.

    Einen Kommentar schreiben:


  • Sipple
    antwortet
    Hi

    Läuft denn smarthome.py überhaupt?

    ps -ef zeigt dir die laufenden Prozesse.

    Wenn es läuft, stoppe es mal und starte neu. Das Visu-Plugin muss auch aktiv sein. Siehe hier:

    SmartHome.py - Visu Plugin


    -------------

    You could run SmartHome.py (/usr/local/smarthome/bin/smarthome.py) with different arguments.
    • --start or 'None'
    • --stop
    • --debug or -d: set the log level to debug
    • --no-daemon or -n: run as foreground process, setting the loglevel to debug
    • --help or -h: to show the options

    Einen Kommentar schreiben:

Lädt...
X