Ankündigung

Einklappen
Keine Ankündigung bisher.

- √ - Error bei Verbindung smartvisu zum smarthome.py

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    - √ - Error bei Verbindung smartvisu zum smarthome.py

    Ok, wie gewünscht noch einmal das ganze in einem neuen Thread.

    Die Verbindung smartvisu <-> smarthome.py kann nicht hergestellt werden und führt zu einem Error in der Smartvisu "Could not connect to smarthome.py server!".

    Konfiguration:
    Wie im Thread https://knx-user-forum.de/smarthome-...rtem-eibd.html beschrieben, läuft bei mir der EIBD auf dem Wiregate im Heimnetzwerk. Das Raspberry steht im Netzwerk meiner Zweitwohnung und stellt eine OpenVPN Verbindung (routing) zum Wiregate her. Eine kleine Skizze hab ich im Anhang hinzugefügt.

    Der EIBD funktioniert meines Erachtens problemlos, groupswrite auf der Konsole schaltet zu Hause das Licht ein und aus, wie gewünscht.

    Ich komm aber einfach nicht dahinter warum die smartvisu nicht mit smarthome reden möchte. Ich hab schon versucht in der smartVisu Config die URL smarthome.local durch localhost und die IP des raspberrys zu ersetzen. Das klappt leider nicht.

    Und ich bin mir nicht sicher, ob SH richtig läuft. Die LOG liefert mir keine eindeutigen Fehler, insofern sollte hier ja alles ok sein. Allerdings werden die HTML seiten in /var/www/smarthome im Browser nicht korrekt angezeigt.

    Browser: Chrome 26.0.1410.64
    Debug+Conf: https://knx-user-forum.de/313717-post9.html
    Angehängte Dateien

    #2
    Hallo,

    den eibd und das Problem mit der Darstellung der Seiten in /var/www/smarthome können wir an dieser Stelle erst einmal ausblenden, das hat nichts mit Deinem eigentlichen Problem zu tun.

    In der smartVISU Config sollte hier auf jeden Fall die IP des Raspberry stehen.

    In welchem Netz steckt denn der Browser-Client?
    Kannst Du Dich per telnet von Deinem Browser-Client mit den Pi verbinden?
    Code:
    telnet PI-IP 2424
    Kommt eine Verbindung zustande?

    Gibt es evtl. Filterregeln die diese Verbindung blockieren?

    Bis bald

    Marcus

    P.S. für später: Du könntest in der plugin.conf bei dem KNX Plugin auch einfach host = 192.168.2.100 eintragen. Damit würdest Du den eibd auf dem Pi übergehen.

    Kommentar


      #3
      ok, das klappt gleich mal nicht.

      Ein "netstat -a | grep 2424" liefert:

      Code:
      tcp        0      0 *:2424                  *:*                     LISTEN
      Verbinden kann ich mich aber nicht. Also ich muss gleich gestehen, dass ich nur rudimentäre Linux Kenntnisse habe. Ich wollte mal iptables prüfen, das gibts aber offensichtlich gar nicht. Bevor ich jetzt irgendetwas tot konfiguriere frage ich lieber nach was ich tun soll.

      Plugin.conf sieht jetzt so aus:
      Code:
      # plugin.conf
      
      [knx]
         class_name = KNX
         class_path = plugins.knx
         host = 192.168.1.100
      #   port = 6720
      #   send_time = 600 # update date/time every 600 seconds, default none
      #   time_ga = 1/1/1 # default none
      #   date_ga = 1/1/2 # default none
      ...
      Ich sollte vielleicht noch anmerken, dass mein Browser momentan im gleichen Netzwerk sitzt wie der PI. OpenVPN hab ich testweise mal auf beiden angehalten. Daran liegts also nicht.

      Kommentar


        #4
        Hi,

        kannst Du den Pi anpingen?
        EDIT: Blöde Frage, sonst könntest Du ja nicht die Webseite aufrufen.

        Bis bald

        Marcus

        Kommentar


          #5
          Hi,

          kannst Du bitte das Original-Image von uns noch mal testen? Ohne die ganzen Änderungen mit dem VPN und so?

          Bis bald

          Marcus

          Kommentar


            #6
            Hi,

            ok, image neu aufgespielt. Bei einer telnet Verbindung kommt jetzt einfach gar keine Ausgabe. Aber auch kein "connection refused". Ich hab das mal geSharked, siehe Anhang. Das ließt sich für mich aber wie die Steuererklärung, daraus werde ich nicht schlauer.

            Der Fehler smartVisu <-> smarthome besteht aber immer noch.

            Ich hab auch mal putty linux vom Stick gebootet. Dort läuft FireFox als browser und bei dem kam ein anderer Fehler, irgendwas mit Websocket nicht gefunden.

            Ansonsten wäre ich am WE wieder zu Hause und kann mal alles ins gleiche Netzwerk hängen.

            Gruß und Danke
            Angehängte Dateien

            Kommentar


              #7
              Hallo,

              ok. Ok jetzt kannst Du den Websocket erreichen. (Telnet zeigt bei dem nichts an). Dann kann das auch die smartVISU und es hängt an der Config oder Deinem Browser.

              Aber bitte probier es in dem Netzwerk in dem auch der Pi hängt.

              Bis bald

              Marcus

              Kommentar


                #8
                Hallo,

                sorry, da war jetzt der Urlaub dazwischen.

                Ich bin jetzt einen Schritt weiter. Die Telnet Verbindung funktioniert, im Logfile lässt sich alles nachvollziehen:

                Code:
                2013-06-09 19:18:54,325 SmartHome.py DEBUG    192.168.1.10:52795 sent '{"cmd":"item","id":"eg.buero.licht.decke","val":"1"}' -- __init__.py:json_parse:257
                2013-06-09 19:18:54,328 SmartHome.py DEBUG    eg.buero.licht.decke = True via Visu 192.168.1.10:52795 -- item.py:_update:214
                2013-06-09 19:18:55,227 Scheduler    DEBUG    series next time: 2013-06-09 19:19:05+02:00 -- scheduler.py:_next_time:238
                Die Telegramme kommen aber nicht am KNX Bus an.

                Muss gleich dazu sagen, dass ich das immer noch nicht zu Hause testen konnte und nach wie vor über den VPN im Bridge Modus arbeite. Direktes schreiben auf den Bus über
                "groupswrite ip:192.168.2.100 1/2/3 1"
                funktioniert aber problemlos.
                Kann man sich irgendwie anschauen, was genau an den gesendet wird?

                Kommentar


                  #9
                  Hi,

                  kannst Du bitte smartupdate.sh ausführen und SH.py neu starten?

                  Funktioniert es dann?

                  Bis bald

                  Marcus

                  Kommentar


                    #10
                    smartupdate.sh finde ich nicht. Ich hab aber heute morgen mal die Beta eingespielt, meine irgendwo gelesen zu haben, dass es kein smartupdate.sh mehr gibt.??

                    Kommentar


                      #11
                      ja, wenn Du die Beta-Version eingespielt hast, gibt es kein smartupdate.sh mehr. Dann brauchst Du aber SmartHome.py nicht updaten.
                      Das ist quasi aktuell.

                      Poste bitte mal ein komplettes Debug Log und die Item Konfiguration.

                      Wo läuft der eibd (IP) und auf welchem Rechner führst Du groupswrite aus?
                      In Deiner Conf unten steht "host = 192.168.1.100" und bei groupswrite steht die 192.168.2.100.

                      Bis bald

                      Marcus

                      Kommentar


                        #12
                        also Konfiguration ist immer noch so wie im ersten Post.

                        192.168.2.100 ist das Wiregate im Heimnetz

                        192.168.1.1 ist das Netwerk in der zweiten Wohnung
                        192.168.1.100 ist das Smarthome

                        Der EIBD läuft auf dem Wiregate. Das Smarthome hab ich über VPN mit dem Wiregate verbunden. Den Groupswrite habe ich auf der shell von Smarthome erfolgreich getestet.

                        Ich bin am WE zu Hause, dann kann ich mal alles im gleichen Netzwerk testen.

                        Hier die Log ab Neustart smarthome.sh:
                        Code:
                        2013-06-09 23:06:59,395 SmartHome.py INFO     Start SmartHome.py 0.8-169-gf39d59c -- smarthome.py:__init__:192
                        2013-06-09 23:06:59,399 SmartHome.py DEBUG    Python 2.7.3 -- smarthome.py:__init__:193
                        2013-06-09 23:06:59,404 SmartHome.py INFO     Init Scheduler -- scheduler.py:__init__:53
                        2013-06-09 23:06:59,408 SmartHome.py INFO     Init Plugins -- smarthome.py:__init__:208
                        2013-06-09 23:06:59,419 Scheduler    DEBUG    creating 5 workers -- scheduler.py:run:59
                        2013-06-09 23:06:59,428 SmartHome.py DEBUG    Plugin: knx -- plugin.py:__init__:42
                        2013-06-09 23:06:59,467 SmartHome.py DEBUG    Plugin: ow -- plugin.py:__init__:42
                        2013-06-09 23:06:59,485 SmartHome.py ERROR    Onewire: could not connect to 127.0.0.1:4304: [Errno 111] Connection refused -- __init__.py:connect:62
                        2013-06-09 23:06:59,490 SmartHome.py DEBUG    Plugin: cli -- plugin.py:__init__:42
                        2013-06-09 23:06:59,501 SmartHome.py DEBUG    Plugin: visu -- plugin.py:__init__:42
                        2013-06-09 23:06:59,585 SmartHome.py DEBUG    Plugin: sql -- plugin.py:__init__:42
                        2013-06-09 23:06:59,610 SmartHome.py DEBUG    SQLite 3.7.13 -- __init__.py:__init__:59
                        2013-06-09 23:06:59,635 SmartHome.py DEBUG    sqlite next time: 2013-06-10 03:02:00+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:06:59,638 SmartHome.py DEBUG    Plugin: rrd -- plugin.py:__init__:42
                        2013-06-09 23:06:59,733 SmartHome.py INFO     Init Items -- smarthome.py:__init__:210
                        2013-06-09 23:06:59,759 SmartHome.py DEBUG    knx: eg.buero.licht.decke listen on 1/2/30 -- __init__.py:parse_item:222
                        2013-06-09 23:06:59,762 SmartHome.py DEBUG    knx: eg.buero.licht.decke listen on and init with 1/2/30 -- __init__.py:parse_item:231
                        2013-06-09 23:06:59,770 SmartHome.py DEBUG    knx: eg.buero.rolladen.prozent listen on 2/2/2 -- __init__.py:parse_item:222
                        2013-06-09 23:06:59,773 SmartHome.py DEBUG    knx: eg.buero.rolladen.prozent listen on and init with 2/2/2 -- __init__.py:parse_item:231
                        2013-06-09 23:06:59,779 SmartHome.py DEBUG    knx: eg.buero.temperatur reply to 1/3/1 -- __init__.py:parse_item:254
                        2013-06-09 23:06:59,783 SmartHome.py WARNING  'eg.buero.temperatur' attribute 'ow_id' outdated. See http://mknx.github.com/smarthome/plugins/owng/ for valid keywords and values. -- __init__.py:parse_item:414
                        2013-06-09 23:06:59,989 SmartHome.py DEBUG    knx: second.sleeping.light.level listen on 3/2/14 -- __init__.py:parse_item:222
                        2013-06-09 23:06:59,993 SmartHome.py DEBUG    knx: Light listen on 3/2/12 -- __init__.py:parse_item:222
                        2013-06-09 23:07:00,203 SmartHome.py INFO     Start Plugins -- plugin.py:start:63
                        2013-06-09 23:07:00,211 ow           DEBUG    1w-disc next time: 2013-06-09 23:07:00+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:00,231 SmartHome.py INFO     Start Logics -- logic.py:__init__:32
                        2013-06-09 23:07:00,234 SmartHome.py DEBUG    reading logics from /usr/smarthome/etc/logic.conf -- logic.py:__init__:38
                        2013-06-09 23:07:00,242 rrd          DEBUG    rrd next time: 2013-06-09 23:08:40+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:00,255 SmartHome.py DEBUG    Logic: hello -- logic.py:__init__:45
                        2013-06-09 23:07:00,312 SmartHome.py DEBUG    Logic: dummy -- logic.py:__init__:45
                        2013-06-09 23:07:00,327 SmartHome.py DEBUG    dummy next time: 2013-06-09 23:07:07+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:00,334 visu         DEBUG    series next time: 2013-06-09 23:07:06+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:00,366 sh.con       DEBUG    knx: enable group monitor -- __init__.py:handle_connect:106
                        2013-06-09 23:07:00,370 sh.con       DEBUG    knx: init read -- __init__.py:handle_connect:112
                        2013-06-09 23:07:00,376 sh.con       INFO     KNX: connected to 127.0.0.1:6720 -- my_asynchat.py:connect:69
                        2013-06-09 23:07:00,544 Scheduler    DEBUG    1w-disc next time: 2013-06-09 23:17:00+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:00,633 sh.gc        DEBUG    Garbage collector: collected 912 objects. -- smarthome.py:_garbage_collection:345
                        2013-06-09 23:07:00,766 Scheduler    DEBUG    sh.gc next time: 2013-06-10 02:04:00+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:04,249 hello        INFO     Hello World! -- hello.py:<module>:3
                        2013-06-09 23:07:06,217 Scheduler    DEBUG    series next time: 2013-06-09 23:07:16+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:07,053 dummy        DEBUG    first.living.humidity = 52 via Logic None -- item.py:_update:214
                        2013-06-09 23:07:07,230 Scheduler    DEBUG    dummy next time: 2013-06-09 23:12:07+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:08,430 dummy        DEBUG    second.sleeping.temperature = 21 via Logic None -- item.py:_update:214
                        2013-06-09 23:07:08,486 dummy        DEBUG    second.bath.temperature = 24 via Logic None -- item.py:_update:214
                        2013-06-09 23:07:16,319 Scheduler    DEBUG    series next time: 2013-06-09 23:07:26+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:26,229 Scheduler    DEBUG    series next time: 2013-06-09 23:07:36+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:30,747 SmartHome.py INFO     WebSocket: incoming connection from 192.168.1.10:54774 -- __init__.py:handle_accept:115
                        2013-06-09 23:07:31,006 SmartHome.py DEBUG    192.168.1.10:54774 sent '{"cmd":"proto","ver":2}' -- __init__.py:json_parse:257
                        2013-06-09 23:07:36,326 Scheduler    DEBUG    series next time: 2013-06-09 23:07:46+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:44,676 SmartHome.py DEBUG    192.168.1.10:54774 sent '{"cmd":"monitor","items":["eg.buero.licht.decke"]}' -- __init__.py:json_parse:257
                        2013-06-09 23:07:46,185 SmartHome.py DEBUG    192.168.1.10:54774 sent '{"cmd":"item","id":"eg.buero.licht.decke","val":"1"}' -- __init__.py:json_parse:257
                        2013-06-09 23:07:46,189 SmartHome.py DEBUG    eg.buero.licht.decke = True via Visu 192.168.1.10:54774 -- item.py:_update:214
                        2013-06-09 23:07:46,223 Scheduler    DEBUG    series next time: 2013-06-09 23:07:56+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:07:56,320 Scheduler    DEBUG    series next time: 2013-06-09 23:08:06+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:08:06,215 Scheduler    DEBUG    series next time: 2013-06-09 23:08:16+02:00 -- scheduler.py:_next_time:238
                        2013-06-09 23:08:16,313 Scheduler    DEBUG    series next time: 2013-06-09 23:08:26+02:00 -- scheduler.py:_next_time:238

                        Kommentar


                          #13
                          Error bei Verbindung smartvisu zum smarthome.py

                          Hi,
                          1. im ersten Post ist keine Konfig (dort ist ein Link zu einem anderen Thread)
                          2. ein Moving Target (ach ja hab heut morgen das Beta-Image eingespielt) zu debuggen ist schwer
                          3. die Plugin.conf aus dem anderen Thread wird nicht von SH.py verwendet. Das KNX Plugin verbindet sich mit der 127.0.0.1.
                          4. Wie im 2. Post in diesem Thread erwähnt solltest Du dem Plugin die IP des WG mitgeben
                          5. mach bitte das gelöst Häckchen wenn es funktioniert.

                          Bis bald

                          Marcus

                          Kommentar


                            #14
                            Hi,

                            sorry, hat wieder ein wenig gedauert.

                            Läuft.
                            Es lag an der Einstellung unter [knx] in der Plugin.conf. Dort habe ich unter host jetzt die IP zum Wiregate eingetragen. Das war ein klassischer Denkfehler. Ich hatte den EIBD auf dem Raspberry als IP Schnittstelle zum Wiregate eingerichtet und smarthome.py auf den lokalen EIBD geroutet. Der EIBD läuft aber ja bereits auf dem Wiregate.
                            Also hab ich den lokalen EIBD auf dem Smarthome jetzt abgeschaltet.


                            Ich fasse noch einmal kurz zusammen, was ich gelernt hab:

                            EIBD auf dem Smarthome.PY:
                            1. EIBD konfigurieren in /etc/default/eibd
                            2. Plugin.conf [knx] auf host = 127.0.0.1
                            3. smartVisu Treiber auf smarthome.py und smarthome.local stellen

                            EIBD auf Wiregate:
                            1. EIBD muss nicht konfiguriert werden, da auf Wiregate
                            2. Plugin.conf [knx] auf host = "IP zum Wiregate"
                            3. smartVisu Treiber wie oben.

                            Gruß Thomas

                            Kommentar

                            Lädt...
                            X