Ankündigung

Einklappen
Keine Ankündigung bisher.

- √ - Problem mit develop branch und python 3.2

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    - √ - Problem mit develop branch und python 3.2

    Hi,

    habe heute mal versucht den akuellen Stand des develop branch mit python 3.2 zum laufen zu bekommen. Dabei erhalte ich folgende Fehler:

    Exception in thread Scheduler:
    Traceback (most recent call last):
    File "/usr/lib/python3.2/threading.py", line 740, in _bootstrap_inner
    self.run()
    File "/usr/smarthome/lib/scheduler.py", line 143, in run
    self._next_time(name)
    File "/usr/smarthome/lib/scheduler.py", line 278, in _next_time
    ct = self._crontab(entry)
    File "/usr/smarthome/lib/scheduler.py", line 355, in _crontab
    return self._sun(crontab)
    File "/usr/smarthome/lib/scheduler.py", line 441, in _sun
    next_time = self._sh.sun.rise(doff, moff)
    File "/usr/smarthome/lib/orb.py", line 60, in rise
    self._obs.date = datetime.datetime.utcnow() - dateutil.relativedelta.relativedelta(minutes=moff) + dateutil.relativedelta.relativedelta(seconds=2)
    AttributeError: 'Orb' object has no attribute '_obs'

    oder

    Traceback (most recent call last):
    File "/usr/smarthome/lib/scheduler.py", line 327, in _task
    exec(obj.bytecode)
    File "/usr/smarthome/lib/env/location.py", line 5, in <module>
    sh.env.location.sunrise(sh.sun.rise())
    File "/usr/smarthome/lib/orb.py", line 60, in rise
    self._obs.date = datetime.datetime.utcnow() - dateutil.relativedelta.relativedelta(minutes
    =moff) + dateutil.relativedelta.relativedelta(seconds=2)
    AttributeError: 'Orb' object has no attribute '_obs'

    Initial kommt auch folgende Warnung:
    2013-10-14 21:03:03,021 WARNING Main Could not find/use ephem! -- orb.py:__init__:41

    Ich verwende das raspi image mit python3.2 smarthome.py -d. Ist das noch ein Seiteneffekt der Umstellung oder ist mein image noch nicht richtig aktualisiert?

    Danke und Gruß
    Mark

    #2
    https://knx-user-forum.de/smarthome-...0-release.html !!!

    pyephem für Python 3 installieren
    HM-KNX - KNX-Interface für Hörmann Garagentorantriebe: http://www.ing-budde.de

    Kommentar


      #3
      Hallo Mark,

      wenn es da schon scheitert, dann lasse es bitte und warte auf das Release.

      Danke

      Marcus

      Kommentar


        #4
        Problem mit develop branch und python 3.2

        Mist, den Schritt hab ich wohl übersehen. Danke!

        Kommentar

        Lädt...
        X