Ankündigung

Einklappen
Keine Ankündigung bisher.

- √ - network-plugin - http antwort

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    - √ - network-plugin - http antwort

    ich versuche grad meine Wago 750 über http-get-requests an smarthome.py anzubinden für kritische Funktionen hab ich zwar die knx-klemme, aber die hat ja auch "nur" 250 Objekte.
    Das ganze funktioniert soweit auch ganz gut, doch leider gibt smarthome.py keine korrekte HTTP-Antwort zurück.

    habe ich irgend was falsch gemacht oder gibt smarthome.py einfach kein HTTP 200 Responsecode zurück?

    Christian

    #2
    Zitat von Ferengi Beitrag anzeigen
    ich versuche grad meine Wago 750 über http-get-requests an smarthome.py anzubinden für kritische Funktionen hab ich zwar die knx-klemme, aber die hat ja auch "nur" 250 Objekte.
    Das ganze funktioniert soweit auch ganz gut, doch leider gibt smarthome.py keine korrekte HTTP-Antwort zurück.

    habe ich irgend was falsch gemacht oder gibt smarthome.py einfach kein HTTP 200 Responsecode zurück?

    Christian
    Also hier kommen 200er zurück:

    Angehängte Dateien
    Greetings, Torsten

    Kommentar


      #3
      hallo,

      ich glaub du hast mich falsch verstanden, hat nix mit der smartvisu zu tun sondern dem networkplugin, und dem direkten http kontakt zu smarthome

      Code:
      # http request to set the item 'network.incoming' to '123'
      $ wget "http://XX.XX.XX.XX:8090/item|network.incoming|123"

      Kommentar


        #4
        Hi Christian,

        da kommt momentan kein 200er zurück. Ich schreibe es mal auf die nice2have liste.

        Bis bald

        Marcus

        Kommentar


          #5
          danke,

          geht zwar so auch, aber meine wago weis dann leider nicht obs geklappt hat oder nicht.

          Christian

          Kommentar


            #6
            Zitat von Ferengi Beitrag anzeigen
            hallo,

            ich glaub du hast mich falsch verstanden, hat nix mit der smartvisu zu tun sondern dem networkplugin, und dem direkten http kontakt zu smarthome

            Code:
            # http request to set the item 'network.incoming' to '123'
            $ wget "http://XX.XX.XX.XX:8090/item|network.incoming|123"

            Upps, war wohl noch zu früh am Tag :-)
            Greetings, Torsten

            Kommentar


              #7
              Hallo Christian,

              Zitat von Ferengi Beitrag anzeigen
              doch leider gibt smarthome.py keine korrekte HTTP-Antwort zurück.
              verwendest Du zufällig develop? Oder das 0.9 Release?

              Wenn develop, dann könntest Du es testen. Es sollte jetzt ein 200 OK zurück kommen, wenn alles klappt und ein 400 Bad Request wenn es Probleme mit dem Item gab.

              Bis bald

              Marcus

              Kommentar


                #8
                hallo,

                das ging ja schnell, noch verwende ich kein develop.
                Aber wenn das so ist werde ich mich am Wochenende soweit es die Zeit erlaubt ausprobieren.
                Danke!

                Christian

                Kommentar


                  #9
                  Hi Christian,

                  dann warte einfach bis zum Release. Ich habe es schon mal angetastet und es funktioniert hier bei mir.

                  Bis bald

                  Marcus

                  Kommentar


                    #10
                    sieht gut aus, nochmals danke für die schnelle umsetzung

                    Kommentar

                    Lädt...
                    X