Ankündigung

Einklappen
Keine Ankündigung bisher.

AVM Plugin

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Hallo zusammen,

    Ich habe grade versucht, meine Fritz DECT 301 von einer sehr alten config auf die neue mit structs etc. umzustellen. Leider funktioniert seitdem weder das Setzen noch das Auslesen der Temperatur. Für die DECT 200 Steckdosen klappt zumindest das Schalten, aber auch nichts weiter (z.B. auslesen der Temp).

    Was mich auch wundert ist, dass im WebIF der AVM Plugin keine Smarthome-Geräte angezeigt bekomme, so wie ich das in der online-Doku sehen kann. Ich habe nur "AVM Items", "Log Einträge" und "Plugin-API". In den "items" wiederum finde ich alles, was über die Structs hinzugefügt wird... Komisch das alles.

    Irgendwas mache ich also generell falsch, aber ich komm nicht drauf was. Hat jemand von euch eine config, in der auch DECT 301 sind und könnte derjenige das mal teilen? Muss ich "temp" und "settemp" nach "current_temperature" und "target_temperature" umbenennen? Brauch ich dann den avm_data_type noch?

    Meine Config sieht so aus:
    Code:
    %YAML 1.1
    ---
    avm:
        fritzbox:
            info:
                struct:
                  - avm.info
            reboot:
                type: bool
                visu_acl: rw
                enforce_updates: yes
    
        wlan:
            gf_wlan_1:
                type: bool
                visu_acl: rw
                avm_data_type: wlanconfig    # 2,4ghz
                knx_dpt: 1
                knx_send:   x/x/xx
                knx_listen: x/x/xx
                enforce_updates: 'true'
                avm_wlan_index: 1
    
            gf_wlan_1_ssid:
                type: str
                visu_acl: ro
                avm_data_type: wlanconfig_ssid    # 2,4ghz
                avm_wlan_index: 1
    
    
        dect:
            std_dg_buero:
                type: bool
                avm_data_type: aha_device
                avm_ain: 'xxxxx xxxxxxx' # has to be identical to id in fritzbox (also with spaces!)
                visu_acl: rw
                knx_dpt: 1
                knx_send:   x/x/xx
                knx_listen: x/x/xx
                enforce_updates: 'true'
                struct:
                    - avm.smarthome_general
                    - avm.smarthome_switch
                    - avm.smarthome_powermeter
                    - avm.smarthome_temperature_sensor
    
                do_not_switch_off_night:
                    type: bool
                    value: 0
    
            std_flex:
                type: bool
                avm_data_type: aha_device
                avm_ain: 'xxxxx xxxxxxx' # has to be identical to id in fritzbox (also with spaces!)
                visu_acl: rw
                knx_dpt: 1
                knx_send:   x/x/xx
                knx_listen: x/x/xx
                enforce_updates: 'true'
                struct:
                    - avm.smarthome_general
                    - avm.smarthome_switch
                    - avm.smarthome_powermeter
                    - avm.smarthome_temperature_sensor
    
                do_not_switch_off_night:
                    type: bool
                    value: 1
    
            bad_eg_heizkoerper:
                type: num
                avm_data_type: aha_device
                avm_ain: 'xxxxx xxxxxxx' # has to be identical to id in fritzbox (also with spaces!)
                visu_acl: rw
                struct:
                  - avm.smarthome_general
                  - avm.smarthome_hkr
                  - avm.smarthome_temperature_sensor
    
                # these items need to be child items from hkr_device
                temp:
                    type: num
                    avm_data_type: current_temperature
                    value: -1
                    visu_acl: rw
                    knx_dpt: 9
                    knx_send:   x/x/xx
                    knx_listen: x/x/xx
                    enforce_updates: 'true'
    
                settemp:
                    type: num
                    avm_data_type: target_temperature
                    value: -1
                    visu_acl: rw
                    knx_dpt: 9
                    knx_send:   x/x/xx
                    knx_listen: x/x/xx
                    enforce_updates: 'true'
                    database: 'yes'
                    
            bad_dg_heizkoerper:
                type: num
                avm_data_type: aha_device
                avm_ain: 'xxxxx xxxxxxx' # has to be identical to id in fritzbox (also with spaces!)
                visu_acl: rw
                struct:
                  - avm.smarthome_general
                  - avm.smarthome_hkr
                  - avm.smarthome_temperature_sensor
    
                # these items need to be child items from hkr_device
                temp:
                    type: num
                    avm_data_type: current_temperature
                    value: -1
                    visu_acl: rw
                    knx_dpt: 9
                    knx_send:   x/x/xx
                    knx_listen: x/x/xx
                    enforce_updates: 'true'
    
                settemp:
                    type: num
                    avm_data_type: target_temperature
                    value: -1
                    visu_acl: rw
                    knx_dpt: 9
                    knx_send:   x/x/xx
                    knx_listen: x/x/xx
                    enforce_updates: 'true'
                    database: 'yes'
    Gruß und Danke,
    //giase
    Zuletzt geändert von Giase; 02.08.2022, 15:31.

    Kommentar


      Zitat von Giase Beitrag anzeigen
      Was mich auch wundert ist, dass im WebIF der AVM Plugin keine Smarthome-Geräte angezeigt bekomme
      Die Ursache liegt vielleicht darin, dass man das AHA-Interface für die smarthome Geräte in den Einstellungen des Plugins aktivieren muss.
      Dazu AdminIF --> Plugins --> Konfigruation --> AVM --> avm_home_automation auf True

      Schau da mal nach. Dann sehen wir weiter.

      Kommentar


        Vielen Dank Sisamiwe, das war’s! Komisch, dass das nicht default auf true ist.
        Im log hab ich dazu auch nichts gesehen. Wäre vielleicht hilfreich, eine Warnung zu haben.

        Danke nochmal!
        //giase

        Kommentar

        Lädt...
        X