Ankündigung

Einklappen
Keine Ankündigung bisher.

Raspberry Image Version 2.2 mit SmarthomeNG 1.5.1

Einklappen
Dieses Thema ist geschlossen.
X
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Onkelandy
    antwortet
    Es wird bald ein Image geben, Sisamiwe
    Funktioniert bei dir das subscriben via mqtt Plugin auch nicht? Klappt es mit der neuesten Mosquitto Version?

    Einen Kommentar schreiben:


  • Sisamiwe
    antwortet
    Onkelandy

    Könntest du, falls es ein neunes Image mit shNG 1.4 geben sollte, den mosquitto in der letztgültigen Version (ich glaube 1.4.14) mit einbinden?
    Das ist etwas kompliziert, da im Repo von Debian nur die Version 1.4.10 ist, und das Nachinstallieren diverse Abhängigkeitsprobleme hat.
    Was meinst Du?

    Einen Kommentar schreiben:


  • Johannes911
    antwortet
    Onkelandy hat schon mal recht, der Raspberry booted und ist im Netzwerk erreichbar. Danke schon mal dafür! Die nächsten Fragen kommen bestimmt ;-)

    Einen Kommentar schreiben:


  • Sisamiwe
    antwortet
    Onkelandy
    So wie ich das recherchiert habe, muss für glib-2.0 vorher noch ein anderes Paket installiert werden.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Die 2. Partition ist mit ext formatiert, Windows kann das nicht von sich aus lesen, nur mit Tools wie zB von Paragon-Software.
    Das Beste ist aber ohnehin, du legst die SD Karte in deinen Raspi, startest und greifst dann via SSH bzw. Samba darauf zu.
    https://sourceforge.net/p/smarthomen...ge/wiki/Samba/

    Einen Kommentar schreiben:


  • Johannes911
    antwortet
    Hallo zusammen,
    irgendwo fehlt mir wohl ein Schritt.
    Ich habe das Raspi_SmarthomeNG_public_2.0.1.ing heruntergeladen und mit Win32DiskImager auf eine SmartCard gebracht.
    Windows zeigt mir danach zwei Laufwerke an, das erste mit dem Verzeichnis overlays und 23 andere Dateien. Im Verzeichnis overlays sind viele *.dtbo-Files.
    Auf das zweite erzeugt Laufwerk kann ich nicht zugreifen, Windows möchte es vor der Nutzung gerne erst einmal formatieren.

    Meinem Verständnis nach sollte ich doch die smartHome-py-Files und auch die SmarVISU-Files irgendwo sehen können? Oder fehlt mir da ein Schritt? Was mache ich gerade falsch?

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    Woher der glib-2.0 Error kommt, ist mir auch noch schleierhaft. Ich werde für das neue Image mal schauen, ob hier ein Modul installiert wurde, das es eh nicht braucht und dann das mit dem Update testen.

    Das Sinnvollste ist aber wohl tatsächlich, die Module einzeln upzudaten.

    Einen Kommentar schreiben:


  • psilo
    antwortet
    dann gib acht.bei ruamel.yaml darfst du nicht auf die neuste.. siehe pypi übersicht im dev backend

    Einen Kommentar schreiben:


  • Sisamiwe
    antwortet
    bmx
    Danke.

    Ich habe Probleme mit dem smarttv Plugin (siehe hier) und habe deshalb ein neues Testsystem aufgesetzt. Bei diesem wollte ich alles aktualisieren und zu prüfen, ob der Fehler dann weg ist.

    Einen Kommentar schreiben:


  • bmx
    antwortet
    Hm. Prinzipiell solltest Du nicht alles einfach upgraden was geht sondern nur was sinnvoll ist.

    Du kannst zunächst pip3 aktualisieren mit
    Code:
     
     sudo python3 -m pip install --upgrade pip
    und dann macht es Sinn, die für den Kern benötigten Module zu aktualisieren mit
    Code:
     
     sudo pip3 install -r requirements/base.txt
    Was Du dann noch brauchst, hängt eigentlich von Deinen Plugins und den dort benötigten Paketen ab.

    Code:
    sudo pip3 install --upgrade <paketname hier>
    installiert und aktualisiert ggf. ein Paket auf die neueste verfügbare Version.

    Schau mal ins Backend, dort ist eine Auflistung zu sehen, welche Pakete installiert sind mit welchen Versionen etc.

    Einen Kommentar schreiben:


  • Sisamiwe
    antwortet
    Steht so in der Beschreibung des Image
    Python 3.5 Packages

    All dependencies for SmarthomeNG including plugins are installed plus some additional packages like pymysql, awake, etc.
    List all installed packages with sudo yolk --list

    How to update: sudo yolk --upgrade
    Install additional packages: sudo pip3 install PACKAGENAME
    To use the conf to yaml converter you might need to downgrade ruamel!
    sudo pip3 install —upgrade ruamel.yaml==0.15.0

    Einen Kommentar schreiben:


  • bmx
    antwortet
    Warum nimmst Du yolk und nicht pip3?

    Einen Kommentar schreiben:


  • Sisamiwe
    antwortet
    Hallo,
    ich habe heute basierend auf dem aktuellen Image ein Testsystem aufgesetzt. Beim Update der python packages mit yolk --upgrade gibt es diverse Fehlermeldungen.

    Hier die Ausschnitte:
    HTML-Code:
        Package glib-2.0 was not found in the pkg-config search path.
      Perhaps you should add the directory containing `glib-2.0.pc'
      to the PKG_CONFIG_PATH environment variable
      No package 'glib-2.0' found
      Command '['pkg-config', '--print-errors', '--exists', 'glib-2.0 >= 2.38.0']' r                                                              eturned non-zero exit status 1
    
      ----------------------------------------
      Failed building wheel for PyGObject
    HTML-Code:
      Package cairo was not found in the pkg-config search path.
      Perhaps you should add the directory containing `cairo.pc'
      to the PKG_CONFIG_PATH environment variable
      No package 'cairo' found
      Command '['pkg-config', '--print-errors', '--exists', 'cairo >= 1.13.1']' retu                                                              rned non-zero exit status 1
    
      ----------------------------------------
      Failed building wheel for pycairo
      Running setup.py clean for pycairo
    HTML-Code:
        Package cairo was not found in the pkg-config search path.
        Perhaps you should add the directory containing `cairo.pc'
        to the PKG_CONFIG_PATH environment variable
        No package 'cairo' found
        Command '['pkg-config', '--print-errors', '--exists', 'cairo >= 1.13.1']' returned non-zero exit status 1
    
        ----------------------------------------
    Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-96eelft3/pycairo/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-cq_ooovn-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-96eelft3/pycairo/
    Wie kann man das beheben?

    Einen Kommentar schreiben:


  • bmx
    antwortet
    Vermutlich. Ich habe es nirgendwo gefunden, nimm es halt raus.

    Einen Kommentar schreiben:


  • Onkelandy
    antwortet
    astral steht halt im all.txt von 1.3 drin.. aber funzt bei mir auch alles mit einer höheren Version.. vielleicht, weil es eh nicht genutzt wird ?

    Einen Kommentar schreiben:

Lädt...
X