Ankündigung

Einklappen
Keine Ankündigung bisher.

SmarthomeNG Image File für Raspberry Pi

Einklappen
Das ist ein wichtiges Thema.
X
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Onkelandy ,
    denkst Du bitte auch an die Alternative EIBD?
    Gruß
    Hans

    Kommentar


      Du willst wirklich tote Pferde reiten? Funktionieren für Dich keine der älteren KNXD Versionen? (0.12 funktionier soweit ich weiss mit quasi allem). Ansonsten wäre das ein Fall für das KNXD Forum.

      Ich persönlich finde es keine Idee eine Software, die nicht mehr supported wird in das Image aufzunehmen.
      Viele Grüße
      Martin

      Stay away from negative people. They have a problem for every solution.

      Kommentar


        Mein Motto ist "never change a running system"!
        Ich habe so viel Zeit mit KNXD "verbraten" und bei Fragen im entspr. Forum nur arrogante Antworten und keine Lösungen bekommen. Wenn SmarthomeNG nicht mit EIBD kommt, werde ich komplett nach Cometvisu gehen. Die Funktionalität reicht für meine Anwendungen und der Support ist kompetent und gut.
        Ich wünsche allen ein frohes Weihnachtsfest und ein gesundes und erfolgreiches Jahr 2019!
        Gruß
        Hans

        Kommentar


          Ich habe mir den Thread im knxd Forum angeschaut und abgesehen von makki's Kommentar (er ist halt so, hat aber meistens recht) habe ich da keine arroganten Antworten gesehen. Mir ist allerdings aufgefallen, das Smurf Dich mehrfach nach einem Log gefragt hat, um auszuschließen, dass es dort einen KNXD Bug gibt, Du aber kein Log geschickt hast. Dass Smurf das Thema dann zu den Akten legt, kann ich nachvollziehen.
          Viele Grüße
          Martin

          Stay away from negative people. They have a problem for every solution.

          Kommentar


            Wenn SmarthomeNG nicht mit EIBD kommt
            SmartHomeNG kommt WEDER mit dem EIBD noch dem KNXD. Das KNX Plugin müsste meines Wissens (hatte vor "NG" noch eibd) auch mit EIBD können?!? Installier ihn Dir halt einfach? Das sollte auch mit dem Image zu dem der Thread hier ist gehen.. Wo ist das Problem?

            Ich hab das Ding damals auf einer Synology kompiliert bekommen, das war zwar ein mittleres Weltwunder, aber selbst das ging..

            Kommentar


              Ja, das KNX Plugin unterstützt den EIBD auch weiterhin (KNXD ist ja auch "nur" eine Weiterentwicklung von EIBD")
              Viele Grüße
              Martin

              Stay away from negative people. They have a problem for every solution.

              Kommentar


                psilo ,
                ich habe mich falsch ausgedrückt. Dies hier ist ja der Tread für das Image-File (onkelandy) und im Image-File hätte ich gern auch den EIBD.

                Kommentar


                  Machen wir doch mal Folgendes Tontechniker
                  - Deinstalliere knxd: dpkg -P knxd
                  - Installier die zwei Packages im Anhang mittels dpkg -i *.deb
                  - Danach die Befehle:
                  Code:
                  echo "/usr/local/lib" | sudo tee -a /etc/ld.so.conf.d/bcusdk.conf
                  sudo ldconfig
                  Ich bin hier nach dem gegangen: https://forum.fhem.de/index.php/topi...pvg5#msg333561

                  Wenn das funzt, binde ich die Packages und die eibd-Option in das setup_knxd ein. Wenn es nicht funzt, können wir ein paar Minuten in die Problemlösung stecken
                  Angehängte Dateien

                  Kommentar


                    Danke Onkelandy ,
                    ich komme leider erst wieder in neuen Jahr dazu, Deinen Vorschlag auszuprobieren.
                    Dir ein frohes Fest und ein gesundes und erfolgreiches Jahr 2019!
                    Hans

                    Kommentar


                      Neues Image gibts eh erst mit dem 1.6 Release, also kein Stress.
                      Selbes retour, schöne Feiertage!

                      Kommentar


                        Hallo an alle!

                        ich habe mir von Onkelandy das neue Image mit der 2.2 installiert und aufgespielt.
                        Leider bekomme ich nicht wie gewohnt mit sh.log die Fehler angezeigt...sondern:

                        Code:
                        sh.log
                        2018-08-14  14:49:19 WARNING  __main__          --------------------   Init SmartHomeNG 1.5.1.master (cc1288de)   --------------------
                        2018-08-14  14:49:19 WARNING  __main__          Running in Python interpreter 'v3.5.3 final' on linux platform
                        2018-08-14  15:26:12 WARNING  __main__          SmartHomeNG stopped
                        2018-08-14  15:26:29 WARNING  __main__          --------------------   Init SmartHomeNG 1.5.1.master (cc1288de)   --------------------
                        2018-08-14  15:26:29 WARNING  __main__          Running in Python interpreter 'v3.5.3 final' on linux platform
                        2018-08-14  18:14:10 WARNING  __main__          SmartHomeNG stopped
                        2018-08-14  18:14:37 WARNING  __main__          --------------------   Init SmartHomeNG 1.5.1.master (cc1288de)   --------------------
                        2018-08-14  18:14:37 WARNING  __main__          Running in Python interpreter 'v3.5.3 final' on linux platform
                        Das ganze läuft mit einem Raspberry PI3 B+.
                        Hat jemand das Problem auch gehabt?

                        Gruß und Dank Andreas

                        Kommentar


                          Das ist kein Problem, sondern "works as designed". In dem smarthome-warnings.log werden nur Warnungen und Fehler angezeigt (WARNING, ERROR, CRITICAL). Alle INFO und DEBUG Meldungen landen im smarthome-details.log. Was genau im smarthome-details.log landet kannst Du im etc/logging.yaml konfigurieren. Genaueres dazu steht in der Doku
                          Viele Grüße
                          Martin

                          Stay away from negative people. They have a problem for every solution.

                          Kommentar


                            Hallo Martin,

                            soweit habe ich es gerade verstanden . Was ich nicht verstehe ist, wenn ich die logging.yaml von meinem laufenden system auf das neue kopiere...
                            bekomme ich trotzdem nur die zwei Zeilen. Beim "alten" System sehe ich ja in schön in grün das shNG startet und die Infos zum Alexa-Plugin usw...

                            Des Weiteren was mich auch verwundert ist, dass das Backend nicht richtig Funktioniert. Gestern Nacht hatte ich es laufen...und habe mir wieder was zerschossen...
                            backend.JPG
                            Eigentlich sieht das hier ja anders aus....

                            das ist die plugin.yaml
                            Code:
                            BackendServer:
                                plugin_name: backend
                            Ich hatte gestern noch irgend etwas unter dem Punkt Backend erweitert...und dann lief es wie gewohnt

                            Danke für Hinweise

                            Kommentar


                              Zitat von ASSR85 Beitrag anzeigen
                              ich ja in schön in grün das shNG s
                              Was siehst Du da? SmartHomeNG zeigt nichts in grün an.

                              Zitat von ASSR85 Beitrag anzeigen
                              Des Weiteren was mich auch verwundert ist, dass das Backend nicht richtig Funktioniert. Gestern Nacht hatte ich es laufen...und habe mir wieder was zerschossen...
                              Auch hier ist die Doku Dein Freund: module.yaml (Parameter starturl)

                              Viele Grüße
                              Martin

                              Stay away from negative people. They have a problem for every solution.

                              Kommentar


                                Zitat von Msinn Beitrag anzeigen
                                Was siehst Du da? SmartHomeNG zeigt nichts in grün an.


                                Auch hier ist die Doku Dein Freund: module.yaml (Parameter starturl)
                                Sorry vllt. falsch Ausgedrück.... mit der Eingabe von sh.log sieht man div. Zeilen in grün, und Hinweise in gelb, Fehler in rot/lila.. ---> Ich bekomme aber immer die gleichen Meldungen auch wenn ich in der logging.yaml alles Auskommentiere.

                                Mit der Doku....ich bekomme es nicht hin. Ich ändere so lange rum, bis ich das Image wieder neu Aufsetzen muss .

                                Kommentar

                                Lädt...
                                X