Ankündigung

Einklappen
Keine Ankündigung bisher.

SmarthomeNG Image File für Raspberry Pi

Einklappen
Das ist ein wichtiges Thema.
X
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

    Zitat von ASSR85 Beitrag anzeigen
    Mit der Doku....ich bekomme es nicht hin. Ich ändere so lange rum, bis ich das Image wieder neu Aufsetzen muss .
    ???

    was ist an dem einstellen des Parameters starturl in .../etc/module.yaml so schwer?
    Code:
    http:
         module_name: http
         starturl: backend
    Viele Grüße
    Martin

    Kommentar


      Das hat alles nichts mit dem Image zu tun. Dort ist einfach die Standard-Install von smarthomeNG drauf.
      Wenn du zuvor eine deutlich ältere Version hattest, ist da natürlich einiges neu. Unter anderem eben das logging.yaml.

      Wenn du mehr Infos zu einem Plugin, etc. haben willst, musst du das im besagten File unter loggers einstellen, zB
      Code:
          lib.item:
              handlers: [develop_file]
              level: DEBUG
      Mit sh.develop bekommst du dann diese Messages angezeigt.

      Kommentar


        Heute, 15:08
        Zitat von ASSR85 Beitrag anzeigen
        Mit der Doku....ich bekomme es nicht hin. Ich ändere so lange rum, bis ich das Image wieder neu Aufsetzen muss .
        ???

        was ist an dem einstellen des Parameters starturl in .../etc/module.yaml so schwer?
        Code:
        Schwer ist das nicht...aber es Funktiontioniert halt einfach nicht. Ich bekomme beim Backend denn Fehler:

        Oops, Error 500: The server encountered an unexpected condition which prevented it from fulfilling the request.
        Ich ging davon aus...dass ich mit sh.log die Fehler raus bekomme....aber das gibt es jetzt anscheinend nicht mehr so wie ich das gewohnt bin

        Danke Onkelandy für den Hinweis. Ich hätte jetzt da ewig rum gedoktert.

        Kommentar


          Zitat von ASSR85 Beitrag anzeigen
          Oops, Error 500: The server encountered an unexpected condition which prevented it from fulfilling the request.
          Auch hier wieder mein Verweis auf die Doku.

          showtraceback: True Liefert den Traceback für die Fehler jeweiligen Fehler auch im Browser (nicht nur im Log, wo er immer eingtragen wird).

          Code:
          http:
              module_name: http
              starturl: backend
              showtraceback: True
          Viele Grüße
          Martin

          Kommentar


            Hallo miteinander!

            Als Linux-Neuling (mehr auf https://knx-user-forum.de/forum/supp...s-anschließen) habe ich mir das Image auf einen USB-Stick gebrannt, mit einem LAN-Kabel meinen Router und den Raspi 3B+ verbunden, per HDMI einen Monitor am Raspi angeschlossen, den Raspi mit dem USB-Stick gebootet und bin bis zur Eingabeaufforderung
            SmartHomeNG login:
            gelangt.

            Da ich keine Tastatur am Raspi habe, habe ich mal im Internet gesucht und die Möglichkeit gefunden, per Putty vom Windows-Rechner auf den Raspi zuzugreifen.

            In dem Putty-Fenster ist auch eine Eingabeaufforderung aufgetaucht, da habe ich als Benutzername smarthome eingegeben und bin dann bis zu einer Zeile
            [smarthome@SmartHomeNG ~]$
            gelangt.

            Auf dem an den Raspi angeschlossenen Monitor hat sich in der Zeit nichts verändert.

            Jetzt kann ich schon im Browser mit der auch in Putty eingebenen IP-Adresse das Backend von Smarthome aufrufen:
            IP-Adresse/backend



            Als nächstes würde ich gerne den Raspi nicht mehr per LAN-Kabel, sondern per WLAN an den Browser anschließen. Was muss ich dafür tun?

            Danke im voraus
            KNXer01

            Kommentar


              Servus KNXer01,

              nun das ist wenig SmartHomeNG spezifisch. Sondern mehr von dem darunterliegenden Betriebssystem, bei dir wohl ein raspbian in der Version ???

              Schau mal ob du hiermit klar kommst, ansonsten mal google bemühen mit der genauen Version vom Raspian ;-)

              https://www.elektronik-kompendium.de...pi/1912221.htm

              oder

              https://linuxundich.de/raspberry-pi/...-einzurichten/

              Viele Grüße
              Jannis

              Kommentar



                Hallo Jannis,

                Zitat von startrix Beitrag anzeigen
                nun das ist wenig SmartHomeNG spezifisch.
                Ja, ich brauche sicher manchen Hinweis auf Linux-Grundlagen, sorry. SmartHomeNG ist für mich DIE Motivation überhaupt, mich mit Linux zu beschäftigen!


                Sondern mehr von dem darunterliegenden Betriebssystem, bei dir wohl ein raspbian in der Version ???
                Laut dem Changelog zur Version 2.2 von Onkelandys Image ist die Grundlage des Images ein Raspbian stretch lite vom Juni 2018.


                Danke!
                Wie in deinem ersten Link als "Variante2" genannt, habe ich per Putty mein WLAN in der Datei wpa_supplicant.conf eingetragen. Wenn ich die Datei nochmal neu lade, sehe ich auch, dass meine Einträge dort sind.

                In der Router-Übersicht wird aber der Raspi nicht im WLAN angezeigt. Jetzt müsste ich also herausfinden, warum er es nicht ins WLAN schafft bzw. wie ich ihn doch dorthin bringen kann.

                Schöne Grüße
                KNXer01




                Kommentar


                  Zitat von KNXer01 Beitrag anzeigen
                  In der Router-Übersicht wird aber der Raspi nicht im WLAN angezeigt. Jetzt müsste ich also herausfinden, warum er es nicht ins WLAN schafft bzw. wie ich ihn doch dorthin bringen kann.
                  Was für einen Raspberry hast du denn? Ist WLAN schon onboard oder hast du einen WLAN Stick per USB dran?

                  VG Jannis

                  Kommentar


                    Raspberry 3 B+ mit WLAN onboard

                    Kommentar


                      Vielleicht kannst du den Weg und die Settings noch kurz hier posten. Dann könnt ichs in das systemsetup integrieren ohne viel Probieren

                      Kommentar


                        Da ich keine Tastatur am Raspberry habe, habe ich über Putty vom Windows-10-Notebook aus über den Router auf den per LAN-Kabel angeschlossenen Raspberry zugegriffen.

                        Die IP-Nummer vom per LAN angeschlossenen Raspi konnte ich in der Router-Übersicht über das Heimnetz ablesen.

                        (Das war bei mir noch bisschen dadurch kompliziert, dass die Router-Oberfläche der o2-Homebox 2 (6641) anscheinend mit einem Kennwort geschützt war, von dem ich überhaupt nichts wusste. Wenn man den Router auf Werkseinstellungen zurücksetzt, um das Kennwort zu löschen, muss man seine Zugangsdaten für Telefon und Internet neu eingeben. Die findet man entweder in seinem perfekt sortierten Briefarchiv zuhause oder am ehesten online unter Mein O2 beim Archiv mit den Briefen von O2.)

                        Jedenfalls habe ich die IP per copy+paste in Putty eingetragen und für weitere Zugriffe abgespeichert.

                        Dann habe ich mich mit dem Benutzernamen smarthome eingeloggt und die Datei
                        wpa_supplicant.conf aufgerufen mit
                        sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

                        Darin standen schon wie in dem Artikel
                        Raspberry Pi: WLAN-Adapter einrichten unter Variante 2 beschrieben die Zeilen

                        ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
                        update_config=1

                        Die Zeile
                        country=DE
                        hat gefehlt, das habe ich so gelassen, hoffentlich habe ich damit kein Problem ausgelöst.


                        Jedenfalls habe ich darunter dann die Zeilen

                        network={
                        ssid="WLAN-SSID"
                        psk="WLAN-PASSWORT"
                        }

                        mit den entsprechenden Angaben für mein WLAN eingetragen.

                        Damit die Änderung wirksam wird, muss man dann entweder noch das WLAN ein-/ausschalten oder kann den ganzen Netzwerk-Stack nochmal neu starten, aber das sollte mit einem Netz-Reset des gesamten Raspi auch erledigt werden, oder?

                        Kommentar


                          Hallo Kollegen,

                          nur so als Info..... ( hab SH NG neu installier - Raspi 3B - )

                          Nach "system_update" geht die Anmeldung über Putty
                          Standard user: smarthome
                          Password: none

                          nicht mehr.

                          Jetzt will er
                          user: "pi"
                          Password: "raspberry"
                          Gruß, JG

                          Kommentar


                            Sehr sonderbar. Kannst du danach über "su smarthome" in den smarthome User wechseln?
                            Schau doch mal im
                            /etc/ssh/sshd_config, ob da ein AllowUsers oder DenyUsers drin ist. Siehe auch hier: https://www.ostechnix.com/allow-deny...r-group-linux/

                            Kommentar


                              Moin Andy,

                              danke für Deine Antwort.....

                              Konnte unter dem User "pi" mit folgendem Befehl das Kennwort für User "smarthome" ändern:
                              sudo passwd {USERNAME}

                              Muß ja den User "smarthome" verwenden, um Dateien bearbeiten zu können.

                              In der "/etc/ssh/sshd_config", steht nix von AllowUsers oder DenyUsers
                              Angehängte Dateien
                              Gruß, JG

                              Kommentar


                                Hallo Kollegen,

                                kann die Visu nicht aufrufen ...... ( BackendServer, läuft )

                                Frage:
                                Muß in der "plugin.yaml" folgender Eintrag vorhanden sein ?
                                # Bereitstellung eines Websockets zur Kommunikation zwischen SmartVISU und SmartHomeNG
                                websocket:
                                plugin_name: visu_websocket
                                #ip: 0.0.0.0
                                #port: 2424
                                #tls: no
                                #wsproto: 4
                                #acl: rw
                                in der "plugin.yaml.default" ist es vorhanden, im Image "plugin.yaml" ist es nicht vorhanden.

                                Wenn ich "websocket" hinzufüge, kommt folgender Fehler
                                2019-01-12 07:53:57 WARNING __main__ -------------------- Init SmartHomeNG 1.5.1.master (c4e9acc3) --------------------
                                2019-01-12 07:53:57 WARNING __main__ Running in Python interpreter 'v3.5.3 final' on linux platform
                                2019-01-12 07:54:06 WARNING lib.plugin Plugin section 'visu' uses same class 'WebSocket' and instance 'default' as plugin section 'websocket'
                                2019-01-12 07:54:07 WARNING plugins.cli CLI: You should set a password for this plugin.
                                2019-01-12 07:54:09 ERROR lib.connection _websocket: problem binding 0.0.0.0:2424 (TCP): [Errno 98] Die Adresse wird bereits verwendet
                                2019-01-12 07:54:09 ERROR lib.connection unregister a connection with filenumber == 12 for epoll failed
                                2019-01-12 07:54:25 ERROR lib.connection _websocket: problem binding 0.0.0.0:2424 (TCP): [Errno 98] Die Adresse wird bereits verwendet
                                2019-01-12 07:54:25 ERROR lib.connection unregister a connection with filenumber == 13 for epoll failed
                                Hoffe die Frage ist nicht zu dumm, bin hilflos
                                Gruß, JG

                                Kommentar

                                Lädt...
                                X