Ankündigung

Einklappen
Keine Ankündigung bisher.

Error occurred in twig-template engine!

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • wvhn
    antwortet
    Sobald Du das Plugin visu_smartvisu in smarthomeNG aus der Konfiguration entfernt und smarthomeNG neu gestartet hast, löschst Du am besten den Ordner /var/www/html/smartVISU/pages/base komplett und ziehst Dir die Dateien als ZIP-Datei neu aus GitHub: Version v2.8.

    Gruß
    Wolfram

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Bei der recht alten Version von SmarthomeNG (v1.5.1) einfach das visu_smartvisu Plugin nicht mit laden, wenn man es nicht braucht. Dann sind die Einträge im Log weg.

    Einen Kommentar schreiben:


  • wvhn
    antwortet
    Also das visu_smartvisu-Plugin von smarthomeNG versucht offensichtlich, Templates in das smartvisu-Verzeichnis zu kopieren. Also ist es so eingestellt, dass es Seiten generieren soll. Dazu muss der User, unter dem smarthomeNG läuft (üblicherweise heute "smarthome"), in der Gruppe www-data sein und die Rechte auf das smartVISU-Verzeichnis müssen für smarthome:www-data eingerichtet werden.

    Zudem kannst Du im plugin einstellen, ob smarthome Seiten generieren soll und ob es Widgets zu smartVISU kopieren soll, die für smarthomeNG-Plugins mitgeliefert werden. Wenn Du das alles nicht brauchst, deaktiviere das Plugin.

    Das alles hat mit smartVISU und dem beschriebenen Fehler aus der twig Template Engine nichts zu tun. Du könntest höchstens versuchsweise mal den Ordner ./pages/smarthome bzw. ./pages/base/tplNG leeren. Vielleicht sind dort Dateien angekommen, die Probleme machen.

    Gruß
    Wolfram
    Zuletzt geändert von wvhn; 24.07.2021, 07:38. Grund: TplNG ergänzt

    Einen Kommentar schreiben:


  • Manuel1889
    antwortet
    Ich finde leider nichts. Habe jetzt nochmal alles durchgesehen und leider keinen Fehler gefunden. Ich nutze nicht die automatische Seitengenerierung.

    Das einzige was ich gefunden habe. Bekomme im log immer beim start des systems folgende Fehlermeldung:
    Code:
    2021-07-23 10:34:02 WARNING __main__ -------------------- Init SmartHomeNG 1.5.1.master (cc1288de) --------------------
    2021-07-23 10:34:02 WARNING __main__ Running in Python interpreter 'v3.5.3 final' on linux platform
    2021-07-23 10:34:55 WARNING plugins.cli CLI: You should set a password for this plugin.
    2021-07-23 10:35:03 ERROR lib.scheduler Error parsing crontab "* * * * *": too many values to unpack (expected 4)
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy rooms.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy navi.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy category_page.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy widgetblock_blk_noh.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy roomlite.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy roomslite.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy widgetblock_blk_std.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy category.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy room.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy widgetblock2_blk_std.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy navi_sep.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy widgetblock2_std_std.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy widgetblock_std_std.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy navigation.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy heading.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:04 ERROR plugins.visu_smartvisu Could not copy index.html from /usr/local/smarthome/plugins/visu_smartvisu/tplNG to /var/www/html/smartVISU/pages/base/tplNG
    2021-07-23 10:35:13 ERROR lib.scheduler Error parsing crontab "* * * * *": too many values to unpack (expected 4)
    Habe aber sowohl auf
    Code:
    /usr/local/smarthome/plugins/visu_smartvisu/
    als auch den Ordner
    Code:
    /var/www/html/smartVISU
    volle Berechtigungen vergeben, leider bekomme ich trotzdem weiterhin immer diese Fehlermeldung.

    Einen Kommentar schreiben:


  • wvhn
    antwortet
    Erstmal allen Code checken, den Du selbst innerhalb smartVISU geändert hast. Ggfls. die Stellen hier posten.
    Wenn Du innerhalb von smartVISU nichts geändert hast und die automatische Seitengenerierung von smarthome verwendest (sofern es die in deiner Version schon gibt), dann gib bitte mehr Info zu den installierten Versionen von smarthome und den Plugins.

    Gruß
    Wolfram

    Einen Kommentar schreiben:


  • Manuel1889
    antwortet
    Danke für die schnelle Rückmeldung. Hast du einen Tipp wie ich weiter vorgehen kann?

    lg. Manuel

    Einen Kommentar schreiben:


  • wvhn
    antwortet
    Das ist sicherlich ein anderes Problem. Da man in der (inzwischen uralten) Version v2.8 die zusätzlichen Widgets noch selbst importieren muss, ist entweder beim Importieren ein Fehler passiert, oder es ist ein Syntaxfehler in der neuen Visu-Seite. Vermutlich fehlt irgendwo eine schließende Klammer oder ein Anführungszeichen. Dann kann der Parser der Twig Template Engine den Code nicht mehr richtig interpretieren.

    Gruß
    Wolfram

    Einen Kommentar schreiben:


  • Manuel1889
    antwortet
    Hallo, ich habe leider das selbe Problem.
    Habe gestern nur das Sonos Plugin erstellt und ein items file angelegt für den Sonos lautsprecher. Funktionieren tut alles bis auf die Visu. Auch die Sonos funktionalität fuktioniert.

    Kann mir eventuell jemand sagen wie ich den Fehler eingrenzen kann? Habe die gestern bearbeiteten Files schon geprüft und nichts gefunden.
    Auch sh.log und sh.error sagen auch nichts dazu.

    Vielen Dank

    Bildschirmfoto 2021-07-18 um 10.46.20.png

    Einen Kommentar schreiben:


  • greentux
    antwortet
    Merci! Hat geholfen.

    Einen Kommentar schreiben:


  • wvhn
    antwortet
    Für alle, die (wie ich) beim Suchen auf diesen Thread stoßen. Ich hatte diesen Fehler am WE beim Update auf SH 1.6.1 und Ausprobieren der verschiedenen Visu-Versionen mehrmals.
    Ein konsequentes Setzen aller Rechte im SmartVISU-Verzeichnis für den verwendeten User (User muss in der Gruppe "www-data" sein)
    Code:
    cd /var/www/html
    sudo chown -hR <DeinUserName>:www-data smartVISU
    und Anpassung der Schreib-/Leserechte (CHMOD 775 ...) hat jedes Mal Abhilfe geschaffen..
    Zuletzt geändert von wvhn; 27.11.2019, 11:33.

    Einen Kommentar schreiben:


  • macs412
    antwortet
    Zusatz:
    Jetzt kommt noch das "Feature" hinzu dass die config.ini, wie von Geisterhand, gelöscht wird.
    Wenn ich diese wieder reinspiele, funktioniert alles wie oben beschrieben.

    Einen Kommentar schreiben:


  • macs412
    antwortet
    Das gleiche Problem ist bei mir wieder aufgetaucht.

    Bin zu mindestens auf etwas gekommen.
    Wenn ich in der config.ini Cache auf false setze funktioniert alles wieder ohne Probleme.
    Sobald Cache auf "true" ist habe ich wieder den selben Bildschirm.

    Code:
                                                                           smartVISU
                                                                  10:43, 21.11, v2.9
    --------------------------------------------------------------------------------
    
    Error occurred in twig-template engine!
    Lösche ich die config.ini wird diese zwar wieder neu erzeugt, aber es steht nichts drinnen.

    Jemand eine Ahnung woran das liegen kann?



    Zitat von smai Beitrag anzeigen
    macs412 könnte es sein, dass du in SmartHomeNG etwas geändert hast und dieses dann durch das Plugin visu_smartvisu Veränderungen an der smartVISU gemacht hat (z.B. in der pages/base/root.html).
    Ich würde die smartVISU-Dateien mal neu reinkopieren.
    - im SmartHome wurden nur neu Items hinzugefügt, welche alle ohne Probleme funktionieren.
    - Die pages/base/root.html wird zwar geändert, entspricht aber der Originaldatei.
    - smartVISU-Dateien neu reinkopieren hilft nichts

    Einen Kommentar schreiben:


  • smai
    antwortet
    macs412 könnte es sein, dass du in SmartHomeNG etwas geändert hast und dieses dann durch das Plugin visu_smartvisu Veränderungen an der smartVISU gemacht hat (z.B. in der pages/base/root.html).
    Ich würde die smartVISU-Dateien mal neu reinkopieren.

    Einen Kommentar schreiben:


  • ASSR85
    antwortet
    Ich hatte mir mal die VISU lahm gelegt in dem ich bei der Config -Seite unter der VISU-Name ein ' (Apostroph) gesetzt hatte. Es ging keine Seite mehr.
    Allerdings war glaub das Backend erreichbar. Ich würde mal den pages Ordner leer machen und mit den Imageseiten füllen.
    Zuletzt geändert von ASSR85; 02.11.2017, 07:40.

    Einen Kommentar schreiben:


  • Tom Bombadil
    antwortet
    Auf Port 8383 lauscht das Backend von smarthomeNG. Dort kannst Du zumindest schon mal überprüfen, ob du über das Siemens-Plugin Werte bekommst (Definition von entsprechenden smarthomeNG-Items vorausgesetzt).

    Aber warum der Aufruf der sV das Backend abschießt, erschließt sich mir nicht. Vielleicht ist jemand anderes da schlauer ...

    /tom

    Einen Kommentar schreiben:

Lädt...
X