Ankündigung

Einklappen
Keine Ankündigung bisher.

Error occurred in twig-template engine!

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • greentux
    antwortet
    Merci! Hat geholfen.

    Einen Kommentar schreiben:


  • wvhn
    antwortet
    Für alle, die (wie ich) beim Suchen auf diesen Thread stoßen. Ich hatte diesen Fehler am WE beim Update auf SH 1.6.1 und Ausprobieren der verschiedenen Visu-Versionen mehrmals.
    Ein konsequentes Setzen aller Rechte im SmartVISU-Verzeichnis für den verwendeten User (User muss in der Gruppe "www-data" sein)
    Code:
    cd /var/www/html
    sudo chown -hR <DeinUserName>:www-data smartVISU
    und Anpassung der Schreib-/Leserechte (CHMOD 775 ...) hat jedes Mal Abhilfe geschaffen..
    Zuletzt geändert von wvhn; 27.11.2019, 11:33.

    Einen Kommentar schreiben:


  • macs412
    antwortet
    Zusatz:
    Jetzt kommt noch das "Feature" hinzu dass die config.ini, wie von Geisterhand, gelöscht wird.
    Wenn ich diese wieder reinspiele, funktioniert alles wie oben beschrieben.

    Einen Kommentar schreiben:


  • macs412
    antwortet
    Das gleiche Problem ist bei mir wieder aufgetaucht.

    Bin zu mindestens auf etwas gekommen.
    Wenn ich in der config.ini Cache auf false setze funktioniert alles wieder ohne Probleme.
    Sobald Cache auf "true" ist habe ich wieder den selben Bildschirm.

    Code:
                                                                           smartVISU
                                                                  10:43, 21.11, v2.9
    --------------------------------------------------------------------------------
    
    Error occurred in twig-template engine!
    Lösche ich die config.ini wird diese zwar wieder neu erzeugt, aber es steht nichts drinnen.

    Jemand eine Ahnung woran das liegen kann?



    Zitat von smai Beitrag anzeigen
    macs412 könnte es sein, dass du in SmartHomeNG etwas geändert hast und dieses dann durch das Plugin visu_smartvisu Veränderungen an der smartVISU gemacht hat (z.B. in der pages/base/root.html).
    Ich würde die smartVISU-Dateien mal neu reinkopieren.
    - im SmartHome wurden nur neu Items hinzugefügt, welche alle ohne Probleme funktionieren.
    - Die pages/base/root.html wird zwar geändert, entspricht aber der Originaldatei.
    - smartVISU-Dateien neu reinkopieren hilft nichts

    Einen Kommentar schreiben:


  • smai
    antwortet
    macs412 könnte es sein, dass du in SmartHomeNG etwas geändert hast und dieses dann durch das Plugin visu_smartvisu Veränderungen an der smartVISU gemacht hat (z.B. in der pages/base/root.html).
    Ich würde die smartVISU-Dateien mal neu reinkopieren.

    Einen Kommentar schreiben:


  • ASSR85
    antwortet
    Ich hatte mir mal die VISU lahm gelegt in dem ich bei der Config -Seite unter der VISU-Name ein ' (Apostroph) gesetzt hatte. Es ging keine Seite mehr.
    Allerdings war glaub das Backend erreichbar. Ich würde mal den pages Ordner leer machen und mit den Imageseiten füllen.
    Zuletzt geändert von ASSR85; 02.11.2017, 07:40.

    Einen Kommentar schreiben:


  • Tom Bombadil
    antwortet
    Auf Port 8383 lauscht das Backend von smarthomeNG. Dort kannst Du zumindest schon mal überprüfen, ob du über das Siemens-Plugin Werte bekommst (Definition von entsprechenden smarthomeNG-Items vorausgesetzt).

    Aber warum der Aufruf der sV das Backend abschießt, erschließt sich mir nicht. Vielleicht ist jemand anderes da schlauer ...

    /tom

    Einen Kommentar schreiben:


  • macs412
    antwortet
    Eine detailliertere Fehlerbeschreibung gibt es leider nicht.

    Wie gesagt, habe an der Seite nichts geändert.

    Egal welche Seite ich unter config_pages eingebe, es kommt immer die gleiche "Fehlermeldung".

    Bin noch auf folgendes gekommen.

    Wenn ich den Raspberry neu starte, kann ich auf http://192.168.0.11:8383/ zugreifen.
    Sobald ich einmal http://192.168.0.11/smartVISU aufrufe, egal welche Seite unter config_pages eingetragen ist, ist http://192.168.0.11:8383/ nicht mehr erreichbar.

    Hat jemand eine Idee dazu?

    Einen Kommentar schreiben:


  • Tom Bombadil
    antwortet
    Kommt unter dem Error normalerweise nicht eine etwas detailliertere Fehlerbeschreibung? Gesehen haben wir das Ding vermutlich alle schon - irgendwo ist halt ein Fipptehler im Code unter smartvisu/pages/deine_seite/index.html oder in einer der anderen Dateien.

    Gib mal im smartvisu-Verzeichnis in der config.php unter 'config_pages' ein anderes Verzeichnis ein (z.B. 'docu' oder ein anderes der Verzeichnisse unter smartvisu/pages/) - dann kannst Du die SV zumindest wieder aufrufen.

    Den Fehler auf Deiner eigenen Seite muss Du trotzdem finden und beseitigen, ohne genauere Beschreibung geht das von hier nicht ...

    /tom
    Zuletzt geändert von Tom Bombadil; 01.11.2017, 20:11.

    Einen Kommentar schreiben:


  • macs412
    antwortet
    Habe da nichts geändert.
    Kann man herausfinden an welchen Seiten das liegen kann?

    Einen Kommentar schreiben:


  • Msinn
    antwortet
    Fehlerhafte Seiten in der smartVISU 2.8...

    Einen Kommentar schreiben:


  • macs412
    hat ein Thema erstellt Error occurred in twig-template engine!

    Error occurred in twig-template engine!

    Bekomm seit kurzem Beim Aufruf von http://192.168.0.11/smartVISU den folgenden Bildschirm:

    Code:
                                                                           smartVISU
                                                                  17:03, 01.11, v2.8
    --------------------------------------------------------------------------------
    
    Error occurred in twig-template engine!
    http://192.168.0.11/smartVISU2.9 funktioniert.

    Hat jemand eine Ahnung woran das liegen kann?
Lädt...
X