Ankündigung

Einklappen
Keine Ankündigung bisher.

- √ - RaspberryPi Image und WG

Einklappen
X
 
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • Elo
    antwortet
    Zitat von JNK Beitrag anzeigen
    Mach die mal rein, bei mir ging es auch nicht ohne. Ich guck mir nachher mal an, ob es da einen Bug gibt.
    Bei mir klappt es jetzt ohne diesen Eintrag. Das zweite Problem lag, wie ich befürchtet hatte, an (m)einem Fehler in der Visu (sind meine ersten Versuche mit der Visu).
    Euer Tipp mit dem KNX Eintrag in der Plugin.conf war das Entscheidende.
    Danke dafür! (jetzt weiß ich nur noch immer nicht, ob es besser ist, die eibd Einstellungen zu entfernen, bzw. was ich davon noch benötige).

    Einen Kommentar schreiben:


  • JNK
    antwortet
    RaspberryPi Image und WG

    Mach die mal rein, bei mir ging es auch nicht ohne. Ich guck mir nachher mal an, ob es da einen Bug gibt.

    Gruß,

    der Jan

    Einen Kommentar schreiben:


  • Elo
    antwortet
    RaspberryPi Image und WG

    Zitat von JNK Beitrag anzeigen
    Visu Plugin hast Du aber wohl auch nicht installiert. Siehe oben.
    Doch, das ist in dem Image alles eingerichtet. Jedoch ist die Portangabe mit "#" deaktiviert. Aber das wird ja sicherlich einem Grund haben.

    Einen Kommentar schreiben:


  • JNK
    antwortet
    RaspberryPi Image und WG

    Das sieht soweit auch gut aus. Visu Plugin hast Du aber wohl auch nicht installiert. Siehe oben.

    Gruß, der Jan

    Einen Kommentar schreiben:


  • Elo
    antwortet
    Zitat von JNK Beitrag anzeigen
    Es sollte da ein Logfile geben (typischerweise /usr/local/smarthome//var/log/smaerthome.log).
    Da steht auszugsweise nach dem Booten:
    2013-08-26 20:01:27 SmartHome.py INFO Init Items
    2013-08-26 20:01:28 SmartHome.py INFO Start Plugins
    2013-08-26 20:01:28 SmartHome.py INFO Start Logics
    2013-08-26 20:01:28 sh.con INFO KNX: connected to 192.168.100.26:6720
    2013-08-26 20:01:32 hello INFO Hello World!

    Wenn hier alles ok ist, suche ich den Fehler in der Visu. Will nur voher sicher sein, dass hier alles stimmt.
    Werden hier auch die Schaltbefehle protokoliert oder wo kann ich diese überprüfen?

    Einen Kommentar schreiben:


  • JNK
    antwortet
    Also:

    WG mit eibd, wie auch immer an den KNX angebunden. IP-Adresse A.A.A.A
    RPi mit Image, IP-Adresse B.B.B.B

    in der smartvisu sh.py einstellen, IP B.B.B.B, port 2424
    in der plugin.conf von sh.py:

    Code:
    [knx]
       class_name = KNX
       class_path = plugins.knx
       host = A.A.A.A
    #   port = 6720
    #   send_time = 600 # update date/time every 600 seconds, default none
    #   time_ga = 1/1/1 # default none
    #   date_ga = 1/1/2 # default none
    #   busmonitor = False
    
    [visu]
        class_name = WebSocket
        class_path = plugins.visu
    #   ip='0.0.0.0'
       port=2424
    #   visu_dir = False
    #   smartvisu_dir = False
    Könnte es sein, dass das Visu-Plugin nicht in der config war? Bitte mal die items.conf von sh.py posten.

    Gruss,

    der Jan

    Einen Kommentar schreiben:


  • evilg
    antwortet
    Zitat von JNK Beitrag anzeigen
    Ok, dann etwas ausführlicher:

    Du hast sh.py bereits laufen, und es macht auch eine Verbindung zum eibd des Wiregate? Sehr gut. Das war Schritt (1) von oben.

    der Jan
    Also, ich glaube wir reden aneinander vorbei.

    Ich habe ein Wiregate laufen. Dieses hängt mit einer USB Schnittstelle am Bus. -> läuft

    Jetzt habe ich noch ein Ras.Pi. Darauf läuft das Image von MKNX.
    Das enthält ja die SmartVisu.

    Ich möchte nun das die Smartvisu über das WG verbindung zum EIB aufnimmt.

    Wenn ich in der Konsole "groupswrite ip:localhost 0/0/67 1" eingebe
    passiert nichts auf dem Bus.
    Wenn ich "groupswrite ip:192.168.2.111 0/0/67 1" eingebe
    sendet er.
    Zitat von JNK Beitrag anzeigen
    Ich nehme mal an: smarthome.py als Backend? Dann in

    /usr/local/smarthome/etc/plugin.conf

    Code:
    [knx] class_name = KNX class_path = plugins.knx host = <IP des Wiregate>
    Habe ich gemacht( bei host die IP des Wiregate eingegeben.)

    Aber wie konfiguriere ich nun die Smartvisu?
    Unter Konfig smarthome.py wählen und die IP des WG eingeben klappt nicht.
    Die IP des Ras.pi klappt auch nicht. Welchen Port muss ich eintragen?

    Sorry für die blöden fragen aber irgendwie checke ich das noch nicht so ganz.

    Danke für die schnellen Antworten.

    Einen Kommentar schreiben:


  • JNK
    antwortet
    Wir entfernen uns etwas vom Thema, aber ip:localhost KANN auch nicht funktionieren, es läuft ja kein konfigurierter eibd auf dem localhost.

    Ich kenne das Image nicht, deswegen kann ich Dir auch nur begrenzt helfen. Meckert smarthome.py über irgendwas? Es sollte da ein Logfile geben (typischerweise /usr/local/smarthome//var/log/smaerthome.log). Da sollte drinstehen, ob es Probleme mit der Verbindung zum eibd gibt. Wenn da nix steht, ist das erstmal gut. Wenn da was steht: bitte mal posten, was da steht.

    Gruss,

    der Jan

    Einen Kommentar schreiben:


  • Elo
    antwortet
    Vielen Dank für die Tipps. Ich kann aber noch immer nichts über die Visu schalten. Wie kann ich sicher prüfen, ob zumindest die Grundkonfiguration der Verbindung stimmt?
    Ich habe in der plugin.conf unter KNX die IP vom WG eingetragen. Die eibd Konfing brauche ich nicht, habe ich oben gelesen. Muss ich hier etwas deaktivieren?
    groupswrite ip:WG-IP funktioniert, groupswrite ip:localhost nicht.

    Einen Kommentar schreiben:


  • JNK
    antwortet
    Ok, dann etwas ausführlicher:

    Du hast sh.py bereits laufen, und es macht auch eine Verbindung zum eibd des Wiregate? Sehr gut. Das war Schritt (1) von oben.

    Du willst nun der SmartVISU beibrigne entsprechend über sh.py auf den Bus zuzugreifen? Du gehst auf die Seite Configuration (das ist das Ding mit em Zahnrad), da gibts ne Option I/O Connection, da wählst du "Smarthome.py", und trägst darunter entsprechend die Adresse des Systems ein, auf dem Smarthome.py läuft (also vermutlich die, vom Raspberry Pi). Speichern nicht vergessen, los gehts.

    Gruss,

    der Jan

    Einen Kommentar schreiben:


  • evilg
    antwortet
    Ich möchte mit smartvisu (läuft auf ra pi) über das wg auf den bus zugreifen.
    mit der ets habe ich keine probleme über das Wg zu verbinden.

    Einen Kommentar schreiben:


  • JNK
    antwortet
    Für was?

    I/O Connection: Smarthome.py, IP des Rechners auf dem SH.py läuft (nicht 127.0.0.1 oder localhost, wirklich die richtige IP!).

    Gruss,

    der Jan

    Einen Kommentar schreiben:


  • evilg
    antwortet
    Ok hab ich gefunden, aber was stelle ich in der Visu bzw config.php ein?

    Einen Kommentar schreiben:


  • JNK
    antwortet
    Ich nehme mal an: smarthome.py als Backend? Dann in

    /usr/local/smarthome/etc/plugin.conf

    Code:
    [knx]
       class_name = KNX
       class_path = plugins.knx
       host = <IP des Wiregate>
    funktioniert einwandfrei.

    Gruss,

    der Jan

    Einen Kommentar schreiben:


  • evilg
    antwortet
    Hab exakt das selbe Problem.
    Wo genau stelle ich die IP ein?
    Welchen Port muss ich verwenden?

    Einen Kommentar schreiben:

Lädt...
X